FPGASID Prototyp Alpha Test

  • andi6510 schrieb:

    ZeHa schrieb:

    Wäre auch cool zu wissen woran das liegt, falls da jemand eine Antwort drauf haben sollte
    Koennte das Huellkurvenproblem sein, welches c0zmo und ich auf der DoReCo identifiziert haben. Auf einem original-SID werden die Huellkurven nicht immer sauber gestartet, so dass die attack-phase abgekuerzt wird. FPGASID rev 5 macht dies nicht ganz richtig nach: manchmal faellt hier die Huellkurve komplett aust und man hoert gar nichts.Ein bugfix, den ich auf der DoReCo gebaut habe, macht es so wie die Emulatoren: Die Huellkurve startet immer korrekt. Ist aber auch nicht schoen, da es eben nicht original ist.

    Ich muss mal ein bisschen forschen um rauszufinden, wie genau ein original-SID das ganze nun so macht.
    Hm, da wäre jetzt interessant wie sich eine korrektur des bugs allgemein auf unterschiedliche musikstücke auswirken würde. Wenn eher negativ dann wäre es besser den bug quasi im fpgasid nachzubauen. Wenn es sich aber auf "korrekt funktionierende" musikstücke nicht auswirken würde dann würde es unter umständen sinn machen sogar diesen bug zu korrigieren?
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • katarakt schrieb:

    Hm, da wäre jetzt interessant wie sich eine korrektur des bugs allgemein auf unterschiedliche musikstücke auswirken würde. Wenn eher negativ dann wäre es besser den bug quasi im fpgasid nachzubauen. Wenn es sich aber auf "korrekt funktionierende" musikstücke nicht auswirken würde dann würde es unter umständen sinn machen sogar diesen bug zu korrigieren?

    @c0zmo wird es bestätigen: mit Rev 5 fehlt manchmal eine komplette Note, weil die Hüllkurve nicht startet, mit meinem temporären Fix funktioniert alles, aber die attack-Phase klingt zu prägnant. Jetzt gilt es das Zwischending zu finden. Ich schreibe gerne mehr, wenn ich das Problem vollständig verstanden habe, aber es fehlt einfach noch ein Puzzlestück für den vollen Durchblick.
  • Hallo Leute!

    Jetzt hätten wir es also alle irgendwie nach 2018 geschafft... :)

    Wie am 24ten angekündigt gab es ja noch ein kleines Weihnachts-Release von mir. So nach und nach scheinen die ersten von Euch das ja schon aufgespielt zu haben und wie es so ist, die ersten Fehler wurden gefunden:

    Ein freundlicher Alphatester wies mich darauf hin, dass 'Retroversion' nicht funktioniert (Anfang fehlt im 6581 mode).

    Als ich die Sache untersucht hatte, musste ich feststellen, dass ich beim Beheben eines von @x1541 gemeldeten Bugs (leises AM-Radio Pfeifen im 8581 mode, selbst wenn VOL=0) ein Eigentor geschossen habe und den gefixten Bug durch etwas noch Blöderes ersetzt habe ;)

    Derzeit hat der 6er Release also folgendes bekanntes Problem:
    Ausgangssignalpegel um Faktor 2 zu hoch und dadurch Clipping des Signals bei hohen Ausgangspegeln sowie komplettes Verschwinden des Signals bei gewissen Filterkombinationen im 6581 mode, weil dann der DC-Offset im geclippten Bereich liegt.

    Release 7 wird dann wieder repariert sein: Der Ausgangspegel wird um den Faktor 2 reduziert sein (der FPGASID ist also dann etwas leiser), dafür wird nichts mehr geclippt und alles sollte wieder hörbar sein. Und ja, das Problem von @x1541 ist dann auch behoben... :)

    Ich möchte noch ein bisschen abwarten, ob sich noch mehr Probleme finden und dann für den ersten Produktionslauf ein Release 7 fertig haben, in dem aber nur noch Fehler behoben werden und keine neuen Features rein kommen um das Risiko wieder etwas kaputt zu machen zu minimieren.

    Zum Thema Produktion gibt es leider im Moment noch nicht viel zu berichten. Der Lohnfertiger hat immer noch kein GO für die Produktion, was aber eher an organisatorischen Dingen als an technischen liegt. Ich habe mir angewöhnt in solchen Dingen sehr viel Geduld zu haben, sonst wird man nur kribbelig...
  • [Edit von andi6510: hab das hier mal aus dem Konfigtool-Thread hierher kopiert - bezieht sich auf Revision 6]

    Das andere hat mit dem Digifix zu tun. Der führt mitunter beim Endpart von Comalight 13 zu massiven Störungen der Ausgabe. Ich habe aber noch nicht mit echtem 8580+Digifix oder Firmware5+Digifix gegen getestet.
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von andi6510 ()

  • x1541 schrieb:

    Das andere hat mit dem Digifix zu tun. Der führt mitunter beim Endpart von Comalight 13 zu massiven Störungen der Ausgabe. Ich habe aber noch nicht mit echtem 8580+Digifix oder Firmware5+Digifix gegen getestet.
    Wäre toll, wenn Du das noch mal gegenchecken könntest. Vor allem ob das schon in rev 5 mit drinnen ist. Wenn nicht, bin ich zuversichtlich, dass ich das bereits für release 7 repariert habe.

    Welche Settings hast Du benutzt? Digifix=$64, SID=8580 ist meine Vermutung. Stimmts?
  • andi6510 schrieb:

    x1541 schrieb:

    Das andere hat mit dem Digifix zu tun. Der führt mitunter beim Endpart von Comalight 13 zu massiven Störungen der Ausgabe. Ich habe aber noch nicht mit echtem 8580+Digifix oder Firmware5+Digifix gegen getestet.
    Wäre toll, wenn Du das noch mal gegenchecken könntest. Vor allem ob das schon in rev 5 mit drinnen ist. Wenn nicht, bin ich zuversichtlich, dass ich das bereits für release 7 repariert habe.
    Welche Settings hast Du benutzt? Digifix=$64, SID=8580 ist meine Vermutung. Stimmts?

    Ja genau. Testen kann ich das aber erst kommenden Samstag, und da kannst Du gleich selber mit testen ;)
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Leider hatte ich keine Zeit die letzten Wochen, bin umgezogen und Weihnachten ist immer die Hölle los auf Arbeit.
    Ab nächster Woche habe ich aber wieder Zeit und werde dann auch wieder testen können,
    warte dann aber gleich auf das 7er release.
    Werde dann berichten, freu mich drauf :)