FPGASID Prototyp Alpha Test

  • andi6510 schrieb:

    ZeHa schrieb:

    Wäre auch cool zu wissen woran das liegt, falls da jemand eine Antwort drauf haben sollte
    Koennte das Huellkurvenproblem sein, welches c0zmo und ich auf der DoReCo identifiziert haben. Auf einem original-SID werden die Huellkurven nicht immer sauber gestartet, so dass die attack-phase abgekuerzt wird. FPGASID rev 5 macht dies nicht ganz richtig nach: manchmal faellt hier die Huellkurve komplett aust und man hoert gar nichts.Ein bugfix, den ich auf der DoReCo gebaut habe, macht es so wie die Emulatoren: Die Huellkurve startet immer korrekt. Ist aber auch nicht schoen, da es eben nicht original ist.

    Ich muss mal ein bisschen forschen um rauszufinden, wie genau ein original-SID das ganze nun so macht.
    Hm, da wäre jetzt interessant wie sich eine korrektur des bugs allgemein auf unterschiedliche musikstücke auswirken würde. Wenn eher negativ dann wäre es besser den bug quasi im fpgasid nachzubauen. Wenn es sich aber auf "korrekt funktionierende" musikstücke nicht auswirken würde dann würde es unter umständen sinn machen sogar diesen bug zu korrigieren?
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • katarakt schrieb:

    Hm, da wäre jetzt interessant wie sich eine korrektur des bugs allgemein auf unterschiedliche musikstücke auswirken würde. Wenn eher negativ dann wäre es besser den bug quasi im fpgasid nachzubauen. Wenn es sich aber auf "korrekt funktionierende" musikstücke nicht auswirken würde dann würde es unter umständen sinn machen sogar diesen bug zu korrigieren?

    @c0zmo wird es bestätigen: mit Rev 5 fehlt manchmal eine komplette Note, weil die Hüllkurve nicht startet, mit meinem temporären Fix funktioniert alles, aber die attack-Phase klingt zu prägnant. Jetzt gilt es das Zwischending zu finden. Ich schreibe gerne mehr, wenn ich das Problem vollständig verstanden habe, aber es fehlt einfach noch ein Puzzlestück für den vollen Durchblick.