FPGASID Prototyp Alpha Test

  • andi6510 schrieb:

    ZeHa schrieb:

    Wäre auch cool zu wissen woran das liegt, falls da jemand eine Antwort drauf haben sollte
    Koennte das Huellkurvenproblem sein, welches c0zmo und ich auf der DoReCo identifiziert haben. Auf einem original-SID werden die Huellkurven nicht immer sauber gestartet, so dass die attack-phase abgekuerzt wird. FPGASID rev 5 macht dies nicht ganz richtig nach: manchmal faellt hier die Huellkurve komplett aust und man hoert gar nichts.Ein bugfix, den ich auf der DoReCo gebaut habe, macht es so wie die Emulatoren: Die Huellkurve startet immer korrekt. Ist aber auch nicht schoen, da es eben nicht original ist.

    Ich muss mal ein bisschen forschen um rauszufinden, wie genau ein original-SID das ganze nun so macht.
    Hm, da wäre jetzt interessant wie sich eine korrektur des bugs allgemein auf unterschiedliche musikstücke auswirken würde. Wenn eher negativ dann wäre es besser den bug quasi im fpgasid nachzubauen. Wenn es sich aber auf "korrekt funktionierende" musikstücke nicht auswirken würde dann würde es unter umständen sinn machen sogar diesen bug zu korrigieren?
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • katarakt schrieb:

    Hm, da wäre jetzt interessant wie sich eine korrektur des bugs allgemein auf unterschiedliche musikstücke auswirken würde. Wenn eher negativ dann wäre es besser den bug quasi im fpgasid nachzubauen. Wenn es sich aber auf "korrekt funktionierende" musikstücke nicht auswirken würde dann würde es unter umständen sinn machen sogar diesen bug zu korrigieren?

    @c0zmo wird es bestätigen: mit Rev 5 fehlt manchmal eine komplette Note, weil die Hüllkurve nicht startet, mit meinem temporären Fix funktioniert alles, aber die attack-Phase klingt zu prägnant. Jetzt gilt es das Zwischending zu finden. Ich schreibe gerne mehr, wenn ich das Problem vollständig verstanden habe, aber es fehlt einfach noch ein Puzzlestück für den vollen Durchblick.
  • Hallo Leute!

    Jetzt hätten wir es also alle irgendwie nach 2018 geschafft... :)

    Wie am 24ten angekündigt gab es ja noch ein kleines Weihnachts-Release von mir. So nach und nach scheinen die ersten von Euch das ja schon aufgespielt zu haben und wie es so ist, die ersten Fehler wurden gefunden:

    Ein freundlicher Alphatester wies mich darauf hin, dass 'Retroversion' nicht funktioniert (Anfang fehlt im 6581 mode).

    Als ich die Sache untersucht hatte, musste ich feststellen, dass ich beim Beheben eines von @x1541 gemeldeten Bugs (leises AM-Radio Pfeifen im 8581 mode, selbst wenn VOL=0) ein Eigentor geschossen habe und den gefixten Bug durch etwas noch Blöderes ersetzt habe ;)

    Derzeit hat der 6er Release also folgendes bekanntes Problem:
    Ausgangssignalpegel um Faktor 2 zu hoch und dadurch Clipping des Signals bei hohen Ausgangspegeln sowie komplettes Verschwinden des Signals bei gewissen Filterkombinationen im 6581 mode, weil dann der DC-Offset im geclippten Bereich liegt.

    Release 7 wird dann wieder repariert sein: Der Ausgangspegel wird um den Faktor 2 reduziert sein (der FPGASID ist also dann etwas leiser), dafür wird nichts mehr geclippt und alles sollte wieder hörbar sein. Und ja, das Problem von @x1541 ist dann auch behoben... :)

    Ich möchte noch ein bisschen abwarten, ob sich noch mehr Probleme finden und dann für den ersten Produktionslauf ein Release 7 fertig haben, in dem aber nur noch Fehler behoben werden und keine neuen Features rein kommen um das Risiko wieder etwas kaputt zu machen zu minimieren.

    Zum Thema Produktion gibt es leider im Moment noch nicht viel zu berichten. Der Lohnfertiger hat immer noch kein GO für die Produktion, was aber eher an organisatorischen Dingen als an technischen liegt. Ich habe mir angewöhnt in solchen Dingen sehr viel Geduld zu haben, sonst wird man nur kribbelig...
  • [Edit von andi6510: hab das hier mal aus dem Konfigtool-Thread hierher kopiert - bezieht sich auf Revision 6]

    Das andere hat mit dem Digifix zu tun. Der führt mitunter beim Endpart von Comalight 13 zu massiven Störungen der Ausgabe. Ich habe aber noch nicht mit echtem 8580+Digifix oder Firmware5+Digifix gegen getestet.
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von andi6510 ()

  • x1541 schrieb:

    Das andere hat mit dem Digifix zu tun. Der führt mitunter beim Endpart von Comalight 13 zu massiven Störungen der Ausgabe. Ich habe aber noch nicht mit echtem 8580+Digifix oder Firmware5+Digifix gegen getestet.
    Wäre toll, wenn Du das noch mal gegenchecken könntest. Vor allem ob das schon in rev 5 mit drinnen ist. Wenn nicht, bin ich zuversichtlich, dass ich das bereits für release 7 repariert habe.

    Welche Settings hast Du benutzt? Digifix=$64, SID=8580 ist meine Vermutung. Stimmts?
  • andi6510 schrieb:

    x1541 schrieb:

    Das andere hat mit dem Digifix zu tun. Der führt mitunter beim Endpart von Comalight 13 zu massiven Störungen der Ausgabe. Ich habe aber noch nicht mit echtem 8580+Digifix oder Firmware5+Digifix gegen getestet.
    Wäre toll, wenn Du das noch mal gegenchecken könntest. Vor allem ob das schon in rev 5 mit drinnen ist. Wenn nicht, bin ich zuversichtlich, dass ich das bereits für release 7 repariert habe.
    Welche Settings hast Du benutzt? Digifix=$64, SID=8580 ist meine Vermutung. Stimmts?

    Ja genau. Testen kann ich das aber erst kommenden Samstag, und da kannst Du gleich selber mit testen ;)
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Leider hatte ich keine Zeit die letzten Wochen, bin umgezogen und Weihnachten ist immer die Hölle los auf Arbeit.
    Ab nächster Woche habe ich aber wieder Zeit und werde dann auch wieder testen können,
    warte dann aber gleich auf das 7er release.
    Werde dann berichten, freu mich drauf :)
  • Hallo Leute,

    gerade habe ich Revision 07 released. Darin sind die Verzerrungen im 8580 Modus repariert. ConfiGuru hat ein paar neue Kleinigkeiten bekommen. Vor allem eine Lautstärkekontrolle im Diag-Modus um das Gepiepe bei Bedarf abzuschalten.

    Auf dem CRT2018 habe ich mit @x1541 zusammen ein paar mal die ConfiGuru Flashfunktion durchlaufen lassen. Das war ohne Floppyspeeder sehr zeitaufwendig. Daher habe ich auf der Homepage noch ein paar Extrainfos zu den Ladezeiten der Firmware eingefügt, damit niemand den Prozess einfach aus Zeitgründen abbricht.

    Bitte probiert doch mal die Flash-Funktion von ConfiGuru aus und gebt mir Feedback, ob es geklappt hat. Nur Mut! Wenn irgend was schief geht, kann man ja immer noch per USB-Blaster flashen.
  • Hi Andi,

    zuerst mal grossen Respekt fuer die Leistung! Sowohl fuer die neue Firmware, als auch fuer das Konfig Tool! Ich war aeusserst beeindruckt wie gut das komplette Paket jetzt funktioniert!

    Ich habe, wie von Dir vorgeschlagen, die Flash-Funktion des ConfiGuru zusammen mit meinem 1541U2 (mit der noch unveroeffentlichten Firmware 3.2alpha) verwendet und war total ueberrascht wie schnell und problemlos das alles zusammen spielt! Ich habe die erste Diskette im 1541U2 gemountet und diese vom ConiGuru ueberpruefen lassen. Den Diskettenwechsel habe ich mit der Automatik des 1541U2 gemacht, indem ich den mittleren Knopf einfach laenger gedrueckt habe. Das hat vollkommen problemlos geklappt. Nach der Ueberpruefung habe ich dann wirklich flashen lassen. Zuerst wieder mit der mittleren Taste des 1541U2 zurueck auf die erste Diskette geschaltet und das Flashen gestartet. Dann erneut umgeschaltet auf die 2. Diskette und das Flashen erfolgreich abgeschlossen. Klasse, alles sehr fluffig durchgelaufen, ohne grossartige Zwischenfaelle.

    Evtl. einen kleinen Verbesserungsvorschlag. Als Demo verwoehnter Bengel "erwartet" man eigentlich, dass das Programm (in dem Fall ConfiGuru) selbst erkennt, dass die Diskette gewechselt wurde und dann automatisch weiter laeuft. Tut es aber nicht, da wusste ich dann erst mal nicht was ich machen sollte und hab scheinbar zuerst die falsche Taste gerueckt (ich weiss nicht mehr genau welche) und war beim ersten Versuch dann wieder rausgeschmissen. Wenn ggf. irgendwo gestanden haette, dass ich "RETURN" druecken soll, um weiter zu machen, waere das IMHO nicht passiert. Wie gesagt, das ist aber echt jammern auf verdammt hohem Niveau!

    Danach hab ich dann erst mal mit dem neuen SIDplayer der 1541U2 (Danke Wilfred) ein paar HSVC 2SID im Stereo Modus (mit 2* 8580, der 2te auf D420, D500 und DE00) durchgehoert und war begeistert vom IMHO super sauberen Stereo Klang und dem problemlosen abspielen des 2. SID auf den verschiedenen Adressen!

    Ich wuerde mal behaupten: Andi, alles richtig gemacht! Vielen Vielen Dank! Der FPGA SID ist mir bis jetzt schon sehr ans Herz gewachsen! (sogar mehr als der SIDFX :) )


    Gruss
    Martin

    P.S.: Evtl. sollte ich noch erwaehenen, dass ich JaffyDos 1.2 mit dem 1541II JiffyDOS ROM in der U2 verwendet habe und es deshalb doch recht schnell war! ;)
  • Super, das klingt sehr gut alles.
    Bekomme am Wochenende meine letzten Möbel und kann dann wieder alles aufbauen,
    nächste Woche wird dann der FPGASID aktualisiert und getestet.
    Freu mich schon, werde berichten :)
  • marty schrieb:

    P.S.: Evtl. sollte ich noch erwaehenen, dass ich JaffyDos 1.2 mit dem 1541II JiffyDOS ROM in der U2 verwendet habe und es deshalb doch recht schnell war!
    Danke schon mal fuers Testen! Und ja, mit JiffyDos lauft das wie ne Eins!

    Das mit dem fehlenden Hinweis, dass man die Diskwechsel-Meldung wegdruecken muss (Return oder Space), nehme ich ernst. Es sollte gerade beim Flashen moeglichst nichts bloed unterbrochen werden.
  • marty schrieb:

    Evtl. einen kleinen Verbesserungsvorschlag. Als Demo verwoehnter Bengel "erwartet" man eigentlich, dass das Programm (in dem Fall ConfiGuru) selbst erkennt, dass die Diskette gewechselt wurde und dann automatisch weiter laeuft.
    Kennt jemand eine Routine, die genau das macht und mit den unterschiedlichen Floppylaufwerken klar kommt? Eigentlich braucht man das ja nur für die 1541 und die 1571, falls in der letzteren eine 1541 Diskette liegt. Es sollte sich aber auch mit anderen Lösungen vertragen also SD2IEC und Ähnliches. Ich bräuchte das in Assembler und es darf nicht viel Speicher verschlingen. Der wird nämlich langsam knapp...

    Inzwischen werde ich irgendwo einen Hinweis anbringen. Sowas wie "[SPACE] to continue" oder so.
  • andi6510 schrieb:

    marty schrieb:

    Evtl. einen kleinen Verbesserungsvorschlag. Als Demo verwoehnter Bengel "erwartet" man eigentlich, dass das Programm (in dem Fall ConfiGuru) selbst erkennt, dass die Diskette gewechselt wurde und dann automatisch weiter laeuft.
    Inzwischen werde ich irgendwo einen Hinweis anbringen. Sowas wie "[SPACE] to continue" oder so.
    Die variante mit tastendruck finde ich eh besser wie die automatische erkennung. Die autom. erkennung macht bei kopierprogrammen sinn oder bei games wo ständig diskettenwechesl stattfinden, aber hier wo man einen flash-vorgang macht finde ich die klassische tastendruck-variante ausreichend.
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • katarakt schrieb:

    Die variante mit tastendruck finde ich eh besser wie die automatische erkennung. Die autom. erkennung macht bei kopierprogrammen sinn oder bei games wo ständig diskettenwechesl stattfinden, aber hier wo man einen flash-vorgang macht finde ich die klassische tastendruck-variante ausreichend.
    Was soll das? Wenn der automatische Wechsel problemlos einzubauen ist, warum sollte man das nicht tun? Erst recht, wenn der Sourcecode dafuer bereits vorhanden ist!
    Man sollte es dem unbedarften Benutzer beim Update der FPGASID Firmware ruhig so einfach wie moeglich machen und die Erkennung macht es sehr einfach.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von marty ()

  • Ach, erinnerungen an damals...disk nicht richtig eingelegt und es ratterte schon los und solche geschichten. Gerade bei einem flash-vorgang evtl. nicht so super aber gut, von mir aus darf das feature ruhig eingebaut werden, an mir solls ganz gewiss nicht scheitern :)
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.