Assy 250407 - schwarzer Bildschirm

  • Assy 250407 - schwarzer Bildschirm

    Ich bin wieder in bastellaune und habe mir wieder einen patienten angeschafft.

    Diesmal wieder ein brotkasten mit 1541. In der 1541 ist wohl ein schnellader verbaut, ich hatte noch keine zeit reinzuschauen um welchen es sich handelt aber das ist jetzt erstmal nebensächlich. Wichtiger ist den brotkasten wieder zum laufen zu bekommen....es geht nix, black screen nach dem einschalten.

    Es handelt sich um assy 250407:



    Wie man sieht steckt vermutlich auch das passende kernal für den schnellader...etwas komisch mit 2 zwischensockel und bischen verdrahtungsgewurstel an den zwischensockeln aber wird ja wohl so auch mal gelaufen sein.

    Spannungen gemessen = 12,14v und 4,90v
    Spannung am vic passt auch.
    Spannung am expansion port passt.

    Eingeschaltet...schwarzer bildschirm, ok, tot.

    Check64 only angestöpselt mit dead test einstellung:
    1. eingeschaltet, bildschirm komplett weiß...1 minute gewartet, keine veränderung, kein bildschirm flash etc...aus geschaltet
    2. eingeschaltet, bildschirm komplett grün...keine veränderung nach einer minute, kein bildschirm flash etc...aus geschaltet
    3. eingeschaltet, war dann wieder schwarz, kein bildschirm flash etc...aus geschaltet

    Check64 auf diagnose eingestellt und alle adapter angeschlossen, schwarzer bildschirm. Dann alle adapter rausgezgen und check64 weiterhin mit diagnose einstellung...plötzlich kommt dieses bild, reproduzierbar nur wenn alle diagnose-adapter abgezogen sind und einstellung auf diagnose:





    RAMS, VIC und andere kandidaten normale temperatur....aber die PLA wird nach 2 minuten im eingeschalteten zustand seeehr heiß, dachte jetzt glüht der gleich, schnell finger weg. Glaube daß die normal nicht so heiß wird nach 2 minuten.


    Ok...was würdet ihr sagen ? ...ich würde mal vorsichtig auf PLA tippen? Wenn die rams kaputt wären sollte doch der dead test reagieren oder?
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • 1. SID heraus nehmen.
    2. Die gesockelten Chips (SID, VIC, Kernal) in einem anderen Rechner testen.

    Das letzte Bild sieht nach HiRes-Bitmap aus: die schwarzen und hellgrauen Streifen entstehen durch das typische 00/ff-Muster der RAMs. Die sichtbaren Buchstaben in der unteren Hälfte müssen aber aus irgend einem ROM kommen, entweder aus dem internen Char-ROM oder aus dem Modul.
    Yes, I'm the guy responsible for the ACME cross assembler
  • Oh, ich hatte ja schon mitbekommen daß es die keramik vics wohl nicht so oft gibt aber sind die echt so selten? Ist auf jeden fall der erste den ich habe, ja. Sind die "haltbarer"?

    Ok, glaube das könnte eine längere baustelle geben. Werde erstmal VIC und SID in anderem gerät testen. Kernal muss ich mal schauen ob ich einen cevi mit gesockeltem kernal habe. Danach dann mit der PLA weitermachen (ich warte immer noch auf die bestellte entlötlitze :( ).

    Vielen dank erstmal für eure unterstützung :)
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Assy 250407 - schwarzer Bildschirm

    Ich würde mich als erstes auf die PLA konzentrieren. Der SID ist erstmal uninteressant und der VIC produziert ja anscheinend ein Bild.
    Viele Grüße
    Thomas

    - CHECK64 - The C64/C128(D) Diagnostic Set -> zum Beitrag: CHECK64 | Manuals
    - Anfertigung von Kühlkörperklammern -> zum Beitrag: Kühlkörperklammern Info: Kein lästiges Kleben mehr
    - Veranstaltung Kölner-Retrotreff -> zur Homepage:
    koelner-retrotreff.de
  • Einen? Hunderte! :D
    MT-RAMs sterben wie die Fliegen und tauchen hier in gefühlten 50% aller Reparaturthreads auf.

    Gerrit hat allerdings einen Qualitätsunterschied zwischen zwei verschiedenen Geschwindigkeitsversionen ausgemacht, d.h. die eine Sorte geht karpott, die andere nicht.
    Yes, I'm the guy responsible for the ACME cross assembler
  • Mac Bacon schrieb:

    Gerrit hat allerdings einen Qualitätsunterschied zwischen zwei verschiedenen Geschwindigkeitsversionen ausgemacht, d.h. die eine Sorte geht karpott, die andere nicht.
    Die MT4264-20 waren bisher die, die immer den Geist aufgaben. Aber in letzter Zeit hatten wir auch schon defekte -15.

    Aber zuerst die PLA auslöten und woanders testen. Wenn sie so heiss wird, daß man sie nicht mehr anfassen kann ist das ein Zeichen für Kernschmelze => defekt.
  • So, konnte jetzt endlich weitermachen und habe als erstes die PLA ausgelötet und dann nen PLAnkton eingesetzt. Jetzt kommt wenigstens schonmal stabil und reproduzierbar folgende einschaltmeldung:



    ...check64 mit und ohne steckergedöns reproduzierbar folgendes bild:



    Ich vermute daß die alte PLA wohl schon defekt war und hatte schon damit gerechnet daß mehr sein könnte, was meint ihr?
    Bilder
    • 20161119_190215.jpg

      128,82 kB, 1.200×675, 12 mal angesehen
    • 20161119_185508.jpg

      86,58 kB, 1.200×675, 12 mal angesehen
    • 20161119_185445.jpg

      86,39 kB, 1.200×675, 10 mal angesehen
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Steck mal ein Standard-Kernal-ROM rein. Solange da ein alternativer Kernal drin ist, weiß man nicht, ob der schwarze Bildschirmhintergrund normal oder ein Fehler ist.
    Aufgrund der Dollarzeichen vermute ich mindestens einen RAM-Defekt, bei Datenbit 2.
    Das erklärt aber nicht die vermurkste Anzeige von check64, da muss noch was anderes kaputt sein.
    Yes, I'm the guy responsible for the ACME cross assembler
  • Bei dem cevi war auch die passende 1541 mit parallelkabel dabei daher vermute ich einfach mal daß auf dem kernal speeddos drauf ist oder ein anderer schnellader mit schwarzem hintergrund aber gut, kann sein daß dieser seltsame kernal mit zwischensockel und verdrahtung auch defekt ist. Problem ist daß ich kein kernal habe zum testen, es sei denn bei einem meiner anderen wenigen brotkästen ist einer gesockelt, irgendwo meinte ich einen gesockelten bei mir gesehen zu haben...hmm...ich chekc das mal.

    Datenbit 2 müßte demnach U22 sein. Ok, werde erstmal nach dem kernal sehen. Achso, des normale diagnostic vom check64 funktioniert weiterhin noch nicht, nur der dead test so wie oben zu sehen ist.
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Werde demnächst beim reichelt bestellen und will mir jetzt mal ein kleines lager pro bauteil zulegen welches man ständig benötigt für die cevis und 1541, ist doch doof jedes mal zu bestellen wenn man nen neuen patienten hat bzw. ewig warten...kann mir kurz jemand helfen welche bauteile ich noch mitbestellen soll?

    74LS06
    SN74LS257BN
    SN74LS139AN
    74LS14 (letzes mal beim conrad SN74LS14N)
    ...was noch?

    Übrigens, den PLA hatte ich dieses mal mit der neuen günstigen pollin entlötpumpe rausopereiert welche gerrit mal empfohlen hatte soweit ich noch weiß. Meine entlötstation hatte ich dieses mal nicht benutzt weil die lötpunkte so klein waren. Also das ging hammermäßig gut! Damit bekomme ich dann wohl auch die 40-füßler raus! Wenn ich das gewußt hätte daß eine neue pumpe so gut sein kann hätte ich mir die entlötstation nicht gekauft :rolleyes:
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Ich habe tatsächlich ein brotkasten mit gesockeltem kernal gefunden. Dieses funktionierende habe ich nun in den patienten eingesetzt mit gleichem fehler, daher kann ich jetzt das kernal ausschließen. Ich werde jetzt besagtes ram auslöten und dann erstmal wieder auf die teile bestellung warten (habe reichelts black friday zu spät bemerkt mit vsk frei).
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Gerrit schrieb:

    Ein kleiner Nachtrag... nachdem ich es wissen wollte, habe ich mir bei der letzten Bestellung bei Pollin ein 3 Stück der 41256 (OK, GM71256-12, Datecode 893x) mit der Best. Nr. 101 047 beilegen lassen. Kosten ja nur 40 Cent das Stück.

    Alle 3 bestehen in einem C64 mit 250407 den RAM-Test der Diag-Cartridge ohne Fehler. Ich konnte mir sogar die Verbindung von Pin 1 mit Pin16 sparen (41256 von TI bestehen drauf). Zumindest für den C64 sind sie also benutzbar wenn man keine 4164 in Griffweite hat.
    Ich hatte ganz vergessen zu fragen welcher RAM-ersatz für das board zu verwenden ist und habe in einem alten thread die info von gerrit mal rauszitiert...ist das noch aktuell oder gibt es mitlerweile andere alternativen, auch bei reichelt? Bei pollin gäbe es die rams jedenfalls noch :)
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
  • Pin 1 + Pin 16 muß man laut Gerrits zitat nicht verbinden bei diesen rams (siehe post 16) :)
    Die sockel habe ich bei reichelt mitbestellt weil ich die dort schon in meinem warenkorb gespeichert und ich auch nicht weiters bei pollin gesucht hatte.
    Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.