Hello, Guest the thread was called5.7k times and contains 59 replays

last post from GenerationCBM at the

Firmware-Support für "Evo2" gewünscht....

  • ah, ok, dann hab ich den fkaschen schluss gezogen, denn jetzt kompilierts auch, wenn ich nur eine RTC in der config hab, danke fuer den fix.


    trotzdem liefert "T-RI" 30,SYNTAX ERROR :-(


    ich hab alle SOFTI2C_* defines gecheckt, zwischen larsp harware variant und original evo2 firmware, da ist alles exact gleich.


    zur sicherheit hab ich den original evo2 source nochmal compiliert und da geht die uhr.


    koennte es sein. dass der DS1307 codepfad seit dem umbau einen bug hat?

  • trotzdem liefert "T-RI" 30,SYNTAX ERROR :-(

    Hast du denn die Zeit vorher gesetzt?


    Quote

    koennte es sein. dass der DS1307 codepfad seit dem umbau einen bug hat?

    Zumindest mit dem DS1307-Modul von eBay was ich zum Testen verwende funktionierte es.

  • Hast du denn die Zeit vorher gesetzt?

    jupp. die evo firmware liefert auch die richtige zeit zurueck. ausserdem muesste ich ja ein 31,SYSNTAX ERROR bekommen, wenn es an der nicht gesetzten uhr liegt, oder?


    >> If the RTC isn't present, both commands return
    >> 30,SYNTAX ERROR,00,00; if the RTC is present but not set correctly T-R will
    >> return 31,SYNTAX ERROR,00,00.


    ich werde also wohl oder uebel versuchen muessen, da irgendwie eine serielle dranzukriegen. das ding hat eine 6-polige ISP schnittstelle von denen ich mit freiem auge sehe das sie mit pad 2, 3 und 4 vom atmel verbunden ist. aha, ist aber SPI und reset laut datenblatt. ich brauch den pin10 (TX0) oder?

  • jupp. die evo firmware liefert auch die richtige zeit zurueck. ausserdem muesste ich ja ein 31,SYSNTAX ERROR bekommen, wenn es an der nicht gesetzten uhr liegt, oder?

    Als ob ich die Nummern auswendig kennen würde...


    Quote

    ich werde also wohl oder uebel versuchen muessen, da irgendwie eine serielle dranzukriegen. das ding hat eine 6-polige ISP schnittstelle von denen ich mit freiem auge sehe das sie mit pad 2, 3 und 4 vom atmel verbunden ist. aha, ist aber SPI und reset laut datenblatt. ich brauch den pin10 (TX0) oder?

    TX0 klingt gut

  • TX0 klingt gut

    soweit so gut. ich hab debug uart eingeschalten, baudrate auf 115200 und buf_shift auf 8 eingestellt:


    CONFIG_RTC_DSRTC=y
    CONFIG_UART_DEBUG=y
    CONFIG_UART_BAUDRATE=115200
    CONFIG_UART_BUF_SHIFT=8


    aber da bekomm ich keinen sinnvollen output (ich lass die ausgaben von picocom mit drinnen, damit man die einstellungen sieht)...


    ich hab auch andere baudraten probiert: 19200 und 38400. ich sehe, dass ca alle 250ms etwas ausgegeben wird dann mal wieder alle 500ms, manchmal kommen richtige bursts. jemand eine idee?

  • soweit so gut. ich hab debug uart eingeschalten, baudrate auf 115200 und buf_shift auf 8 eingestellt:
    (...)
    aber da bekomm ich keinen sinnvollen output (ich lass die ausgaben von picocom mit drinnen, damit man die einstellungen sieht)...

    Kein Wunder - mit einem 8MHz-Quarz hat man eine ziemlich hohe Frequenzabweichung bei 115200 Baud und die von mir verwendete Formel zur Berechnung des Divisors rundet in dem Fall auch noch ungünstig. Nimm lieber 19200.

  • fsck!


    hab mich grandios verschaut. das evo2 ist DOCH eine andere HW VARIANTE naemlich mit i2c auf port A und nicht auf C und SDA und INTRQ sind vertauscht. sonst ist alles gleich!


    :cry:


    hier ein minimales diff zu arch-config.h



    und hier eine config


    damit bekommt man Evo2 support mit RTC aber ohne display in die aktuelle git version.


    Unseen: hat das eine chance drauf, dass du es uebernimmst?

  • Unseen: hat das eine chance drauf, dass du es uebernimmst?

    Als neue Hardwarevariante mit eigener Bootloader-ID ja, aber nicht als Änderung der bisherigen larsp-Konfiguration - das würde den RTC-Support auf schon existierenden Platinen kaputtmachen.


    Die Soft-I2C-Routinen so umbiegen, dass sie dynamisch auf einen anderen Port umkonfigurierbar sind würde deren Code vermutlich zu sehr aufblasen: Bit Set/Clear auf feste Ports geht mit jeweils einem Befehl, wenn der Port dynamisch ist wird daraus eine Sequenz aus Lesen/Modifizieren/Schreiben (was auch doof ist, wenn man im Interrupt ebenfalls Port-Schreibzugriffe machen will)

  • Ich hatte einen C64 mit internem SD2IEC EVO2 und Display nach zwei Jahren Inaktivität mal wieder in Betrieb genommen.
    Er zeigte die Firmware Version 1.0.2 an. Auf der Website von 16xEight sah ich dann eine neueren Datums aber leider ohne Versionsangabe.
    Hätte ich doch erst diesen Thread gelesen :S
    Ich habe also die vermeintlich neuere Firmware auf die SD-Karte gespeichert und die Firmware geflasht.
    Nun meldet sie sich mit Version 1.0.0alph und hat wesentlich mehr Macken als die zuvor verwendete 1.0.2 Version.
    Meine Kontaktversuche und email an Daniel Müller von 16xEight wurden leider nicht beantwortet und nun sitze ich da mit meiner Alpha-Firmware.
    Kann mir irgendjemand mit einer Firmware Datei helfen, die neuer als die Alpha Version ist, am besten mit LCD und RTC Unterstützung?
    Mit einer Rückkehr zur Version 1.0.2 wäre ich schon zufrieden.
    Gruß,
    Bit Shifter

  • CapFuture hatte doch mal eine Version gemacht. Zwar nicht explizit fürs EVO, läuft aber damit. Müsste die hier sein
    LCD-SD2IEC Firmware 1.0.0 für LarsP-Layout

    Bei Interesse kann ich die aktuelle SD2IEC mit LCD Support gerne hochladen ...

    --------------------------------------------------------------------------------------------------------
    RapidFire BBS: rapidfire.hopto.org:64128

  • 'Firma' ist etwas hoch gegriffen; das ist ein Einzelkämpfer, der sich schon ganz zu Anfang ne blutige Nase geholt hat, weil er zwar arg viel für seinen Shop geworben, aber nicht -wie von der Lizenz gefordert- den Quelltext für sein Produkt veröffentlicht hat. Die Nachwehen davon sehen wir grad...


    ...und natürlich wäre es nett, wenn nicht jeder Hersteller ohne Not eine völlig neue Pin-Belegung basteln würde; dann würden wenigstens die Standard-Sachen laufen, auch wenn der Support nicht mehr gegeben ist.

  • 'Firma' ist etwas hoch gegriffen; das ist ein Einzelkämpfer, der sich schon ganz zu Anfang ne blutige Nase geholt hat, weil er zwar arg viel für seinen Shop geworben, aber nicht -wie von der Lizenz gefordert- den Quelltext für sein Produkt veröffentlicht hat. Die Nachwehen davon sehen wir grad...


    ...und natürlich wäre es nett, wenn nicht jeder Hersteller ohne Not eine völlig neue Pin-Belegung basteln würde; dann würden wenigstens die Standard-Sachen laufen, auch wenn der Support nicht mehr gegeben ist.

    Ich gebe Dir völlig recht. Aber ich habe nun mal das Evo2 und es ist auf meinem C64 Reloaded Board intern festgelötet und das Display ist ins Gehäuse eingearbeitet.
    Der Umstieg auf ein anderes SD2IEC System wäre schon mit einigem Aufwand verbunden und ist nur der letzte Ausweg.