New, 1541 Ultimate-II+: Bugs, Features und Einstellungen

  • TurboMicha schrieb:

    ?? dann ist es ja nicht der "letzte Batch" gewesen ??!

    hast du die 3 Widerstände (handgelötet) drunter ??
    Auf der Platine war ein Aufkleber mit Rev A:432. Sollte also ein früherer Batch sein. Bis gestern hatte es ja auch funktioniert, nur hörte dann die Funktion einfach auf. Die Widerstände habe ich nicht verändert. Nur beim runterlöten des U5 mit Heißluft ist mir der C1 davon geflogen, scheint aber nicht kritisch zu sein, zumindest läuft alles noch. An der 5V leitung des USB lagen dann zwar nur 4,5V an, aber der Stick läuft zumindest wieder.
  • Ein kleiner Tipp am Rande: Wenn man mit ftp Dateien überträgt, sollte man darauf achten, seinen ftp-client auf jeden Fall im BINARY Modus zu verwenden. Ansonsten wird die Datei als "Textdatei" übertragen, was dazu führt, das vor jedes byte mit dem wert $0a ein zusätzliches byte mit $0d eingefügt wird (Windows vs Unix line endings).

    Wenn man eine Update-Datei so überträgt, kann das ziemlich schiefgehen! Bei mir ist irgendwann ein Update nach ein paar hundert bytes einfach hängen geblieben, die Ultimate hat danach garnichts mehr gemacht.

    Ich habe schon überlegt, wie ich die firmware über ISP flashen muss, habe dann aber aus Verzweiflung noch ein bischen rumgedrückt, und siehe da: Hält man beim Einschalten den mittleren Taster gedrückt, bootet die Ultimate in die Recovery-Firmware, die im redundanten Flash gespeichert ist, von dort konnte ich dann wieder updaten.

    Diese Information findet sich leider nicht im Quick Start Guide, wahrscheinlich wieder nur auf Facebook irgendwo? Ich wusste nur, dass Gideon das als feature irgendwo angepriesen hat (redundanter Flash-Speicher verhindert bricking), also war es naheliegend, das es irgendwie über die Taster gehen musste.
  • Guten Abend,

    ich klinke mich hier mal mit ein. Als absult Beginner in Sachen 1451UII+ beschäftigt mich gerade eine Frage. (Zum besseren Verständniss, ich habe das Modul noch nicht! Ich warte noch.)

    Die 1451 UII+ hat DualSid wie ich es in den Specs. lese. Nun Frage ich mich, ersetzt das eine reale StereoSid Hardwareerweiterung mit der man also z. Bsp. den 6581 und den 8580 abwechselnd oder auch gleichzeitig nutzen kann?

    Oder macht so eine zusätzliche reale Hardwareerweiterung trotzdem Sinn (wenn man sowas möchte) und wie funktioniert das DualSid Feauture der 1451 UII+?

    Die Frage wird für die Wissenden bestimmt pipikram sein. Ich würde dazu gerne genaueres wissen wollen.

    Nachtrag noch vergessen: wie sieht es dann mit der DigiFix-Problematik des 8580 z. Bsp. im C128DCR aus?

    Kann mich dazu bitte jemand aufklären.

    LG

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von olly ()

  • olly schrieb:

    Oder macht so eine zusätzliche reale Hardwareerweiterung trotzdem Sinn (wenn man sowas möchte) und wie funktioniert das DualSid Feauture der 1451 UII+?
    Die Ultimate kann zwei SIDs in Software emulieren, ich glaube das basiert auf einer schon etwas älteren Resid-Version. Du kannst einen oder zwei SIDs zusätzlich auf eine bestimmte Adresse legen, die Ausgabe erfolgt immer über den Audio-Out der Ultimate.

    Wenn man nur mal kurz Stereo-Tunes hören will, reicht das aus. Wenn man echte SIDs bevorzugt, sollte man eine Hardwarelösung nehmen.
  • Hallo,

    C=Mac schrieb:

    Nach einigem hin und her klappt es auch

    Eines der Probleme war, dass die REU und die emulierte 1541 die gleiche Geräteadresse hatten (hat jedenfalls MP3 gestört).

    Seit dem umstellen der Geräteadresse läuft's
    mmhhh, muss die REU der Ultimate zwingend eine Geräte-Adresse haben?

    Eine echte CBM-REU hat sowas nicht. Die wird wohl bei Benutzung intern vom jeweiligen Programm (z.B. Geos) vergeben.
    Auf jeden Fall sind zwei gleiche Adressen für verschiedene Geräte nicht nur in Geos problematisch....

    Gruß
    Werner
  • wweicht schrieb:

    mmhhh, muss die REU der Ultimate zwingend eine Geräte-Adresse haben?

    Eine echte CBM-REU hat sowas nicht. Die wird wohl bei Benutzung intern vom jeweiligen Programm (z.B. Geos) vergeben.
    Auf jeden Fall sind zwei gleiche Adressen für verschiedene Geräte nicht nur in Geos problematisch....
    Ich kenne von der REU auch keine Geräteadresse, und habe alle wesentlichen 1541 Ultimate-Modelle (1541 U1 Plus, 1541 U2, 1541 U2 Plus). Vermutlich wurde da was verwechselt... eventuell die Adresse vom IEC-Device (wenn man davon ausgeht, dass die Adresse der emulierten 1541 es kaum sein wird, bleibt eigentlich nur jene übrig).
    ---
    Meine Github-Projekte: github.com/markusC64/
    1541 Ultimate II Firmware Releases: github.com/markusC64/1541ultimate2/releases
    1541 Ultimate II Update instructions: github.com/markusC64/1541ultimate2/wiki
  • wweicht schrieb:

    mmhhh, muss die REU der Ultimate zwingend eine Geräte-Adresse haben?

    Eine echte CBM-REU hat sowas nicht. Die wird wohl bei Benutzung intern vom jeweiligen Programm (z.B. Geos) vergeben.
    Auf jeden Fall sind zwei gleiche Adressen für verschiedene Geräte nicht nur in Geos problematisch....
    Kann ich nicht wirklich sagen ;(

    Bei einer realen REU hab ich mich auch nie darum gekümmert, ab damit in den Expansionsport und nicht mehr drum kümmern, der Rest soll der Compi bzw. die Software machen.

    Ich weiss nur als die REU-Adresse die gleiche war (10), wie die der emulierte 1541 kam es unter MP3 immer wieder zu Hänger.
    Als ich die Adresse auf 12 setzte, haben MP3 und Wheels nur gemeldet: "Keine REU vorhanden" und den Dienst quittiert.
    Seit ich sie auf 11 gesetzt habe, läuft alles (MP3, Wheels, BurstNibbler).


    markusC64 schrieb:

    Ich kenne von der REU auch keine Geräteadresse, und habe alle wesentlichen 1541 Ultimate-Modelle (1541 U1 Plus, 1541 U2, 1541 U2 Plus). Vermutlich wurde da was verwechselt... eventuell die Adresse vom IEC-Device (wenn man davon ausgeht, dass die Adresse der emulierten 1541 es kaum sein wird, bleibt eigentlich nur jene übrig).
    DMA Load Mimics ID betrachte ich als REU-Adresse, vielleicht liege ich aber auch völlig falsch ?(
    Jedenfalls seit ich diese auf 11 gesetzt habe, läuft's.

    - IEC Drive and printer ist auf Disabled
    - Soft Drive Bus ID ist auf 10, vielleicht stört diese Einstellung?


    Noch eine Frage, betreffend Module (crt) installieren:
    Hab ich das richtig im Kopf, es gehen nur 8 KB oder 16 KB Versionen?
    Also keine Spielmodule mit mehreren 100 KB.

    Gruss C=Mac.
  • C=Mac schrieb:

    Ich weiss nur als die REU-Adresse die gleiche war (10), wie die der emulierte 1541 kam es unter MP3 immer wieder zu Hänger.
    Eine REU hat keine IEC-Geräteadresse, die hängt ja schließlich nicht am IEC-Bus.

    Das Software-IEC-Gerät ist bei der Ultimate mit Geräteadresse 10 vorbelegt.

    C=Mac schrieb:

    DMA Load Mimics ID betrachte ich als REU-Adresse, vielleicht liege ich aber auch völlig falsch
    "DMA Load Mimics ID" ist leidiglich die Adresse, die beim DMA-Run/Load eines PRG nach $BA (letztes benutztes IEC-Gerät) geschrieben wird, um dem Kernel weiszumachen, das PRG wäre von dieser Geräteadresse geladen worden (und nicht nur direkt in den Speicher geschoben worden).
  • Da wird doch der Hund in der Pfanne verrückt bzw. ich.

    Hab das jetzt nochmal durch probiert, mit der REU (Ultimate) und MP3/Wheels 128.

    Und es funktioniert einfach, egal welche Adresse ich bei "DMA Load Mimics ID" eingebe.

    Entweder ich leide unter geistiger Umnachtung oder die Technik denkt sich, komm den vera...... wir mal ;(

    Im Moment funktioniert wie's soll.

    Gruss C=Mac.
  • Kurze Frage in die Runde: Könnte jemand einmal Artillery von Shape mit dem Retro Replay testen? Bei mir lädt da immer nur der "Hidden Part" und nicht die Demo selbst. Mit dem Action Replay hingegen läuft es einwandfrei. Mit dem Retro Replay habe ich sowieso immer wieder sporadische Freezes (bis jetzt nur Demos getestet).

    Wäre interessant zu wissen ob ich der Einzige damit bin, wenn ja muss ich mal meine alte Ultimate 2 rausholen, mit der lief immer alles einwandfrei.

    Tante Edit: Im Moment verwende ich auf der Ultimate 2+ 3.0e_452+_v5

    LG
    Patrick
  • Gestern wollte ich mal wieder ein Spielchen zocken, drücke die mittlere Taste und gehe bis zur .d64-Datei. Hier hab ich die Rechts-Taste gedrückt, um mir den Inhalt anzusehen, das hat schon ziemlich lang gedauert und die rechte grüne LED hat dabei sehr schnell geflackert. Dann hatte ich "Mount and Run" ausgewählt. Das hat wieder lang gedauert und die LED hat geflackert. Einmal ist die U auch komplett abgestürzt...
    Was ist das? Hängt das mit U5-Chip zusammen?
  • Ingo schrieb:

    Gestern wollte ich mal wieder ein Spielchen zocken, drücke die mittlere Taste und gehe bis zur .d64-Datei. Hier hab ich die Rechts-Taste gedrückt, um mir den Inhalt anzusehen, das hat schon ziemlich lang gedauert und die rechte grüne LED hat dabei sehr schnell geflackert. Dann hatte ich "Mount and Run" ausgewählt. Das hat wieder lang gedauert und die LED hat geflackert. Einmal ist die U auch komplett abgestürzt...
    Was ist das? Hängt das mit U5-Chip zusammen?
    Also bei mir ging mit dem U5-Ausfall gar kein USB mehr, da dort dann die Spannungsversorgung (5V) fehlte. Es wurde erst gar kein Stick mehr gefunden.

    Ich hatte auch schon mal Probleme bei der Ultimate als das Dateisystem auf dem Stick zerschossen war, da hatte die Ultimate auch zu kämpfen und es hat nicht richtig funktioniert auf dem Stick zu zugreifen.
  • Ich würde da ein USB 2.0 Verlängerungskabel zwischentun. Dann kommen die zusätzlichen zweckentfremdeten USB 3.0 Leitungen nicht an und können keinen Schaden anrichten.

    So kann das gefahrlos getestet werden.
    ---
    Meine Github-Projekte: github.com/markusC64/
    1541 Ultimate II Firmware Releases: github.com/markusC64/1541ultimate2/releases
    1541 Ultimate II Update instructions: github.com/markusC64/1541ultimate2/wiki
  • Neu

    Ich sehe gerade, dass die CRT Kompatibilitätsliste auf rr.pokefinder.org/wiki/CRT_ID ergänzt worden ist und jetzt Informationen zur 1541 Ultimate II+ mit Firmware 3.0e beinhaltet.

    Unter "Final Cartridge 3" findet sich "yes (seems broken)". Weiß einer da genaueres, was da nicht gehen soll?
    ---
    Meine Github-Projekte: github.com/markusC64/
    1541 Ultimate II Firmware Releases: github.com/markusC64/1541ultimate2/releases
    1541 Ultimate II Update instructions: github.com/markusC64/1541ultimate2/wiki