IBM PS/2 Experten anwesend? Hilfe bei Model 30 286 benötigt

  • IBM PS/2 Experten anwesend? Hilfe bei Model 30 286 benötigt

    Moin moin,

    ich bin quasi wie die Jungfrau zum Kind an 2 Stück IBM PS/2 gekommen.
    1x Model 30 286 und 1x Model 80 386

    Den 80er habe ich noch nicht getestet. Ich möchte mich erst an dem 30er versuchen.
    Leider gibt es einen Boot Error. Von Floppy bootet er auch nicht. Die Floppy läuft zwar an (LED aktiv), aber rattert nicht.

    Video: Model 30 Boot Error

    Vielleicht kann ja jmd. mal seinen Senf dazu geben.

    Vielen Dank und beste Grüße
  • Also, der Dallas Uhrenbaustein ist leer bzw. defekt, Festplatte wohl i.o. aber logischerweise falsch im Bios konfiguriert. Floppy ist vermutlich unrettbar defekt. Da man das Bios Interface von einer speziellen Diskette laden muss, hänge ich jetzt ersteinmal fest. Schaue ich mir mal das Model 80 an.
  • Die IBM FDD's haben sehr oft ein Problem mit den SMD Kodensatoren. Trotzdem würde ich jetzt nicht gleich den Lötkolben auspacken, sondern zuerst mal den R/W Kopf reinigen und die Laufschienen des Laufwerks reinigen und schmieren. Du weiss ja nicht, wo der Rechner gelagert war, ob's vielleicht eine staubige Umgebung (Garage) war. Von Diskette sollte er eigentlich booten, auch mit falschen CMOS-Einstellungen, denn der Laufwerkstyp 3,5" 1.44MB wird automatisch erkannt. Die Festplatte funktioniert allerdings erst wieder, wenn das CMOS wieder eingerichtet ist. Dazu muss der Dallas repariert werden. Der ist eigentlich immer gesockelt, die Anleitung findest du hier. Die Festplatte ist zwar eine herkömmliche ST-506, hat aber einen ESDI-ähnlichen Konnektor, funktionsfähig sind die Dinger mittlerweile sehr schwer aufzutreiben. Falls die Festplatte auch mit den richtigen CMOS-Einstellungen nicht mehr geht, bleibt als Alternative der Lo-Tech IDE Adapter.

    Wenn du mir den Dallas und eine neue CR2032 zusenden willst, reparier ich ihn dir. Dann bitte PN.

    Nur für den Fall: nicht wegschmeissen, das Ding. Ich habe auch an einem defekten Gerät Interesse.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Hallo,

    ich habe meinen 286 Modell 30 gerade erst vor wenigen Tagen an den Start gebracht, hier das Ergebnis:
    circuit-board.de/forum/index.p…?postID=555185#post555185

    Also Du musst nur den Dallas Mod machen, dann die Systemdisk laufen lassen und damit den PC einstellen. Wenn Deine Floppy platt ist, kannst Du auch ggf. die Floppy von dem 386er nehmen. Das habe ich auch gemacht, ich habe hier noch einen PS/2 i77 stehen.

    Dann einfache eine serielle Verbindung aufbauen und Du kannst die Software von einem anderen PC ziehen....

    Gruß
    S.
    Die Zeiten ändern sich:
    Bei dem C64 war ein blauer Bildschirm noch ein Zeichen dafür, das alles in Ordnung ist....
  • Vielen Dank für die Antworten. Um den Dallas Chip kümmere ich mich, sobald das Floppy Problem gelöst ist. Vielen Dank für das nette Angebot. Im Model 80 befindet sich eine Floppy mit einem anderen Anschluss, Pinsteckerleiste statt Platinenstecker. Die Anschlüsse auf dem MB sind glaube ich nicht kompatibel? Den 80er konnte ich auch noch nicht testen, weil das VGA Kabel nicht passt, es fehlt ein Loch in der Buchse. Dafür habe ich den 30er schonmal gereinigt, sieht jetzt fast aus wie neu. Ich werde als nächstes mal die orig. Tastatur und Monitor zerlegen und reinigen. Daran müsste dann auch der 80er laufen.
  • Ja, das kann man. Bringt ja nur nichts da man den PC nach der Systemdiskette ja neu starten muss. Kann sein das er dann ggf. die Daten noch behält - glaube ich aber nicht (kann mich nicht mehr genau daran erinnern.)
    Man kommt halt nicht weiter, wenn man das "Bios" nicht einstellen kann.

    Zu den Diskettenlaufwerken: es gibt wohl ein Adapterkabel, so das man auch aktuelle Diskettenlaufwerke anschließen kann. Bin da noch am raussuchen und würde es dann auch hier posten....
    Die Zeiten ändern sich:
    Bei dem C64 war ein blauer Bildschirm noch ein Zeichen dafür, das alles in Ordnung ist....
  • Ja, wäre super, wenn du da einen Schaltplan finden würdest. Habe mir auch schon den Wolf gesucht. Ich habe mich mal getraut die Floppy aus dem 80err anzuschließen. Da tut sich überhaupt nix, komplett tot. Wenigstens habe ich den 30er dadurch nich geschrottet, die alte Floppy verhält sich immer noch wie vorher, pure Verzweiflung ;).
  • Hast du dir unter den genannten Links oben eine Referenzdiskette für das Modell 30 runter geladen ? Bootet diese Disktette in einem anderen Rechner bzw. ist sie grundsätzlich in einem anderen Rechner lesbar ? Zwar eine blöde Frage, aber du hast schon F1 gedrückt ?
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Multisync schrieb:

    Hast du dir unter den genannten Links oben eine Referenzdiskette für das Modell 30 runter geladen ? Bootet diese Disktette in einem anderen Rechner bzw. ist sie grundsätzlich in einem anderen Rechner lesbar ? Zwar eine blöde Frage, aber du hast schon F1 gedrückt ?
    hehe, ich habe sogar ein Video im ersten Post wo ich F1 drücke ;) Logischerweise habe ich die Trivialitäten schon durch. Aber trotzdem Danke für den Hinweis.
  • Aktuell ist doch nur die Floppy und der leere Dallas Chip ein Problem. Wie der Dalles wieder flott gemacht wird, ist schon geklärt.
    Fehlt also nur eine passende Floppy, was nicht so einfach ist, da IBM hier einen eigenen Anschluß hat. Die PS/2 IBM haben 40PIN Floppykabel und keinen extra Stromanschluß (heutiger Standard sind 34PIN + extra Stromanschluß).
    Man kann sich ein Adapterkabel bauen, das was ich bis jetzt gefunden habe, ist aber nicht ohne vcfed.org/forum/showthread.php…-faulty-PS-2-floppy-drive
    Die Zeiten ändern sich:
    Bei dem C64 war ein blauer Bildschirm noch ein Zeichen dafür, das alles in Ordnung ist....
  • Ich habe jetzt bei 2 Floppy-Laufwerken, die nicht mehr lesen wollten, die SMD-Elkos getauscht und beide funktionieren wieder. Natürlich gibts noch einige andere Fehlerquellen, wenn ein Laufwerk nicht mehr tut, aber das mit den Elkos ist ein bekannter Fehler und immer einen Versuch wert.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Multisync ()

  • Meine Floppy aus dem 286 Modell 30 lief ja auch nicht. Das Problem war, das die Elkos unter der Schwungmasse/Stator? des E-Motors lagen und als ich den abbauen wollte, sofort die Schraube (auf der Hauptwelle) abgerissen habe - war wohl hochfeste Schraubensicherung drunter. Daher bei der Demontage dort bitte besonders vorsichtig sein ...
    Die Zeiten ändern sich:
    Bei dem C64 war ein blauer Bildschirm noch ein Zeichen dafür, das alles in Ordnung ist....
  • Syntax Err0r schrieb:

    Meine Floppy aus dem 286 Modell 30 lief ja auch nicht. Das Problem war, das die Elkos unter der Schwungmasse/Stator? des E-Motors lagen und als ich den abbauen wollte, sofort die Schraube (auf der Hauptwelle) abgerissen habe - war wohl hochfeste Schraubensicherung drunter. Daher bei der Demontage dort bitte besonders vorsichtig sein ...
    Model 30 FDD hab ich mir grad angesehen. Stimmt, ist unzugänglich. Bei den Alps aus dem Model 60 war's vergleichsweise einfach. An die SMD-Elko's kommt man ran, ohne was abzubauen. Auf der Unterseite der zweiten Platine sind normale Elkos, die hab ich drin gelassen.
    .....................................................................
    I love the smell of burnt aluminum oxide in the morning
  • Syntax Err0r schrieb:

    Meine Floppy aus dem 286 Modell 30 lief ja auch nicht. Das Problem war, das die Elkos unter der Schwungmasse/Stator? des E-Motors lagen und als ich den abbauen wollte, sofort die Schraube (auf der Hauptwelle) abgerissen habe - war wohl hochfeste Schraubensicherung drunter. Daher bei der Demontage dort bitte besonders vorsichtig sein ...
    Ist das ein Mitsubishi oder Alps? Bei meinem Alps sind 3 SMD Elkos nebem dem "Rotor" frei zugänglich.