C16 spricht 1541 nicht an

  • Hoppla, so viel Enthusiasmus :)


    Vielen Dank an alle, v.a. Gerrit.
    Werd am Feierabend mal sehen ob ich Dioden finde und ob die funktionieren :D


    Andere serielle Geräte hab ich leider nicht...

  • Hein09,


    noch ein Test: wenn Du den C16 resettest sollte die 1541 kurz anlaufen (bitte jemd.: Korrektur wenn ich falsch liege). Geht das oder kommt kein Mux von der Floppy?


    Den Weg der Leitungen des seriellen Ports (anhand der Schaltung) mit dem Ohmmeter durchmessen, vom "letzten Pin" bis zum Ausgang der Buchse (heißt: jerweils die längstmögliche galvanische Strecke). Dabei die Meßkabel umpolen: das checkt gleich die eventuellen Dioden.
    Belegung der seriellen Buchse kann ich Dir aus dem Stehgreif nicht nennen. Googeln oder "frag nen Freund".


    Hans

  • ¡Hola!


    @Hans: ja, beim Start rödelt sie kurz, aber danach reagiert sie auf nichts mehr. Hilft dir das irgendwie weiter?


    Hab gerade gecheckt, und ich hab alle drei Dioden.
    Auch mal versucht zu messen, aber iwi keine Ahnung was ich da grad treib :D
    Sicherheitshalber lieber wieder zu gemacht...nehme gerne idiotensichere Hinweise entgegen ;)


    Werd dann die Tage mal Ersatzdioden beschaffen, den Bus ohne zu Testen behagt mir grad auch nicht sehr,
    wenns an denen liegt scheinen sie ja ihren Schutzzweck erfüllt zu haben :D


    Immer noch vielen Dank an alle!

  • nAbend Hein09,


    endlich hab ich mir selbst mal die Schaltung angesehen!
    Sorry, die Dioden kannst Du nicht so testen wie ich es oben beschrieben hatte, da sie nicht in Reihe in der Leitung liegen.


    Ich versuche mal den Schaltungsteil hier reinzusetzen...
    C16-Schaltung 005.tif
    ...sollte geklappt haben. Dieses Blatt (von Commodore) zeigt erst die Schaltung des seriellen Ports vom C64 und darunter die des Plus4 und C16.
    U2 ist die CPU, welche den seriellen Port über 3 i/O- Ports bedient. Beim C64 ist das ganz ähnlich, auch mit den Dioden.


    Ich schlage Dir einen Test bei eingeschaltetem Rechner vor!
    - alle gesteckten IC's ausbauen (auf Alupapier o.ä. lagern)
    - Du brauchst einen Draht mit angelötetem Widerstand 1 KOhm
    - und ein Meßgerät gegen Masse.


    Rechner einschalten, Meßgerät an die serielle Buchse Pin 5, Widerstand von Fassung U2 Pin 30 gegen +5Volt bzw. gegen Masse. Das Meßgerät sollte in einem Fall Spannung anzeigen, im anderen Fall nicht.


    Das wäre die Leitung "Data". Das mit den 2 anderen Leitungen wiederholen testet das IC U7 und alles dazwischen, auch die Dioden.


    Kaputt kann dabei eigentlich nichts gehen, wenn immer der Widerstand zwischen den U2-Pins und +/Masse liegt. Das Meßgerät wird zuerst fest angesteckt und die Pins des U2 nur kurz angetippt.


    Die 3 Ports 28, 29 und 30 der CPU gehen übrigens schnell mal kaputt. So eine "halbdefekte" CPU kann man aber aufheben um damit evtl. mal was anderes zu testen.


    In der Schaltung sind übrigens 4, nicht 3 Dioden eingezeichnet. Vielleicht gibt's ja eine von obiger Schaltung abweichende Variante; kann ich nicht sagen.
    Der Test unter Spannung muß aber in jedem Fall funktionieren. Und weil es 3 unabhängige Leitungswege sind solltest Du gute Vergleiche haben was defekt ist und was nicht.


    Daß die Floppy beim Reset anläuft sagt mir nur daß noch "etwas" von der Verbindung da ist. Evtl. ist das die ATN-Leitung (???).


    Hans