Hello, Guest the thread was called5.8k times and contains 48 replays

last post from walter01 at the

A590 HD extreme Problem

  • Verzeiht mir erstmal meinen Crosspost vom A1k Forum, aber hier sind genug Leute die sich mit dem Amiga auch auskennen und es ist mein Heimatforum.


    Nachdem ich es geschafft habe mittels Amiga Explorer meine WB Disketten zu retten steht schon direkt die nächste Baustelle an.


    Ich habe eine A590 Festplatte mit originaller 20MB XT Festplatte. Diese wollte ich jetzt installieren. Ob sie jemals funktioniert hat weiß ich nicht.
    Sie war bei einem Kauf dabei. Die Original Disketten sind wie immer nicht lesbar. Daraufhin habe ich mir eine ADF besorgt und diese auf eine Diskette kopiert.


    Jetzt fängt das erste Problem an. An einem Emulator kann ich von der Diskette aus starten. Am A500 geht das nicht. Da muss ich das System mit einer WB Diskette starten.


    Ich habe die Dateien PrepHD und Prep-prp, RDSK auf die WB Diskette kopiert.
    Weil er die beiden letzteren Dateien im System Path gesucht hat.


    Die Originale Diskette sollte ja bootbar sein und er hätte die restlichen benötigten Dateien im Path gefunden. Doch dadurch, das ich mit einer anderen Diskette gestartet habe, und diese einen anderen Namen hat konnte er die Dateien natürlich nicht finden.
    Deswegen die Kopiererei.


    Dip Schalter ist der erste auf on und der Rest auf off.
    Im Handbuch steht, das es wegen Autoboot und Kickrom 1.3 ist.
    Wenn ich jetzt PrepHD starte kriege ich den Fehler


    Code
    1. Error -1 on device open!
    2. Attempting to prep the hard disk failed.
    3. Check your hardware and try again


    Würde mich ein anderer fragen würde ich sagen die Festplatte hat das zeitliche gesegnet. Anmerken möchte ich noch, das keinerlei Ram Bausteine auf der Platine sind.


    Jumper für HD steht auf XT
    Jumper Speicher steht auf Amnesia
    DIP1-4 on-off-off-off


    Zur Ergänzung. Ich habe gesehen das das IDE Flachbandkabel falsch herum draufgesteckt wurde. Dieses habe ich berichtigt.


    Jetzt startet der Amiga nicht mehr mit dem DIP Schalter 1 auf ON

    Code
    1. Autoboot Rom, speziell für Kickstart 1.3


    Der Bildschirm bleibt weiss. nach einer langen Zeit startet der Rechner von Diskette. Ich warte jetzt bei PropHD darauf das was passiert.


    edit:


    Bin jetzt einen ticken weiter. PrepHD bestätige ich mit yes und er geht direkt in den Prompt. Passiert also nichts. Bei der HDToolbox ist er jetzt bei Searching XT Device adress 0 unit 0 stehengeblieben.


    Wenn ich den Amiga jetzt starte kriege ich den Fehler not a dos disk in unit 0. Kann den Fehler paar mal wegdrücken und er fängt dann an von Diskette irgendwas zu laden.
    Leider passiert danach nichts. Ich kann CLI Fenster verschieben und sehe den Desktop, aber keine Icons.

  • Wenn du das CLI Fenster wegschiebst, ohne vorher loadwb ausgeführt zu haben, ist die Workbench immer leer. Kann es sein, dass deine A590 Diskette gar nicht bootfähig ist, weil der Bootblock fehlt? Kann man beheben, indem man die Workbench startet und in der shell folgenden Befehl ausführt:


    install df0:

  • Lange ist es her, dass die A590 auch mal hatte....


    Damals ist mir recht schnell das Netzteil hops gegangen und ich hatte die A590 mit einem XT-Netzteil betrieben :) Die olle 20MB HDD war so laut, dass ich immer ein Kissen drauf liegen hatte :)


    Zu deinem Problem:


    Die lange Bootzeit ist sicherlich das Resultat eines Timeouts. Der Controller versucht die HDD zu finden und startet dann durch. Ich weiß nicht mehr, ob sich der Controller auch schon gemeldet hat, wenn du beim Reset beide Maustasten drückst? Probier das mal bitte.


    Stelle auch mal DIP Switch3 auf 0 ... Der gibt der HDD mehr Zeit für den Spin up

  • Doch hat er ,... ;-)
    es ist die original Commodore 20MB / XT Festplatte,..
    die kann man auch nicht auf einen modernem Rechner formatieren,..


    Das A590 kann ja diese Platte (MBF oder s.ä wie die früher hiess).... oder die an dem zweitem Controller Stecker,..


    Diese Festplatten von früher sind zu >90% kaputt... ich habe hier von 3 Stück, zwei Kaputte...
    die, die noch läuft ist aus einem Commodore PC20 wo man auch einen Parkbefehl eingeben kann,..


    Klappt denn der Kontrolle A590 ohne Festplatte als Speichererweiterung überhaupt ??
    Ich meine die Jumper waren doch mehr für die RAM Bausteine oder nicht??


    viel erfolg...

  • Ich versuche gerade mittels der CLI die Workbench manuell zu laden. Dazu mache ich assign mit den benötigten Ordnern.
    Jetzt kriege ich aber immer einen Unable to load Sys:System/FastMemFirst: its not a valid DOS disk Fehler.


    Und wenn ich prepHD von der Diskette starten will, dann will er immer Dateien vom Hauptverzeichnis der Diskette zu laden. Das geht ja aber nicht, weil keinerlei Path Einträge vorhanden sind
    und er anfängt auf dh0: zu suchen und bei deren zugriff er einen Fehler erhält.

  • ide ? wäre es nicht sinniger da einen ide-cf adapter zu installieren ?
    die cf-card kann man dann auch schön auf dem pc einrichten und dann ins amigasystem stecken.


    habs so bei meinem 1200er und 2000er gemacht :)


    gruss

  • ide ? wäre es nicht sinniger da einen ide-cf adapter zu installieren ?
    die cf-card kann man dann auch schön auf dem pc einrichten und dann ins amigasystem stecken.


    habs so bei meinem 1200er und 2000er gemacht :)


    gruss

    An dem Controller läuft kein IDE in dem Sinn, daß man eine CF-Karte daran betreiben könnte !
    Es laufen nur die alten XT-Ide-Platten, also 8-bit IDE .


    CU,


    AC

  • ide ? wäre es nicht sinniger da einen ide-cf adapter zu installieren ?
    die cf-card kann man dann auch schön auf dem pc einrichten und dann ins amigasystem stecken.


    habs so bei meinem 1200er und 2000er gemacht :)


    gruss

    Ist ja schön für dich, aber der A590 hat nur 8-Bit IDE ( XT-IDE ) da kann man mit den IDE-CF Adaptern so gar nichts anfangen. Die extrem teuere Variante am A590 wäre ein SCSI CF Adapter... wenn man den überhaupt bekommt, muss man etwas mehr Geld auf den Tisch legen. Billiger und praktikabler wäre es, die olle XT-Platte rauszuschmeissen und geben eine 4GB SCSI-Platte zu ersetzen. Setzt wimre aber ein aktuelles SCSI-ROM voraus... ist aber relativ leicht zu bekommen.

  • Erkennt die HD Toolbox denn die Platte? So wie ich dein Posting verstanden habe, kannst Du dort ja nichts auswählen, sprioch Program stürtzt ab, bevor du was wählen kannst.


    Was zeigt dir das Programm an, wenn du die A590 absteckst? Zeigt dir die Workbench ein HDD Laufwerk an, wenn du einfach die Workbench per Diskette lädst?
    Was passiert, wenn du die HDD absteckst? Also Flachbandkabel löst? Dann sollte die A590 erkannt werden, aber keine HDD. ISt dem so?

  • Erkennt die HD Toolbox denn die Platte?

    Die Festplatte wird erkannt nach dem ich die Workbench von der Setup Diskette starte. Ich kann bei der HDtoolbox alles einstellen. Nur wenn ich auf speichern klicke passiert nichts mehr.
    Danach kann ich aus dem Programm auch nicht mehr raus. Ich kann die Buttons zwar anklicken aber das Programm wechselt nicht mehr zwischen den Fenstern.

  • Noch mal ein paar Fragen:


    Du hast auch einen Amiga mit Kickstart >= 1.3? (Will nur sicher gehen)
    Dir wird in der HDDToolBox das SCSI.Device angezeigt, um auf die HDD zuzugreifen?
    Du kannst die physikalischen Parameter von der HDD auslesen (CHS)? Nicht das du eine HDDToolbox hast auf der bereits eine andere HDD eingetragen ist und daher deine HDD crashed.

  • Genau. Kickstart 1.3


    Ich starte die HDtoolbox, er sucht die Adressen ab und zeigt mir dann die XT Festplatte mit einer 20 MB Partition an.
    Laut Toolbox hat diese das Fast File System und ist Bootable. Ich kann in diesem Fenster die Parameter ändern und in den Hauptbildschirm zurückkehren.
    Da ist ein Button auf dem Save Config to Hardisk steht, o.ä.


    Nach dem Speichern übernimmt das Programm keine Befehle mehr. Kann rumklicken wie wild und nichts verändert sich.