ACA-500 plus

    • hat schon jemand die v0.99 installiert? Scheint heute released worden zu sein.
      Theorie ist, wenn man alles weiß, aber nichts funktioniert. Praxis ist, wenn alles funktioniert, aber keiner weiß warum.
      Bei uns sind Theorie und Praxis vereint: Nichts funktioniert und keiner weiß warum.
    • meine Karte ist heute nach 2 Wochen hier in Thailand angekommen. Die haben mir echt (nur)7% Mehrwertsteuer draufgeknallt. Dafuer habe ich die 19% in Deutschland gespart. Jetzt habe ich noch keinen Amiga 500 hier. (Sowas kennt hier kein Mensch). Wer noch einen funktionstuechtigen (auch gerne ohne Netzteil ) hat, moege sich bei mir melden. per Mail: thaiwolf2010@googlemail.com oder per Telefon 0066836504880 (billige Vorwahl nehmen)
      Danke Dir Jens nochmal
    • Das hat nichts zu tun mit "traut sich nicht" - es sind noch bekannte Fehler drin, aber jetzt sind wir (mit Lokalisierung und einem 64-Bit Dateisystem im Flash) feature-complete und können uns auf bekannte Fehler stürzen.

      In einer internen Version sind schon wieder zwei weitere Bugs gefixed, und an der deutschen Übersetzung muss ich noch ein paar Dinge um ein paar Zeichen kürzen. Dann müssen wir untersuchen, ob die neuen Einstell-Möglichkeiten auch dann korrekt in alten, gespeicherten Profilen mit default-Werten angezeigt werden. Gerade das Ändern von Datenstrukturen von Version zu Version ist immer kritisch. Wir könnten natürlich die Empfehlung aussprechen "nach dem Update Reset auf factory default ausführen", aber das ist nicht so schön wie die Übernahme von gespeicherten Einstellungen.

      Es handelt sich hier aber wirklich um einen "release candidate"; wenn jetzt nicht noch große Probleme berichtet werden, die ebenso große Umbauarbeiten zur Folge haben, gibt es eine V1.0. Danach kommt die nice-to-have Entwicklung, auf die es auf der HELP-Seite schon einen Hinweis gibt.

      Ich weiß nicht genau, welchen wissenschaftlichen Namen die von uns angewendete Versionierung hat. Grundsätzlich ist es "A-punkt-B", wobei A und B ganze Zahlen, inklusive 0 sind. A ist die "major" und B die "minor" Versionsnummer. Das Übertragen auf eine Dezimalzahl, die sich der 1 annähert, ist nicht korrekt. Als wir angefangen haben, haben wir bei 0.1 begonnen, das ging hoch bis 0.9 und dann weiter bei 0.10. Das sieht auf den ersten Blick vielleicht aus wie ein Rückschritt, ist aber die konsequente Anwendung "Zahl B bei jedem Durchlauf um 1 erhöhen".

      Jens
      icomp.de/shop-icomp - Online einkaufen und offline bei Rewe, Penny, DM und Weiteren im Laden bezahlen.
    • Wiesel schrieb:

      Ich weiß nicht genau, welchen wissenschaftlichen Namen die von uns angewendete Versionierung hat.
      Ich wuerde es die "klassische" Versionierung nennen. Heute gibts ja gefuehlt leider nur noch die OpenSource Versionierung mit der nie erreichten 1.0 und die kommerzielle Versionierung wo nach Projektplant 1.0 draufgeklatscht wird egal welchen Stand die Software hat...
      Acht C64 haben auch 64-Bit...
    • katarakt schrieb:

      Wäre aber völlig ok. Hauptsache es wird deswegen nix vernachlässigt
      Die ACA500plus ist ein sehr erfolgreiches Produkt, und bei den hohen Verkaufszahlen gibt es auch entsprechend hohen Supportaufwand. Den zu reduzieren geht nur, wenn wir Updates liefern, die wirklich Probleme lösen, bzw. die Notwendigkeit reduzieren, eine Anleitung zu lesen. Das ist nämlich das häufigste Problem: Der Amiga ist noch aus einer Zeit, in der man ausführliche Anleitungen lesen musste, bis man eine CF-Karte partitionieren und formatieren kann. Diese Zeit ist heute vorbei; kaum jemand liest noch Anleitungen, die länger sind als ein Tweet.

      Resultat: Es muss einfach funktionieren ohne Einrichtungsschmerzen, sonst ist es nicht gut. Momentan arbeiten zwei Leute an der ACA500plus Software. Denen könnt Ihr die Arbeit erleichtern, wenn saubere Bugreports kommen. Dazu gehört (bitte!):

      - der genaue Weg zum Reproduzieren eines Fehlers, mit Beschreibung der Config (1200er Turbokarte? Sonstige Hardware? Screenshot der Settings!)
      - eine Gegenprüfung, ob das auch mit einer älteren Version der Firmware auftritt
      - eventuell eine Beschreibung dessen, was "erwartet" wäre, falls es sich um einen Fehler handelt, der nicht "Absturz" ist.
      - eventuell einen Screenshot einer Fehlermeldung

      Und ganz wichtig: Bitte alles zusammen in einer e-Mail verschicken, Anhänge auf sinnvolle Größe reduzieren und KEINEN Link in ein Forum dazu packen. Um einen Bug zu fixen möchte niemand auf Schnitzeljagt gehen.

      danke,
      Jens
      icomp.de/shop-icomp - Online einkaufen und offline bei Rewe, Penny, DM und Weiteren im Laden bezahlen.
    • Ich habe mit der ACA 500 plus in Verbindung mit dem RTC Clock Modul das Problem, dass die Uhrzeit weder nach einem Kalt- noch einem Warmstart gehalten wird. Da ich bereits 3 RTC Module ausprobiert habe, ist ein Defekt des Moduls auszuschließen. Natürlich habe ich neue CR1220 Batterien installiert.

      Das Verhalten zeigt sich in beiden Fällen: RTC im Trapdoor-RAM (A512) und auch auf der ACA. Ist das ein bekannter Bug?