Hello, Guest the thread was called1.8k times and contains 11 replays

last post from x1541 at the

Blauer Pet 2001, Hardwaredefekt

  • Hallo PET-Freunde,


    habe gestern einen blauen PET erworben, der in recht gutem Zustand ist. Leider fehlte schon nach einigen Stunden Betrieb ein Bit im Videobild, so dass man mit dem Rechner nichts mehr anfangen kann X( .


    Kennt jemand das Problem? Weiss jemand welcher Chip hier verdächtig ist?
    Kennt jemand jemanden, der so was beheben kann?


    Ich wäre für jede Form der Unterstützung sehr dankbar.


    Herzlichen Gruß aus Bonn
    Frank


    P.S.: Habe einen 4032, den ich notfalls als "Teileträger" missbrauchen könnte, lieder sind hier die Chips nicht gesockelt.

  • Da ist wahrscheinlich eines der beiden Video-RAMs defekt. Je nach Mainboard Typ sind das 6550 oder 2114 Chips. Letztere gibt es noch für faires Geld zu kaufen, erstere nicht. Du kannst aber bei den 6550 testweise ein oder zwei Chips von der linken Seite her vom System-RAM abzwacken und testweise einsetzen. Wenn dann der Fehler weg ist, interessiert Dich vielleicht meine Video-6550-Adapterplatine (siehe Homepage).

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • Hallo "x1541",


    danke für die schnelle Antwort. Mittlerweile ist der PET gänzlich verstorben :grr: Ich weiss jetzt nicht, was ich damit machen soll. Aüßerlich sieht er fast aus wie neu (insb. keine abgegriffenen Tasten) und ist völlig original.


    Ich würde ihn also schon gerne wiederbeleben. Die Frage ist nur, bekommt man so ein altes Gerät überhaupt stabil oder hat man dann einen Defekt nach dem anderen? Sollte man ggf. einen äußerlich runtergekommenen PET als "Organspender" suchen? Können Sie fachmännisch so ein Teil reparieren? Sonst jemand kompetent?


    .... viele Fragen - ich hoffe dennoch auf Feedback.


    Herzlichen Dank
    Frank

  • Bei meinem 2001er PET (auch blauer Bildschirmrahmen, aber schwarzes Typenschild, nicht ganz so schön wie Deiner) war es ähnlich. Da ist ein RAM Chip nach dem anderen hops gegangen. Ich habe dann sämtliche gesockelten ICs durch moderne ICs bzw. Ersatzplatinen ersetzt. Wenn nötig, kann man auch die Spannungsregler tauschen und einen neuen Kondensator für den Trafo spendieren. Das habe ich mir aber bisher gespart, weil die Kiste jetzt absolut stabil ist. Braucht ja ohne die Original-RAMs und ROMs viel weniger Strom, insofern sind Regler, Trafo und Kondensator viel weniger gefordert.


    Das hier habe ich getauscht, mit Preisen von heute:


    original - Ersatz - Preis
    6502 - 6502 - ca. 5-10 Euro (nur noch Gebrauchtware)
    6522 - 6522 - ca. 5-10 Euro (dito)
    6520 - 6821 - ca. 10 Euro (Neuware Reichelt.de) (2 Stück nötig)
    6540 - meine Adapter
    6550 - meine Adapter


    meine Adapter kosten komplett 45 Euro, da ist einer für 6550 und 6540 im System und zwei Stück für die 6540 und 6550 im Videoteil dabei. Damit ist der PET zwar innen nicht mehr original, aber er läuft absolut zuverlässig, und man hat die noch guten ICs noch sicher auf der Seite.


    Ein paar Bilder wie mein PET mal aussah, bzw. jetzt aussieht gibt es hier:
    http://people.freenet.de/x1541/hardware/petram-p.html
    Die Platinen sind inzwischen alle professionell gefertigt, wie unten zu sehen.


    Reparieren *kann* ich das Gerät schon, nur zeitlich sieht es eng aus. Deswegen mag ich in der Richtung momentan nichts zusagen. Auch ist es ja so dass der Versand diesen Schätzchen immer nicht so gut tut. Ein kompetenter Helfer in der Nähe wäre also wohl gut.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

    Edited 2 times, last by x1541 ().

  • Hallo X1541,


    tröstend, dass Ihnen ähnliches passiert ist. Vielleicht wäre es wirklich das beste,
    den PET mit Ihren Updates wiederzubeleben. Es gäbe sicher auch eine Gelegenheit, das Gerät bei Ihnen vorbeizubringen. Eile habe ich eh keine, bin noch sehr mit meinem TRS-80 Model I beschäftigt, der bislang nicht abgequalmt ist :D


    Was würde denn so eine "Auferstehung" insgesamt ca kosten? Zur Antwort ggf.: frank_seger@web.de


    Nochmals Danke
    Frank

  • Kleiner Tip : Meine Telefonnummer würde ich nicht so unbedingt öffentlich preisgeben.
    Oder hast Du Lust auf ständige Anrufe zwecks Werbung oder sonstigem.
    Man weiß ja nie wer hier so alles unterwegs ist oder welche lustigen Robots dieses Forum nach brauchbaren Adressen und Telefonnummern durchsuchen.
    Die Email-Adresse dürfte schon genügen...


    Editier's halt noch schnell !!

  • Ahhhh! bodensee! Da wohn ich doch, warum hab ich den PET nicht ;)

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • ... so jetzt läuft alles wieder! Defekt waren ROM #4 und ein 74LS244-Buffer. Eingesetzt wurde das Board von Herrn Welte, um das ROM-Problem zu beheben. Das ist wirklich eine tolle Lösung. Der Rechner ist dann zwar nicht mehr ganz original, dafür aber flexibel und stabil. Auf Dauer scheinen die alten ROMs/RAMs ohnehin nicht zu laufen.


    Jetzt kann als nächstes passende Software gesucht werden. Welches Diskettenlaufwerk paßt denn an den alten PET? (8250lp habe ich nicht hinbekommen, oder sind Kassetten vielleicht die authentische Lösung). Bin auch hier für Tipps dankbar.

  • Auf dem Board sind ja BASIC1, BASIC2 und BASIC4 vorinstalliert. Ich hab das hier noch getestet, ausser mit BASIC1 funktioniert eine Floppy (2031 oder SFD1001) einwandfrei. Hier nochmal die Settings, um das richtige BASIC zu wählen:


    Code
    1. DIP switch
    2. 123456789
    3. -------xx main ROM bank $B000-$E7FF, $F000-$FFFF
    4. 00: bank 0 (BASIC 1.0rev)
    5. 01: bank 1 (BASIC 1.0)
    6. 10: bank 2 (BASIC 2.0)
    7. 11: bank 3 (BASIC 4.0)


    (vollständig unter http://people.freenet.de/x1541/hardware/dipswitch.TXT aber da fehlen die BASIC Versionen)


    Wenn die Floppy mit BASIC2 oder 4 nicht geht, dann liegt möglicherweise noch ein weiterer Defekt an einem Portbaustein oder an den Bustreibern vor.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!