Angepinnt XU1541/USB2IEC Installationsanleitung unter Windows 7 64-Bit

  • XU1541/USB2IEC Installationsanleitung unter Windows 7 64-Bit

    XU1541/USB2IEC Installationsanleitung
    unter Windows 7 Home Premium 64-Bit





    Zuerst bitte folgende Dateien herunterladen. Das XU1541/USB2IEC noch NICHT anschließen und auch die 1541 NICHT in Betrieb nehmen!

    Download OpenCBM V0.4.99.97
    GUI4CBM4WIN v0.6.5.1

    Download XU1541 Treiber von zeldin
    Auf der GitHub Seite einfach rechts unten auf Download ZIP klicken. Im Archiv befindet sich der Ordner windrv. Diesen einfach entpacken.



    edit by FXXS: Versionsnummern
  • Installation OpenCBM

    Entpack nun das 7Zip Archiv und starte die Installation von OpenCBM. Folge einfach den Schritten, wie auf den Bilder abgebildet.


    Nach erfolgreicher Installation erscheinen auf deinem Desktop 2 neue Verknüpfungen, CBMXfer und GUI4CBM4Win. Mach nun einen Rechtsklick mit der Maus auf CBMXfer und wähl Eigenschaften im Submenü aus.


    Wähl nun den Karteireiter Kompatibilität und mach einen Haken bei Kompatibilitätsmodus rein. Es sollte automatisch Windows XP SP3 erscheinen. Falls nicht, einfach auswählen.


    Wiederhol die letzten beiden Schritte noch bei GUI4CBM4Win.

    Installation von OpenCBM abgeschlossen!
  • Installation des Treibers für das XU1541/USB2IEC

    Treiber Installation Teil 1:
    Verbinde nun deine 1541 via seriellem Kabel mit dem XU1541/USB2IEC (ich habe dies so gemacht, man kann die Verbindung auch nach der Installation herstellen). Lass deine 1541 aber noch augeschaltet!

    Windows hat ein neues Gerät gefunden und sucht nun automatisch nach dem Treiber.


    Bei mir hat er ihn nicht gefunden und zeigt unter Geräte und Drucker die XU1541 mit einem Warnicon an.


    Mach nun einen Rechtsklick mit der Maus auf XU1541 und wähl Eigenschaften im Submenü aus.


    Wähl im Karteireiter den Punkt Treiber aktualisieren aus.
  • Treiber Installation Teil 2:
    Klick nun im neuen Fenster (siehe Bild) auf Durchsuchen und wähl den Ordner windrv (wie im ersten Beitrag unter Download beschrieben!).


    Windows meldet eine Warnung, daß der Hersteller des Treibers nicht überprüft werden konnte. Bitte klick auf den unteren Menüpunkt, daß du den Treiber dennoch installieren möchtest.


    Glückwunsch, der Treiber wurde nun erfolgreich installiert.


    Unter Geräte und Drucker findest du nun das XU1541 korrekt installiert und ohne Warnicon.


    Wenn du nun die Eigenschaften des XU1541 aufrufst und den Karteireiter Hardware auswählst, sollten die Informationen erscheinen, welche im Bild gezeigt werden.



    Damit wäre die Installation des Treibers abgeschlossen!
  • OpenCBM und die Commodore 1541 in Aktion

    OpenCBM und die Commodore 1541 in Aktion:
    Nun schalten wir die Commodore 1541 ein und starten GUI4CBM4Win. Besondere Einstellungen hab ich nicht vorgenommen! Klick nun auf den Button Status. Unten in der blauen Statuszeile sollte nun die Meldung deines Diskettenlaufwerkes stehen.


    Ich habe nun eine Diskette ins Laufwerk geschoben und habe auf den Button Directory geklickt.



    Kommen wir zum Kopieren eines D64 Images vom PC zur Commodore 1541:
    Beim Klicken auf den Button Browse (linke Seite) öffnet sich ein Fenster und man muss den Ordner/das Laufwerk angeben, wo sich die zu kopierenden Dateien befinden. Anschließend einfach die gewünschte Datei (in meinem Fall war das TURRI1-0.D64) anklicken, so daß sie markiert ist, und dann den Pfeil nach rechts anklicken zum Kopieren.

    OpenCBM fragt nun, ob man die Diskette vorher formatieren möchte. Beim kopieren einer D64 Datei braucht man dies nicht, da die Image (D64) Datei 1:1 übernommen wird. Alte Dateien auf der Diskette werden gelöscht!

    Die 1541 fängt nun an arbeiten! Auf der rechten Seite gibt es eine Log-Ansicht. Dort sollte sich nun was tun.


    Nach ca. 2 Minuten sollte das Kopieren fertig sein. Das neue Inhaltsverzeichnis (Directory) erscheint nun.


    Glückwunsch, die erste Diskette von einem Windows PC zur Commodore 1541 wurde erfolgreich kopiert.
  • FAQ zu OpenCBM und XU1541/USB2IEC:

    Q: Wenn ich eine PRG Datei kopiert habe, reagiert der Treiber bzw. das Diskettenlauf nicht. Woran kann das liegen?
    A: Ich habe festgestellt, daß der Treiber und/oder das Laufwerk den Vorgang (das Kopieren) abschliessen, aber den Auftrag nicht beenden. Keine Sorge, einfach 5-6 Sekunden warten und dann auf Reset klicken. Sollte es immer noch nicht gehen, nochmal 5-6 Sekunden warten. Dann Reset anklicken. Danach geht das Arbeiten wieder. Keine Ahnung, wieso das bei PRG Dateien so ist.

    Übrigens, um PRG Dateien schneller zu kopieren, erstell ich mir eine D64 Imagedatei mit DirMaster und schieb die PRG Dateien einfach rein, speichern, fertig. Dann kopier ich die komplette D64 Datei zur Diskette.

    Link zu DirMaster 3.0


    ... weitere Q&A folgen bestimmt ...
  • Ich drück dir die Daumen.

    Ich habe extra für euch alles Deinstalliert, mit Registry Cleaner die letzten Einträge entfernt und jungfräulich angefangen. Und, die Verbindung klappt bestens. Allerdings benutze ich lieber CBMXfer zum kopieren, da es dort scheinbar schneller geht. Kann aber auch täuschen ^^. Jedenfalls gehen beide Programme einwandfrei bei mir.


    Nachtrag um Doppelpost zu umgehen:
    Ich habe meine Benutzerkontensteuerung standardmäßig deaktiviert. Wer sie aktiviert hat und es zu Problemen kommt, sollte OpenCBM als Administrator eventuell ausführen!
  • Um Verwirrung zu vermeiden würde ich die Versionsnummer oben korrigieren. "V0.6.5.1" gehört allein zu GUI4CBM4WIN, das ist die aktuellste Version. OpenCBM ist bei "V0.4.99.97" oder was auch immer genau bei Spiro als Beta zusammengeklöppelt zu finden ist wenn man sich auf die Suche im Unterholz macht.

    Und CBMXFer ist definitiv das bessere (jüngere, weiter entwickelte) Frontend für OpenCBM, wenn auch nicht sehr viel besser. GUI4CBM4WIN ist doch ziemlich unterentwickelt um nicht zu sagen defekt. Davon abgesehen können beide so eine ganze Menge nicht, was die standardmässigen OpenCBM-Kommendozeilentools erledigen können. Sind als Frontends also eher limitierend für den User.

    Die zeldin-Treiber sind übrigens einfach die normalen weil aktuellen libUSB-Treiber (d.h. signiert, also ohne das lästige Abschaltgeraffel beim Booten) plus USB VID/PID Unterscheidung im .INF File, im Gegensatz zu den unsignierten Treiber-Antiquitäten die sonst so für xu1541/USB2IEC angeboten werden. Siehe auch Wiki: c64-wiki.de/index.php/OpenCBM
  • Auf mein Geweine in der SB gab es eine Antwort.

    Draco schrieb:

    [Heute, 21:04] Draco: ah ja "instcbm xu1541" muss man aufrufen
    :lol23:

    Hat sofort funktioniert ohne weiteres Gefummel.

    Dankeschön Draco. :bussi:

    :lol23:

    Mitwäre das nicht passiert! :prof:
    :syshack: Meine 3D-Drucker Teile auf thingiverse.com/oobdoo/designs :strom:
    Sammlung | 85 Bücher bzw. 24.427 Buchseiten mit Z80/8080 Power
  • GenerationCBM schrieb:

    Um Verwirrung zu vermeiden würde ich die Versionsnummer oben korrigieren. "V0.6.5.1" gehört allein zu GUI4CBM4WIN, das ist die aktuellste Version. OpenCBM ist bei "V0.4.99.97" oder was auch immer genau bei Spiro als Beta zusammengeklöppelt zu finden ist wenn man sich auf die Suche im Unterholz macht.

    Und CBMXFer ist definitiv das bessere (jüngere, weiter entwickelte) Frontend für OpenCBM, wenn auch nicht sehr viel besser. GUI4CBM4WIN ist doch ziemlich unterentwickelt um nicht zu sagen defekt. Davon abgesehen können beide so eine ganze Menge nicht, was die standardmässigen OpenCBM-Kommendozeilentools erledigen können. Sind als Frontends also eher limitierend für den User.

    Die zeldin-Treiber sind übrigens einfach die normalen weil aktuellen libUSB-Treiber (d.h. signiert, also ohne das lästige Abschaltgeraffel beim Booten) plus USB VID/PID Unterscheidung im .INF File, im Gegensatz zu den unsignierten Treiber-Antiquitäten die sonst so für xu1541/USB2IEC angeboten werden. Siehe auch Wiki: c64-wiki.de/index.php/OpenCBM
    Danke für den Hinweis. Ich kann leider in meinen Beiträgen nichts mehr ändern. Müßte also ein Moderator bitte tun.


    Auf mein Geweine in der SB gab es eine Antwort.

    [Heute, 21:04] Draco: ah ja "instcbm xu1541" muss man aufrufen
    :lol23:

    Hat sofort funktioniert ohne weiteres Gefummel.

    Dankeschön Draco. :bussi:

    :lol23:

    Freut mich, daß es bei dir funktioniert :) . Mich wundert es nur, daß ich diesen Schritt nie tun mußte. Woran kann das liegen?
  • RKSoft schrieb:

    Freut mich, daß es bei dir funktioniert :) . Mich wundert es nur, daß ich diesen Schritt nie tun mußte. Woran kann das liegen?

    So ist mir das Denken und RTFM erspart geblieben. :whistling:
    Woran das liegen kann weiß ich nicht. Werde aber noch Win 7 mit 32/64 Bit testen.
    Mitwäre das nicht passiert! :prof:
    :syshack: Meine 3D-Drucker Teile auf thingiverse.com/oobdoo/designs :strom:
    Sammlung | 85 Bücher bzw. 24.427 Buchseiten mit Z80/8080 Power
  • oobdoo schrieb:

    Auf mein Geweine in der SB gab es eine Antwort.

    Draco schrieb:

    [Heute, 21:04] Draco: ah ja "instcbm xu1541" muss man aufrufen


    Habe den Treiber ohne gelbes Ausrufezeichen installiert bekommen unter Win7 64Bit. Aber nur mit den Treibern von zeldin.
    Was noch nicht klappt ist GUI4CBM wegen dem Pluginfehler. Leider zickt instcbm noch rum. :gruebel
    Mitwäre das nicht passiert! :prof:
    :syshack: Meine 3D-Drucker Teile auf thingiverse.com/oobdoo/designs :strom:
    Sammlung | 85 Bücher bzw. 24.427 Buchseiten mit Z80/8080 Power
  • Nachdem alles installiert war und ich diesen blöden Plugin Fehler wieder hatte, habe ich einfach mal so das OpenCBM drüber installiert und schwupps, surrt die Floppy auch unter 64Bit Win7 wie sie soll. :tanz:
    Mitwäre das nicht passiert! :prof:
    :syshack: Meine 3D-Drucker Teile auf thingiverse.com/oobdoo/designs :strom:
    Sammlung | 85 Bücher bzw. 24.427 Buchseiten mit Z80/8080 Power
  • Ace von Heisenberg schrieb:

    Wow. Endlich hat mal einer Eier in der Hose und erstellt ne Anleitung für alle. Respekt und besten Dank dafür.
    Kein Thema! Muss mich ja auch mal revanchieren für eure Hilfen hier. ;)

    oobdoo schrieb:


    Nachdem alles installiert war und ich diesen blöden Plugin Fehler wieder hatte, habe ich einfach mal so das OpenCBM drüber installiert und schwupps, surrt die Floppy auch unter 64Bit Win7 wie sie soll. :tanz:
    Sprich, erst Treiber installieren (von zeldin), danach OpenCBM = es funzt?! Auch wenns komisch ist, aber hauptsache es funktioniert nun. Hoffe, daß wir anderen mit diesem Thema und deren Beiträge helfen können bzw. konnten.
  • RKSoft schrieb:

    Sprich, erst Treiber installieren (von zeldin), danach OpenCBM = es funzt?! Auch wenns komisch ist, aber hauptsache es funktioniert nun. Hoffe, daß wir anderen mit diesem Thema und deren Beiträge helfen können bzw. konnten.

    Werde ich Ausprobieren. Dann allerdings mit einem 32Bit Win 7.

    Hm, ich hatte gedacht man könnte mit XU1541 ein D64-Image von einer Diskette erstellen. :gruebel
    Mitwäre das nicht passiert! :prof:
    :syshack: Meine 3D-Drucker Teile auf thingiverse.com/oobdoo/designs :strom:
    Sammlung | 85 Bücher bzw. 24.427 Buchseiten mit Z80/8080 Power
  • Von Broti den Tip bekommen, DirMaster zu verwenden. Die Version 3 davon greift beim Programmstart auf das XU1541 zu, ebenso wenn ich durch das Disk-Menü mit der Maus fahre.
    Aber beim Batch Processing passiert nix. Wenn ich ein Directory als Text ausgelesen haben will, dann wird zwar ne Datei angelegt, es steht aber nichts drine. ?(

    Nachtrag:
    Wenn DirMaster das als HTML speichern soll, dann wird eine 2k Datei angelegt. Ist aber ohne gelesenen Inhalt. Wärend ich sonst Zugriffe habe, passiert bei "Process" kein Zugriff auf die XU. ?(
    Mitwäre das nicht passiert! :prof:
    :syshack: Meine 3D-Drucker Teile auf thingiverse.com/oobdoo/designs :strom:
    Sammlung | 85 Bücher bzw. 24.427 Buchseiten mit Z80/8080 Power
  • OpenCBM-Support in DirMaster 3 ist sehr rudimentär (wie so vieles in DirMaster 3...), da würde ich mich nicht drauf verlassen. Das Readme selbst listet das als "experimental" auf, von ausgeprägter Stabilität sollte man also nicht ausgegehen.

    Sofern die Verbindung klappt, kann man natürlich D64-Images ziehen. Falls die genannten Frontends Schwierigkeiten machen, einfach per Kommandozeile im OpenCBM-Verzeichnis (insbesondere via "d64copy.exe").