Hello, Guest the thread was called4.6k times and contains 48 replays

last post from alke01 at the

1581 bockt. Was ist Defekt?

  • Hallo ihe Experten!
    Ich habe hier meine 1581 nach fast zwanzig Jahren aus dem Keller geholt und ausprobiert. Das Ergebnis kann man sich denken: sie läuft nicht.
    Grundsätzlich funktioniert mein ebenso alter C64 mit der angeschlossenen 1571 problemlos. Zumindest Laden und Speichern. Formatieren habe ich nicht probiert.
    Schalte ich meine 1581 mit eingelegter Diskette ein, rattert sie kurz - ich schiebe das auf einen hin- und hergeschobenen Schreib-Lese-kopf. Die Disketten drehen sich auch (Schleifgeräusch). Rote und Grüne Lampen leuchten und die Grüne geht schnell wieder aus. Auch ohne eingelegte Diskette rattert das Laufwerk kurz (aber leiser).
    Wenn ich mit 'load "$",8' das Verzeichnis laden möchte, kommt bei einigen Disketten ein >File not found error<, die grüne LED erlischt und die Leuchtintensität der roten LED schwankt - sie blinkt ohne auszugehen.
    Wenn ich dann den Fehlerkanal auslesen möchte, hängt sich der Rechner auf und ist nur mit RUN/STOP+RESTORE wieder zum Leben zu erwecken.
    Bei den meisten Disketten leuchtet jedoch die grüne LED dauerhaft und der Rechner ist blockiert.


    Wenn ich den Fehlerkanal gleich nach dem Einschalten des Laufwerks auslesen will, erscheint die Meldung: "73 COPYRIGHT CBM DOS V10 1581 0 0". Möchte ich den Fehlerkanal noch ein weiteres mal auslesen, blockiert wieder der Rechner.
    Hat jemand eine Idee wo das Problem liegt? Wieso bockt das Fehler auslesen? Grundsätzlich funktioniert es, warum jedoch nicht immer sondern nur ein mal?


    Ich habe das Laufwerk sowohl als einziges, dann als zweites und dann als erstes von zweien probiert - mit identischem Ergebnis (Auch das Kabel mal getauscht). Die 1571 funktioniert jederzeit. Das Netzteil von einer 1541-II wurde auch einmal (erfolglos) versuchsweise mit der 1581 benutzt.

  • GRUNDSÄTZLICH lässt man keine 1581 im Keller liegen. Die nimmt man idealerweise Abends sogar mit ins Bett! :drunk:


    :lol33:


    Ja das sehe ich auch so. :ballon


    Meine 1581 darf nur deswegen nicht ins Bett, weil die 8250Sk viel anschmiegsamer ist, durch die Größe und die Rundungen. :lol27:

  • Lass mich teilhaben. Warum stört die Datasette?

    Vermutlich, weil die 1581 dann glaubt im 128er-Burstmode zu sein, weil die Datasette die eine Leitung stört. Ist wegen dei 1571 die funktioniert nicht unbedingt wahrscheinlich, aber die Datasette testweise abstöpfseln wäre ja trotzdem die am einfachsten zu testende Möglichkeit.
    1581 vs, 1530/31

    Schätzungsweise liegt es an der ATN IN Leitung des seriellen Ports, die von der 1570/71/81 mißbraucht wird. Der C128 ist darauf vorbereitet, der C64 nicht. Man müsste im C64 wohl nur die entsprechende Leiterbahn durchkratzen und dann würde es auch mit Datasette laufen.


    Datasette an/aus - schalter wegen 1581

    Die 1581 braucht den Pin für den Burstmodus am 128er. Der 64er braucht den Pin gar nicht- zumindest im Normalbetrieb. Floppyspeeder könnten den -theoretisch- verwenden, aber der geht im 64er auf den FLAG-Eingang einer CIA. Das macht eine sinnvoll schnelle Abfrage nahezu unmöglich, von daher bezweifle ich daß das jemals genutzt wurde.


    am 128er ist da ein Gatter zwischen, da kann allenfalls die Floppy die Datasette lahmlegen- die Busroutinen sind aber so ausgelegt, daß das normalerweise nicht passiert.
    (...) gemacht hab ich das nicht- bislang hatte ich das eh für eine 'urban legend' gehalten, daß die 1581 streikt, wenn man eine Datasette dran hat. Kommt eventuell auch auf die Version der Datasette an, da gabs ja einige recht verschiedene Schaltungen...

    Einen Thread gefunden, wo das auch wirklich die Datasette die Fehlerursache war: 1581 will nicht mehr...
    und noch einen:

    Super!!! es funzt, ich habe meine Datasette angeschlossen gehabt. Ich die Data rausgezogen und es läuft.
    (...)
    Es schein wirklich an der Datasette zuliegen.

    und die Datesette funktioniert dann auch nicht unbedingt:

    Bei mir war das Problem, wenn ich die Floppy 1581 drann hatte funktionierte die Datasette auch nicht. Ich hatte damals einem Pin im Floppyladekabel entfernt. Weis jetzt aber nicht mehr welchen.


    sl FXXS

  • alke01, Du rettest mir den Tag! Ein fettes :thnks: dafür!
    Ja, Datasette-Kabel raus und schon läuft die Kiste! Daß ich von den bisher knapp zehn getesteten Disketten nur bei einer das Inhaltsverzeichnis auslesen kann, liegt wohl eher an den Disketten als am Laufwerk. Erstaunlich: die gleich alten 5,25" Disketten sind nach >20 Jahren in der Regel wesentlich besser erhalten als die alten 3,5 Zoller. Hätt' ich nicht gedacht.


    Hurra! Ich bin glücklich! :juhu:


    Weiß vielleicht noch jemand ob ich auch HD-Disketten nutzen kann? Bei den 5,25"-Laufwerken für den C64 geht das ja nicht, aber beim 1581...? Woher kann man denn heute noch 3,5" DD's bekommen?
    Was meint ihr; lohnt es sich die alten 3,5" Disks zu formatieren um sie zu nutzen, oder sind nicht nur die Daten sondern auch die Beschichtung hin?
    Hier habe ich das auch schon einmal gefragt, nachdem der dort gemeldete Quelltext super für einseitige 5,25"-Disketten funktioniert: wie kann man denn einzelne Sektoren bei einer 1581 überprüfen und dann ggf. auch einzeln auslesen/kopieren (auf ein anderes Laufwerk)?


    Schöne Grüße aus dem sonnigen Norden
    ajunra

  • Hallo ihr, zu früh gefreut... :cry
    Erstmal: zumindest ich mache in Foren KEINE Aprilscherze. Ich denke daran, daß spätere Hilfesuchenden ja nicht auf das Datum sondern auf den Text achten - und ich gehe von mir aus: Ich möchte meine Zeit und u.U. mein Geld nicht in einen blödsinnigen Aprilscherz stecken!


    Also das Laufwerk kann im Moment leider nichts mehr lesen. Selbst die eine Diskette die es heute Morgen noch erkannt hat, wird nicht mehr gelesen. Es kommt ein: ?file not found mit 74 drive not ready 40 0. Seltsam ist aber, daß ich es auch schon geschafft habe das Verzeichnis einer Diskette genau ein mal auszulesen. Andere Diskette rein, LOAD "$",9 und es kommt wieder die oben genannte Meldung - ggf. auch nur ein >74 drive not ready 0 0<. Dann wieder die eben gelesene: Auch nur eine Fehlermeldung. Also absolut unzuverlässig; mehr defekt als ganz.


    Aber das Auslesen des Fehlerkanals blockiert ohne Datasette wenigstens nicht mehr den ganzen Rechner. Nun scheint das Problem am Laufwerk zu liegen.


    Wäre ein Defekter elko ein möglicher Grund? Das Laufwerk (Mechanik) selber ist - im Gegensatz zu den 5,25"-Laufwerken - ziemlich gekapselt und schwierig auseinander zu nehmen. Eine Kopfreinigung (hab' ich letzte Nacht versucht) ist recht schwierig. Die Gleitstange auf die der Kopf hin- und hergeschoben wird, habe ich gefettet. Allerdings weiß ich nicht ob und wie ich den Diskettenantrieb schmieren kann.
    Vielleicht kennt sich ja doch jemand mit den 1581er aus...
    Ich habe übrigens die Seriennummer 000255. :)


    P.S. Ich habe noch nie einen Lötkolben benutzt... :(

  • Lass mich teilhaben. Warum stört die Datasette?


    Weil
    a) beim C64 die SRQ-Leitung vom seriellen Bus nicht von der RD-Leitung der Datasette entkoppelt ist (anders als beim 128er!)
    b) einige Datasetten-Modelle die RD-leitung im inaktiven Zustand nicht offen lassen, sondern auf einen festen Pegel legen und
    c) die 1581 (angeblich, und die 1571 angeblich nicht) dadurch bei der Burst-Mode-Erkennung ins Straucheln kommt.