Hello, Guest the thread was called9.4k times and contains 34 replays

last post from Bazong at the

Cortex in externem Gehäuse -> Probleme

  • Habt ihr da evtl. noch einen Tip für mich?


    Miss mal im Betrieb die 5 Volt an der USB Buchse des Gotek. ;)


    Hintergrund.
    Das Gotek wird mit 5 Volt betrieben, die 1:1 an die USB Buchse weitergegeben werden.


    Schließt man ein Gotek extern an kann es passieren, das an der USB Buchse die Spannung grenzwertig ist.
    Dieses Problem gibt es teilweise sogar bei intern verbauten Goteks wenn die Spannung nicht stimmt.

  • Am besten die 12 Volt nehmen, einen 5 Volt Regler dazu und die gibst du auf den USB Port des Gotek.


    Alternativen.
    Einen sparsameren USB Stick probieren.


    Größere bzw. kürzere Zuleitung zum LW und 100nf+470µf von Pin 1 auf Pin 4 der USB Buchse legen.


    Ein A500 Netzteil nehmen was am oberen Ende der Toleranz liegt.


    Das ganze kann man natürlich auch kombinieren.

  • So....ich habe nun nochmal ein paar Tips befolgt, aber leider bisher keinen Erfolg gehabt.


    Ich habe die SELECTOR.ADF nochmal neu auf den Stick aufgespielt, habe einen paar andere Sticks ausprobiert und das Kabel gekürtzt. Desweiteren habe ich auch nochmal die Spannung am USB-Port gemssen -> 4,8 Volt.


    Vielleicht ist mein Kabel ja auch falsch belegt? Ich habe die Belegung von Salator auf Seite 1 genommen. Ist das wirklich korrekt für eine externe Floppy als DF1?

  • Desweiteren habe ich auch nochmal die Spannung am USB-Port gemssen -> 4,8 Volt.


    Ich vermute da hast du dein Problem, das ist so gerade noch im grünen.


    Wenn du jetzt etwas auf dem Stick speicherst wird noch mehr Strom benötigt und schon hat der ein Problem.
    Oder besser gesagt du. :drunk:


    Da reicht auch nur der Bruchteil einer Sekunde, also das was ein normales Multimeter nicht messen könnte.

  • Also ich habe ja den Bootselector-Umschalter. Das Kabel funktioniert bei mir so.
    In Normalstellung kann ich vom internen Floppy booten und der Gotek ist als DF1 nutzbar. Booten von DF1 und Images in die Slots legen kann ich am A500 natürlich nicht.
    In Umschaltstellung ist der Gotek DF0 und bootfähig, das interne Floppy wäre theoretisch DF1 wenn das Motorsignal am Kabel anliegen würde (ohne Motorsignal lässt es sich nur unter Xcopy nach Klick auf "Drives on" nutzen)


    Der Wechsel im Kabel von _SEL1 auf _SEL0 ist technisch vermutlich nicht korrekt. Ich habe das nur so gemacht um nicht mit der Jumper-Einstellung experimentiern zu müssen und weil ich ohnehin kein weiteres Laufwerk anschließenn will. Der Gotek wird am Kabel genau so angeschlossen wie intern.



    @Booten von DF1 am A500: Gibts da vielleicht irgendwas, was man auf die Disk in DF0 packen kann und was dann die Boot-Sequenz auf DF1 aufruft?

  • Also die Spannung kann ich inzwischen auch ausschließen. Ich habe das Gotek mit der externen Datenleitung, aber mit der internen Stromversorgung angeschlossen. Da das Laufwerk als internes Laufwerk einwandfrei funktioniert, und bei diesem Versuch der Fehler jedoch bleibt, gehe ich von einer korrekten Spannungsversorgung aus.


    Eigentlich bleibt jetzt nur noch ein Problem mit der Verkabelung. Wohlmöglich stimmt etwas mit der SELn Verkabelung nicht, so das die Firnwareversion nicht sauber ausgelesen werden kann....oder weiß was ich.....
    Wenn man nicht in den SELECTOR will funktioniert das Mistding auch als DF1 einwandfrei. Ich habe das Laufwerk nochmal intern angeschlossen, ein paar Slots belegt und ein paar Demos geschaut.

  • Kabel kürzen und Spannungskram messen hätteste dir sicher sparen können. Denn grundsätzlich läuft es ja, das booten von der selector.adf etc. nur eben am Ende des Vorgangs passt 'was nicht (überein), wie du ja auch schon vermutest. Also ist es unwahrscheinlich, dass es an z.B. der Kabellänge liegt.


    Man sollte es als Spielerei betrachten, so'n "China Kram" bzw. die selfmade Firmware. Manchmal denke ich, dass manche(nicht du) zu viel von sowas erwarten.

  • Hi, ich hatte auch vor das gotek in ein externes laufwerk zu packen und dann am 500'er und 600'ter zu nutzen.


    Am 500'er habe ich auch das Problem das wenn ich mit bootselector arbeite mir das komplette dateisystem auf dem stick zerschossen wird.
    Desweiteren habe ich mit meinem 9 pol auf usb adapter für die maus das problem das ich nicht dauerhaft die Maustasten drücken kann und somit den 600'er nicht in dem Bootmenü starten kann.


    Deshalb hab ich diesen plan mal bis auf weiteres verworfen. Wäre halt schön gewesen den gotek extern für beide rechner nutzen zu können.
    Ich habe jetzt die internen leitungen nach aussen gelegt und der gotek wird auf den rechner gelegt.


    Die frage wäre auch ob es für den 600'er auch so einen bootselector gibt (Hardware ) dann würde ich mal weiter testen mit einem anderen externen Gehäuse ob der gotek dann funktioniert.


    Gruß


    Stones

  • Die frage wäre auch ob es für den 600'er auch so einen bootselector gibt (Hardware ) dann würde ich mal weiter testen mit einem anderen externen Gehäuse ob der gotek dann funktioniert.

    Soweit ich mich informiert habe, kann man auch am A600 eine entsprechenden Umschalter anbauen. Allerdings ist die OP wohl nicht reversibel, da hierfür Leiterbahnen auf der Platine aufgetrennt werden müssen. Außerdem ist die Lötarbeit aufgrund der SMD Bauweise im A600 wohl nicht ganz trivial. Ich habe mich inzwischen auch von der Lösung verabschiedet. Das Gotek und der A600 werden bei mir wohl keine Freunde mehr :(

  • ich muss mich jetzt hier mal reinpressen, auch wenns jetzt kurz weh tut, aber:


    1. Bedeuted DF0 und DF1 sowas wie Master und Slave beim IBM PC ??
    2. Wird gebootet nur über DF0 , also sucht der amiga immer nur nach DF0 gejumperte FDDs um von dem zu booten ?
    3. über den breiten ext. connector wie oben abgebildet >> kann ich da auch DF0 gejumperte Laufwerke connecten um von diesen zu Booten, also extern ?
    4. muss ich dieses DF0 jumpern intern auf der amiga platine machen oder immer am LW selbst ?? (sorry die Frage sollte eigentlich der erste Punkt sein)


    ich muss kurz anmerken dass ich bisher nur mit herkömmlichen PCs zu tun hatte und hoffe , irgendjemand hier kann sich hier für mich erbarmen und für mich
    dolmetschen :whistling:

  • 1. Nein (nicht wirklich) ;)
    2. Ja
    3. Ja, siehe weiter in Punkt 4
    4. Am Amiga mit dem Basteln eines Amiga500 Bootselector (google), siehe ciruitboard Forum


    Das Gotek muss ebenfalls immer als DF0 gejumpert sein ("S0", statt "S1" Jumper setzen). (Wie es sein würde, wenn sollte man es als DF1 extern als DF1 betirebt weiß ich nicht. Aber das macht ja eh kaum meiner.)

  • Hi,
    ich habe dasselbe Problem wie Salator: Am A500 mit HW-Bootselektor (siehe Mingos Seiten) kann ich ein Gotek (mit HcX firmware) und ein internes LW umschalten, booten usw.
    Boote ich über Diskette (DF0), sehe ich in der WB DF1 (Gotek).
    Boote ich über Gotek (DF0), siehe ich kein interne LW mehr. Nur der Trick mit Xcopy und "Drives On" funktioniert.


    Herumsuchen deutet auf ein fehlendes Motor-On Signal hin, das man wohl mit einiger TTL-Logik erzeugen müsste - umgesetzt scheint das aber noch niemand zu haben, oder?