Hello, Guest the thread was called1.4k times and contains 2 replays

last post from for(;;) at the

Fe3v0.9 sd2iec does not work, but normal sd2iec does.

  • Hi,

    I finally got to assembling my FE3 version 0.9! Yeah!

    When I boot the VIC 20 I get the normal VIC 20 screen. When I insert a FAT16 formatted SD card, the green LED pulses. Next I try to LOAD"$",8, but there is a device not found error. The same happens when I use device numbers 9, 10 and 11.

    Strange, because when I connect a SD2IEC device (http://www.sd2iec.co.uk/id14.html), I can read the contents of the SD card.

    What can be wrong? I checked the connections to the serial connector twice with a multimeter. I also experimented with the jumpers, but maybe I do something wrong with them. What would the correct jumper settings be? I also tried changing the 3.3V and 5V CLPD jumper...

    The ICs have no label sticker on them,so I do not know hat version is on them...


  • I also tried changing the 3.3V and 5V CLPD jumper...

    Very bad idea! The CPLD is most likely a 3.3V chip and 5 Volts may fry it.

    Double check the SD card slot solder joints. They seem to be the cause of troubles in most cases.

    Measure the resistance between the SD card slot pins (above the solder joint) and the AVR controller. It should be the resistance of one of the two resistors of the voltage divider.

    If these are okay, check that you did not swap the resistors of the voltage divider.

    Also check your 3.3V regulation.