IEC-ATA blockiert, macht aber nichts

  • IEC-ATA blockiert, macht aber nichts

    Hallo an alle,

    ich habe den IEC-ATA V2.1 mit NLQ-HD
    V0.52 als Firmware und bis heute früh ging alles super. Dann habe
    ich die platte ausgebaut und am PC per USB angeschlossen um SID Files
    zu Speichern. Beim Rückbau der Festplatte , verhält sich das teil
    seltsam. Ich habe kein Floppylaufwerk angeschlossen und will
    load"$",8 eingeben (,8 ist iec-ata) steht am Bildschirm
    loading da, passiert aber nichts. Ich lasse das IEC-ATA
    angeschlossen, mache aber Strom aus und schalte mein Laufwerk (,9)
    ein. Floppylaufwerk geht super, jetzt schalte ich wieder IEC-ATA ein,
    schon kann ich auch mein Floppylaufwerk nicht mehr ansprechen. Beim
    einschalten geht die Grüne LED an und nach kurzer zeit wieder aus.
    Kürze zeit hatte da mal die Rote LED schnell aufgeblinkt, aber jetzt
    kommt die rote LED gar nicht. Gibt es da eine RESET Möglichkeit ?
    Bis auf IC6 habe ich alle IC ausgetauscht. Ist aber das gleiche. IC6
    habe ich leider kein. Auf der Festplatte ist keine .d64 oder versteckte datein, habe ich hier schon gelesen. Was kann ich noch machen?

    So :drunk: und ab ins :zzz: :thumbsup:
    Ich schreibe langsam, weil ich weiß, dass du nicht besonders schnell lesen kannst :thumbsup:
  • Habe was gefunden:

    es ist der Fehler "73,...", hier wird der Bus blockiert.


    Dafür sind diese befehle gedacht:
    -ui, uj = reset (open15,8,15,"ui") (das aktuelle Directory bleibt erhalten)
    -aui = additional ui = reset (open15,8,15,"aui") (das aktuelle Directory wird zurückgesetzt)


    Kann ich aber noch nicht testen. Da wird der AVR neugestartet bzw. aktive Buffer zurück gesetzt.
    Habe ich das richtig verstanden ? ?(
    Ich schreibe langsam, weil ich weiß, dass du nicht besonders schnell lesen kannst :thumbsup:
  • Versuche mal eine andere Festplatte am C64 mit den Proggis von NLQ neu einzurichten. Wenn danach wieder alles in Ordnung ist, hat es wohl die Struktur zerschossen, als du die Platte am PC angestöpselt hast.

    Ich hatte das auch mal bei meiner IEC-ATA- Allerdings war da noch die Dienstagstreff-Firmware drauf. Mit der NLQ-Firmware hatte ich das Problem noch nicht.
  • Habe eine neue Festplatte Formatiert (FAT32) und am C64 angehangen, leider das gleiche. Auch diese befehle bringen nicht.
    Da scheind das problem zu sein "hd74ls244p", ist der Ic drausen gehen die anderen geräte wieder.
    Es ist auf der platine noch eine stelle für ein Resetschhalter, wofür ist der?
    Mir gehen die Ideen aus :böse
    Ich schreibe langsam, weil ich weiß, dass du nicht besonders schnell lesen kannst :thumbsup:
  • Totgeglaubte leben länger!

    Habe jetzt gerade nochmal flashen können ??? Festplatte kann es nicht sein, habe die alte Festplatte angehangen.
    Ich hatte nur diesen Octal Buffers "hd74ls244p" kurz raus und wieder eingebaut. Warum ich wieder flashen musste, verstehe ich auch nicht.
    Können die RESET befehle das verursacht haben?

    Hauptsache es geht wieder :thumbup:
    Ich schreibe langsam, weil ich weiß, dass du nicht besonders schnell lesen kannst :thumbsup:
  • Hd Has Problems With Identify Drive Command

    Habe jetzt die Festplatte Formatieren wollen und nun das:

    SENDING IDENTIFY DRIVE COMMAND
    78,SYSTEM ERROR,86,00

    - 4 verschiedene Festplatten angehangen, alle als "MASTER" (2 x 20GB ,1 x 80GB, 1 x 160 GB)
    - am PC fat32 Formatiert, LED blinkt (rot)



    Rest der Log:
    00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
    0000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0040: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0050: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0060: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0070: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0080: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0090: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00A0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00B0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00C0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00D0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00E0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00F0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0100: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0110: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0120: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0130: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0140: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0150: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0160: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0170: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0180: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    0190: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    01A0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    01B0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    01C0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    01D0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    01E0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    01F0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

    HD HAS PROBLEMS WITH IDENTIFY DRIVE COMMAND
    Ich schreibe langsam, weil ich weiß, dass du nicht besonders schnell lesen kannst :thumbsup:
  • Habe jetzt die Festplatte Formatieren wollen und nun das:

    SENDING IDENTIFY DRIVE COMMAND
    78,SYSTEM ERROR,86,00
    Der AVR sendet das IDENTIFY DRIVE COMMAND an die HD. Daraufhin muss die HD das Data-Request-Bit aktivieren. Dies macht die HD bei dir nicht. Enweder kommt das Kommando nicht bei der HD oder die Antwort der HD nicht beim AVR an. Das IDENTIFY DRIVE COMMAND ist das erste Kommando überhaupt. Somit denke ich, dass durch das Umstecken irgendetwas an der IEC-ATA-Hardware beschädigt wurde; ich weiß aber auch nicht was.
  • Benutzer online 1

    1 Besucher