Hello, Guest the thread was called1.9M times and contains 21439 replays

last post from strik at the

Heute so gebastelt ...

  • Hab mir genau das Teil von dieser Page zusammengebraten. d64 erstellen verbirgt sich hinter dem "DAD"-Button.

    👍

    Auf der anderen Seite ist eine andere Hardware beschrieben, zusammen löten ist leider nicht so mein Ding.
    Ein Rechner weniger am Schreibtisch ist für mich schon viel Wert, wenn ich von einem viel zu wenig habe, dann ist es Platz.
    vielen Dank für die super Infos.
    manfred.moser könntest Du bitte mal testen ob es mit Deinem Bausatz auch funktioniert. Wäre gut für mich zu wissen.

    Mit freundlichen Grüßen

    Markus

    Irgend wie wird hier das RAD immer wieder neu erfunden?! Einfach einen Arduino mit Atmega32u4 nehmen Firmware drauf flahen und die paaa kabel direkt anlöten! Ich habe davon bestimmt 30 Stk gebaut! Wenn man dann noch die 9 Datenleitungen für ein Parallelkabel drann macht. Kopiere ich dir eine Diskette in ca. 20 - 30 Sek.

  • Dann Bau doch ein 31. und verkaufs ihm zum fairen Preis.

  • Ich bau nix mehr für andere. weil viele oft undankbar dann sind!

    Aber hier habe ich gerade auch das Thema gefunden Zoomfloppy mit günstigem Teens device!


    Ein stück weiter unten ist alle beschrieben!

  • Irgend wie wird hier das RAD immer wieder neu erfunden?! Einfach einen Arduino mit Atmega32u4 nehmen Firmware drauf flahen und die paaa kabel direkt anlöten! Ich habe davon bestimmt 30 Stk gebaut! Wenn man dann noch die 9 Datenleitungen für ein Parallelkabel drann macht. Kopiere ich dir eine Diskette in ca. 20 - 30 Sek.

    Hi, das ist schön das es für Dich so einfach ist, ich hab da leider nicht so die Kenne. Allerdings will ich von der Lösung mit dem parallel Kabel weg, so kopier ich die zZ selber. Da aktuelle Rechner keinen parallel Port haben interessiert mich eine Lösung per USB.

  • Irgend wie wird hier das RAD immer wieder neu erfunden?! Einfach einen Arduino mit Atmega32u4 nehmen Firmware drauf flahen und die paaa kabel direkt anlöten! Ich habe davon bestimmt 30 Stk gebaut! Wenn man dann noch die 9 Datenleitungen für ein Parallelkabel drann macht. Kopiere ich dir eine Diskette in ca. 20 - 30 Sek.

    Hi, das ist schön das es für Dich so einfach ist, ich hab da leider nicht so die Kenne. Allerdings will ich von der Lösung mit dem parallel Kabel weg, so kopier ich die zZ selber. Da aktuelle Rechner keinen parallel Port haben interessiert mich eine Lösung per USB.

    mit Parallelkabel meint cmc1976scs die parallele Verbindung XUM1541 zur Floppy. Auf PC-Seite wird via USB verbunden. Das ist ja der Vorteil :)

    "Was heute noch wie ein Märchen klingt,kann morgen Wirklichkeit sein.Hier ist ein Märchen von übermorgen.Es gibt keine Kupferka­bel mehr,es gibt nur noch die Glasfaser und Terminals in jedem Raum.Man siedelt auf fernen Rech­nern.Die Mailboxen sind als Wohnraum erschlossen.Mit heute noch unvorstellbaren Geschwindigkeiten durcheilen Computerclubs unser Da­tenverbundsystem.Einer dieser Com­puterclubsist der CCC.Gigantischer Teil eines winzigen Sicher­heitssystems,das die Erde vor Bedrohungendurchden Gilb schützt.Begleiten wir den CCC und seine Mitglieder bei ihrem Patrouillendienst am Rande der Unkenntlich­keit. CCC'84 nach ORION'64"

  • mit Parallelkabel meint cmc1976scs die parallele Verbindung XUM1541 zur Floppy. Auf PC-Seite wird via USB verbunden. Das ist ja der Vorteil :)

    Ich sag ja, ich hab davon nicht die Kenne 😁 bin mehr Anwender als das ich die Hintergründe der Elektronik verstehe, auch gehört das Löten nicht zu meinen Spezialgebieten, daher würde ich so ein Teil lieber erwerben als selber bauen. 😉

  • Grad nochmal geschaut, ich hatte einen Pro Micro verwendet, an den einfach das IEC-Kabel angelötet wird


    Am schönsten fände ich eine Variante ohne Kabel, wo der Stecker so angebracht ist das man die Platine (im Idealfall im Gehäuse) direkt in die Floppy steckt und dann nur noch das USB Kabel anschließen muss. zB so eins wie es bei Druckern verwendet wird. Aber das ist eigentlich auch nur ein optimaler Design Wunsch, solange es funktioniert wäre ich ja schon zufrieden (da ich keine Ahnung habe wie man Platinen herstellt und ja auch nicht löten kann, eine Gehäusedatei könnte ich ggf. erstellen, sollte ich auch zufrieden sein mit dem was ich bekommen kann 😁)

  • Suchanzeige hier im Marktplatz aufgeben.

    Konfuzius sagt…Hüte dich vor Männern, deren Bauch beim Lachen nicht wackelt.

    Es ist keine Schande, nichts zu wissen, wohl aber, nichts lernen zu wollen.


    --------------------------------------------------------------------------------------------------------------------------

  • 👍

    Auf der anderen Seite ist eine andere Hardware beschrieben, zusammen löten ist leider nicht so mein Ding.
    Ein Rechner weniger am Schreibtisch ist für mich schon viel Wert, wenn ich von einem viel zu wenig habe, dann ist es Platz.
    vielen Dank für die super Infos.
    manfred.moser könntest Du bitte mal testen ob es mit Deinem Bausatz auch funktioniert. Wäre gut für mich zu wissen.

    Mit freundlichen Grüßen

    Markus

    So, ich hab jetzt eins der XU1541 getestet. Es hat eine Weile gedauert, bis ich es ans laufen gebracht habe, aber inzwischen geht es einwandfrei.


    Es gab meherere Dinge zu lösen.

    1. Die Firmware auf dem ATMega8 musste korrekt installiert werden. Da die Platine keinen ISP-Header hat, musste ich den AT-Mega im TL-866 programmieren.

    Die Firmware ohne Bootloader zu flashen hat nicht funktioniert, da dann kein USB-Gerät am PC erkannt wurde.
    Ich kam dann darauf, wie es geht. Den Bootloader mit dem TL-866 auf den Chip, dann den Treiber in Windows installieren, anschließend kann man die eigentliche Firmware über USB mit dem Update-Tool von opencbm flashen.

    Darauf muss man aber erst mal kommen.

    2. Der Treiber auf dem Windows10-X64 musste installiert werden. Mit dem Zadig-Treiber als libusb-win-32 hat es dann geklappt. Der Treiber aus opencbm hat bei mir nicht korrekt funktioniert.

    3. opencbm musste korrekt installiert werden. Ich hatte zuerst immer einen Plugin-Fehler, bis ich den Hinweis hier im Forum gefunden hatte, dass man den Befehl "instcbm xu1541" aus dem Verzeichis ...\opencbm\amd64 heraus aufrufen muss. Erst dann war der Plugin-Fehler weg und es hat dann funktioniert.


    Mit dem XU1541 kann ich jetzt D64-Images vom PC auf reale Disketten schreiben oder auch umgekehrt. Das ganze habe ich mit den Programmen "Gui4cbm4win" und auch mit dem etwas komfortableren "CBMXfer" durchprobiert.

    Focko : Falls Interesse an einem XU1541 besteht, dann bitte eine Konversation starten. Ich kann Dir eins zum Selbstkostenpreis abgeben.


    Hab 5 Stück gebaut, es fehlen aber noch die 6-poligen IEC-Buchsen. Bei meinem Testgerät hab ich ein IEC-Kabel direkt an die Platine gelötet um es testen zu können. Das geht natürlich auch.

  • ... oder versuche es mal bei ebay-Kleinanzeigen oder quoka, das sind Flohmärkte.

  • Hast Du das Gehäuse irgendwie vorbereitet (ausser gut geputzt...), also angeschliffen, oder gar gespachtelt oder so?

    Nur mit einem feinem Schleifschwamm das Gehäuse angeschliffen.

    Welche Farbe hast Du genommen?

    Acryl Lack "Enzianblau"


    Ich hätte da persönlich Sorge wg. der langfristigen Verträglichkeit, daher wäre es toll, wenn Du weiter berichtest, wie es Dir mit dem Teil

    ergeht.


    Auch so Dinge, wie die Reinigung, wenn es mal wieder einstaubt etc.

    Ja, das wird sich noch zeigen, ob die sich die Farbe durch die Zeit verändert bzw. ob ich vielleicht doch eher noch eine Versiegelung aufbringen sollte.

    LG
    znarF

  • 1. Die Firmware auf dem ATMega8 musste korrekt installiert werden. Da die Platine keinen ISP-Header hat, musste ich den AT-Mega im TL-866 programmieren.

    Die Firmware ohne Bootloader zu flashen hat nicht funktioniert, da dann kein USB-Gerät am PC erkannt wurde.

    Richtig, der Bootloader enthält den USB-Code. Ohne den funktioniert nichts.

    Ich kam dann darauf, wie es geht. Den Bootloader mit dem TL-866 auf den Chip, dann den Treiber in Windows installieren, anschließend kann man die eigentliche Firmware über USB mit dem Update-Tool von opencbm flashen.

    Darauf muss man aber erst mal kommen.

    Wenn dein TL-866 in der Lage ist, etwas zu flashen, ohne den Chip vorher zu löschen, ist es ganz einfach:

    1. Bootloader flashen (mit Löschen)
    2. Firmware flashen (ohne Löschen)

    Falls das nicht geht kann man auch ein HEX-File erzeugen, welches beides (Firmware und Bootloader) enthält: Einfach die Ende-Kennung der Firmware entfernen (letzte Zeile) und dann firmware.hex und den Bootloader hintereinander in eine neue Datei kopieren. Aber da muss man erst einmal drauf kommen.


    2. Der Treiber auf dem Windows10-X64 musste installiert werden. Mit dem Zadig-Treiber als libusb-win-32 hat es dann geklappt. Der Treiber aus opencbm hat bei mir nicht korrekt funktioniert.

    3. opencbm musste korrekt installiert werden. Ich hatte zuerst immer einen Plugin-Fehler, bis ich den Hinweis hier im Forum gefunden hatte, dass man den Befehl "instcbm xu1541" aus dem Verzeichis ...\opencbm\amd64 heraus aufrufen muss. Erst dann war der Plugin-Fehler weg und es hat dann funktioniert.

    Falsche Reihenfolge.

    Neuere OpenCBM (>= 0.4.99.103) installieren den Treiber automatisch. Die aktuelle Version hat noch ein Problem mit dem Update der Treiber, wird aber in der kommenden behoben sein.

    Der Install-Befehl lautet: "instcbm xu1541" (aus dem Hauptverzeichnis); es sucht dann die passende Version (i386 oder amd64) heraus, erzeugt einen schönen Eintrag in "Software" zum Deinstallieren und installiert am Ende, wenn gewünscht, die Treiber.


    Das ist das Problem, wenn in solchen Foren so viele veraltete Informationen liegen.