Hello, Guest the thread was called5.5k times and contains 54 replays

last post from Brainstorm at the

VC 1541 will nicht am gleichen Ort bleiben

  • Hallo liebe C64 Gemeinde,


    mein VC 1541 muckt derzeit gehörig auf und liest mal Disketten einwandfrei und paar Sekunden später andere Diskette nicht mehr. Obwohl paar Minuten vorher alle Disketten nahezu gingen. Klar, sind einige defekt.


    Aber der Lesekopf macht echt Ärger. Kann man den nicht irgendwie justieren, ohne ein Programm. Hab es schon mehrere Stunden versucht den richtig zu justieren, mal klappt es wieder. Und paar Minuten später dann nicht mehr. Könnte natürlich auch an nem anderen Problem leigen, aber ich vermute den Lesekopf.

  • Das ist Quatsch, wenn du den einmal verschoben hast, brauchst du nur einen Init machen, und dann fährt er sich selber wieder in die richtige Position:


    OPEN1,8,15,"I":CLOSE1

    Okay, sorry, wusste ich nicht ;-). Habe zwar schon lange C64, aber spiele damit eher, als zu reparieren. Bin also Laie in der Hinsicht, versuche aber an anhand eurer Tipps, alles zum Laufen zu bringen.


    Gut, den Code kannte ich noch nicht. Es knattert dann, aber wenn ich dann eine Diskette einlege und laden möchte, versucht er es kurz zu laden, aber bricht kurze Zeit später ab, und knattert.
    FILE NOT FOUND ERROR. Obwohl ich die Spiele heute nachmittag noch zocken konnte.


    Liegt es also am Kabel? Weil beim Einschalten des C64, müsste doch der VC1541 kurz laden? Was er im Moment nicht tut.

  • Das Netzteil ist bestimmt im Arsch. Siehe mein Problem mit der gleichen Floppy und änliches Verhalten - Wenn das Netzteil kalt war musste man den Kopf "anschieben". War das Netzteil aber mal auf Temperatur verschwand der "komische" Fehler ...

  • Das Netzteil ist bestimmt im Arsch. Siehe mein Problem mit der gleichen Floppy und änliches Verhalten - Wenn das Netzteil kalt war musste man den Kopf "anschieben". War das Netzteil aber mal auf Temperatur verschwand der "komische" Fehler ...


    Der VC1541 wird diekt an die Strombüchse angeschlossen. Ich hab 2 solcher Kabel und mit beiden tritt der selbe Effekt auf. Ich vermute daher Kabelbruch des Serialanschlusses. Aber das scheint auch merkwürdig. Ein Kabel kann doch nicht dauernd kaputt gehen.

  • Möglich, daß es am Kabel liegt. Du solltest aber den Init bei eingelegter Disk machen.


    EDIT: Das Rattern ist dabei normal, sollte aber nur einmal passieren. Wenn es öfters passiert, ist die Disk wohl tatsächlich nicht mehr lesbar. Hast den S/L-Kopf schon mal gereinigt?


    Auch dann klappte es nicht. Viele Disks sind noch lesbar. Der S/L-Kopf ist sauber und gereinigt. Dein Code habe ich wie gesagt auch versucht, aber bei jeder Diskette das Gleiche: Knattert sehr früh und findet nur FILE NOT FOUND ERROR.


    Vermute also das Serialkabel, das nicht mehr richtig funktioniert. Grund: Beim Einschalten müsste der VC1541 angesprochen werden, was er nicht wird.

  • Beim einschalten des C64 macht die Floppy einen Reset, wodurch es kurz läuft und die LED aufleuchtet.


    Vielleicht liegt ein Wackelkontakt in dem Kabel vor, welches zum Lesekopf geht, da dies dauernd bewegt wird.


    Vermute ich auch. Neuerdings macht die Floppy wie gesagt kein Reset beim Einschalten. Kann also nur das Kabel sein oder der Anschluss davon, was ich allerdings für unwahrscheinlicher halte.

  • Oder ein Logikbaustein in der Floppy ist defekt, und leitet den Reset nicht mehr weiter. Das eine hat aber mit dem anderen nichts zu tun, denke ich. Daß die Floppy auf Befehl anläuft, und auch offensichtlich den Init ausführt, zeigt eigentlich, daß die IEC-Kommunikation funktioniert. "FILE NOT FOUND" deutet schon eher auf ein Leseproblem hin. Versuch doch mal eine Diskette neu zu formatieren, ob diese dann lesbar ist?


    OPEN1,8,15,"N:TEST,64":CLOSE1

  • Ist das eine Floppy mit Schnappverschluss?


    Falls ja, kann es sein, dass der S/L-Kopf nicht mehr richtig angedrückt wird. Nach dem Einschieben der Diskette muss der S/L-Kopf nach unten gedrückt sein. Unter Umständen musst Du den Schnapper selbst ein Stück herausziehen, um den S/L-Kopf anzudrücken. Im Normalfall rastet der Schnapper definiert ein. Igendwann ist entweder innen die Feder ausgeleiert oder die Reibung am Verschluss ist zu hoch.
    Ich würde auf jeden Fall erst einmal ausschliessen wollen, dass es sich nicht um ein einfaches mechanisches Problem handelt. Genau diesen Effekt mit dem Schnapper hatte ich auch schon.


    Gruß Dirk

  • Oder ein Logikbaustein in der Floppy ist defekt, und leitet den Reset nicht mehr weiter. Das eine hat aber mit dem anderen nichts zu tun, denke ich. Daß die Floppy auf Befehl anläuft, und auch offensichtlich den Init ausführt, zeigt eigentlich, daß die IEC-Kommunikation funktioniert. "FILE NOT FOUND" deutet schon eher auf ein Leseproblem hin. Versuch doch mal eine Diskette neu zu formatieren, ob diese dann lesbar ist?


    OPEN1,8,15,"N:TEST,64":CLOSE1

    Wie lange dauert denn das Formatieren von 664 Blöcken?
    Glaube aber nicht, dass es funken wird, teste es aber natürlich.

  • Danke an Alle für ihre Hilfe,


    Problem gelöst. Es war wider Erwarten das Serialkabel. Ich hab noch eins gefunden, und siehe da, beim Einschalten wird der VC1541 wieder erkannt und wird angesprochen. Und auch die Spiele laden wieder ohne Probleme.


    Am besten man hat zig Video-, Serial-, und Netzteil-Kabel. Kabelbruch scheint ein sehr häufiges aber leicht zu lösendes Problem zu sein.