Hello, Guest the thread was called3.9k times and contains 28 replays

last post from Kongo-Otto at the

Amiga 1200 mit 5,25" Disk-Laufwerk

  • Hallo,


    habe ein 5,25" Diskettenlaufwerk für den Amiga aus der Bucht gefischt und an meinen Amiga 500 mit Kick 2.0 angeschlossen. Das Laufwerk wird erkannt, aber jede der über 300 PD-Disketten wird nur als "N:DOS" Diskette erkannt. Am A1200 das gleiche. Formatieren kann ich die Disketten, aber NUR am A500, am A1200 geht es nicht. Meine 3,5" Laufwerke funktionieren beide an den jeweiligen Amiga's sodaß ich denke das es nicht an meinen Rechnern liegt. Muss man für das 5,25" Laufwerk einen bestimmten Treiber einbinden oder bin ich einfach wieder mal nur zu doof?

  • Ist das ein Amiga 1020 Laufwerk? Das hatte keinen Diskchange Sensor.


    Aus der CBM Museum Seite:

    Quote

    Das Laufwerk verwendet ein modifiziertes 1571-Gehäuse und einen ALPS Mechanismus. Der Laufwerksanschluß ist durchgeschliffen. Man kann das Gerät auch mit dem regulären AmigaOS verwenden, nur muss das anmelden des Laufwerks und der Diskettenwechsel dem Betriebssystem von Hand ("mount" und "diskchange"-Befehl) bekanntgemacht werden.

  • Ich glaube Laufwerke werden per default immer als 3,5" erkannt, für 5,25" brauchst du einen speziellen mountlist Eintrag. Schau dir mal die devs:mountlist an, evtl. gibt's da schon einen passenden Eintrag mit df2: oder so. Dann müsstest du nur "mount df2:" eingeben, und dann auf df2: zugreifen. 5,25" DD Disketten haben normalerweise immer 40 Tracks.

  • Also in der Mountlist steht nix, auch in der Startup-Sequence nix(ausser mount > nil: devs:dosdrivers/~(#?.info) - keine Ahnung wofür der Eintrag gut ist. Ist allerdings auf beiden meiner Amigas vorhanden, also dem A1200 mit Kickstart V39.106 und Workbench V 40.42 sowie beim A500 mit Kickstart 37.299 und Workbench V38.35.


    Also wenn ich nun einer Disketten in das Laufwerk schiebe kommt immer das gleich Icon "DF2:THB" und hinter dem B ist noch ein kleines Quadrat, ca. halb so hoch wie das B. Wenn ich auf das Icon klicke kommt oben die Meldung "Diesem Piktogram ist kein Standardprogramm zugeordnet. Formatieren lässt sich die Diskette über die WB jedoch problemlos mit 880KB.


    Nun ist mir noch folgendes aufgefallen: Bein A500 mit DirOpus: Wenn ich dort eine Diskette in das 5,25" Laufwerk schiebe (keine neu formatierte) dann kommt immer die Meldung: "Keine DOS Disk in Laufwerk DF2:"


    Ich bin echt ein wenig ratlos. Ich würde gerne das Laufwerk am A1200 betreiben da ich den A500 nur zum spielen benutze und mit dem A1200 halt versuche zu "arbeiten", mensch, früher hab ich doch auch keine Probleme mit meiner Kiste ( da war es noch ein A2000 mit Kickstart 2.0 ) gehabt ?!?

  • Sind den die Disketten überhaupt im AmigaDos Format?
    Die meisten spiele waren ja trackloader und hatten kein Amigafilesystem drunter.


    Für 5,25" Disk braucht es keine mountlisten oder Treiber, solange das LW die 80 Tracks unterstützt. Bei 40 Tracks wird man wohl eine Mountliste erstellen müssen.

  • Für den Amiga gibt es keine 5 ¼" Disketten (aus der Sicht des Amigas), die werden als 3,5" erkannt und behandelt. Es gibt mehrere verschiedene Schaltungen um ein externes Laufwerk am Amiga zu betreiben. Wenigstens eine davon ist mit den "neuen" Amigas (A600,1200,4000) nicht kompatibel und funktioniert nur an den alten Amigas (A500,1000,2000,3000). Du wirst wohl so ein Laufwerk erwischt haben. Ob es dafür einen Fix gibt, weiß ich ehrlich gesagt nicht.

  • Also es handelt sich bei den Disketten um eine grosse Public Domain Sammlung (Fred Fish und Kickstart). Jetzt hat sich aber der Verkäufer nochmal gemeldet und mir geschrieben das es sein kann das dieses Laufwerk damals als DOS Laufwerk am Amiga betrieben wurde und die Disketten dann auch im DOS Format beschrieben wurden ?!? Ich wollte das mal ausprobieren und habe dann im "Storage -> DOS Drivers" Verzeichnis auf das Icon "PC1" geklickt (ich habe das Laufwerk inzwischen als DH1:" am A500 angeschlossen. Hat aber nix gebracht. Wie genau kann ich denn das DH1: als DOS Laufwerk einbinden?

  • Also ich habe auch noch 2 von diesen Laufwerken. Das eine hat sogar eine Trackanzeige, war damals also nicht billig. Nun gingen beide auch nicht. Gleiche Fehlermeldung, angeschlossen am A2000.
    Die Floppys lagen aber auch eine Weile im Schrank. Ich habe sie geöffnet und siehe da, an beiden Laufwerken hat sich am Schreib/Lesekopf die obere Metallabdeckung gelöst und lag einfach so rum. Evtl. liegt hier der gleiche Fehler vor.
    Bis bald Amigerix

  • Schnell aufgeschraubt und gesehen das alles gut ist, hätte mich auch gewundert da ich ja im Prinzip mit dem Laufwerk arbeiten kann ( Disketten formatieren und neu beschreiben geht ja am A500 ). Es ist ein Chinon Modell FZ506 (siehe Fotos). Vieleicht hilft das ja weiter (Jumperbelegung?)

  • Yep - das scheint ein Laufwerk für eine PC-Karte zu sein. Die PC-Karten für den Amiga hatten nämlich auch so 23-polige Anschlüsse, damit man die 3,5" Laufwerke untereinander austauschen konnte.


    Ein PC-Laufwerk ist leider nicht ohne Weiteres am Amiga nutzbar, weil es mit 360RPM dreht. Für das Amiga-880K Format braucht man aber die 300RPM, die ein 3,5" Laufwerk normalerweise dreht.


    Die Umdrehungsgeschwindigkeit kann man normalerweise auf der Platine vom Motortreiber anpassen, das ist oft nur ein simpler Löt-Jumper. Ob das aber ausreicht um DD-Disks zu lesen und schreiben, wage ich zu bezweifeln, denn der Schreibstrom eines HD-Laufwerkes ist deutlich geringer als der eines DD-Laufwerkes. Die unterschiedlichen Beschichtungen der Disketten erfordern eigentlich eine saubere Umschaltung des Schreibstromes.


    Jens

  • Aber wie gesagt, der Verkäufer hatte dieses Laufwerk damals am Amiga betrieben, es lässt sich ja auch nutzen wenn ich die vorhandenen Disketten neu formatiere und beschreibe. Er weiss halt nur nicht mehr ob er diese Disketten am Amiga im PC-Format beschrieben hat (da er eine PC-Karte im Amiga hatte) oder im Amiga Format. Es sind alles Public-Domain Programme auf den Disketten, von Fred Fish und Kickstart. Wenn es damals am Amiga lief, dann muss es doch heute auch noch dafür geeignet sein ?!?

  • Wenn da eine PC-Karte im Rechner steckte, hatte der Vorbesitzer zwei Anschlüsse, an die er das Laufwerk anschließen konnte. Du hast nur Einen.


    Zugegeben, die FredFish und Kickstart-Disks waren alle auf 880k-Format ausgelegt und müssten ohne Treiber und ohne Mountlist zu lesen/schreiben sein, aber wer weiß, ob die Beschriftung Deiner Disketten noch stimmt?


    Jens

  • also ich habe mir damals Backups auf 5 1/4 Z gezogen. Leider kann ich davon nichts mehr gebrauchen, alles die gleiche Fehlermeldung wie bei deinem LW. Da mecker noch einer über 3 1/2 Disketten, die nicht mehr laufen.
    Wobei von der Haltbarkeit waren die 3 Z vom Schneider die besten (Nie Ärger mit gehabt), aber das ist ein anderes Thema.
    Es scheint mir also mehr ein Problem der Disketten zu sein, die in die Tage gekommen sind.
    Solltest Du PD brauchen, müsstest Du dich einfach mal melden.
    Bis bald Amigerix