Hello, Guest the thread was called65k times and contains 386 replays

last post from stynx at the

Selbstbau 68k Rechner

  • Hi,


    heute mal ein kleiner Teaser. Ich hab am Wochenende die zur Verfügung stehende Zeit genutzt und die SMD Bauteile gelötet. Damit ist ein weiterer Schritt getan, bald die ersten Bausätze anbieten zu können.


    So sah das vorgestern und gestern etwa bei mir aus:



    Bogo

  • PS: bei deiner Bestellbestätigung fehlt noch, was man als Verwendungszweck bei Banküberweisungen eintragen soll.


    Oh, ja, stimmt. Das werde ich ändern. Name (wie im Shop angegeben) und/oder die Bestellnummer aus der Bestätigungsmail sollten ausreichen, damit ich die Zahlung zuweisen kann.


    Wenn der Kiwi so eine Wertsteigerung hat, muss ich mir doch noch einmal Gedanken über den Preis machen. ;)

  • Hallo,


    ich hab die ersten Bausätze fertig. Viele sind es noch nicht, aber Bauteile für den nächsten Schwung sind bereits bestellt. Wer Interesse hat, kann im Kiwi Shop bestellen.


    Bogo


    Zitat vom Shop: "Dieser Bausatz ist nicht für Anfänger geeignet! Es wird vorausgesetzt, dass elektrotechnisches Wissen, Löt-Werkzeug und Messinstrumente vorhanden sind."


    :baby:

  • Der Bausatz hat weit über 100 Bauteile. Was machst Du, wenn Du aus Versehen davon welche vertauschst oder falsch herum einbaust und der Rechner gar nicht startet? In dem Fall wirst Du dem Fehler irgendwie auf die Schliche kommen müssen. Ich und die anderen Bastler werden so gut wie möglich helfen, aber wenn man keine Möglichkeit hat, etwas zu kontrollieren (messen), wird das schwierig. Ich habe verschiedene Bauteile einzeln in Tütchen verpackt und beschriftet, so dass es eigentlich auch für den Laien zu schaffen sein sollte. Ich hab aber auch keine Lust dafür verantwortlich gemacht zu werden, wenn jemand konsequent z.B. ICs falsch herum einbaut, durch zu viel Lötzinn Kurzschlüsse verursacht und sich nachher beschwert. Also ein Multimeter sollte vorhanden sein und auch das elektrotechnische Wissen, dass z.B. bei Elkos die Polarität zu beachten ist. Das ist damit gemeint...


    Wer absoluter Anfänger ist und noch nie einen Bausatz gelötet hat, fängt lieber mit etwas Kleinem an. Ich möchte nicht, dass jemand bei einer so großen Investition hinterher enttäuscht ist. Dann wäre ich es nämlich auch.


    Bogo


    [Edit]Ich bin halt nur ein Ein-Mann-Unternehmen und mache das alles in meiner Freizeit. Die Hälfte der Bausätze sind übrigens bereits auf dem Weg zu ihren neuen Besitzern und so wird es bald hoffentlich mehr Erfahrung und gegenseitige Hilfe geben.[/Edit]

  • Ist heute angekommen und habe es mal zusammengelötet. Ein paar Sachen die mir beim Löten aufgefallen sind:


    - X2 ist etwas zu nah an C45 und berührt fast das Pad
    - R54 und X4 sind auch etwas zu nah
    - Bohungen für L1 sind etwas zu eng
    - CN2 nicht im Bestückungsdruck zu sehen, nur "Keyboard"
    - CN3 nicht im Bestückungsdruck zu sehen, nur "Mouse"
    - bei den Chinch Anschlüssen waren etwas Plastikvorsprünge an den beiden Enden, die man für ein bündiges Einlöten vorher abschmirgeln sollte
    - war nicht offensichtlich, wie man CN12 (und CN5) einlöten sollte (Pin eins, der quadratische Pin auf der Platine, ist auf derselben Seite wie die Aussparung, vermute ich mal)
    - das SIMM war nicht eindeutig, wie rum es rein sollte (die Plastiklaschen links, in Richtung der Tantalkondensatoren, denke ich)
    - am besten wäre noch eine Versionsnummer auf der Platine


    Läuft aber leider nicht. Habe mal per Oszilloskop gemessen und an der CPU scheint irgendwas auf dem Datenbus zu laufen. Aber bei Pin 4 an U7 kommt nichts raus, liegt konstant 5V an. An Pin 3 liegt 0V an, der Inverter geht also generell. Die Kondensatoren und den Widerstand habe ich geprüft, sind 33 pF und 4,7M.


    Was mir noch aufgefallen war: J8-J11 ist nicht im Schaltplan unter https://www.ist-schlau.de/downloads/Kiwi-schematics.pdf vorhanden, ist das für die SID Filter? Gibt es einen Schaltplan der zur Lieferung passt?


    Wäre auch gut wenn es läuft ein paar Beispielprogramme zu haben. Ich habe in deinem Forum gesehen, daß du die Amiga Boing-Anwendung portiert hast. Das wäre prima, wenn man das als Test mal laufen lassen könnte. Gibt es den Source Code dazu irgendwo?

  • Hallo Gartenzwerg,


    Ist heute angekommen und habe es mal zusammengelötet.


    wow bist Du schnell. :)


    Ein paar Sachen die mir beim Löten aufgefallen sind


    Vielen Dank für das Feedback! Genau auf sowas bin ich angewiesen. Die Bohrungen von L1 sind mir auch aufgefallen, als mir die neuen geliefert worden. Beim kurzen Test passte es so grad eben. Für den nächsten Run werden die Bohrungen größer. Die Quarze kann ich noch ein Stück abrücken. Ursprünglich waren sie noch näher.
    Über die weiteren Anmerkungen freue ich mich besonders, da es noch keine Aufbauanleitung gibt und genau die Dinge deutlich gemacht werden müssen.
    Die Aussparungen der Pfostenwannen zeigen beide nach links (wenn man das Board so vor sich liegen hat, dass man das Logo richtig herum sieht).


    Läuft aber leider nicht. Habe mal per Oszilloskop gemessen und an der CPU scheint irgendwas auf dem Datenbus zu laufen. Aber bei Pin 4 an U7 kommt nichts raus, liegt konstant 5V an. An Pin 3 liegt 0V an, der Inverter geht also generell. Die Kondensatoren und den Widerstand habe ich geprüft, sind 33 pF und 4,7M.


    Das ist schade. So auf die Schnelle würde ich kontrollieren, ob ich nicht einen Fehler beim CS8900a gemacht hab. Der ist etwas tricky zu löten und ich konnte nur danach messen, aber nicht testen, ob alles richtig ist. U7 ist für den Betrieb zunächst uninteressant. Der erzeugt den Takt für den Farbcarrier, damit der RGB Encoder ein Farbsignal bei S-Video und Composite erzeugt. Fehlt U7, gibt es bei diesen beiden Videosignalen nur Schwarz-Weiß, aber der Rechner an sich muss laufen...


    Was mir noch aufgefallen war: J8-J11 ist nicht im Schaltplan unter https://www.ist-schlau.de/downloads/Kiwi-schematics.pdf vorhanden, ist das für die SID Filter? Gibt es einen Schaltplan der zur Lieferung passt?


    Wäre auch gut wenn es läuft ein paar Beispielprogramme zu haben. Ich habe in deinem Forum gesehen, daß du die Amiga Boing-Anwendung portiert hast. Das wäre prima, wenn man das als Test mal laufen lassen könnte. Gibt es den Source Code dazu irgendwo?


    Bist Du schon im Kiwi Forum angemeldet? Das lege ich Dir nahe. In der letzten Zeit ist das Meiste dort gelaufen, da seit dem Board Lauf vom Frühjahr bereits zwei Briten einen Kiwi bauen. Zudem richte ich Dir einen Zugang zum Subversion ein, wenn Du mir sagst, mit welchem Benutzernamen Du arbeiten möchtest. Dann hast Du nicht nur Zugriff auf die Boing Ball Demo, sondern auch alle anderen Programme (Vektor Demo, Diashow, EmuTOS, Boulder Dash, etc). Im internen Bereich ist auch der aktuelle Schaltplan. Da hast Du allerding Recht. Der gehört spätestens jetzt in den freien Download Bereich. Das hab ich vergessen und hole ich heute nach.
    Desweiteren ist es sinnvoll, Probleme bei der Inbetriebnahme im Kiwi Forum zu besprechen, damit andere Kiwi Bastler davon profitieren können. Die meisten sitzen nicht hier...


    Bogo

  • War ansonsten nicht so schwierig zu löten. Kann man in 3-4 Stunden machen, wenn man etwas geübt ist und die Bauteile gut vorsortiert, z.B. alle Widerstände der Nummer nach hinlegen, sodaß man dann den richtigen findet, wenn man die auf dem Board durchgeht. In Eagle gibt es übrigens ein Script um die Indizes automatisch von links nach rechts und unten nach oben umzunummerieren, was sehr bei der Suche von Komponenten hilft, vielleicht hat gEDA sowas ja auch.


    Das Problem mit U7 glaube ich nicht, daß das an CS8900a liegt, dann der müsste dann ja Pin 4 kurzgeschlossen haben. Und bei dem Pierce-Oszillator den du verwendet hast, sollte man generell mit dem Oszilloskop auch den Ausgang bei Pin 2 messen können, da der niederohmig ist. Aber können wir auch in deinem Forum weiter diskutieren, gibt dort jetzt einen gartenzwerg :)


    Edit: Ist tatsächlich ein Problem mit dem Oszillator, denn ich kann U7 rausnehmen und einen externen Signalgenerator an Pin 4 anschliessen und das Signal bricht nicht zusammen. Am Videoausgang ist aber noch nichts zu sehen.

  • War ansonsten nicht so schwierig zu löten. Kann man in 3-4 Stunden machen, wenn man etwas geübt ist und die Bauteile gut vorsortiert, z.B. alle Widerstände der Nummer nach hinlegen, sodaß man dann den richtigen findet, wenn man die auf dem Board durchgeht.


    Das freut mich. Ich hab auch kein Bauteil vergessen? Das war eine meiner Sorgen beim Zusammenstellen.


    In Eagle gibt es übrigens ein Script um die Indizes automatisch von links nach rechts und unten nach oben umzunummerieren, was sehr bei der Suche von Komponenten hilft, vielleicht hat gEDA sowas ja auch.


    Interessant. :) Bei gEDA ist mir so ein Skript bisher nicht bekannt. Lediglich eines, welches die Refdefs komplett neu vergibt.


    Das Problem mit U7 glaube ich nicht, daß das an CS8900a liegt, dann der müsste dann ja Pin 4 kurzgeschlossen haben


    Ich dachte dabei vorhin mehr an das, was bei Dir auf dem Datenbus abgeht. Aber da hab ich noch halb geschlafen. Auf dem Weg zur Arbeit fiel mir nämlich ein, dass der Datenbus des CS8900a hinter dem 8-auf-16-Bit Puffer liegt.


    Aber können wir auch in deinem Forum weiter diskutieren, gibt dort jetzt einen gartenzwerg :)


    Prima, ich hab Dich grad freigeschaltet. Deinen SVN Zugang richte ich jetzt auch ein und schreib Dir ne PM.


    Edit: Ist tatsächlich ein Problem mit dem Oszillator, denn ich kann U7 rausnehmen und einen externen Signalgenerator an Pin 4 anschliessen und das Signal bricht nicht zusammen. Am Videoausgang ist aber noch nichts zu sehen.


    Interessant. Das erörtern wir im Kiwi Forum näher. Ich nehm mir gleich nochmal den Schaltplan vor und lege den aktuellen in den Download Bereich.


    Bogo

  • Der Bausatz hat weit über 100 Bauteile. Was machst Du, wenn Du aus Versehen davon welche vertauschst oder falsch herum einbaust und der Rechner gar nicht startet? In dem Fall wirst Du dem Fehler irgendwie auf die Schliche kommen müssen. Ich und die anderen Bastler werden so gut wie möglich helfen, aber wenn man keine Möglichkeit hat, etwas zu kontrollieren (messen), wird das schwierig. Ich habe verschiedene Bauteile einzeln in Tütchen verpackt und beschriftet, so dass es eigentlich auch für den Laien zu schaffen sein sollte. Ich hab aber auch keine Lust dafür verantwortlich gemacht zu werden, wenn jemand konsequent z.B. ICs falsch herum einbaut, durch zu viel Lötzinn Kurzschlüsse verursacht und sich nachher beschwert. Also ein Multimeter sollte vorhanden sein und auch das elektrotechnische Wissen, dass z.B. bei Elkos die Polarität zu beachten ist. Das ist damit gemeint...


    Also die Bauteile ggf. mit entsprechender Polung auseinanderhalten kann ich wohl. Löten trau ich mir auch zu. Aber wie ist das mit dem Zusammenbau? Muß man da einen richtigen Schaltplan für lesen (können) oder was wird da mitgeliefert?

  • Bei den ersten habe ich den Schaltplan noch nicht mitgeliefert, sondern lediglich noch einmal ein Ausdruck des Platinenaufdrucks im Maßstab 1:1. Ich denke, ich werde den nächsten Bausätzen auch den Schaltplan beilegen. Dann gibt es noch ein paar Bauteile, bei denen nicht auf Anhieb klar ist, wie herum man sie löten muss. Gartenzwerg hat seinen gestern aufgebaut und schon einige kreative Kritik geübt, welche ich umsetzen werde und zum Teil bereits umgesetzt habe.


    Leider läuft seiner noch nicht. Das heißt im Umkehrschluß, wir müssen direkt schon bei seinem Bausatz etwas in die Tiefe gehen. Woran es liegt, wissen wir noch nicht, aber wir werden hier bestimmt berichten, wie es weiter geht...


    Ansonsten ist alles dabei, was man zum Einstieg benötigt und im besten Fall sollte es ausreichen, alles zu löten. Sprich: für den Zusammenbau braucht man keinen Schaltplan lesen können, aber wenn es dann so aussieht, dass danach erstmal gar nichts passiert, fängt es an interessant zu werden.


    Um es klar auf den Punkt zu bringen: Ich kann den Bausatz momentan noch nicht Interessenten empfehlen, die zwar Werkzeug zum Löten haben, aber denen das Equipment und Know-How fehlt, danach zu debuggen, falls es noch nicht läuft.


    Bogo