GEOS 3.53 für PLUS/4 und C16 mit 64KB!

  • GEOS 3.53 für PLUS/4 und C16 mit 64KB!

    Damit das Thema nicht im GEOS-Bereich untergeht, hier der Link dazu auch in diesem Bereich:

    GEOS 3.53: Neue Distribution für PLUS/4 und C16 mit 64 KB!


    Kurzer Hintergrund: Es gab ein paar Hinweise über GEOS 3.5 im Internet verteilt. GEOS 3.5 ist eine GEOS 2.0 Umsetzung, laufbar direkt auf einem PLUS/4-Rechner und auch einem C16, aufgerüstet auf 64 KB und natürlich braucht man eine Floppy 1551 zum Booten (durch ihren Parallelanschluß läuft sie 3-4 Mal schneller als eine 1541). Ich suchte und fand zunächst 8 D64-Images mit GEOS 3.52 und bootbaren Versionen in Deutsch und Englisch. Danach fand ich die große Distribution mit viel mehr D64-Images. Ich fand, dass man da etwas Ordnung reinbringen kann und habe mir diese GEOS 3.52er-Distribution vorgenommen, Hilfetexte angepasst, Namen verändert usw.

    Nun sind die ersten beiden GEOS 3.53er Images fertig: Eine Bootdiskette in Deutsch und eine in Englisch und mit GeoWrite und GeoDraw drauf!

    Ich habe diese Images natürlich mit Star Commander und einem XE1541-Kabel auch auf echte Disketten kopiert und mit Erfolg auf einem echten PLUS/4 gestartet.
    Die D64-Images laufen am Besten auf dem EMU YAPE 1.02.

    Links zu den Images folgen alsbald.


    Gruß EPA
  • Die bei Plus/4 World erhältliche GEOS 3.52-Version will bei mir weder mit VICE noch mit Yape starten. Bei VICE bleibt GEOS beim Startscreen stehen und bei Yape lädt es zwar bis zum Desktop (oder TopDesk?), es kommt allerdings der Fehler "Systemfehler nahe $90AC, RESET-Taste drücken". Habe versucht, etliche Einstellungen zu verändern, ohne Erfolg. Kennt jemand ein Problem für meine Lösung?
    Dieser Beitrag wurde bereits 64 mal editiert, zuletzt von »Bagitman« (Heute, 00:03)
  • Das ist mir schon bewusst. Deshalb ist ja in einem Plus/4-Emulator auch die 1551 eingestellt. Aber selbst mit einer 1541 läuft dieses GEOS nicht an.
    Dieser Beitrag wurde bereits 64 mal editiert, zuletzt von »Bagitman« (Heute, 00:03)
  • Bagitman schrieb:

    Die bei Plus/4 World erhältliche GEOS 3.52-Version will bei mir weder mit VICE noch mit Yape starten. Bei VICE bleibt GEOS beim Startscreen stehen und bei Yape lädt es zwar bis zum Desktop (oder TopDesk?), es kommt allerdings der Fehler "Systemfehler nahe $90AC, RESET-Taste drücken". Habe versucht, etliche Einstellungen zu verändern, ohne Erfolg. Kennt jemand ein Problem für meine Lösung?
    Bin am gleichen Fehler im YAPE auch hängengeblieben. Habe aber nun eine Lösung gefunden per blöden Zufall:

    Es müssen sowohl Laufwerk 8 und 9 beide als 1551 angehängt werden, und beide im CPU level compatibily mode. Wird Laufwerk 9 mit IEC level compatibily mode gesetzt und nur 8 im CPU level, so erscheint der Systemfehler. Das sind die Einstellungen im YAPE.

    Am realen Plus/4 müßte ich es mal probieren. Mag aber auch daran liegen, das ich nie viel von GEOS für den Plus/4 gehalten habe, aber wahrscheinlich noch mehr, das ich meistens 2* die 1551 am Plus/4 hängen und eingeschaltet habe.

    Ich habe sogar noch heute aktuelle Kontaktdaten zu dem Programmierer, man könnte theoretisch anfragen ob er für andere Projekte an dem Paket helfen könnte bzw. auch will. Umso ärgerlicher noch, das er nur wenige km von einen regelmäßigen Retroevent entfernt wohnt, ich hatte ihn diesbezüglich auch versucht anzusprechen, ob er mal rüberkommen mag. Ist aber bei dem Versuch geblieben, bisher jedenfalls.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von cbm-warrior ()

  • cbm-warrior schrieb:

    Es müssen sowohl Laufwerk 8 und 9 beide als 1551 angehängt werden, und beide im CPU level compatibily mode.
    Hey, funktioniert. Da muss man aber auch erst mal drauf kommen, dass der YAPE von Haus aus gleich zwei Laufwerke aktiviert hat.

    Jetzt wüsste ich nur noch gerne, wie man bei YAPE die Windowsmaus einfängt.
    Dieser Beitrag wurde bereits 64 mal editiert, zuletzt von »Bagitman« (Heute, 00:03)
  • Geos 3.5 fand ich damals sehr interessant.
    Allerdings habe ich mich da nicht weiter mit beschäftigt, weil es keine echte Proportionalsteuerung mit Maus für den +4 gab.
    Sind da mittlerweile Lösungen vorhanden, eine "echte" Maus am +4 zu betreiben (bitte keine Maus mit Joystick-Modus)? Ob Amiga, ST oder PC-Maus wäre mir da erstmal einerlei.
  • Stuckalf schrieb:


    Sind da mittlerweile Lösungen vorhanden, eine "echte" Maus am +4 zu betreiben (bitte keine Maus mit Joystick-Modus)? Ob Amiga, ST oder PC-Maus wäre mir da erstmal einerlei.


    Ich kenne keine, aber das ist auch kein allzu großes Problem. Heutige Mäuse mit USB sind da nicht so einfach, aber eine serielle Maus muss man nur anschließen. Der +4 hat ein langsames serielles Interface, das für die 1200bps einer seriellen Maus ausreichend ist. Anschließen und einen Treiber schreiben - that's all.
    If we're evil or divine - we're the last in line. - Ronnie James Dio (1984) -
  • cbm-warrior schrieb:

    Nein, das muß seperat erst eingestellt werden, das 2 1551 emuliert werden.
    Also der Yape, den ich hier verwende ist die 64Bit-Version 1.0.10, und dort war tatsächlich ohne mein Zutun Laufwerk 9 schon mit einer 1551 eingestellt (wenn auch nur im Performance-Mode.)

    Kann der Yape denn überhaupt eine Maus-Emulation? Und wenn nein, warum nicht? Gabs für den Plus/4 gar keine Maus?
    Dieser Beitrag wurde bereits 64 mal editiert, zuletzt von »Bagitman« (Heute, 00:03)
  • Nein, der Plus/4 hat "von Haus aus" keinen entsprechenden Eingang, um eine "echte" Maus abzufragen.

    Beim C64 behalf man sich seinerzeit mit der Nutzung der Paddle-Eingänge des Soundchips.
    Die 1351 Maus von Commodore wird analog abgetastet über Widerstandswerte. Man kann sie aber so umschalten (beim Einstöpseln rechte Maustaste festhalten, glaube ich), dass sie einen Joystick emuliert.

    Eine Amiga- oder ST-Maus liefert kontinuierliche Signale an den Joystick-Port. Dummerweise sitzen dort beim C64 und beim Plus/4 einige Anschlüsse, die man auch für die Tastaturabfragen braucht. Daher lässt sich eine Amiga- oder ST-Maus nur anschließen, wenn nicht gleichzeitig auch die Tastatur abgefragt werden soll.

    Dem Plus/4 fehlen zum Anschluss einer "analogen" Maus wie der 1351 die entsprechenden Paddle-Eingänge.
    Ein Anschluss über den Userport könnte gehen. Aber ich glaube, das wurde noch nie realisiert. Ich hatte das vor Jahren hier mal abgeklopft, ob schon etwas in der Art gebastelt wurde.
    Bislang hat sich das anscheinend nicht geändert.

    Und so ein System wie Geos lässt sich nur mit einer echten Maussteuerung flüssig bedienen.
  • Amiga-/ST-Maus an den Userport stöpseln, 1351 an SID-Erweiterung stöpseln, PS/2-Maus an den Cas-Port stöpseln (alles mit entsprechendem Adapter, is' ja klar)... kein Problem, aber man muß 'nur' noch einen Treiber schreiben... und genau da hakt es, weil das der weit aufwendigere Teil des Projektes ist.
  • mc71 schrieb:

    Amiga-/ST-Maus an den Userport stöpseln, 1351 an SID-Erweiterung stöpseln, PS/2-Maus an den Cas-Port stöpseln (alles mit entsprechendem Adapter, is' ja klar)... kein Problem, aber man muß 'nur' noch einen Treiber schreiben... und genau da hakt es, weil das der weit aufwendigere Teil des Projektes ist.
    Viel mehr ist das Problem, das praktisch damit nichts wirklich genormt wäre und das bringt einen nicht wirklich weiter.

    Viel sinnvoller wäre ein zusätzlicher Laufwerkstreiber für die 1581.
  • mc71 schrieb:

    Amiga-/ST-Maus an den Userport stöpseln, 1351 an SID-Erweiterung stöpseln, PS/2-Maus an den Cas-Port stöpseln (alles mit entsprechendem Adapter, is' ja klar)... kein Problem, aber man muß 'nur' noch einen Treiber schreiben... und genau da hakt es, weil das der weit aufwendigere Teil des Projektes ist.

    Im "Streaming Mode" ist das aber keine große Herausforderung. Wenn es jedoch speziell für die GEOS-Version passend sein soll, muss es wohl einer von den dreien machen, die das tatsächlich benutzen wollen. :ö)
    Damit hat es sich dann sicher erledigt.
    Dateien
    If we're evil or divine - we're the last in line. - Ronnie James Dio (1984) -
  • Fiel mir eben ein: es geht eigentlich noch viel einfacher.

    Ein Arduino Nano mit MAX232 am Joystickport dürfte reichen. Der Arduino setzt dann das Streaming der Mouse in Joystick-Klicks um. Dann braucht man gar keine Software für den +4 ändern. Das sollte auch mit einer USB-Maus funktionieren.
    If we're evil or divine - we're the last in line. - Ronnie James Dio (1984) -
  • Meine Wahl wäre eher ein Anschluss einer Amiga Maus. Ein nativer Treiber ist da leichter umzusetzen.
    Ich weiß aber nicht, ob sich der Userport des Plus/4 über einen Emulator wie Vice an eine "physikalische" Maus hängen lässt.
    Laut Featureliste von Vice gibt es ein "
    New joyport system which currently supports attaching the following devices to the native port..."Darunter sind u.a. auch die Amiga- und ST-Maus gelistet. Außerdem ist die 1351 für das SIDCart aufgeführt.
    Weiß jemand, an welchen Ports (Hex-Adresse) die SID-Paddles bei der SIDCart-Emulation im Vice zur Verfügung stehen?
  • cbm-warrior schrieb:

    Am realen Plus/4 müßte ich es mal probieren. Mag aber auch daran liegen, das ich nie viel von GEOS für den Plus/4 gehalten habe, aber wahrscheinlich noch mehr, das ich meistens 2* die 1551 am Plus/4 hängen und eingeschaltet habe.
    Jetzt kapiere ich gar nicht mehr. Auf meinen realen Disketten ist auch die Version 3.52. (Angezeigt wird dieser aber nur als Version 3.5!)

    Wenn ich mit einer eingeschalteten 1551 GEOS lade, wird abgefragt, ob ich mit einen Laufwerk arbeiten will oder ich soll das B-Laufwerk einschalten, also eine 1551 mit Geräteadresse 9. Dann wird der Desktop geladen. Zu dem Systemfehler komme ich gar nicht erst. Wenn ich mit 2 Laufwerken boote und später die 9 ausschalte, hängt GEOS so lange, bis die 9 wieder eingeschaltet wird.

    Hat jemand beim Test an einen realen echten Plus/4 mit 1551 auch die Abfrage, ob mit einen oder zwei Laufwerken gearbeitet werden soll? Bitte mal nachprüfen, wer es kann.