1551 Defekt Blink nur beim Einschalten

  • 1551 Defekt Blink nur beim Einschalten

    Gude,

    Ich habe meine 1551 im Erstbesitz, doch leider seit längeren Defekt.

    Die Floppy wollte ich damals einschalten und danach war Sie nicht mehr betiebsbereit. :(


    Nachdem Einschalten blinkt die rechteckige LED 2xmal, kurze Pause ,2xmal usw.
    Der Plus4 kann die 1551 nicht mehr ansteuern und es kommt die Fehlermeldung -Device not present error-.

    Wie kann ich die 1551 Reparieren?
    Ich bedanke mich schon mal im Vorraus für eure Hilfe.

    Beste Grüße
    Rik 8)
  • Hallo Rik,

    falls der Tausch des RAM's, wie von Gerrit beschrieben, den Fehler nicht behebt, kann ich Dir anbieten Messungen an meiner funktionierenden Floppy 1551 durchzuführen!
    Praktisch remote durchgeführte Vergleichsmessungen... :D

    Have fun...

    TheChief
    PS: 230 Volt können verdammt tötlich sein aber nur einmal pro Person... :bgdev
  • Ge*l,

    ich habe die Floppy schon mehr oder weniger abgeschrieben und wäre nur noch brauchbar für die Vitrine.

    Da freu ich mich wirklich, dass ich die 1551 wahrscheinlich wieder verwenden kann. :thumbsup: Und das in der kurzen Zeit eine helfende Antwort/Unterstützung zu bekommen.

    Nur wie kriege ich den alten Baustein raus (weil der eingelötet ist)? Und woher bekomme ich noch einen passenden Ersatz?
    Der verbaute U5 wäre ein Toshiba TMM2116AP-15 8414HAK.

    Wo kann man die Fehlercodes der 1541 nachlesen?

    Beste Grüße
    Rik 8)
  • Hallo Rik,

    die Fehler-/Flash-Codes für die 1541 stehen z.B. hier:

    ftp.zimmers.net/pub/cbm/schema…1541/service/Page_04.html

    Hier findest noch ein paar Informationen zu Deiner 1551:

    ftp.zimmers.net/pub/cbm/schema…rives/new/1551/index.html

    Ersatz findest Du zeitweise auf eBay (auch bei ausländischen Händlern) oder bei Retro-Händlern im Netz.
    Für den Aus- und Einbau des Bausteins brauchst Du jemanden der GUT löten kann, da die Platine ja schließlich erhalten bleiben soll! :bgdev

    Evtl. im Bekanntenkreis mal fragen, jeder der z.B. eine Elektronik-Ausbildung hat sollte das können oder Du fragst mal bei einem Radio-/ Fernsehhändler in der Nähe ob er Dir den Tausch für eine ordentliche Spende in die Kaffeekasse erledigt! ^^

    Have fun...

    TheChief
    PS: 230 Volt können verdammt tötlich sein aber nur einmal pro Person... :bgdev
  • Da dieser Baustein noch problemlos zu bekommen ist würde ich da nicht lange fackeln. Einfach die Pins rundrum direkt am IC abschneiden (mit passendem Werkzeug kein Problem) und dann einzeln auslöten. Das geht schön einfach. Mit der Lötpumpe die Löcher freimachen und einen 24pol Sockel einlöten. Dort das neue RAM einstecken. Fertig.

    Vor dem Löten ein Foto der Platine machen, alle gesockelten ICs auf einer Antistatikmatte zwischenlagern und alle Stecker so markieren, daß man sie nachher wieder korrekt aufstecken kann. Das Foto hilf dann beim korrekten Einstecken der ICs nach der Reparatur.
  • Meistens ist es so, das bei den 1551 auf der Platine selten was kaputt geht.

    Viel häufiger sind die Laufwerksmechaniken oder der parallele Anschluß an den Expansionsport defekt.

    Aus diesem Grund habe ich sicher noch einige 1551 Platinen hier liegen, meist sogar noch komplett bestückt. Da ist der Platinentausch etwas schneller.

    T-Rik: Wenn Du eine vollständige Platine haben willst, melde Dich mal. Wir werden uns sicher einig.

    Wer noch mit dem Plus/4 wirklich arbeitet, der braucht ne 1551. Schön flott schon ohne Speeder, und sehr viele Programme sind auf die 1551 zugeschnitten und in den Versionen entsprechend flott.
  • Hallo,

    ich hatte heute etwas Zeit und Motivation genug meine 1551 zusammen zu bauen.

    Die neue gebrauchte Tauschplatine ist jetzt verbaut. Eiin kleines Dankeschön noch an cbm-warrior für die Platine.

    Zur Freude meinerseits ist jetzt das Blinken weg :thumbsup:


    Aber die blöde Floppy wag es doch glatt sich zu widersetzen - Gemeinheit. :baby:

    Wenn ich mit dem Plus4 auf die 1551 zu greifen möchte erhalte ich jetzt die Fehlermeldung 'Device not present error'.

    Jetzt habe ich Angst das der Stecker auch noch einen Knall hat. :cry (Anschluss erfolgte natürlich bei ausgeschalteten Geräten)
    Fehlermeldungen in Form von Blinken oder ähnliches an der 1551 sind nicht mehr vorhanden. Es leuchtet nur dauernd die Betriebsleuchte.

    Was fehlt der Floppy jetzt noch? ?(


    Beste Grüße
    Rik 8)
  • T-Rik schrieb:

    Aber die blöde Floppy wag es doch glatt sich zu widersetzen - Gemeinheit. :baby:

    Wenn ich mit dem Plus4 auf die 1551 zu greifen möchte erhalte ich jetzt die Fehlermeldung 'Device not present error'.

    Zunächst mal: Blöd ist die Floppy sicher nicht. Sonst würde sie dir das Anschlußkabel selbstständig um den Hals wickeln und warten, bis Du dich gegenüber der 1551 wieder benimmst .... :bgdev

    Erscheint die gleiche Fehlermeldung, wenn du sie als Gerät 9 ansprichst? Wenn ja, ist der Paddle defekt, ansonsten ist die intern als Gerät Nr. 9 gejumpert.
  • Gude,

    ich kann Sie zu Grabe tragen ;( - Nee nur wieder in die Vitrine. ;)

    Von Adresse 8 Bis 15 alles durch probiert keine für mich positive Reaktion.

    Kann die Schnittstelle (Userport richtig?) vom Plus 4 auch was haben? Der ist Gebraucht, mein eigener Erstbesitz streikt zur Zeit.

    Bekommt man noch den IC mit 40-Pin aus der Umbauanleitung vom Paddle? Google brachte durch meine Befragung keine Ergebnisse.


    Was glaust du denn wie ich mit meiner 1551 umgehe? Gestreichelt, gereinigt, auf die Knie bin ich gegangen und gebetet und auch Ihr gehuldigt und versprochen, dass Sie einen besonderen Ehrenplast am Plus 4 erhält.
    Und dann jetzt die Mimose spielen. Haste schon einen Mann schon weinen sehen. ;)
    Aber ich spiele jetzt oder später nicht mit Ihr Ikea (Knut) :kaputt , da würde die Commodore-Floppy unfreiwillig auch mal "Windows" besser kennenlernen. Ein bissl Spaß muss sein.

    Nebenbei falls jemand wieder eine defekte 1551 hat oder einige Teile davon. Hat jemand noch einen Stecker über? Hätte Interesse dran. Braüchte ich für eine erstmal dumme theoretische Idee.

    Beste Grüße
    Rik 8)
  • T-Rik schrieb:

    Von Adresse 8 Bis 15 alles durch probiert keine für mich positive Reaktion.

    Kann die Schnittstelle (Userport richtig?) vom Plus 4 auch was haben? Der ist Gebraucht, mein eigener Erstbesitz streikt zur Zeit.

    Bei der 1551 geht nur Geräteadresse 8 oder 9 - alles andere bleibt Laufwerken am seriellen Bus vorbehalten.

    Die Schnittstelle ist der Expansionsport. Aber bei Dir hört sich alles nach einen defekten Paddle an.

    Der 6525 ist auch am Amiga verbaut worden ... frag mich aber nicht wo und wofür. Amiga ist nicht meine Baustelle. Der 1551 ist es egal, ob ein A oder B hinten dranhängt, oder gar nichts. Außerdem ist auf der Platine, die du getauschst hast, ein 6525 drauf. Wenn der noch in Ordnung ist, nimm den.
  • cbm-warrior schrieb:


    Der 6525 ist auch am Amiga verbaut worden ... frag mich aber nicht wo und wofür. Amiga ist nicht meine Baustelle. Der 1551 ist es egal, ob ein A oder B hinten dranhängt, oder gar nichts. Außerdem ist auf der Platine, die du getauschst hast, ein 6525 drauf. Wenn der noch in Ordnung ist, nimm den.


    Äh, nein... Die 1551 läuft mit 2 MHz, also muss das auch der 6525 abkönnen, du brauchst mindestens einen 6525A.


  • Äh, nein... Die 1551 läuft mit 2 MHz, also muss das auch der 6525 abkönnen, du brauchst mindestens einen 6525A.


    Das ist mir neu. Ich dachte immer die rennt mit 1mhz wie die 1541 und erst mit der 1570 kamen die 2mhz. Ich nehm das einfach mal so hin.


    Gruß x1541

    per tapatalk 2 versendet
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • x1541 schrieb:



    Äh, nein... Die 1551 läuft mit 2 MHz, also muss das auch der 6525 abkönnen, du brauchst mindestens einen 6525A.


    Das ist mir neu. Ich dachte immer die rennt mit 1mhz wie die 1541 und erst mit der 1570 kamen die 2mhz. Ich nehm das einfach mal so hin.


    Mein Oszi und der Schaltplan behaupten 2 MHz. Man darf nicht vergessen, der 6510T hat kein SO-Signal und das ganze System läuft mit nur einer IRQ-Quelle, dem 555 der meiner Erinnerung nach ca. alle 10ms einen IRQ auslöst. Alles andere muss per Polling passieren. Anscheinend reichten dafür 1 MHz nicht mehr.

    Zum 6525 ohne 'A'. Da sollte man nochmal genau hinschauen, es gab immer wieder MOS ICs die ein 'A' nachträglich gestempelt bekamen. Dieses war irgendwo auf dem IC plaziert, nicht direkt hinter der Nummer. Ich hab einen solchen 6510 und ein paar 6526.
  • Das mit dem fehlenden SO Signal macht Sinn. Die 1571 nutzt im 2mhz modus SO auch nicht, nur im 1mhz 1541 kompatiblen modus.

    Gruß x1541

    per tapatalk 2 versendet
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Hallo Leute also zur Reparatur einer 1551 ist es sehr selten das verlötete Bauteile defekt sind
    in der Regel gehe nur drei Sachen an der Elektronik Kaput die 6525/6525A/6526B auf dem Mainbord sowie der ROM 318008-01 DOS
    die CPU 6510T geht so gut wie nie kaput und auf dem Paddle ist der 6523T meistens durch sehr selten die PLA 251641-03 die ist aber gelötet!
    also sollte das Laufwerk und der Traffo noch gehen dann zuerst den Paddle tauschen und danach den 6525
    nix Löten nur fragen !!!
    grüße
  • Schrieb nicht mal ein kluger Kopf, eigentlich sei ein 8255-Baustein (ebenfalls Tri-Port, aber aus dem PC-Bereich und daher viiiel billiger/ leichter zu haben) ein prädestinierter Ersatz für den 6525 Triport-Baustein von MOS? weil ebenfalls 3 x 8 = 24 Portpins vorhanden? Nur sei der aus irgendeinem Grund komplizierter (Ansteuerung, Register ..) ?
    Gesendet über das Bimetall Thermorelais meines Rowenta DW 4015 Dampfbügeleisens