Hello, Guest the thread was called1.4k times and contains 38 replays

last post from imarssen at the

A500 Speicherweiterung wird nichtmehr erkannt.

  • Nach dem ich nun Weiß, das meine interne Floppy dochnicht defekt ist, sondern wohl was mit dem Amiga nicht stimmt, bin ich mal auf fehlersuche gegangen.
    Das erste was aufgefallen ist, was das er bei ca. jedem 5 booten ( Stromschalter an / aus, kein reset! ) direkt mit einer fehlermeldung kommt, statt dem disketten logo. Also ner Guru/Softw.Fail, auch wenn keine disk drin liegt.
    Dann fiel mir auf, das die speicherweiterung ncihtmehr erkannt wird. Schalterstellung is völlig egal. Ich kenne diese art erweiterung eh nicht, meine früher war nur reingesteckt und fertig, diese hier hat eine der board chips per zwischensockel an nem kabel hängen.
    512kb games wie Turrican, laufen aber fehlerfrei. Bei anderen games, braucht er mehrere ladeanläufe. Vor kurzem ging das gerät noch einwandfrei.
    Meine gedanken sind nun: Disketten großteils defekt und ram erweiterung im Eimer. Das extra Ram müsste ja ihn der Workbench oben angezeigt werden oder? Da steht momentan immer 392864 und früher mein ich das dort halt entsprechend mehr gestanden hat. Kann ich die Ram erweiterung nun in die tonne hauen, oder gibts ne rettungs möglichkeit?

  • Hab sie schon aus und rein und kontakte geprübt und so, die kabel stescke alle einmal abgezogen und wieder dran, aber nix :(
    Bei Ebay wollen die doch echt knapp 15 euro + Versand, also knapp 20 euro dafür, son wucher. Ich wollte eigendlich sogar mal mehr ram reinhauen, so auf 2,3 oder 2,5 MB, weiß nichtmehr was es da für karten gab, aber das ist
    bei den preisen ja utopisch.

  • Naja, normalerweise langt eine 512KB-Erweiterung in den meisten Fällen beim 500er.
    Aber ich bin mir nicht wirklich sicher ob das wirklich an der Mem-Card liegt.
    Der Ideal-Fall wäre natürlich den Rechner zu einem Usertreffen in der Nähe mitzunehmen, bzw. eine Speicher-Erweiterung von einem Bekannten zu testen ;)
    Gruß

  • ja 512K, also dann auf insgesammt 1MB.
    Also ich kenne mich da nicht so aus, aber sie hat einen der Chips auf den Mainboard mit einem zwischensockel und die chips haben ein OKI logo drauf. Leider ist das auch schon alles was drauf steht und ich hab die ganze platine abgesucht. Sie ist recht lang und füllt 3/4 des schachtes unten aus, meine die ich als kind hate, war nur halb so lang.

  • ja 512K, also dann auf insgesammt 1MB.
    Also ich kenne mich da nicht so aus, aber sie hat einen der Chips auf den Mainboard mit einem zwischensockel und die chips haben ein OKI logo drauf. Leider ist das auch schon alles was drauf steht und ich hab die ganze platine abgesucht. Sie ist recht lang und füllt 3/4 des schachtes unten aus, meine die ich als kind hate, war nur halb so lang.


    Mach doch mal ein Foto und stells hier rein. Die Karten mit GARY-Zwischensockel waren normalerweise diese Hacks die bis zu 1.8MB konnten.


    Ansonsten sind defekte RAMs natürlich eine Möglichkeit bei so alter Hardware. Falls die RAMs gesockelt sind könnte es auch ein Kontaktproblem zwischen RAM und Sockel sein (nachdrücken)


    Als letztes wäre noch in RAM-Mismatch möglich. Die alten FAT AGNUS mit der Nummer 8371 unterstützen nur bis 256Kx1 DRAMs, erst mit dem 8372A sind auch 256Kx4 möglich (Refresh). Eine Speicherkarte mit nur 4 RAMs zusammen mit einem 8371 kann funktionieren, muss aber nicht.

  • Hier mal das Foto:


    Ok, das sieht doch mal gut aus. Das ist eine dieser Hack-Erweiterungen die eigentlich 1.8MB Slow-RAM bringen müsste. Der AGNUS passt auch, auf dieser Revision war immer ein 8372A verbaut.


    Die RAMs sind auch alle gesockelt. Bau sie mal aus (vorsichtig mit einem kleinen Schraubenzieher aus den Sockel hebeln ohne die Pins zu verbiegen! Merken wie sie im Sockel steckten!) und wieder ein, u.U. hast du korrodierte Kontakte. Weiter solltest du mal im Betrieb fühlen ob einer der Chips heiss wird. Leicht warm ist OK, aber wenn so ein RAM heiss wird ist es garantiert defekt. Passenden Ersatz (414256-DRAMs) findet man z.B. auf alten VGA-Karten mit ET4000.


    Das Kabel zum GARY auf beiden Seiten auch mal mehrfach ab- und wieder aufstecken um die Kontakte zu reinigen.


    Wo gehen die roten und schwarzen Kabel hin und warum hängt das schwarze Kabel in der Luft?

  • Hi, ich glaube sie läuft wieder. Ich habe mal die weiße Batterie abdeckung abgenommen und da war ein wenig schmock darunter, den ich vorsichtig entfernt habe, dann habe ich den pin connector wo normal der schalter dran ist, mal überbrückt.
    und nun bekomme ich in der WB oben fplgenden wert angezeigt 2227720 (Vorher wars 392864 ). Bin nicht so gut im Bytes umrechnen, vieviel MB zeigt er da bitte an ?

  • Hi, ich glaube sie läuft wieder. Ich habe mal die weiße Batterie abdeckung abgenommen und da war ein wenig schmock darunter, den ich vorsichtig entfernt habe,


    Wobei man diese Batterie/Akku dringend entfernen/wechseln sollte.


    Quote


    dann habe ich den pin connector wo normal der schalter dran ist, mal überbrückt.
    und nun bekomme ich in der WB oben fplgenden wert angezeigt 2227720 (Vorher wars 392864 ). Bin nicht so gut im Bytes umrechnen, vieviel MB zeigt er da bitte an ?


    Das sind jetzt die ca. 2.3MB die man mit so einer Erweiterung bekommt. Ist wie gesagt ein Hack, aber war damals eine billige und einfache Möglichkeit mehr als 1 MB in einem A500 unterzubringen. Nachteil: Das RAM wird weiterhin vom AGNUS verwaltet, ist also genauso langsam wie Chip-RAM auch wenn es als Fast-RAM gelistet wird.

  • Also als erstes: Ich weiß nun, das der kippschalter der übeltäter ist, der überträgt selbst im EIN modus keinen saft. Die erweiterung ist also OK.
    Frage wegen des Hacks. Was ist denn rein für Spiele wie Indiana Jones 4 oder Monkey 2 mehr zu empfehlen. Ne langsame Hack erweiterung die aber mehr ram bietet, oder eine normale auf 1 mb die aber echtes Fastram ist ?

  • Also als erstes: Ich weiß nun, das der kippschalter der übeltäter ist, der überträgt selbst im EIN modus keinen saft. Die erweiterung ist also OK.
    Frage wegen des Hacks. Was ist denn rein für Spiele wie Indiana Jones 4 oder Monkey 2 mehr zu empfehlen. Ne langsame Hack erweiterung die aber mehr ram bietet, oder eine normale auf 1 mb die aber echtes Fastram ist ?


    Jede Speichererweiterung die diesen Anschluss im A500 benutzt ist Slow-RAM oder Chip-RAM, für echtes Fast-RAM brauchst du etwas was entweder im CPU-Sockel sitzt oder links am Erweiterungsport angeschlossen wird.


    Zum Thema Spiele... Normalerweise ist die Speichermenge interessant und ob genug Chip-RAM vorhanden ist.


    Ob deine Speicherkarte einen Umbau auf 1 MB Chip-RAM erlaubt und dann noch korrekt funktioniert ist eine andere Frage. Von der Theorie her müsste sie dann 1.5MB Slow-RAM und 512KB Chip-RAM liefern...

  • ok zum abschluß dann noch: kann ich zu dieser erweiterung zusätzlich eine turbokarte einbauen, damit auch wing commander mal flüssig läuft, oder zicken die sich dann gegenseitig an, und was für eine ist zu empfehlen. Ne bezugsquelle oder preis, wären ein nettes sahnehäubchen ;P

  • Wobei man diese Batterie/Akku dringend entfernen/wechseln sollte.

    Das würde ich auch empfehlen. Bevor die irgendwann doch ausläuft, und dann die Platine ruiniert. Entweder entfernt lassen (hab ich bei mir so). Oder gegen neue auswechseln.

    Das sind jetzt die ca. 2.3MB die man mit so einer Erweiterung bekommt. Ist wie gesagt ein Hack, aber war damals eine billige und einfache Möglichkeit mehr als 1 MB in einem A500 unterzubringen. Nachteil: Das RAM wird weiterhin vom AGNUS verwaltet, ist also genauso langsam wie Chip-RAM auch wenn es als Fast-RAM gelistet wird.

    Ha, die kenn ich doch. Ich hab auch eine 1.8MB RAM-Erweiterung von BS, aber meine hat ZIP-RAMs. Sonst sieht meine so ähnlich aus. Wobei ich die roten Kabel (ich vermute zum Abschalten/Einschalten der Erweiterung, aber möglichst den Computer vorhher ausschalten, sicher ist sicher) mit Anschlussstecker kontrollieren. Die Stecker auf der RAM-Erweiterung scheinen mir in Schneid/Klemmtechnik zu sein. Nicht gerade der zuverlässigste Kontakt. Und die Schalter auch mal auf Durchgang prüfen. Bei mir hatte sich ein Kippschalter für einen Kickstart-Umschalter verabschiedet. Sollte eigentlich auf der Kick 2.04 Stellung schalten. Tat er aber nicht, nur noch die andere Stellung funktionierte noch. Bei der Kick 2.04 Stellung hat er die zwei Pins gar nicht mehr kurzgeschlossen und stattdessen einfach offen gelassen. Das fand der Kick-Umschalter nicht toll, und hat gar kein Kickstart eingeblendet. Demnach schwarzer Bildschirm. Bei mir hatte ich ausserdem das Kabel der RAM-Erweiterung, das zum Gary-Adapter Sockel geht, abgerissen. Die Pins am Adapter-Sockel waren dann unbemerkt aus der Lotstelle gebrochen und hingen dann schief. Also dann kein bzw. Wackelkontakt. Lötstellen nachgelötet und gut war. Und seit dem tut sie es wieder. Bei mir war allerdings der Akku ausgelaufen und ich konnte die Sauerei dann reparieren.

  • Ich nehme an, das BS steht für 'Bestückungsseite' oder 'Bauteilseite'. Auf der Unterseite findest du wahrscheinlich ein 'LS'.


    Gerrit

    Hmm, macht man das so gross drauf wie andere Hersteller (z.B. 3-State) ihr Logo? Also ist das dann ne No-Name RAM-Erweiterung?