Hello, Guest the thread was called6.6k times and contains 39 replays

last post from sm74 at the

Power Mac G3 (Blue & White) macht Probleme

  • Hallo!
    Ich habe vor Kurzem den oben genannten Computer gekauft. Dieser lässt mir jetzt jedoch keine Ruhe.


    Er hat einen 300 MHz Prozessor, hatte 256 RAM (2 Riegel von verschiedenen Herstellern), ein DVD-Laufwerk und 2 Festplatten (eine 60GB IDE und eine SCSI an einem Formac ProRaid, von der ich die Größe nicht weiß).


    Als erstes habe ich OS X 10.4 installiert und weitere 256 MB RAM installiert (also dann 512 insgesamt). Nachdem der Rechner beim Updateversuch auf 10.4.11 immer abgeschmiert ist, hatte ich mir das Update manuell geladen und installiert. Der Rechner lief dann, allerdings etwas instabil.


    Habe mir dann gedacht, dass ich das System nach so vielen Fehlgeschlagenen Installationen jetzt einfach noch mal frisch aufsetzen könnte, da ich ja nun wusste, wie alles geht.


    So weit so gut.


    Habe danach keine OS X Installation mehr geschafft... Die neuen RAM Riegel habe ich mal auf Verdacht ausgebaut, danach gings.


    Hatte dann vor, alles wieder zu installieren und danach erst mal einen langen Test mit den womöglich defekten Riegeln, die ich wieder einsetzen wollte, zu machen. Also erst mal das Update auf 10.4.11 versucht zu installieren.


    Dabei stürzte der Rechner dann allerdings ab (schwarze Zeilen mit weißem Text erscheinen auf einmal mitten im Bild (jedoch nicht die Meldung, man müsse seinen Rechner neu starten)). Was dort stand kann ich nicht mehr genau wiedergeben.


    Als ich das System daraufhin neu starten wollte, kam ich nicht mehr in den GUI. Wollte dann versuchen, den Mac neu zu starten und noch mal das System zu installieren, allerdings bootet er nun nicht mehr von CD (?!?!?!). C gedrückt halten hilft nichts. Ansonsten habe ich von CMD-OPT-SHIFT-DEL gelesen? Welche Tasten sind das überhaupt auf der standard Windows Tastatur? Geht diese Kombination damit überhaupt?


    Jetzt stecke ich fest mit einem zerschossenen OS und einem nicht mehr von CD startendem Mac.


    Nebenbei habe ich übrigens bemerkt, dass die SCSI Platte nicht erkannt wird. Woran kann das liegen? Da der Mac ja kein BIOS hat, weiß ich nicht wo ich solche Sachen einstellen soll.


    Wisst ihr weiter?

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • Dass die SCSI-Platte nicht erkannt wird, hat einen einfachen Grund: Der iMac hat eine IDE Platte. Wenn du auf das 40 polige Kabel eine Platte mit 50 Pinnen gequetscht hat, wird die Platte logischerweise trotzdem nicht erkannt. Wenn es nur ein Schreibfehler ist: Ist die Platte möglicherweise zu groß (ich meine Gigabyte, nicht Zentimeter)? Wenn die Platte größer ist als 8 GByte, muss sie partitioniert werden, da sonst MacOS X nicht installiert werden kann. (Übrigens: Ich bin davon ausgegangen, dass auf dem Ur-iMac 10.4 gar nicht, bzw. nur mit Tricks (PostXfacto oder wie das Programm heißt) installiert werden kann. Vielleicht liegt es daran?
    Was das RAM betrifft: Da ist der Knubbel sehr wählerisch. Wenn das Ram stimmt, sollte es allerdings klappen.


    Weitere Tipps gibt es hier: http://lowendmac.com/imacs/rev-a-imac-g3-233-mhz.html

  • Hi!


    Verstehe nicht was du meinst. Die SCSI Platte ist ordnungsgemäß am Formac und die IDE ist am IDE Anschluss auf dem Mainboard.


    Außerdem geht es um den Power Mac, nicht den iMac. Darauf läuft 10.4 ohne Probleme.


    Ich hatte es ja auch schon am laufen, konnte updaten, konnte BOINC installieren, konnte ins Internet usw... Nur ist der Rechner halt instabil gelaufen... Und als ich angefangen habe, der Sache auf den Grund zu gehen, haben sich Abgründe aufgetan.


    Sobald ich den RAM testen kann, werde ich das mal machen. Das sollte doch dann klappen, wenn die RAMs in Ordnung sind, oder? Oder gibt es da noch mehr zu beachten?

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • ich glaub hier läuft was schief, das ist kein iMac und es ist ein separater SCSI-Controller verbaut...


    Mit diesem wird es so sein: Der braucht seine eigenen Treiber. Mit etwas Glück findet man diese noch zum 'runterladen. Was natürlich erst was bringt, wenn das OS läuft...
    die alten PowerMac waren bzgl. RAM-Riegel sehr wählerisch, hier würde ich wirklich mal mit Riegel testen, die bewiesenermaßen im Mac ohne Probleme laufen.


    Die von Dir genannte Tastenkombi sagt mir noch nicht viel, da ist vielleicht auch was durcheinander gekommen. Meinst Du das Zurücksetzen des Parameter-Ram? Hierzu muss man bei Rechnerstart folgende Tasten eine Weile gleichzeitig gedrückt halten: STRG - ALT - P - R (PC Tastatur) es heißt, abwarten bis der Rechner noch mal startet, der Startton kommt, dann loslassen

  • übrigens, 10.4.11 kann man schon mal eine Weile mit 512MB zum Herumspielen nutzen... aber ein G3 300Mhz ist hier trotzdem schon am Limit würde ich sagen. Wundert mich auch gerade, dass das überhaupt möglich ist und vom Installer nicht abgefangen wird.

  • Der Controllername steht auch da. Ich glaube nicht, dass dieser was mit Adaptec zu tun hat. In diesem Bereich des Forums gibt es auch schon einen Thread dazu glaube ich.


    Ich habe gerade gesehen, dass ich das Rev. 1 Motherboard habe. Kann ich damit überhaupt etwas vernünftiges anstellen? Da hier der eingebaute ATA Chip wohl einfach nicht funktioniert, bleibt mir wohl keine andere Wahl als SCSI zu benutzen. Die neueren Mac OS X haben wohl nicht mehr diesen Workaround, der UDMA deaktiviert...


    Kann es sein, dass daher die Fehler mit den ganzen Abstürzen kommen?


    Kann ich da jetzt einfach einen PCI ATA Controller einbauen und dort meine Platten anschließen?


    Der Installer fängt nichts ab, das passiert erst ab 10.5. Apple hat denke ich nicht ohne Grund dieses Abfangen nicht früher eingebaut...
    Mit 512 MB konnte ich den Mac halbwegs nutzen... Ich will ja nicht einen Alltagsrechner haben, sondern nur etwas "zum spielen" und einfach einen laufenden Mac.

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • ja das mit dem Adaptec war ein Schnellschuss, war etwas viel Text oben, hab überlesen dass ein ein Formac ist.


    Ich geb auch zu, Deine Beschreibungen werden leicht verwirrend, oben Stand noch, Installation auf der IDE ist fehlgeschlagen und läuft nicht mehr richtig, der SCSI funktioniert gar nicht.
    Jetzt schreibst Du aber, IDE eingebaut geht nicht, Du willst SCSI benutzen...


    Hast Du schon mal probiert, die bootfähige OSX-CD ins Laufwerk einzulegen, dann den Reset zu drücken und <alt> gedrückt zu halten?
    Dann sollte nach einigen Sekunden eine Art Bootmenü erscheinen, in dem alle erkannten Laufwerke bzw. Medien angezeigt werden. Hier könntest Du noch mal versuchen, von CD zu starten....

  • Start mit Alt geht auch nicht (wenn das auf der Windows Tastatur auch die Alt Taste ist). Welche Instanz ist für das akzeptieren dieser Befehle zuständig? Wundert mich nämlich wirklich, dass C nicht mehr geht (ging vorher immer).


    Und wieso verwirrend? Das Rev. 1 Mainboard des Power Mac G3 Blue & White hat einen fehlerhaften ATA Chip (IDE Platten laufen also nicht richtig). Deswegen entweder SCSI hinbekommen oder einen neuen (PCI-)Controller einbauen.


    Das System ist durch das herausnehmen der von mir eingebauten 2 128er Riegel ja schon stabil geworden (Install ging wie gesagt, danach ging auch noch ein Install)... Nur stürzte das System danach immer noch ab, auch mit potentiell defektem RAM. Mit dem defekten ATA Chip ist ein weiterer potentieller Störungskandidat im Rennen...


    Um aber dies alles weiter zu überprüfen, muss ich erst mal wissen, warum der Mac nicht mehr auf Tastatureingaben beim Starten reagieren will...

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • Ich kann mich noch erinnern, dass wir im Büro auch einen blauweißen G3 hatten und der mal ganz viel herumgezickt hat, als wir ein neues System installieren wollten. Die Kisten sind extrem zickig, besonders was RAM Bausteine angeht, die nachfolgenden G4 Rechner hingegen sind extrem gutmütig. Wenn der ATA Controller defekt ist und am SCSI ein RAID hängt, würde ich es mal mit einer üblicheren Startkonfiguration probieren: Entweder neuer ATA Controller oder eine Firewire-Platte. Zu Testzwecken kann man einen weiteren Mac per Firewire anschießen und diesen als Boot-Festplatte missbrauchen (Stichwort Targetmode).


    An eine 8GB-Grenze, wie von DrZarkov beschrieben, kann ich mich nicht entsinnen. Der interne ATA Controller kommt aber nur mit Festplatten bis 128 GB klar, außer man patched den HD-Treiber. Bei SCSI, zusätzlichem ATA-Controller oder Firewire gibt es keine GB-Begrenzung.


    Ich bin nicht ganz sicher, ob PC-Tastaturen wirklich zum Startzeitpunkt schon zu 100% funktionieren oder ob nicht erst das OS nach dem hochfahren mit einem Treiber für die vollständige Funktion sorgt. Von daher würde ich sicherheitshalber mal eine original Apple Tastatur probieren.

  • Ich glaube der Mac unterstützt das Booten über Firewire noch nicht.


    In Wikipedia steht, dass man aufgrund des Fehlers des internen Controllers "nicht zwei Festplatten und keine neueren Festplatten" anschließen kann:


    http://en.wikipedia.org/wiki/P…intosh_G3_(Blue_%26_White)


    Naja, das mit C Drücken ging halt vorher... Diese Kombinationen mit OPT und CMD wahrscheinlich nicht... Ich kann mich dunkel erinnern, dass ich als der Rechner mal lief, die Windows Taste zu Hilfe genommen habe, um mehrere Dateien auszuwählen...


    Gut, eine Apple Tastatur werde ich denke ich bald haben.


    Einen Controller habe ich nicht mehr als PCI verfügbar...Da müsste ich nach schauen.

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • Wow, das wäre spitze, JollyJoker! Neues Board legen wir erst mal zur Seite als "Letzte Rettung"... Speicher brauche ich auf jeden Fall... Einen IDE Controller hast du nicht zufällig auch rumliegen?


    Ich habe jetzt übrigens noch was herausgefunden:


    CMD-OPT-SHIFT-DEL soll man drücken, um die interne "Startup Disk" zu umgehen und/oder von externen zu booten (auch von CD).
    Auf einer Windows Tastatur ergibt diese Tastenkombination WINDOWS-ALT-SHIFT-BACKSPACE !!! Für alle die das in Zukunft mal brauchen werden.


    Ich habe jetzt geschafft, von CD (DVD in meinem Falle) zu booten, jedoch erst, nachdem lange dieser Ordner angezeigt wird, worauf wechselnd das Mac-Logo und ein Fragezeichen erscheint...


    Ich werde jetzt noch mal Mac OS X installieren... Da ich eine 60GB IDE Platte eingebaut habe erwarte ich jedoch definitiv Fehler wegen des Controllers... Vielleicht schaffe ich es, meinen RAM wenigstens zu testen.

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • Ach ja, welche Software (Not)-Lösung würdet ihr mir empfehlen, um das Problem mit dem eingebauten Festplattencontroller zu umgehen?

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...

  • Ich glaube der Mac unterstützt das Booten über Firewire noch nicht.


    Kann ich mir nicht vorstellen. Seit es FW gibt, können Macs doch darüber booten. USB-booten ist aber erst bei den Intel-Macs dazugekommen.


    dass man aufgrund des Fehlers des internen Controllers "nicht zwei Festplatten und keine neueren Festplatten" anschließen kann


    Du hast ja nur eine IDE-Platte drin und mit "neueren Platten" werden die welche über 128 GB meinen. Die konnten selbst die G4-Rechner erst recht spät ootb per ATA vollständig verwenden.


    [EDIT] "Stable operation can be achieved if the drive can be limited to Multi-Word DMA Mode 2 (disabling UDMA), although this limits throughput to 16 MB/sec." Also ist auch die Geschwindigkeit bei neueren Platten ein Problem. UDMA kann man wahrscheinlich über alternative Treiber oder Jumper ausschalten. Du kannst auch einfach über SCSI booten, wenn du da statt des RAIDs einfach eine einzelne SCSI-Platte dranhängst. Ansonsten neuen ATA-Controller kaufen.

  • Hallo


    Das gleiche Problem hatte ich mit meiner Frau ihrem Imac G3 auch. Und zwar der Rechner besitzt noch kein Firewire, also muß der TIGER anders installiert werden, damit das funktioniert. Am besten IDE Platte raus, in einem Mac mit mind. G4 Proz einbauen, oder an ein externes Gehäuse, und mit dem G4 dann den Tiger installieren. Platte wieder zurück in den G3 und es funktioniert alles einwandfrei.


    Wenn du ihn normal installieren willst, Panther oder Jaguar sind auf der Kiste sehr zu empfehlen und funktionieren auch ohne Probleme. Tiger wie gesagt nur über Umwege.

  • Und zwar der Rechner besitzt noch kein Firewire, also muß der TIGER anders installiert werden, damit das funktioniert.


    Stimmt, das war mir gar nicht aufgefallen. Der blauweiße G3 hat noch gar kein FW onboard, dann kann man Tiger nicht ohne Tricks installieren (FW ist laut Apple Minimalvoraussetzung). Also entweder Vorversion (10.3 Panther) nehmen oder auf einer anderen Maschine auf die umgebaute Platte installieren (so habe ich das bei meinem 350MHz G3 iMac gemacht). Dazu kann man noch sagen, dass diese G3-Rechner unterhalb der 400 MHz Grenze ohnehin nie für OSX gedacht waren und es nur "ganz ok" läuft – aber nicht wirklich snappy.

  • Nun, es "dauert" meist etwas länger, bis der Mac auf SCSI-Geräte zugreift. Macht meiner übrigens auch mit einem 16GB-RAID. ;) Dafür ist aber auch DVD-ROM und ZIP-Laufwerk inkl. passenden Blenden verbaut. Es handelt sich bei meinem Modell auch um das spätere 450MHz-Modell. Also Tiger läuft mit 768MB recht flott darauf und vor allem, Stabil. ;) Und der G3 B&W ist der letzte, der neben dem USB-Port noch den alten ADB-Port für ältere Tastaturen hat. Und FireWire hat er schon, da hängt bei mir ein FW-CD-Brenner dran. :D

  • Wegen Firewire war ich doch jetzt etwas unsicher, daher habe ich bei Wikipedia nachgesehen. Da wird behauptet: "Der Power Macintosh G3 blauweiß (Yosemite) ist Apples erster PC mit Firewire-Schnittstelle; diese ist auch nicht in den Chipsatz integriert, sondern auf einer kleinen Zusatzplatine untergebracht. Auffallend viele Besitzer des Rechners klagen über teilweisen oder vollständigen Ausfall der Firewire-Schnittstellen oder über unzuverlässigen Datentransfer. Abhilfe schafft – wie bei der defekten IDE-Schnittstelle – eine billige Firewire-PCI-Einsteckkarte."


    Von daher sollte einer Tiger-Installation doch nichts im Wege stehen.

  • Das war ja auch nie die Frage. Der Mac hat Firewire, kann jedoch nicht darüber booten.


    Ich hab jetzt den RAM getestet für ein paar Stunden, keine Fehler.


    Ich verstehe aber noch nicht ganz, wie man das mit dem eingebauten Controller umgehen soll. Man soll das Laufwerk an Slave hängen... Was ist damit gemeint? Habe auch gelesen, der in OS X eingebaute Fix für diese Mainboard Revision funktioniert nur, wenn eine Festplatte an Slave hängt.


    Naja... Im Moment richte ich mir mein OS X 10.4.11 ein. Bis jetzt noch keine Probleme. Ich habe 2 Platten am IDE Controller, eine als Master, die andere als Slave. Greift jetzt der in OS X eingebaute Fix?

    Ein <3 für alte Geräte...
    Konsolen: Philips G7000, Amiga CD32, Interton VC4000, Nintendo NES, RFT BSS 01...
    Computer: Commodore 710-D, Robotron KC87, Amiga 1000, Lear-Siegler ADM31...