Hello, Guest the thread was viewed25k times and contains 51 replies

last post from jakblak at the

dtv2ser 0.5 released

  • Oh Mann,


    nach der Neugestaltung der Schaltung habe ich wieder ein Schirmproblem


    Muss mir wohl eine neue Leitung löten.


    Gruß


    stevedee78

  • Hi,

    Und: Das ist der erste dtv2ser Arduino-Nachbau den ich gesehen habe ;)
    Wäre mal interssant zu wissen, wer sich noch so ein gutes Stück hier gebaut hat...

    hab mir grad auch einen gebastelt. Funzt auf Anhieb mit Arduino 2009. :thnks:


    Gruß,
    twinpeaks

  • Die Bilder sehen doch schon mal gut aus... :thumbsup:

    Wenn der Arduino frisch ist, wird es keine alte FW geben - nur den Bootloader.
    Den wird die neue FW auch nicht anfassen.


    Also kann ich alles so lassen und meinen Arduino Uno R3 weiter für andere Projekte nutzen????


    GRuß


    Stevedee78

  • Seit langem wollte ich schon mal mit meinen DTV basteln. Nun habe auch ich mich mal aufgerafft und meinen Arduino2009 umgebaut.


    Der Umbau scheint nach Anleitung problemlos zu sein, die Kabel sind ca. 10cm lang. Firmware flashen war ebenfalls problemlos:


    avrdude: 7184 bytes of flash written
    avrdude: verifying flash memory against dtv2ser-0.5b-250000-arduino2009-atmega328.hex:
    avrdude: load data flash data from input file dtv2ser-0.5b-250000-arduino2009-atmega328.hex:
    avrdude: input file dtv2ser-0.5b-250000-arduino2009-atmega328.hex auto detected as Intel Hex
    avrdude: input file dtv2ser-0.5b-250000-arduino2009-atmega328.hex contains 7184 bytes
    avrdude: reading on-chip flash data:


    Reading | ################################################## | 100% 1.47s


    avrdude: verifying ...
    avrdude: 7184 bytes of flash verified


    avrdude: safemode: Fuses OK


    avrdude done. Thank you.



    Aber nun:



    ./dtv2sertrans -s 250000 diag testsuite
    dtv2sertrans version 0.5, dtv2ser device version 0.5
    result: 0402 Client: Server timed out
    ERROR: dtvtrans server is not alive!
    FAILED: CmdError('Command failed',)


    Das ganze findet unter Linux statt, ich bin einigermaßen ratlos, da ich mir nicht vorstellen kann, dass dies ein Hardwareproblem darstellt (nach meinem Verständnis scheint es ein Kommunikations-Problem zw. FTDI und ATmega328 zu sein). Kann mir jemand bei der Fehlersuche ehilflich sein?


    BTW: warum wird denn an dem DB-Konnektor PIN9 verbunden, nach DTVHacking-Wiki ist der gar nicht angschlossen. Spekulation: "hier gehört eine Verbindung zu DTV-Reset hin"


    blechtasse

  • Hallo blechtasse,


    Haben Sie jemals eine Antwort auf Ihre Frage bekommen?


    Ich habe genau das gleiche Problem. Ich baute meine dtv2ser usb mit einem Arduino 2009, aber wenn ich versuche, es Bootstrap oder etwas zu tun bekomme ich das gleiche Ergebnis wie Sie.


    dtv2sertrans version 0.5, dtv2ser device version 0.5
    result: 0402 Client: Server timed out
    ERROR: dtvtrans server is not alive!
    FAILED: CmdError('Command failed',)


    Ich benutze Windows.Ich habe es nicht in Linux versucht, aber ich bezweifle, dass es einen Unterschied machen sowieso.


    Sorry für die Wiederbelebung einer alten Thread, aber es ist der erste Thread Ich habe auf Google mit genauen dieser Ausgabe zu sehen.


    Auch sorry für mein Deutsch, schuld Google Translate. ;)

  • Hallo zusammen, frohes Neues ! ( knapp 4 Jahre später...)

    vielen Dank für die Anleitung - Hatte lustigerweise genau die gleichen Probleme wie stevedee78 gehabt und die Lösungen dazu haben mir direkt geholfen. Jetzt läuft das Ganze auch mit einem Arduino Uno blasenfrei.


    >>

    Komisch kriege jetzt auch ein


    result: 0402 Client: Server timed out

    Auch das habe ich bei mir gehabt. Lag bei mir daran, dann noch etwas anderes an dem Arduino angeschlossen war (z.b. das USB Kabel zum Programmieren oder Arduino per Netzteil betrieben) Nachdem ich den Arduino nur mit dem FTDI VCC über V-IN betrieben habe, war der Fehler weg. Wichtig scheint auch der USB FTDI Chip zu sein.

    Der DTV sollte auch an ein gutes Netzteil oder frische Batterien angeschlossen sein, die Abschirmung an das DSUB-9 (nicht PIN 9!) Metallgehäuse und auf der anderen Seite auf GND. Danach lief bei mir alles mehrfach super durch.


    Viele Grüße

    JakBlak