Angepinnt Yape unter Linux (Ubuntu) installieren

  • sauhund schrieb:

    keine ahnung, ich hab immer die windows version (unter wine) benutzt, da der sdl port ziemlich outdated ist.
    Iss halt schon unbefriedigend, wenn man weiß, dass es eigentlich nen Linux-Source gibt, der theoretisch tut, aber dann doch mit dem Wine-Geraffel rum fingern muss. Aber wenn das so gut funktioniert, wie du meinst, test ich das auch mal. Ist ja nicht das erste Programm, bei dem es mir so geht. ;)
    12345678901234567890123456789012345678901234567890
    12345678901234567890123456789012345678901234567890
    12345678901234567890123456789012345678901234567890
  • Ich habe mir eben den aktuellsten Source hier besorgt: yapesdl.codeplex.com/SourceControl/latest#README.SDL

    System: Ubuntu 14.04

    apt-get install libsdl2-dev , um die passende SDL auch da zu haben.

    Nach dem Entpacken des Source und make hagelt es dann Fehlermeldungen. Sieht aber schlimmer aus, als es wirklich ist.
    Im Makefile fehlt SaveState.cpp :

    Unter objects: SaveState.o \ nachtragen und

    SaveState.o : SaveState.cpp
    $(CC) $(cflags) -c $<

    damit es auch kompiliert wird.

    Danach läuft make dann geschmeidig durch und mit ./yapesdl kann der Emulator gestartet werden.






    Mit F8 kommt man in dieses Menu. Weiter habe ich mich noch nicht damit beschäftigt.
    If we're evil or divine - we're the last in line. - Ronnie James Dio (1984) -
  • cbmhardware schrieb:

    Im Makefile fehlt SaveState.cpp :

    Unter objects: SaveState.o \ nachtragen und

    SaveState.o : SaveState.cpp
    $(CC) $(cflags) -c $<

    damit es auch kompiliert wird.
    Danke für die Info. Hast du diese Info dem Dev-Team mal gemeldet? (Wobei es schon ziemliche Schlamperei sein wird, weil ich doch davon ausgehe, dass das File auch auf anderen Plattformen benötigt wird und denen das beim Maken eigentlich aufgefallen sein müsste.)
    12345678901234567890123456789012345678901234567890
    12345678901234567890123456789012345678901234567890
    12345678901234567890123456789012345678901234567890
  • 7Saturn schrieb:

    Danke für die Info. Hast du diese Info dem Dev-Team mal gemeldet?

    Nö, noch nicht, da muss man sich vorher bei CodePlex anmelden. Bei Deinem Versuch gab es auch immer wieder die Meldung "Nicht definierter Verweis auf ...", was meist auf Durcheinander oder fehlende Einträge im Makefile hinweist.
    If we're evil or divine - we're the last in line. - Ronnie James Dio (1984) -
  • Benutzer online 1

    1 Besucher