Step-by-Step SD2IEC Lochraster Nachbau

  • @CapFuture1975

    Moin Moin, so etwas hatte ich auf einem Board auf Youtube gesehen. Nee, die laufen noch stabil.
    War nur ne Frage, weil ihr ja schon erfahrener seid.
    Recap hat bestens funktioniert. Die unter dem VIC Deckel waren mit 2,5 µF schon sehr am Ende.
    Zwei der großen hatten einen Kapazitätszuwachs von ca 400µF. Sie waren Ohmsch messbar :)
    Vielleicht bilde ich mir das ein, aber nach dem einschalten war das Startbild ruckzuck da und
    das Bild war besser (tausch der VIC C's ).

    Jetzt bin ich am Netzteil bei :)

    lg
    Scan me, Ping me and give me dirty Hostnames :)
  • Hi An euch,

    ich muss den beutrag mal rausholen, ich habe jetzt auch ein sd2iec nachgebaut nach Lars, ein es wird auch auf der C64 Seite erkannt.
    Nur ich bekomme den Sockel für die SD Karte nicht zum laufen, egal ob ein alter aus einem Kartenlesegerät oder ein SD aud Micro.
    Einen habe ich zum laufen bekommen, (aus einem Kartenlesegerät) jetzt wollte ich noch einen bauen, ohne erfolg.

    Wenn ich alles anschliesse kommt immer wurde nicht gefunden, die LED läuchtet die WP und CD leitungen habe ich angschlossen also auch auf GND.
    gelegt. Leider bin ich gerade nicht an meinem Rechner und kann keine Bilder machen, werde aber heute Abend mal weche einstelle.

    Also langsam bin ich echt am verzweifeln... ist ja nicht das erset Project was ich nachbaue oder selbst baue... aber dies SD Karten sache will net....
  • Gehe mal dieverse Posts zurück, da kannst Du sehen, wie ich meinen zweiten mit SD Kartenleser baue.
    Capfuture1975 war sehr hilfreich mit den belegungen des Lesers und wie er angeschlossen wird.
    Ab Post 462 zu sehen.


    Auf dieser und der nächsten Seite kannst Du den von mir sehen. Ist auf der Heute gebastelt Seite


    Heute so gebastelt ...
    Scan me, Ping me and give me dirty Hostnames :)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von fepo ()

  • Hi an euch,

    ein kurzer zwischen Stand, ich weis nicht warum, aber wenn die die clk leitung die an PIN 8 liegt direckt ohne den 1,8K Wieder stand anschliesse, geht der SD Sockel.
    ich weis jetzt aber nicht warum, gemessen habe ich von VCC auf PIN 8 3,3 - 3,6V.
    Der Atmel 644P wiird mit 5V betrieben und mit einem Step Down die SD auf 3,3 V
  • cmc1976scs schrieb:

    Hi an euch,

    ein kurzer zwischen Stand, ich weis nicht warum, aber wenn die die clk leitung die an PIN 8 liegt direckt ohne den 1,8K Wieder stand anschliesse, geht der SD Sockel.
    ich weis jetzt aber nicht warum, gemessen habe ich von VCC auf PIN 8 3,3 - 3,6V.
    Der Atmel 644P wiird mit 5V betrieben und mit einem Step Down die SD auf 3,3 V
    Mach doch bitte mal Fotos von deinem SD2IEC-Aufbau.

    DoReCo #55 16.12.2017
  • Deine Trennung des Lochstreifens am Atmel sieht sehr abenteuerlich aus. ;(
    Vielleicht solltest Du nochmal sauber trennen.
    Mit nem Bohrer geht es gut und sieht sauber aus.
    Vielleicht ist auch der 1, 8 K kaputt (hochohmig). Den mal durchmessen. Der 3,3K der gegen Masse geht ist wirklich 3,3K ?
    Bitte auch überprüfen. Es sieht nämlich so aus, dass durch einen falschen 3,3K (evtl 33 Ohm etc) die Spannung
    runtergezogen wird.
    Scan me, Ping me and give me dirty Hostnames :)
  • Hi,

    also die trenungen passen habe ich durch gemessen, die 3,3 K sind die zweiten zu erst hatte ich ein Netzwerk mir 3.3K.
    Ich werde noch mal 1,8 K ordern, denn da habe ich keine mehr da!

    Ansonsten werde ich das ganze noch mal auf deinem Steckbrett aufbauen zum Testen. Denn das wurmt mich schon, ist ja nicht
    die erste schaltung die ich nachbaue. Hab schon komplette Arduinos selbst gebaut in DIP wie SMD usw...
  • Danke für die Bilder. Dank der SMD-Bestückung ist ein nachverfolgen auf dem Foto etwas schwierig, aber irgendwo muss da tatsächlich ein Fehler sein. Ich hatte noch nie Probleme mit der SD-Anbindung. Die Leiterbahn-Unterbrechungen kann ich wie mein Vorredner auch nicht gut heißen, wenn man das schon mit einem Cuttermesser macht, dann macht man zwei Ritze parallel und entfernt den Zwischenraum, auch der Grat sollte entfernt werden.

    Deine Leitungen zum MicroSD-Card-Adapter sind auch etwas zu lang, die sollten nicht länger wie 5cm sein.

    DoReCo #55 16.12.2017
  • Ich hab jetzt gerade nicht im Kopf, wie schnell die SPI Signale sind, aber evtl. könnte da sogar so ein Selbstbau Oszi auf dem Steckbrett schon reichen, um mal zu gucken?

    Wenn das Badenheimer Treffen demnächst mal wäre, hätte ich ein Oszi mitbringen können. Evtl. hat auch jemand bei dem Frankfurter Nerd-Treffen eines dabei? Oder Du hast einen Hackerspace in Reichweite?
    Hier könnte ihre Signatur stehen!
  • Hi,

    ich habe ja viel aber leider nicht alles... ich habe heute noch mal Atmel etc bestellt und werde es erst mal aufs Steckbrett aufbauen. Und ich sollte mich echt mal mit Kicad beschäftigen,
    dann wäre schluss mit dem lochraster gedöns!!! Dann muss ich nur noch Zeit finden bei den ganzen Hobbys und Arbeit noch Zeit zu finden :( !!
    Aber ich halte euch am Laufen...