Hello, Guest the thread was called176k times and contains 1387 replays

last post from DJ SID at the

Chameleon - Diskussion über Features

  • wird AntaBaka"s zurück gesendetes auch noch neu geflasht oder ausgetauscht?


    Im Moment müsste sein Chameleon dafür wieder hierher, was sicherlich sinnfrei ist. Einziger Unterschied ist, dass bei einem derzeit hypothetischen Microcontroller-Update der de-brick Jumper gesetzt werden müsste. Antabaka traue ich das ohne Weiteres zu, insofern ist es eine Frage des Versandes, die zwischen Vesalia, der US-Post und Antabaka zu klären ist (oder bist Du grad in Deutschland??)


    Swasti,
    Auflösungen sind software-einstellbar, einfach mal die freeze-Taste (mittlere Taste) für mehr als 0,7 Sekunden gedrückt halten, dann kommst Du ins Menü, wo Du andere Auflösungen einstellen kannst. Aber: Das ist im Moment mehr als nur experimentell. Weder der Skalierungsfaktor, noch Bildposition, schwarze Balken oder Grafikmüll von nicht initialisiertem Speicher werden behandelt. Die Software stellt nur ein paar Werte wie Anzahl Zeilen, Anzahl Pixel und Pixelclock ein (plus noch ein paar andere Kleinigkeiten). Wenn Du da einen Wert gefunden hast, der stabil ein Bild zeigt, kannst Du uns das auf der Yahoo-Liste mitteilen, dann kann der Modus schonmal festgenagelt werden. Dabei ist es egal wie kaputt das Bild aussieht - wenn es stabil ist, ist es für uns ein erfolgreicher Test.


    Alle,
    wie ich gestern schon auf der Yahoo-Liste geschrieben habe, ist in Sachen Core-Update jetzt erstmal eine Herzoperation im Gange: Die Buslogik in Richtung C64 wird so weit umgebaut, dass sie komplett entkoppelt ist vom Ram-Zyklus des Chameleon. Das wird wahrscheinlich einige Wochen dauern, aber das Ergebnis wird sein, dass wir den Turbo aktivieren können, und auch keine Timingprobleme mehr mit irgendeiner C64-Version haben können, ganz einfach weil wir durch diese Unabhängigkeit vorausberechnen können, welche Daten der C64 als nächstes haben will (im Moment hächeln wir immer in Echtzeit hinterher, was "so gerade eben" passt).


    Wenn diese Unabhängigkeit zwischen den zwei Systemen hergestellt ist, können wir auch endlich Gebrauch machen von dem extrem schnellen SD-Ram auf Chameleon, denn dann können wir einfach den Takt hochsetzen. Der steht im Moment bei konservativen 100MHz, und das Ram-Timing bei CL=2 (CL steht für CAS Latency). Mit diesem Timing können wir mit den schnellen Rams bis auf 125MHz gehen, ohne dass uns irgendwelche Probleme erwarten werden (ich glaube, das habe ich schon mehr als einmal hier geschrieben, oder?).


    Jens

  • Einziger Unterschied ist, dass bei einem derzeit hypothetischen Microcontroller-Update der de-brick Jumper gesetzt werden müsste. Antabaka traue ich das ohne Weiteres zu, insofern ist es eine Frage des Versandes, die zwischen Vesalia, der US-Post und Antabaka zu klären ist (oder bist Du grad in Deutschland??)

    Ich hab das schon mit Vesalia geklärt, wird nochmal geschickt.
    Ich bin am kommenden WE in DE und kann es dann selber abholen, ohne meine Holde damit belästigen zu müssen.


  • Eine C Wiki wär cool! :)


    Imho:
    Für eine FAQ ist es noch zu früh, dafür kann (noch) die Yahoo-Group dienen. Mit etwas weniger als 300 Mails ist es zwar auch schon recht mühsam sich durchzulesen, und zugegebenermaßen es ist nicht immer möglich, gezielt nach Fragestellungen zu suchen, aber die Thread-Titel bieten eigentlich schon eine gute Orientierung. Und (*Klugscheiß*): Als Interessierter ist es eh sinnvoll die Liste zu verfolgen, auch wenn man noch keins hat, auch wenn die Hürde "englisch" zu nehmen ist. Die Schwierigkeit ist, das sich noch einige Dinge ändern können, und das müsste alles entweder historisiert oder aktuell gehalten werden.
    Ein C64-Wiki-Artikel würde ich auf jeden Fall begrüßen, aber hier sollte derzeit auch nur das stehen, was erstens "gesichert" (also nicht mehr Beta) ist, UND zweitens nicht klar aus den Manuals hervorgeht. Da die aber auch noch Beta sind, stellt sich auch hier die Frage nach dem "Mehrwert zum jetzigen Zeitpunkt". Ich denke foglendes sollte schon klar sein: Wer sich _jetzt_ ein Chameleon kauft oder schon gekauft hat, _ist_ ein Betatester. Das ist schon eine etwas andere Welt.



    Einziger Unterschied ist, dass bei einem derzeit hypothetischen Microcontroller-Update der de-brick Jumper gesetzt werden müsste.
    Jens


    Ich nehme an, für die Early-Chameleonbesitzer wird dann die Anleitung aus der ersten Vesalia-Mail gelten?



    Weder der Skalierungsfaktor, noch Bildposition, schwarze Balken oder Grafikmüll von nicht initialisiertem Speicher werden behandelt. Die Software stellt nur ein paar Werte wie Anzahl Zeilen, Anzahl Pixel und Pixelclock ein (plus noch ein paar andere Kleinigkeiten). Wenn Du da einen Wert gefunden hast, der stabil ein Bild zeigt, kannst Du uns das auf der Yahoo-Liste mitteilen, dann kann der Modus schonmal festgenagelt werden. Dabei ist es egal wie kaputt das Bild aussieht - wenn es stabil ist, ist es für uns ein erfolgreicher Test.
    Jens


    Also ist ein flimmerndes Bild mit horizontalen Streifen im Border, aber ein deutlich erkennbares und lesbares Bild, ein stabiles Bild im Sinne deines Zitats? Ich hab sie mal alle durchprobiert. Da mir die Entscheidung "stabil oder nicht stabil" etwas schwer fällt, würde ich einfach das Ergebnis jeder Auflösung - evtl. mit abfotografiertem Bild - kurz beschreiben. Ist das Sinnvoll? Ist die Hardware-Konstellation von Belang (also PAL/NTSC, Röhre/Flat, Monitorfabrikat)?

  • so mal ne frage.. bin net so auf dem laufenden....
    ich will das chameleon nur zum zocken und zum nachladen von mehrseitigen games.....
    funktionert dieses feature ohne probleme oder sind da noch probleme zu erwarten?


    Dafür brauchst Du die 1541-Emu, und die ist noch nichtmal beta - warte besser noch ab.


    Jens

  • Ich nehme an, für die Early-Chameleonbesitzer wird dann die Anleitung aus der ersten Vesalia-Mail gelten?


    Nein, da sind wir bereits komplett drüber weg. Die Anleitung aus "Episode 1" wird zu keinem Zeitpunkt mehr gebraucht. Das Tool "FLIP" ist nur bei uns in der Entwicklung zum Einsatz gekommen, und das einzige Mal, als ein Kunde das Tool gestartet hat, hat er das Chameleon wirklich gebricked. Es ist schon "wiederbelebt", hat uns aber dazu begracht, dass wir für den Fall eines Microcontroller-Updates auch diese Funktionalität in ChaCo implementieren werden.


    Tu' Dir selbst einen Gefallen, und lösche diese Anleitung, falls Du sie irgendwo auf der Platte liegen hast. Du wirst sie nie brauchen.


    Jens

  • Mahlzeit,


    ich habe den ganzen Tag mit meiner Ubuntu-Maschine gekämpft - auch wenn ich nicht wirklich weiß, was ich da tuhe, habe ich ChaCo kompiliert bekommen - sowohl GUI, als auch Kommandozeilenversion. Es werden Libusb und wxwidgets-Pakete gebraucht. Die entstandenen Binaries sind extrem klein, so dass ich vermute, dass die nicht ohne diese installierten Pakete funktionieren. Binaries habe ich gerade auf http://beta.icomp.de hochgeladen.


    ChaCo braucht Schreibzugriff auf USB-Nodes. Ich hab' keine Ahnung wie man das aus dem Filemanager heraus macht, aber von der bash aus geht's mit:


    Code
    1. sudo ./Chaco


    Bitte mal Rückmeldung geben, ob das bei Euch funktioniert - danke!


    Jens

  • Bitte mal Rückmeldung geben, ob das bei Euch funktioniert - danke!


    Super, Danke !


    Ich verwende Debian (lenny) und musste libwxgtk2.8-0 installieren, danach startete es sofort. Chameleon wird auch gefunden, danach erscheinen aber leider "timeouts".



    Ich habe das Modul mit dem C64 versorgt und die Mini-USB-Verbindung verwendet. Muss man noch irgendeine wundersame Tastenkombination oder ähnliches verwenden ? - Ich hatte jeweils einmal den Jumper gesetzt und einmal nicht.


    Das Command-Line-Tool meldete sich mit seinem "Parameter-Screen". Damit habe ich mich aber noch nicht weiter befasst. Wollte erstmal das Problemchen mit dem "timeouts" geklärt wissen.

  • Das könnte natürlich mit Deiner Distribution zusammenhängen, wie ich gerade auf der Yahoo-Liste gelernt habe. Die Libusb scheint wohl in jeder Distribution ein bischen anders zu sein, jedenfalls beschwert sich Fedora, trotz identischer Versionsinformation.


    Da die Commandline-Version auch die Libusb braucht, würde ich erwarten, dass die auch nicht geht bei Dir. Versuch' mal die Libusb auf V2.8 zu bringen - vielleicht wird unter Debian nicht so piccy geprüft wie unter Fedora?


    Auf der Yahoo-Liste wurde schon vorgeschlagen, statisch zu linken, aber wie schon erwähnt, habe ich keinen blassen Schimmer wie das funktioniert. Ich mach' auch für heute schluss, sonst werd' ich noch kirre wegen zu viel Arbeit am Computer. Bin seit 8:30 Uhr heute morgen dran...


    Jens

  • Ich werde mal versuchen, ob ich es irgendwie hingebogen bekomme.



    Da ging es und der Bildschirm beim C64 war weg (imo VGA disabled).

  • Auf der Yahoo-Liste wurde schon vorgeschlagen, statisch zu linken, aber wie schon erwähnt, habe ich keinen blassen Schimmer wie das funktioniert.


    Beim Linken "-static" angeben. Veröffentlichen des Quellcodes wäre aber evtl. unproblematischer als irgendwie Linux-Binaries zusammenzumurksen.

  • Hallo Jens,



    Ich war die ganze Woche nicht hier und habe heute gleich mal mit der neuen Chaco Linux Version die Beta 4 auf das Chameleon geflasht ,


    Hat hier unter Mandriva 2010.2 wunderbar funktioniert .


    Gruß Martin

  • Das Problem scheint im Kernel 2.6.2x zu liegen: http://marc.info/?l=linux-usb&…oken+on+2.6.28+x86_64&q=b


    Dummerweise sind das relativ aktuelle Kernel-Versionen. Da müsste man dann entweder das bestehende Kernel patchen und neu kompilieren, oder ganz austauschen. Finde ich beides eher unlustige Optionen.


    Vielleicht klappt es mit V-USB: http://www.obdev.at/products/vusb/index-de.html


    Ich verwende Kernel 2.6.26-2-686 mit Gnome 2.22.3 .

  • Das Problem scheint im Kernel 2.6.2x zu liegen: http://marc.info/?l=linux-usb&…oken+on+2.6.28+x86_64&q=b


    Dir ist aber klar, dass ich bewusst 32-Bit Linux kompiliert habe, und Du hier ein Problem mit einem 64-Bit Kernel beschreibst? Und dass Du mit dem Thread auch gleich die Lösung mit gepostet hast? Guckst Du hier.


    Jens

  • Ich habe mir gestern die Beta4 geflasht.


    1. Bei mir läuft Fanta in Space nach wie vor nicht, obwohl es bei anderen laufen soll!? Ich hab es getestet als D64 (TNT Filebrowser) und als SID. Und selbst wenn ich es von einem SD2IEC lade, geht es nicht. Der Bildschirm wird schwarz, es knackt kurz im SID, und Ende. Läuft übrigens vom MMC64 aus (das D64).
    siehe hier: Chameleon - Diskussion über Features und den Folgeartikel.


    2. Die GeoRAM Emu geht überhaupt nicht, oder das Konfigurationsmenü ist fehlerhaft. Wenn ich z.B. eine 512kB Georam konfiguriere, wird per Testprogramm (von cbmhardware oder per MMC64 GEORAM Plugin) gar keine erkannt. Bei Einstellung 2MB wird eine 256kB Version erkannt, bei Einstellung 4MB eine mit 512kB. Allerdings stürzen sowohl cbmhardware Testprogramm als auch das Plugin direkt ab wenn ein weiterer Zugriff versucht wird. Also bei Start des Tests oder Versuch ein Image zu laden. Dabei habe ich die Retro Replay Emu vorsichtshalber auch mal deaktiviert.


    3. Ich habe eine "lustige" 2GB RS-MMC Karte gekauft, die den Vorteil hat, nicht weit über das Gehäuse überzustehen. Nachteil ist, dass sie bei fast jedem Einstecken das Chameleon komplett neu bootet ... Ich hab das mal mit dem SD2IEC1.2 gegengetestet, dass eine extra verstärkte und abgekoppelte Stromversorgung für die Karte hat, um solche Probleme zu vermeiden. Das resettet sich auch ... Hier mal der Link zum Artikel als Anregung/Warnung: http://cgi.ebay.de/ws/eBayISAP…ame=ADME:B:EOIBSA:DE:1123 Sonst geht sie aber gut :) Ach ja, die Karte hat eine zweite Kontaktreihe, scheint wohl einem weiterentwickelten MMC Standard zu entsprechen.


    4. Die zusätzlichen Screenmodes mit Auflösungen >800x600 flimmern bei mir sowohl auf dem 20" TFT als auch 40" TV. Das wurde ja schonmal berichtet mit dem Flimmern.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • 1. Bei mir läuft Fanta in Space nach wie vor nicht, obwohl es bei anderen laufen soll!?


    Das Posting #1095 von Tronix war vermutlich nicht auf Deinen Bugreport bezogen, sondern auf die generelle Funktion. Hier läuft Fanta in Space jedenfalls nicht, und ich vermute, dass es sich dabei um den CPU-Bug handelt, der auch Arkanoid zum Erliegen bringt. Hier steht noch ein Test der illegalen Opcodes aus, also etwas Methodisches, nicht einfach einzelne Sachen ausprobieren und sich wundern.


    2. Die GeoRAM Emu


    ...hat bei uns noch gar keinen Testcase und ist daher mehr als experimentell. Wenn Du einen Fehler eingrenzen kannst, wäre das toll.


    3. Ich habe eine "lustige" 2GB RS-MMC Karte gekauft, die den Vorteil hat, nicht weit über das Gehäuse überzustehen. Nachteil ist, dass sie bei fast jedem Einstecken das Chameleon komplett neu bootet ...


    Dann entspricht die Karte nicht wirklich den Specs - das Neubooten passiert übrigens auch, wenn Du eine besonders durstige Maus oder Tastatur "hot" anschließt und eine recht schwache Versorgung hast (z.B. einen self-powered hub).


    Mit so einer instabilen Versorgung hast Du übrigens noch mehr Probleme, die bis zu unzuverlässigem Flashen führen kann. Ich hab' gestern ein ähnliches Problem gehabt, als ich versucht habe, das Chameleon mit Strom aus einem USB-Hub zu versorgen, der in einer Tastatur integriert ist. Sowas muss eigentlich schief gehen, aber ich wollte einfach mal den Effekt sehen, damit ich einen Zusammenhang herstellen kann. Ich kann mir vorstellen, dass Du bei besserer Versorgung den Effekt schon nicht mehr beobachten kannst.


    Ach ja, die Karte hat eine zweite Kontaktreihe, scheint wohl einem weiterentwickelten MMC Standard zu entsprechen.


    Kannst Du da mal ein Foto von machen?


    4. Die zusätzlichen Screenmodes mit Auflösungen >800x600 flimmern bei mir sowohl auf dem 20" TFT als auch 40" TV. Das wurde ja schonmal berichtet mit dem Flimmern.


    Eben - da gibts sowohl am Core, als auch an der Software noch einiges zu tun.


    Jens

  • Quote from Wiesel

    Dir ist aber klar, dass ich bewusst 32-Bit Linux kompiliert habe, und Du hier ein Problem mit einem 64-Bit Kernel beschreibst? Und dass Du mit dem Thread auch gleich die Lösung mit gepostet hast? Guckst Du hier.


    Ja, das ist alles etwas merkwürdig. Bei mir trat das Problem mit einem 32bit-Kernel auf. Auf dieser Seite fand ich eine identische Fehlerbeschreibung: also erster Zugriff geht und danach nur noch timeout.
    Ich habe mal Debian 6, Kernel 2.6.32-5-686 auf einem alten 8GB USB-Stick installiert. Das war eine Qual, aber das lange warten hat sich gelohnt. Es funktionierte damit sofort und vollkommen stabil.


    Ich habe den aktuellen Core+ROM auf dem Cartridge. Werde mich dann auch mal ans Testen machen.