Angepinnt VC20 Final Expansion - Aufbau REV 9


  • for(;;)
  • 13996 Aufrufe 99 Antworten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Jim (brain aus dem Denial) schrieb, es gäbe wohl neueren Code für den Bootloader, den er Unseen geschickt hätte und der könnte mit FAT32 und Partitionstabellen umgehen.

    Verwendet habe ich sd2iec.de/bootloader/sd2iec_bootloader_2008-07-09+LarsP.zip - das war die neueste Binary, die ich finden konnte, gibt wohl noch was Neueres.

    Ich habe Unseen nach dem letzten Stand gefragt - wäre ja prima, wenn das mit FAT32 und Partitionstabellen doch noch was würde!
  • Mit dem Bootloader hab ich die Erfahrung gemacht, dass er mit bestimmten Karten nur "manchmal" geht, also man einige wenige bis einige viele Anläufe braucht, bis er die Firmware findet. Nun am Samstag hatte ich es mit einer original Sandisk 2GB MicroSD versucht, die in der Vergangenheit im SD2IEC immer auf Anhieb geflasht hat. Im MMC2IEC 1.4 und 1.6 wollte sie nicht. Ich war schon am Bootloader und Fuses neu aufspielen und setzen, dann ging es plötzlich doch ein einziges Mal :) Dann hab ich andere SD Karten durchprobiert und mit einer Kingston 2GB SD Card ging es dann auf Anhieb bei jedem Versuch sowohl in MMC2IEC 1.4 und 1.6. Damit will ich sagen, dass es mitunter nicht nur an der Formatierung der Karte liegt ...
    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!
  • Ich habe von Jim Brain die neueste Version des Bootloaders erhalten und damit FAT16 / ohne Partitionstabelle und FAT32 / mit Partitionstabelle getestet - funktioniert alles prima!
    Die bereits vorbereiteten Atmels bringe ich noch auf den neuesten Stand, damit ab sofort nur noch der neueste Bootloader raus geht.

    Die r014 gefällt mir prima!
    Die Joystick-Unterstützung im Disk Loader ist wirklich cool - sogar mit Dauerfunktion in der Auswahl, klasse!

    Im Hilfe-Text wäre noch ein Hinweis schön, dass man mit F8 wieder zurück kommt.

    F2-BASIC unnew funktioniert bei mir nicht: ich bekomme nur die Meldung "3583 BYTES FREE" und dann hängt er ohne Cursor.

    edit:

    In der Aufbauanleitung habe ich Schritt 12 "Tantal-Kondensator" und Schritt 20 "SD-Karte vorbereiten" überarbeitet und die FE_First_SD_card.zip aktualisiert.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von for(;;) ()

  • Heute ist mein FE3 angekommen! :lol23:


    Erstmal dickes Lob, die Aufbau Anleitung ist grandios!! :thumbsup:

    Selbst ein Hardware DAU wie ich kann das spielend bewältigen, selbst meine kleine Nichte könnte das (sagt sie, ich wollte das nicht testen).


    + Aufbauzeit etwas über 70 Minuten, bei 5 Kaffetassen (die andere Nervenberuhigung ist eher was für meine Frau, schönen Dank von ihr).
    + Es gab keine Unklarheiten.
    + Was ich jetzt noch kaum glauben kann: - gelötet, eingesteckt, läuft!!!



    Kleine Unklarheiten, "fast Pannen", Missgeschicke:
    • SD Slot

      An diesem Punkt misst man keine 3300 Ohm ...
      Die 0 Ohm, wenn die Karte drin ist ...
      ... löst beim unaufmerksamen Leser Verwunderung aus.

    • Widerstände

      Ihr Hardwaremenschen seit sensationell. Die Widerstände mit Farbringe zu markieren ist eine Sache, diese dann völlig symetrisch aufzubringen eine Andere. Man kann den Wert auch leicht verkehrt lesen!

      Früher gabs die goldenen und silbernen Abschlussringe, da war alles klarer. Super daher, dass die Werte auf dem Klebeband geschrieben wurden!

    • Die Kondensatoren sind derart fest geklebt, man bringt sie nicht heraus. Zum Glück kann man sie abschneiden ...

    • IC Sockel

      Beim raus schneiden der Mittelstege ist mir ein Sockel gleich in drei Teile zerbrochen. Die anderen haben es ausgehalten.

      Wenn man den Sockel oben fest rein drückt und unten lötet, kann man sich leicht verbrennen (wenn man so patschert ist wie ich)!!

      Manche Sockel haben keine Nase. Eine längere und eine kürzere Längsfräsung ersetzen die bewährte Nase der alten Sockel nicht. Zum Glück ist der Platinen Aufdruck noch gut lesbar, so gibt es auch in einem Jahr keine Unklarheiten.

    • PLCC Sockel

      Ohne Fotos wäre es mir nicht möglich gewesen, die Position der abgeflachten Ecke zu finden.

    • Uhrenquarz

      Mir, als armen überforderten Software Menschen ist hinterrücks ein SMD Bauteil unterjubelt worden!
    Letztlich ist alles nur Illusion
    Es gibt hier nichts von Bedeutung
  • Diddl schrieb:

    Beim raus schneiden der Mittelstege ist mir ein Sockel gleich in drei Teile zerbrochen. Die anderen haben es ausgehalten.

    Das kann ich mir bei den spröden Dingern vorstellen. Vielleicht kann man in der Anleitung einen Dremel o.ä. empfehlen, falls vorhanden?
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Bau Dir ein eigenes Modul! EasyFlash
  • Herzlichen Glückwunsch! :bia

    Vielen Dank für die vielen Anregungen zur Aufbauanleitung!

    Was Du mit
    An diesem Punkt misst man keine 3300 Ohm ... Die 0 Ohm, wenn die Karte drin ist ... ... löst beim unaufmerksamen Leser Verwunderung aus.
    genau meinst, ist mir ehrlich gesagt nicht ganz klar.
    Was ich verstanden habe ist, dass es um den SD-Slot-Anschluß Nr. 2 geht (CD=card detect).
    Da wäre sicher ein separater Abschnitt hilfreich, um den Anschluß bei eingelegter bzw. nicht eingelegter Karte zu testen. War's das?

    Mit den Widerständen ist das in der Tat so eine Sache... für mich sehen die alle einfach nur "blau" aus. Das rührt daher, dass bei Reichelt die Metallschichtwiderstände zwei Cent oder so billiger sind, wenn man mehrere nimmt, weshalb diese im Warenkorb gelandet sind.
    Wer den Reichelt-Warenkorb bei Reichelt bestellt, bekommt die dann aber einzeln in Tütchen geliefert, wo Reichelt den Widerstand noch im Klartext aufgedruckt hat, das sollte also keine Probleme bereiten.
    Für die nächsten Bausätze werde ich die üblichen Kohleschichtwiderstände nehmen, also die mit dem goldenem Ring an einer Ende, damit man nicht zwei braune links und rechts hat und sich überlegen darf, wie rum der jetzt gelegt werden will - was der Grund dafür ist, dass ich die noch im Klartext beschriftet ausliefere.

    Das "derart fest geklebt, man bringt sie nicht heraus" war ein guter Stichpunkt. Nun - es ist gar nicht beabsichtigt, die Dinger heraus zu ziehen. Da reisst man eher die Beinchen aus dem Bauteil, als aus der Pappe. Beabsichtigt ist, den Draht oberhalb der Pappe abzuschneiden. Ich werde einen entsprechenden Hinweis in die Aufbauanleitung aufnehmen.

    Dass die Sockel keine Nase mehr haben, sondern eine Seite anders geformt ist, finde ich auch unglücklich, darauf habe ich aber leider keinen großen Einfluß. Aber wenn man den Bestückungsdruck noch sehen kann, passt's ja. Gestaunt habe ich, dass er Dir zerbrochen ist? Den Hinweis darauf, dass die spröde sind, bzw. mit einem Dremel bearbeitet werden können, werde ich aufnehmen.

    Zur Ausrichtung des PLCC-Sockels gibt es in der Aufbauanleitung diese Hinweise:

    Beim quadratischen PLCC-Sockel für den CPLD unbedingt auf die Lage der abgeschrägten Ecke achten - es gibt drei abgerundete Ecken, aber nur eine abgeschrägte Ecke.

    Die abgeschrägte Ecke muss in Richtung der goldenen Kontaktleiste und 40 poliger Atmel zeigen, also da, wo auch das große Loch am PLCC-Sockel ohne silberne Durchkontaktierung ist.


    Ist das untergegangen oder hattest Du Verständnisschwierigkeiten? Soll man an der Formulierung etwas ändern?

    Der Uhrenquarz ist auch so ein Punkt... wir haben ihn ausgewählt, weil er klein ist und damit gut unter dem Sockel plaziert werden kann. Ich muss jetzt ohnehin noch Teile bestellen und werde dabei noch zum Testen einen anderen Quarz bestellen, der längere Beinchen hat und damit "ganz normal" verlötet werden kann - damit nicht wieder jemand "hinterrücks ein SMD-Bauteil untergejubelt wird"! :D
  • for(;;) schrieb:

    Die abgeschrägte Ecke muss in Richtung der goldenen Kontaktleiste und 40 poliger Atmel zeigen, also da, wo auch das große Loch am PLCC-Sockel ohne silberne Durchkontaktierung ist.


    Nö die Beschreibung ist sehr ok. Aber da es Leute gibt die erst mal gucken und nicht lesen (Jogi ;) und offenbar auch ich). Die "Kritik" bezieht sich hier eigentlich nur auf die Beschriftung der Platine.


    for(;;) schrieb:

    genau meinst, ist mir ehrlich gesagt nicht ganz klar.
    Was ich verstanden habe ist, dass es um den SD-Slot-Anschluß Nr. 2 geht (CD=card detect).
    Da wäre sicher ein separater Abschnitt hilfreich, um den Anschluß bei eingelegter bzw. nicht eingelegter Karte zu testen. War's das?


    In dem Fall habe ich mich auf die Tabelle der Messwerte bezogen. Zu dem Zeitpunkt ist NUR der SD Slot eingelötet, noch kein Widerstand. Wenn man also jetzt mit dem Ohmmeter misst, dann bekommt man nicht 3300 Ohm, DAS meinte ich.

    Das Andere war mein Fehler. habe 0 Ohm gelesen und schon gemessen. Wenn ich weitergelesen hätte, wäre mir klar gewesen dass dazu die SD stecken muss.

    Alles Kleinigkeiten, die mir persönlich halt aufgefallen sind ...

    ... wenn alles so super läuft, dann verbeisst man sich halt in Kleinkram. ;)


    ########

    Für mich persönlich ist der Betatest gelaufen. Die drei Bugs die wir gefunden haben sind behoben, mit dem aktuellen CPLD Design läuft das Diagnoseprogramm stundenlang durch.

    Ich werde mich jetzt wieder auf die Fertigstellung der Firmware konzentrieren, es sei denn es findet einer von euch noch ein Problem.

    ########

    Übrigens sind einige Fehler die eingemeldet wurden bei mir nicht nachvollziehbar. Zb. die SD Karte initialisiert immer bei mir immer sofort. Es braucht auch keine 3 Sekunden, wenn ich einschalte und sofort F3 drücke schmiert da nix ab?

    ########

    Noch eine gute Neuigkeit: TLR hat mir eine VICE Version geschickt, wo die FE Emulation noch perfekter ist, - das flashen kann jetzt auch simuliert werden!!

    Die Final Expansion Emulation ist genial! Mir hilft sie auch die Firmware weiter zu entwickeln und Fehler zu finden.
    Letztlich ist alles nur Illusion
    Es gibt hier nichts von Bedeutung
  • Diddl schrieb:

    wenn alles so super läuft, dann verbeisst man sich halt in Kleinkram.

    Diddl schrieb:

    Übrigens sind einige Fehler die eingemeldet wurden bei mir nicht nachvollziehbar.

    Die beiden Aussagen passen nicht so ganz zusammen. Fehler, die nur bei anderen auftreten, sind immer etwas nicht zu unterschätzendes - jedenfalls, wenn man sie ernst nimmt.

    Diddl schrieb:

    das flashen kann jetzt auch simuliert werden!!

    Bedank Dich bei Hannu Nuotio, der hat sich mit dem Datenblatt des Am29F040 hingesetzt und alles nachimplementiert. Getestet und verglichen haben wir das dann mit EF. Die Emulation läuft "besser" als der Originalchip in der Am29F040B-Revision, es funktioniert nämlich z.B. auch Chip-Erase :)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Bau Dir ein eigenes Modul! EasyFlash
  • skoe schrieb:

    Die beiden Aussagen passen nicht so ganz zusammen. Fehler, die nur bei anderen auftreten, sind immer etwas nicht zu unterschätzendes - jedenfalls, wenn man sie ernst nimmt.

    Die beiden Aussagen beziehen sich auch auf unterschiedliche Dinge. Mit perfekt war Nils Aufbauanleitung gemeint, der SD Startfehler wurde eh schon diskutiert, - es scheint wohl irgendwie von der SD Karte abzuhängen?


    skoe schrieb:

    Getestet und verglichen haben wir das dann mit EF.

    Wie geht es denn dem "Schwesternprojekt"? Ich freue mich schon auf den Betatest der easyflash!
    Letztlich ist alles nur Illusion
    Es gibt hier nichts von Bedeutung
  • Diddl schrieb:

    In dem Fall habe ich mich auf die Tabelle der Messwerte bezogen. Zu dem Zeitpunkt ist NUR der SD Slot eingelötet, noch kein Widerstand. Wenn man also jetzt mit dem Ohmmeter misst, dann bekommt man nicht 3300 Ohm, DAS meinte ich.

    Autsch... na klar, da hast Du völlig Recht! Das muss noch geändert werden.
    Wenn die Widerstände noch nicht eingelötet sind, sind die Testpunkte leider recht verstreut auf der Platine. Ich denke, es ist sinnvoller, erst die Widerstände mit einzulöten und dann den SD-Slot zu testen - dann liegen alle Anschlüsse am Atmel und sind leichter zu finden.

    Diddl schrieb:

    der SD Startfehler wurde eh schon diskutiert, - es scheint wohl irgendwie von der SD Karte abzuhängen?

    Ja, so sehe ich das. Ist aber offenbar eine seltene Erscheinung.

    Selbstverständlich wird dieser Fehler ernst genommen. Alle Ungereimtheiten oder Fehler wurden und werden mit Unseen als Entwickler der SD2IEC-Firmware abgeklärt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von for(;;) ()

  • for(;;) schrieb:

    Ist aber offenbar eine seltene Erscheinung.


    Da gebe ich dir Recht.

    Ich habe alle meine Karten zusammen gekratzt, SD, mikro SD, alle möglichen Arten und Kapazitäten. Es gibt welche die gar nicht gehen, egal wie sie formatiert werden. Aber die Karten die gehen, die laufen perfekt bei mir!

    Nochmals grosses Lob an das SD2IEC Design und natürlich der SD2IEC Firmware! Extrem robust, ob Jiffy oder normales IEC, - genial!
    Letztlich ist alles nur Illusion
    Es gibt hier nichts von Bedeutung
  • Diddl schrieb:

    for(;;) schrieb:

    Ist aber offenbar eine seltene Erscheinung.


    Da gebe ich dir Recht.

    Ich habe alle meine Karten zusammen gekratzt, SD, mikro SD, alle möglichen Arten und Kapazitäten. Es gibt welche die gar nicht gehen, egal wie sie formatiert werden. Aber die Karten die gehen, die laufen perfekt bei mir!

    Nochmals grosses Lob an das SD2IEC Design und natürlich der SD2IEC Firmware! Extrem robust, ob Jiffy oder normales IEC, - genial!


    Vielleicht sollte ich mal meine Meldung nochmal konkretisieren. Es geht mir nicht darum, dass evtl. manche SD-Karten erst nach ein paar Sekunden erkannt werden.
    Ich hatte schon vorher angemerkt, das bei fehlendem Laufwerk (IEC-Kabel ausgesteckt) der Rechner hängenbleibt. Warum kann ich mit einem normalen Dos Befehl eine Fehlermeldung bekommen und per Wedge nicht, bzw warum hängt dann der Diskloader?
    Dass eine SD-Karte, die halt ein paar Sekunden zur Initialisierung braucht, das gleiche Problem zeigt ist nur zufällig gesehen worden und nicht das eigentliche Problem.
    Es liegt nicht an der SD2IEC implementierung, da die Fehlermeldung vom Betriebssystem kommt. Auch wenn es nicht oft vorkommt, dass ein solcher Fehler vorkommt, so ist es möglich. Und wenn es auch nur eine Kleinigkeit ist, dann sei doch froh, dass keine gröberen Fehler gefunden worden sind. Die künftigen Abnehmer werden dann ebenso auf diesen Kleinigkeiten rumreiten. Ich kenne das leidlich aus dem Berufsleben.
    Das SD2IEC läuft prima. Das Problem scheint mir in der Firmware (Wedge/Diskloader) zu liegen.

    Zur reproduktion des Fehlers:
    1. FE einstecken (ohne das IEC-Kabel einzustecken)
    2. VC20 einschalten
    3. F7 drücken
    4. in der Wedge @<RETURN> eingeben.
    -> und der Rechner hängt. Noch Fragen?

    Ja, das mit dem fehlenden Kabel ist Absicht. Man muss halt nicht nur alle möglichen, sondern auch alle unmöglichen Fälle abdecken. Und eine Fehlermeldung auszugeben sollte doch nicht so schwer sein.

    Ich hoffe meine Ansprüche sind nicht zu hoch.

    Übrigens ein Emulator ist für die Entwicklung und zur Fehlersuche gut, aber nur bis zu einem bestimmten Punkt. Wenn sich die Hardware nämlich anders verhält wie der Emu. Soll heissen, wenn es im Emu funktioniert muss es nicht auch auf der Hardware funktionieren.

    EDIT: sorry, ich sehe, das ist ein wenig off-topic, da dies hier ja der Aufbau thread ist.

    DoReCo #59 am Sa. 8.12.2018
    ---
    Frankfurter Nerd Stammtisch am 2.11.2018

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von zorro ()

  • Ich bin überrascht - da schaut man mal ein paar Wochen nicht hier rein und das Teil entwickelt sich zu einem Monster :)

    Ich hätte da demnächst für kleines Geld ein paar Atmel ATF1504ASV (3.3V-Typen die aber 5V-tolerant sind) abzugeben. Wenn die in diesem Design laufen, wäre sicherlich Euer Preis wesentlich günstiger.

    Falls momentan die 5V-Variante zum Einsatz kommt: Keine Angst vor 3.3V! Es geht hier lediglich um die Versorgungsspannung, die auf 3.3V gesenkt werden muss. Was aus den Ausgängen kommt, kann direkt mit dem Rest der 5V-Logik verbunden werden. Falls um-designt werden muß, bin ich gern behilflich.

    Jens
    forum.icomp.de/ - Das offizielle iComp Supportforum ist online.
  • Das sind exakt die Typen die im FE3 laufen. Wir können per Jumper umschalten zwischen 5V und 3,3V, meines läuft perfekt mit 3,3V. Mal mit For() reden, keine Ahnung wieviele 1504 der von Digikey geordert hat.

    Aber sonst lassen sich die auch bestimmt mit dem 8 Bit baby zusammen verkaufen, ich hätte mir das gewünscht wo ich meine 8 Bit Babys geordert habe.



    Vielleicht kommt die Woche auch endlich mein Galep PLCC Adapter, dann kann ich die ganzen verschossenen Typen wieder löschen
    Letztlich ist alles nur Illusion
    Es gibt hier nichts von Bedeutung
  • Diddl schrieb:

    keine Ahnung wieviele 1504 der von Digikey geordert hat.


    Ouch - die Preise da sind ja jenseits von Gut und Böse - und da kommt die Einfuhrumsatzsteuer noch drauf! Also ich werde nächste Woche ca. 130 Stück haben, die ich für 1,70 EUR/Stück abgeben würde. Inklusive Steuer natürlich. Die Teile werden von einem professionellen Dienstleister abgelötet und gesäubert, werden also nicht "neu" sein, aber für den Einsatz in einem Sockel immer noch bestens.

    Jens
    forum.icomp.de/ - Das offizielle iComp Supportforum ist online.
  • Diddl schrieb:

    Mal mit For() reden, keine Ahnung wieviele 1504 der von Digikey geordert hat.

    Niedliche 18, von denen knapp ein Drittel raus ist.

    Wiesel schrieb:

    Ouch - die Preise da sind ja jenseits von Gut und Böse - und da kommt die Einfuhrumsatzsteuer noch drauf! Also ich werde nächste Woche ca. 130 Stück haben, die ich für 1,70 EUR/Stück abgeben würde. Inklusive Steuer natürlich.

    :winke:

    edit: Wenn sich jetzt jemand fragt, warum ich die bei Digikey "so teuer" eingekauft habe: man kann die Dinger auch für 1,70 Euro in "neu" haben. Aber dann in solchen Mengen, wo wir auch nicht mal annähernd dran kämen, entsprechende Anzahl Final Expansion zu verkaufen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von for(;;) ()

  • Wiesel schrieb:

    Die Teile werden von einem professionellen Dienstleister abgelötet


    Abgelö ...? Sprechen wir nicht von PLCC?


    Viel verstehe ich ja nicht von Elektronik, also bitte Nachsicht mit einem DAU wie mich, falls wieder mal dumme Fragen dabei sind.

    Kann man PLCC löten? Wenn nicht PLCC, kann man auf der FE3 Platine auch was anderes verwenden?
    Letztlich ist alles nur Illusion
    Es gibt hier nichts von Bedeutung