Hello, Guest the thread was called53k times and contains 80 replays

last post from Retro-Schulzi at the

Festplatte/CF Card mit WinUAE sobearbeiten, das sie nach dem Umstecken in A1200 läuft

  • Hi zusammen. Hoffe, das ich hier im richtigen Brett bin.
    Ich hab folgende Frage. Ist es möglich mit dem WinUAE eine Festplatte oder CF Card so zu beschreiben,
    das sie nach dem Umstecken in einen Amiga 1200 ohne weitere Anpassungen und sonstigen
    Arbeiten sofort bootet ??? Hab schon mit den HD Images rumprobiert, aber nix erreicht.
    Weiss vieleicht jemand von euch Rat ??


    mfg gHost

  • Also, wenn ich das Laufwerk vom PC über das WinUAE Interface einbinde habe ich die "Platte" im Amiga, fein, wird aber leider so beschrieben das der Amiga damit nichts Anfangen kann (keine Partitionierungsdate und nichts).


    Binde ich das PC LW als emuliertes IDE LW im WinUAE Amiga ein - habe ich im Amiga GAR NICHTS. Das LW erscheint nirgens und ist auch sonst nicht zu finden (HDToolBox, e.t.c.).


    Das selbe passiert auch wenn ich für eingebundene LW oder Images den RDB Mode aktiviere....

  • RDB Mode aktiviere....


    Ich hab mal testweise eine CF Karte in nen normalen Cardreader gehauen.


    Wenn ich die jedoch einbinde kommt immer ne fehlermeldung sowas wie KEIN RDB block oder so...


    Wie kann man das händeln?



    Chris

  • ok das hat funktioniert.. nu mal die installed CF in den Amiga bauen...


    AAAber für SFS Filesystem... was muss ich denn bei den settings eintragen?

  • habs schon selbst gefunden...


    1) Copy "SmartFilesystem" to your L: directory (this is just so you
    can locate it easier later on).


    2) Start your Harddisk installation tool, select the Harddisk you want
    to store the Smart Filesystem and go to the screen which allows you
    to add a filesystem to the disk.


    3) On this screen you should be able to select which filesystem to
    add, select l:SmartFilesystem. You now should be able to set the
    DosType (or Identifier) field to 0x53465300 ("SFS\0"). You may
    need to change the filesystem type to 'Custom' first before you can
    set this.


    4) When you're done adding the filesystem, save the changes to disk
    and exit the program.



    Chris

  • wenn ich bloß soweit kommen würde, die CF Karte unter WinUAE mit HDToolbox zu formatieren und beschreiben.


    Als erstes testete ich die CF nur mal so in meinem Amiga 600 mit Workbench 2.1 Kickrom 37.300, bei HDToolbox findet er ein SCSI Device, kann es aber nicht einordnen. Ich kann eine neue Vorgabe festlegen, die Daten der Platte abfragen, dann erkennt er immerhin schon, dass es eine 2GB karte ist. Sollte also alles irgendwie funktionieren. Es scheitert dann am Schreibschutz der Workbench install diskette, die er umschreiben will.


    Jedenfalls ist mein Ansatz nun, die Karte über windows in winUAE in der selben Workbench mit HDToolbox zu formatieren und whdload mit programmen zu installieren, um die karte dann final beschrieben bootbar in den Amiga 600 zu bauen.


    WinUAE starte ich mit der flag -disableharddrivesafetycheck ,dennoch tauchen in HDToolbox in winUAE weder meine PC platte noch meine CF im cardreader auf ... "no drivers" ... die festplatten sind im modus "uae" in den winUAE preferences hinzugefügt worden
    (ich verwende winxp 64bit).




    Ich wäre für jeden Rat dankbar :)



    Viele Grüße,


    Marco


  • Den Schreibschutz der Disk kannste ruhig öffnen. Er möchte seine Device Datenbank auf die Disk ablegen.



    Chris

  • Um deine CF Card in WinUAE finden und formatieren zu können musst du nen rechtsklick auf das HDtoolBox Icon machen dann Icons > Information klicken und dort dann in den Tool Types die Zeile SCSI_DEVICE_NAME=scsi.device in SCSI_DEVICE_NAME=uaehf.device ändern. (enter drücken vorm absaven sonst speichert er die änderung nicht)

  • Danke für die schnellen Antworten :) !


    Chris:
    Den Schreibschutz kann ich leider nicht öffnen, da es eine Original Diskette ohne Schreibschutzschieber ist.


    Torkel:
    Nachdem ich nun statt die Workbench 2.1 die 3.1er starte, erscheinen in den Tool Types auch entsprechende Vorgaben. Hier scheint er nun auch Treiber zu haben, findet aber trotz Umbennenung oder Starten per flag über die Shell nichts.
    In WinUAE habe ich dann das Manuelle Hinzufügen meiner Windowspartitionen und CF Karte rausgenommen und das automatische hinzuladen aktiviert. Nun werden CF Karte und Windows Platten gleich beim Starten der Workbench angezeigt.
    Leider kann ich die CF nicht über den formatieren Befehl direkt in der Workbench anfassen.


    Habt ihr noch eine Idee ?
    Und wie kann ich dann überhaupt Amiga Programme von meiner Windows Platte rüberziehen, wenn er in WinUAE keine Verzeichnisstruktur in dieser erkennt ?


    Vielen Dank schonmal ... ich bin sooo kurz davor meine Kindheitserinnerungen wiederzuerwecken :) ...

  • Versuch mal
    1. Winuae starten in der Dos Box mit winuae -disableharddrivesafetycheck
    2. Im Winuae add HDD und ein funktionierendes HDD image auf der Festplatte angeben (ClassicWB) oder so
    3. Als 2. Image den Card Reader angeben - der jetzt meckert dass das File System nicht passt - kann man ignorieren.
    4. In Winuae die Classic WB Booten
    5. Im Ordner System CLI öffnen
    6. cd tools eingeben
    7. hdtoolbox uaescsi.device eingeben.


    jetzt sollte in der Toolbox der CF cardreader stehen. Nur noch partitionieren (ging bei mir nur max 2 GB)
    dann neu booten und formatieren.
    Bei mir gings nur auf diese Weise - sonst nur mecker vom Emulator.
    Ich hoffe es hilft Dir weiter. Gruß

  • ist dosbox entscheidend ?
    ich lade es über start -> run -> winuae -disableharddrivesafetycheck


    classicWB hdd image mit dem befehl add hardfile laden ?
    beim cardreader wäre dass dann zum beispiel I:/ (laden kann ich da natürlich keine file)
    ClassicWB dann per adf im emulierten diskettenlaufwerk booten ?


    Danke

  • Entschuldige die einfache Frage, aber wie kann ich denn während der Emulation eine ADF in DF0 laden ? Sonst bootet er ja gleich von der workbench in DF0.
    Irgendwie scheine ich mich besonders bescheuert anzustellen. Dachte erst es liegt die ganze Zeit an meinem XP64Bit Windows ... Aber jetzt auf einem anderen PC unter Vista und Vista mit XP32Bit Simulation ändert sich auch nichts :( ...


    Danke für Eure Hilfe,
    Marco

  • Ah vielen dank ... nun kann ich die ClassicWB installieren.
    Beim Starten über einen emulierten a600 meckert er jedoch bei zwei programmen über einen error ... copper und irgendein anderes ... wb selber läuft aber.


    Beim starten von hdtoolbox mit uaehf.device finde ich ein scsidevice ... beim genauen definieren des laufwerks stellt sich heraus, "scsi inquiry failed" ... 20meg werden als größe angezeigt ... ich befürchte, es ist ein teil der classicWB und nicht meine CF Karte. Denn sobald ich diese Virtuelle Platte als neues gerät definiere und speichere, kann ich nicht mehr von dem ClassicWB Image booten und muss neu entzippen/dann installieren.


    Immerhin erkennt er in der ClassicWB jetzt meine PC Festplatten und auch das CF-Drive und zeigt deren Inhalte an ... Das Kopieren von Daten wäre somit gesichert ... wieso aber will er die CF Karte nicht als eigenes Laufwerk in HDToolbox erkennen ? Muss ich die vorher in Windows speziell formatieren oder in winuae noch etwas angeben ?


    Vielen Dank für Eure fantastische Hilfe ... :)


  • Copper wohl weil es AGA benötigt. Das andere vlt weil es mehr Chip will ...(Vermutung)



    Chris