Hello, Guest the thread was called45k times and contains 205 replays

last post from fandenivoldsk at the

FIBR – Der C64 File Browser 1.0 Alpha Download

  • Hi,


    so hab nun die neue 0.5 firmware drauf und das gleiche.
    Nach dem Starten wird von der Karte gelesen, dann ändert sich am bildschirm die Rahmenfarbe und das wars. Es wird nichts angezeigt.
    Eventuell könnte es ja an der SD-Karte liegen, habe aber leider nur 2 und die von der gleichen Firma "Intenso 1GB", kann also nicht weiter testen ob es daran liegen könnte, obwohl sonst alles läuft wie es sollte könnte es wohl doch am FiBr liegen.
    Habe dann mal Testweise die MMC2IEC firmware 0.9 drauf gespielt, und was soll ich sagen. Verzeichnis wird ebenfalls versucht eingelesen und auf dem Bildschirm erscheinen nur wirre Zeichen, ok man kann zwar nichts damit anfangen aber ist ja schonmal ein Schritt weiter ;)



    Gruß Donald



    ..

  • Moin,


    - ich hatte einige Dateien im root Verzeichnis meiner Karte (mit z.T. relativ langen Dateinamen), fibr versucht dann anscheinend das Verzeichnis zu lesen, bleibt dann aber nach kurzer Zeit beim "Loading" Screen hängen. Hab die Dateien dann in ein Unterverzeichnis geschoben und schon gehts ohne Probleme. Dann wird komischerweise auch der Inhalt des Verzeichnisses angezeigt, wo ich die Dateien reingeschoben habe.

    das erscheint mir sehr merkwuerdug, auf welchem system/floppy denn?


    Quote

    - Hin und wieder hab ich in Unterverzeichnissen das "." und ".." Verzeichnis, jedoch nur äußerst sporadisch und sehr unregelmäßig. Und wenn sie angezeigt werden, ist es nicht möglich mit dem ".." Vezeichnis wieder eine Ebene höher zu gelangen.

    die sollten eigentlich nie auftauchen (ausser auf einer 1541 & co)


    Quote

    - hin und wieder passiert es, das wenn ich in ein Verzeichnis wechsle, kein Inhalt angezeigt wird, der Balken zum navigieren aber da ist und ich durch die "unsichtbaren" Einträge durchscrollen kann. Wenn ich dann ein Verzeichnis zurück gehe, wird mir im Navigationsfenster nur noch Datenmüll angezeigt. Innerhalb des "Mülls" finden sich Bruchstücke des zuvor nicht angezeigten Verzeichnisses wieder.

    ok, ich werde noch so einige bugs reparieren duerfen...


    Quote

    Ich hoffe das meine Hinweise ein wenig zum Fehlerfinden helfen können. Ansonsten sieht es nämlich schon ganz gut aus. Auch mit Jiffy Dos Kernal funktioniert es genauso gut wie mit dem Original Kernal. Die Icons werden richtig angezeigt und die Erkennung der Dateitypen scheint auch zuverlässig zu funktionieren. Mit dem Starten von Programmen ist mir bis jetzt auch noch kein Fehler aufgefallen.

    Das klingt ja beruhigend.


    Ich habe mir mal das Programm runter geladen und ein wenig getestet.
    Also keines meiner (normalen) Laufwerke sind richtig erkannt worden.
    Das hängt damit zusammen, das ich praktisch kein Laufwerk mit einer eindeutigen Meldung bei uj habe.
    Überall ist speeddos, jiffidos, sjiffidos prologigdos u.s.w drin.
    Bei den alten Laufwerken wird nur cbm dos v x.x angezeigt.
    Das läst sich beheben, indem man, wenn es kein sd2iec, mmc2iec, iec-ata, mmc64 und weitere erkennt werden, auf Standard umschaltet.

    dem ist auch so, nur wird zuerst ein hinweis mit deiner floppy-kennung ausgegeben (nur waehrend des alpha/beta-testings), danach wird in der 1541 modus umgeschaltet.

    Quote

    1. Lokation der Directory. (t u s der dir)

    Häää?

    Quote

    2. Erkennen des Medientyps. 3.byte im Kopf a=1541 c=cbm 8050 d=1581 ... h=cmdhd 16m usw.
    nur der c type muss gesondert behandelt werden da ist der t auf 39 und s auf 1zu setzen.

    in der disk-/dos-id?

    Quote

    3. Directory holen mit b-r oder mit sec!> 1 .
    Type h hat Unterverzeichnisse (type 6)
    Type D hat Unterpartitionen (type 5)
    Die original ide-ata lifert bei sec!>1 eine 1541 änliche dir,wobwi nur type 1,2 und 3 gibt 3 ist in dem fall ein dir.
    Bei der iecatav2 1.35 gibt es type 1,2,3,4,6 mit den cmd Typen. (rel ist aber nur ein normaler File)
    Warum habt ihr die Uhrzeit und das Datum nicht angezeigt?

    ich arbeite mit "normalen" befehlen - klappt das hier denn auch auf jeder hardware?


    PROBLEM:


    Auf meinem C128D kriege ich FIBR gar nicht zum Laufen. Zuerst kommt "Error identifying the drive 08: 73_CBM DOS V3.0 1571_" Das ist die normale Einschaltmeldung der internen 1571. Dann kommt "Loading..." und das dann erscheinende Browserfenster enthält nur wirre Grafikzeichen.
    Letzteres konnte ich auch in VICE ( x128 ) nachvollziehen.

    128er wurden bis jetzt gar nicht gestetet, aber ich werd's mir mal anschauen. die meldung kommt, weil die id unbekannt ist, wird aber die 1541 behandelt, das mit den wirren zeichen ist noch zu klaeren...


    Ich teste FIBR gerade ein wenig mit sd2iec "beinahe 0.5" und mir fallen spontan zwei Probleme auf:
    a) Nach dem UI zur Identifikation wird CD:/ geschickt. Das funktioniert zwar auf sd2iec um ins Rootverzeichnis zu wechseln, wird aber meines Wissens auf CMD-Laufwerken nicht klappen.

    alle laufwerke werden spezifisch angesteuert, CD:/ nuzte ich bei sd2iec und iecata


    Quote

    b) Ohne eine weitere Datei zu öffnen wird nach dem Auslesen des Directories "CD:MD88-04A.D64" geschickt, das ist zufälligerweise die allererste Datei im Directory. Danach lädt FIBR das Directory des Diskimages und liest gemütlich die Startadressen der Dateien aus (saulahm, aber das liegt an sd2iec). Mit Links dort wieder rauszuwechseln macht wieder das gleiche.

    das ist lustig - ich untersuch das mal.


    bitte bedenkt, dies ist ein aplha release, und ich programmiere erst seit nicht einmal einem halen jahr fuer den c64...


    Ciao, ALeX.

  • das erscheint mir sehr merkwuerdug, auf welchem system/floppy denn?

    Auf einem 64er sowohl mit original als auch Jiffy Dos Kernal. Laufwerk ist das mmc2iec 1.6 von Shadowolf als Laufwerk 8. Firmware war sd2iec 0.4.2. Heute hab ich mit der 0.5 das Problem wieder nachstellen können. Das root Verzeichnis hatte ein paar directories, 2 prg Dateien (fibr und warpcopy) und das Firmware File von unseen (sd2iec.bin). Der Fehler tritt bei mir dann reproduzierbar auf, wenn sich die sd2iec.bin im root Verzeichnis befindet. Lösche ich die gehts wieder.

    bitte bedenkt, dies ist ein aplha release, und ich programmiere erst seit nicht einmal einem halen jahr fuer den c64...

    Sollte ja auch keine Kritik sondern Hilfe zur Fehlersuche sein ;) Und für ein halbes Jahr Programmiererfahrung finde ich das Ergebnis doch schon recht beeindruckend....

  • Heute nochmal getestet.
    -CMD HD wird nicht erkannt was ok ist, dann als 1541 behandelt. Dir's werden nicht unterstützt. Und ins Root geht es auch nicht.
    -IEC-ATA-V1.35 wird als Power 64 erkannt?? hier wird ein Dir angezeigt aber rein kommt man nicht .Und ins Root auch nicht
    Wenn mehr als 3 Files drauf sind stürzt der fibr ab.
    -CMD FD gleiches Bild wie HD.


    Anmerkung: bei allen 3 ist die Arbeitsweise mit Verzeichnissen gleich.
    Wenn kein 1541,1571,fd41,Hanseatik usw. also ohne Unterverzeichnisse erkannt ist und kein Spezial Laufwerk ist
    dann kann man mit
    cd:/ ins Root
    cd:name ins dir
    cd<- eins rauf (Pfeil zurück)


    in allen 3 fällen gibt es auch eine dir mit sec!>1.Wobei die links im IEC-ATA-V1.35 nur face sind.
    Wenn einmal Kopierfunktionen eingebaut werden sollen, würde ich mein xcopy gerne zur Verfügung stellen
    Die Laufwerke von CMD melden sich bei "changeunit" auf der Demo/utiliti Disk der 1581, immer als 1581.


    Aber das ist keine Garantie für das vorhanden sein von verzeichnisfunktionen. Wenn man in einer 1541 Partition ist giebt es Kein cd.


    Es ist also unnötig (abgesehen von spezial Geräten) zu wissen was für ein Laufwerk man hat. Man muss wissen was man für ein Medium verwendet.

  • Heute nochmal getestet.
    -CMD HD wird nicht erkannt was ok ist, dann als 1541 behandelt. Dir's werden nicht unterstützt. Und ins Root geht es auch nicht.
    -CMD FD gleiches Bild wie HD.

    ja, alles was nicht erkannt wird ist 1541 - also ok.

    Quote

    -IEC-ATA-V1.35 wird als Power 64 erkannt?? hier wird ein Dir angezeigt aber rein kommt man nicht .Und ins Root auch nicht
    Wenn mehr als 3 Files drauf sind stürzt der fibr ab.

    warum das als power64 erkannt wird, ist komisch... power64 antwortet auf "UI" mit "00,OK,..." - was antwortet denn IEC-ATA darauf?


    Quote

    in allen 3 fällen gibt es auch eine dir mit sec!>1.Wobei die links im IEC-ATA-V1.35 nur face sind.

    wo gibt es eine beschreibung, was mit sec!>1 zurueckkommt?


    Quote

    Wenn einmal Kopierfunktionen eingebaut werden sollen, würde ich mein xcopy gerne zur Verfügung stellen

    gerne


    ich bin immer noch fleissig am rumcoden, aber da ich nur c64+sd2iec und vice+power64 testen kann, kann ich einiges nur raten...


    und was ich fast vergessen haette: ich bin naechste woche nicht da, also bitte etwas geduld.


    Ciao, ALeX.

  • Also das ursprüngliche IEC-ATA hat kein UJ Kommando und quittiert das mit einem "24, SYNTAX ERROR,00,00"
    Die aktuelle Version hat uj und meldet sich mit "73, IEC-ATA V1.35.2,00,00"
    Das "V1.35.2" ändert sich aber immer wieder.
    Bei ui kommt 00, ok,00,00 und darum wohl Power 64

    Quote

    wo gibt es eine beschreibung, was mit sec!>1 zurueckkommt?

    Das ist Leicht , genau das , was im 1. Dirblock steht.( nach Track und Secktor)
    Wenn du eine normal formatierte 1541 Disk hast,bekommst du nach open1,8,2,"$" und get#1 folgende Bytes in Dezimal 65,0 dann folgt die BAM
    Genaueres im 1541 ,1571, 1581,....Handbuch
    Bei einer 1571 steht an der 2. Stelle ein 128 für Doppelseitig.
    Bei der 1581 kommt 68,0...
    Bei der CMD im nativ Mode 72,0... im 1541 Mode wieder 65,0...
    Bei IEC-ATA bis v1.351 65,0... und ab v1.35.2 69,0...
    Bei ide64 idedos 09 Patch 37 kommt ein 73 als 1.Zahl Also ein I
    Bei der 1541 ist der Buchstabe oft manipuliert, wenn also kein A,B,C,D,E,F,G,H,I kommt nimm de fault A


    Bei A , B ist 1541 Format ohne Dir. Die Daten der Directory folgt nach 254 Byte. an stelle 144 ist übrigens der Dir Header.
    Bei C folgen noch weitere BAM Blöcke.
    Bei D können Unterpartitionen vorhanden sein.
    Bei E giebt es Dirs ( Details im Quellcode)
    F und G weiß ich nicht. :grr:
    H hat wieder Dirs
    I hat ein eigenes Format und Dirs.( gug mal auf deren Webseiten)

  • Ich habe für kurze Zeit ein MMC2IEC (mit sd2iec-Firmware) von Unseen geliehen bekommen und darauf mal zum Spaß FIBR getestet. Nach den ganzen Hiobsbotschaften der anderen Forumsmitglieder hatte ich erwartet, dass gar nix funktioniert. Aber ich konnte mir das Hauptverzeichnis auf dem MMC2IEC ohne Probleme ansehen, in Ordner hineingehen und sogar in D64 hineinkommen. Ich kann auch Programme aus Verzeichnissen und D64 starten und Verzeichnisebenen wieder nach oben gehen. Es läuft nicht perfekt aber doch nicht soooo schlecht, wie sich das hier immer anhört. Zumindest nicht auf der einzigen Hardware, die wir haben.


    (Laufwerkstyp-Erkennung ist noch nicht wirklich gut und Verzeichnistracking funktioniert auch noch nicht richtig und alle anderen Hardwares sind überhaupt noch nicht getestet – aber bei mir läuft es rudimentär – Anscheinend eine positive Ausnahme.)

  • die kommentare klingen schlimmer als sie sind!
    jeder hier weiß, dass das kein einfaches projekt ist und das es sich um eine alpha version handelt. so viel unterschiedliche hardware und dann auch noch so viele firmware-versionen, wo sich auch noch permanent etwas ändert ...
    ich denke, dass in dieser phase möglichst viele kommentare (gerade schlechte) wichtig sind, um bugs zu erkennen.


    ich hab nur eine bedingt schlechte nachricht. hab fibr mit der 1541U getestet und war davon überzeugt, dass es ohne probleme laufen sollte. pustekuchen! hab aber das problem gefunden. ich hatte gerade eine neue firmware für die 1541U geladen, wo unter id9 auch der direkte zugriff auf die sd-karte möglich ist (1541 emulation lief auf id8). damit hatte fibr ein problem.


    kann man bei fibr den autodetect nicht optional machen? sowas in dieser art:


    nach dem start erstmal keine laufwerke scannen sondern diese auswahl:
    taste zum autodetect aller laufwerke
    (z.b. <A> drücken und alle laufwerke werden erkannt und fibr wechselt in den browser)
    oder
    bestimmte ids konfigurieren
    (z.b. nummer der id tippen (8,9,0,1,...) und dann <D> fur detect oder <M> für manuelle auswahl aus einer liste. wechsel in den browser mit <RETURN>)
    wenn das scannen des IEC-busses auf verwendete ids kein problem ist (nur das erkennen des laufwerkstyps), dann könnte man auch eine liste der verwendeten ids anzeigen , mit den pfeiltasten das gewünschte lw auswählen und dann d oder m drücken.


    es wird ja hoffentlich auch weiterhin neue hardwareprojekte und für die vorhandenen neu firmware-versionen geben. laufwerke, die sich nicht eindeutig erkennen lassen, könnte man so vom anwender richtig konfigurieren lassen. und wenn man mal ein laufwerk hat, dass (noch) nicht fibr kompatiebel ist, könnte man fibr trotzdem für die anderen laufwerke benutzen, ohne geräte abstöpseln zu müssen.


    nachteil für leute mit kompatiebler hardware wäre, dass sie nach dem start einmal <A> drücken müssten. ich denke, dass kann man verschmerzen, oder?


    Retrofan: welche firmware version des sd2iec ist den auf dem mmc2iec?


    gruß,
    cyberdyne

  • die kommentare klingen schlimmer als sie sind!


    Ist schon klar, war ja auch so gedacht – es soll ja gemeckert werden. Ich hatte nur nach dem Lesen der Kommentare angenommen, dass noch nicht ein Forumsmitglied ein Verzeichnis in FIBR zu sehen bekommen hat und überhaupt noch nicht weiß, wie das Programm aussieht – bis auf eine schwarze Fläche mit einem Fensterrahmen. Vielleicht ist das ja auch so aber bei mir funktionierte es überraschend gut.


    Retrofan: welche firmware version des sd2iec ist den auf dem mmc2iec?


    Ich weiß es nicht genau aber da die Platine von Unseen ist und D64 unterstützt wird, gehe ich davon aus, dass sie recht aktuell ist (sd2iec 0.5 oder so)

  • Zum Vergleich stelle ich mal einen älteren Filebrowser hier hinein.
    Mit dem iec-ata 1.35 läuft der gut.
    Beim sd2iec mit Software 0.5.1, den ich reudlicherweise von Unseen geliehen bekommen habe, zeigt er das Dir nur an, wenn er in einem D64 ist.
    sonst verweigert er den Zutritt.
    Der FiBr läuft mit dem sd2iec allerdings recht gut.
    Ich habe versucht die Erkennung des FiBR an den iec-ata anzupassen ging aber nicht auf die schnelle, da ich nicht weiß was er erwartet.
    Es währe ganz gut, wenn auf allen Laufwerken incl. 1541 (default) cd:..... immer gesendet würde. Dann würden so Geräte wie CMD sofort besser laufen.
    Denk an die 1581 die hat nicht cd:name sondern /0:name oder /:name und zurück geht es nur mit /ins root. eins zurück geht es nicht.
    Der Filebrowser vom IDE64 MAN verträgt SD und ATA gut.

  • Hallo,


    ich bin von ski-fahren zurueck - ohne mir was gebrochen zu haben!


    deswegen habe ich auch nicht viel geschafft.
    ich bin z.Z. noch dabei, meine dateien (ca. 60, > 10.000 zeilen) etwas zu "sortieren" dabei hat sich auch die reihenfolge geaendert, in der die programmteile im ram liegen, und schwupp es geht nicht mehr... das ist sehr komisch... ich versuch's aber mal zu debuggen.


    Ich habe versucht die Erkennung des FiBR an den iec-ata anzupassen ging aber nicht auf die schnelle, da ich nicht weiß was er erwartet.

    z.Z. erwarte ich auf "UI" ein "24, SYNTAX ERROR," (alles weitere ist mir dann egal) - wird aber geaendert, das es das andere (73, und 24) auf "UJ" erwartet.


    auf was fuer "bugs" muss man eigentlich noch so achten? (dass "JMP (xxff)" anders als erwartet funkionert, weiss ich schon)


    Ciao, ALeX.

  • Ich möchte hier schon mal ankündigen, dass in den nächsten Tagen eine neue Alpha-Version von FIBR released wird. Getestet haben wir sie mit der sd2iec Firmware 0.5.1 und bei uns läuft sie schon sehr rund (wobei natürlich auch einige bekannte Bugs vorhanden und noch nicht alle Features enthalten sind – ist halt Alpha-Status). Support ist von der Theorie her auch für iec-ata und IDE-64 gegeben. Da sind wir aber besonders auf Rückmeldungen angewiesen. Also alle, die geeignete Hardware (also sd2iec, iec-ata oder IDE-64) zur Verfügung haben, lasst sie schon mal warmlaufen. :)


    Was an Verbesserungen zur ersten Alpha hinzugekommen ist, wird alx noch in den Post zum Download schreiben.

  • Hi,


    entschuldigt, das es etwas laenger gedauert hat... Aber es gibt jetzt eine neue version von fibr!


    Unterstützte Hardware: C64 mit
    - sd2iec, incl. M2I und D64 (denn schliesslich habe ich fibr wegen dem sd2iec angefangen)
    - ide64, die groessen in blocks sind in 256 bytes blöcken (nicht in 254 wie sonst üblich, liefert das ide64 so)
    - iecata, da ich so'n ding nicht habe, ist alles nur geraten
    - 1541 und kompatible
    - vice & power64


    eine weitere taste:
    - mit 'b' kann man zwischen der darstellung in bloecken (default auf 1541, M2I, D64) und kilo-/mega-/bytes (default auf den anderen) umschalten.


    div. bugs sind entfernt worden und ide64 support deutlich verbessert.


    es koennen nun alle programme gestartet werden (vorher nur welche im bereich $07e8..$cfff).


    Viel Spass damit!


    Der download ist hier (wie immer):
    http://p1x3l.net/downloads/fibr.zip


    Ciao, ALeX.

  • Hab's direkt mal auf meinem mmc2iec mit sd2iec v0.5.1 ausprobiert.
    Die Erkennung scheint nun deutlich besser zu sein wie bei der ersten Version. Das mmc2iec wird bei jedem Start richtig erkannt.
    Das Browsen durch Verzeichnisse funktioniert nun einwandfrei und ist auch recht zügig, da konnte ich keine Probleme mehr feststellen.
    In d64 Images konnte ich auch meistens ordentlich hineinnavigieren. Gelegentlich bleibt der Bildschirm beim Laden des Directories eines d64 schwarz. Scheint wohl nur bei Images zu sein, die in Unterverzeichnissen auf der Karte liegen.
    Starten von Programmen macht auch keine Probleme. Sollten sich auch Programme aus d64 Images heraus starten lassen? Falls ja, funktioniert das nicht bei mir.


    Also, es sind deutliche Verbesserungen zu erkennen, fibr läuft nun deutlich "runder". Weiter so, Du hast da wirklich angefangen, nen klasse Filebrowser zu schreiben.

  • Gelegentlich bleibt der Bildschirm beim Laden des Directories eines d64 schwarz. [...] Sollten sich auch Programme aus d64 Images heraus starten lassen? Falls ja, funktioniert das nicht bei mir.


    Das selten auftretende Problem beim Laden von D64-Directories wird auf evtl. Benennungsprobleme zurückgeführt. ALeX testet schon. Programme sollten sich auch aus D64 starten lassen. Bei mir hat es damit noch keine Probleme gegeben.


    Es wäre sehr schön, wenn von den vielen FIBR-Downloadern einige mehr mal ihre Erfahrungen hier posten würden. Sehr gespannt sind wir auf Reaktionen bzgl. der Lauffähigkeit auf iec-ata und IDE-64, da wir diese Hardware nicht haben. Aber auch sonst sind für für jeden Tipp dankbar, damit wir zügig vorankommen und uns möglichst bald dem Beta-Stadium nähern können.

  • Ich hab den FIBR eben erstmalig kurz im VICE angetestet. Macht einen guten ersten Eindruck.


    Evtl. könnte ich beizeiten ein wenig testen, allerdings habe ich keine Iec-ata, mmc2iec oder IDE-64. Dafür könnte ich mit der kompletten CMD-Palette (HD, FD, RAMLink) sowie mit einem MMC64 dienen.
    Ggf. könnte ich euch auch meine CMD-Hardware leihweise zur Verfügung stellen, falls nötig.


    Übrigens, wenn ihr soweit seit, dass ihr euren Userkreis auf international erweitern wollt, empfehle ich folgende Plattformen: c64.sk, CSDb (sowohl die Datenbank zur Veröffentlichung neuer Versionen, als auch das dortige Forum) sowie das Lemon64 Forum.

  • Hi,


    ide64 sollte klappen...


    CMD-Geraete nicht. aber mit dem naechsten update, da ich ab dann alle unbekannten geraete als cmd betrachte (und nicht mehr als 1541).


    iec-ata nur, wenn sie sich auf "UJ" mit "73,IEC-ATA V..." melden. (also neuere firmware... genau weiss ich es nicht)


    das naechste update gibt's hoffentlich bald, naemlich dann wenn ich den d64 bug (s. wattie) behoben habe.


    Ciao, ALeX.

  • So Jungs und Mädels,


    hier ist eine neue version (und der link ist immer der gleiche...).
    geaendert hat sich:
    - fix: programme in einem d64 starten schlug manchmal fehl
    - fix: programme mit spaces am ende konnten nicht geladen werden
    - add: wenn das laufwerk unbekannt ist, wird es ab jetzt wie ein CMD behandelt
    - improved: beim laden eines programmes wird der name "schoener" ausgegeben


    ich hoffe dass es jetzt erst mal keine fehler mehr gibt, und ich so an neuen sachen stricken kann.


    Ciao, ALeX.