Hello, Guest the thread was viewed833 times and contains 16 replies

last post from dddaaannn at the

mega65 core develo build 100

  • Habe heute mal das neu Core build 100 zusammen mit dem ROM 920392 auf meinem Dev Kit installiert und meine Programme laufen lassen.

    Die Maustasten meiner Amiga Maus funktionieren leider damit nicht. Es liegt nicht am ROM 920392 da es mit ROM 920386 auch nicht funktioniert. Ansonsten sind mir keine Fehler aufgefallen.


    Ich arbeite sonst mit der Kombination Core mega65r3 build 0.95 und ROM 920392. Da gibt es keine Probleme mit der Amiga Maus.

  • (Apologies for English:) Which port are you using with the mouse? Can you confirm that the port is in Amiga mouse mode in Configuration?


    There is a known issue with the right mouse button triggering with mouse movement, specific to an Amiga mouse in port 1. We're hoping to fix this for this release. Maybe this is what you're seeing. https://github.com/MEGA65/mega65-core/issues/751

  • I cannot reproduce mouse buttons not working for an Amiga mouse in port 1 with the latest development core, and I don't know why that might be the case on your machine. (I don't have a DevKit to test with, but I can't think of a reason why that would be a factor.)


    There is a case on the old v0.95 core that would produce this symptom. I'll describe it just in case it's useful, but it contradicts a couple of facts in your report so it might not apply. The v0.95 core was mis-wired such that attempts to read mouse and paddle movements from port 2 actually reported mouse and paddle movements from port 1. Attempts to read mouse buttons from port 2 correctly reported buttons from port 2. So with v0.95, if the mouse (either kind) was connected to port 2 and the program was trying to read from port 1, it would see port 2 mouse movements but not port 2 buttons.


    One additional point of interest: The BASIC "MOUSE ON" command takes a port parameter. This parameter is optional, but I think it's easy to miss the note in the documentation that the default port is actually port 2. (For whatever reason this is how it was on the C65.) With the CIA bug in v0.95, a BASIC program using "MOUSE ON" without specifying the port would read mouse movements from port 1 but mouse buttons from port 2. With the bug fix in v0.96, "MOUSE ON" would read both movements and buttons from port 2.


    Maybe none of that applies to what you're seeing but I thought I'd mention it just in case.

  • Hello dddaaannn, thank you for your comments. I always specify the port with the programmes. "mouse on,1"


    I have now tried port 2 and the mouse buttons are not accepted here either. The mouse pointer runs normally.


    Maybe my AMIGA mouse is abnormal? With my 1351 Commodore mouse and switched to normal mouse does not work in all cores.


    Where can I buy a mouse that definitely works with the new cores? Maybe there are better experiences here.

  • If it works with v0.95, we should continue to suspect the core. I agree that it might be worth suspecting a DevKit-specific issue. We should try to find someone else with a DevKit to repro. Technically the R3 and R3A boards shouldn't be different enough to matter, but it's something I can't test myself.


    I use a mouSTer with a typical Logitech wireless mouse in Amiga mode. I see the known issue with the right mouse button flickering in the v0.96 release candidate, but it otherwise works. I also have a vintage 1351 that works flawlessly.


    Sorry for the inconvenience, and thanks for the reports!

  • I have a guess but it's a long shot. Can you try 920393, the very latest ROM version?


    920393 differs from 920392 in just one way, but it might be relevant. I don't know why this behavior would be specific to DevKits. (So far I haven't had any DevKit owner volunteers to reproduce this, and I don't have a DevKit.)

  • Heya umueller-wsw,

    I don't have a genuine amiga mouse, but I have been testing out issues with the mouster set to amiga-mouse-mode.


    Gardners had some speculative amiga-mouse fixes he asked me to try with my mouster, and it resolved my issues with the mouster-amiga-mouse.


    Here's a link to where you can download the .bit/.cor file from his amiga-fix branch:


    https://builder.mega65.org/job…ega65r3-751-am-build-7.7z


    Hope it helps, let us know how it goes :)


    PS. I tried the fix on my devkit and also my release machine, resolved the issue on both.

  • Unfortunately, the mouse buttons do not yet work with ROM 920393. What a pity.

    Do please try the bitstream that Gurce suggested above. The left button of any Amiga-compatible mouse should now work, if you have Amiga mouse emulation enabled in configure. The right button, however, will not work without making a special joystick extension lead -- exactly the same as would be required to use the right-button of an Amiga mouse on a real C64. The problem is that the Amiga mouse does not have a pull-up on the right mouse button, and nor does the C64 or MEGA65 on the pin used, because it is a POT input on the C64/MEGA65, but is a digital input with pullup on the Amiga, so far as I understand. Same goes for middle button of a 3-button Amiga mouse. I'm going to make up a test cable and confirm function with a MouSTer set to Amiga mode here as soon as I have time.


    VG

    Paul.

  • Hi Gurce,


    Thanks for your help.

    With the combination core 65r3-751-am-build-14 and ROM 920394 the left mouse button does not work on my DEV kit with an AMIGA mouse.


    In my opinion this is due to the ROM, as the current Core 0.96 (Build 100) with the Rom 920386 works with an AMIGA mouse wirelessly or with a cable without any problems.


    After that, the newer ROMS from 920387 no longer work with my AMIGA mice.


    I do not have a MouSTer.


    The AMIGA mode is always set.


    Udo

  • Apologies for the confusion. We're chasing down several unrelated Amiga mouse issues. We have fixes for some but not all of the issues staged for a later core release (not v0.96 but the next one), and our ability to reproduce some issues has been inconsistent, possibly due to the quality of the vintage hardware we've been able to access.


    I've gotten ahold of an Escom mouse and a Commodore Amiga mouse, and I'm getting different broken symptoms. The Amiga mouse doesn't register either button on either port, but in my case this is *not* fixed by downgrading the ROM. I'm not ready to call this definitive, as I don't have an actual Amiga to test the mouse, but I was able to verify that the buttons work electronically, making a circuit with 5 ohms of resistance across the appropriate pins. The Escom mouse worked on a friend's Amiga but didn't work at all on the MEGA.


    I can at least partly explain the theory of the ROM making a difference: the legacy keyboard scanner had a side effect of resetting the CIA directional pins with every IRQ. With the new keyboard scanner in 920387, it no longer does this, revealing some bugs in how the CIA port is handled elsewhere. I'll try reintroducing some CIA resets in the IRQ and see if I can improve things, but because I can't yet reproduce an Amiga mouse working better with an older ROM than a newer one, it'll be tricky for me to confirm. The work continues.