Hello, Guest the thread was viewed60k times and contains 382 replies

last post from Juergen Johannes at the

VICE 3.7 has been released

  • VICE Team is proud to announce the release of VICE 3.7


    This release contains a lot of bug fixes and improvements:

    Downloads can be found at https://vice-emu.sourceforge.io/ or https://github.com/VICE-Team/svn-mirror/releases/tag/3.7.0

    From now on we also publish Debian packages (including the ROMs) of point releases and development releases, which should make it a little easier for Linux users to install an up-to-date VICE with the proper ROMs.


    Merry Christmas and enjoy!

  • Aber CMD-RamLink funktioniert nach wie vor nur unter VICE-C64 :-(

    Sollte das ab VICE 3.7 nicht auch unter VICE-C128 funktionieren?

    Tja. Derjenige, der das implementiert hat, ist leider wie es aussieht kaum mehr aktiv. :|


    Ich persönlich fände es nett, wenn der Bug gefixt würde, dass man von einem 1581 Drive nicht mehr richtig wechseln kann.

  • Tried the new version some minutes ago and have a question. In V3.7 the "8580 filter bias" is set to "0" by default. Is that correct now, or should users change this again to "-3000", as it was always the case in all the older VICE versions? Does anyone know more?


    And then i recognized a problem on my Win7, 32bit-system. About every third time, i start the emulator, it crashes and brings up the error message:


    "x64sc.exe funktioniert nicht mehr. Das Programm wird aufgrund eines Problems nicht richtig ausgeführt. Das Programm wird geschlossen."


    "x64sc.ex don't work anymore ..."


    Especially this seems to occur on my PC, when a few other programs are already open and I then want to open VICE additionally. If no other program is running and I only open VICE, it seems to occurs less often. With V3.6.1 I had a similar problem. However with V3.6 and all VICE versions before, this problem never appeared. Could have something to do, with the changes from V3.6 to V3.6.1 maybe?


    Does anyone else have this error-message from time to time (especially on Win7, 32bit systems), when trying to open latest VICE? Overall V3.7 runs okay on my system, only this crash-message is a little bit strange, because like i mentioned, this never happens in V3.6 here, on my PC.

  • Bei mir schliesst sich x64c.exe (GTK) oft kurz nach dem start wieder, komplett ohne Fehlermeldung. Nach 2-3x starten bleibt das Fenster dann offen. Dieses Problem hatte ich mit 3.6.1. aber auch schon.

    Was in 3.7 neu ist, das mir Directories bei der Image Auswahl nur noch so angezeigt werden.

  • Bei mir schliesst sich x64c.exe (GTK) oft kurz nach dem start wieder, komplett ohne Fehlermeldung. Nach 2-3x starten bleibt das Fenster dann offen. Dieses Problem hatte ich mit 3.6.1. aber auch schon.

    Was in 3.7 neu ist, das mir Directories bei der Image Auswahl nur noch so angezeigt werden.

    Hab hier 3.6.2-dev r42547 drauf, da ist die Directory Anzeige noch in Ordnung. Bei früheren 3.7er builds war das bereits schon kaputt.

    Vielleicht nur ein simples Font Problem? Der enthaltene C64_Pro_Mono-STYLE.ttf Font ist zumindest installiert...

  • Aber CMD-RamLink funktioniert nach wie vor nur unter VICE-C64 :-(

    Sollte das ab VICE 3.7 nicht auch unter VICE-C128 funktionieren?

    Wirklich bedauerlich.


    Mich persönlich stört das missing feature, dass man bei einem »Host file system device« nicht die Kernmöglichkeiten vom SD2IEC hat - hauptsächlich: »Extension hiding« sowie »file extension mode«, also genau das, was auf einen SD2IEC per »xe"-Kommando eingestellt wird.

  • Die MacOS Version stehtzwar als 3.7 auf der Hauptseite, es gibt aber nur 3.6.1.

    So wie ich das mitbekommen habe hat das neueste Gtk3-Release vom 22.12. endlich einen Bug gefixt, durch den die Menupunkte in macOS Ventura nicht anklickbar waren, aber damit zeigt VICE das C64-Bild im Fenster an der falschen Y-Position an. Statt eine Version rauszugeben die auf die eine oder andere Art kaputt ist wurde beschlossen, die Mac-Version nachzuliefern wenn der Mac-Nutzer im Entwicklerteam die Weihnachtsfeiertage überstanden hat und den VICE-seitigen Bug gefixt hat.

  • In V3.7 the "8580 filter bias" is set to "0" by default. Is that correct now, or should users change this again to "-3000", as it was always the case in all the older VICE versions? Does anyone know more?

    Please see VICE feature request #426. This is to be seen in the aftermath of a newer 8580 filter implementation. Just keep the filter bias at its default value if the SID emulation sounds right for you. :)