Hello, Guest the thread was called1.2k times and contains 36 replays

last post from hexfile at the

Ein 1541-II mit dem Mega 65 nutzen

  • Hallo alle Zusammen,


    Ich bin neu hier und hab jetzt meinen Mega 65 bekommen8o...

    Ich versuche jetzt schon eine weile mein Diskettenlauf (1541-II )dem Mega 65 zu nutzen..

    das Handbuch hilft mir da irgendwie nich weiter und meine englisch Kenntnisse sind och nich die besten... das Laufwerk funktioniert Ohne Probleme an meinen alten Brotkasten...

    Muss ich im Freeze menü irgendwas noch einstellen oder eine bestimmte Befehlskette?

    Ich war am C64 er der Musiker als der "Programmierer"...und natürlichbein Zocker:thumbsup:<3

    Ich danke für eure Hilfe.

    Gruß Eydan

  • Das interne Laufwerk wird die Adresse 8 haben genauso wie Deine 1541.

    Also müsstest Du das interne Laufwerk deaktivieren, oder auf Geräteadresse 9 ändern.

    Leider hab ich keinen Mega65 aber ich vermute das es da ein Menü/Setup gibt ?!

  • Leider hab ich keinen Mega65

    Dann änder das. :D


    Ich bin neu hier und hab jetzt meinen Mega 65 bekommen 8o ...

    Ich versuche jetzt schon eine weile mein Diskettenlauf (1541-II )dem Mega 65 zu nutzen..

    Herzlichen Glückwunsch und viel Spaß damit.

    Zum Thema Floppy: grubi hatte, meine ich, eine zum laufen gebracht.

  • Das interne Laufwerk wird die Adresse 8 haben genauso wie Deine 1541.

    Also müsstest Du das interne Laufwerk deaktivieren, oder auf Geräteadresse 9 ändern.

    Wäre es nicht einfacher die 1541-II mit den Dip-Schaltern auf Adresse 9 umzustellen?

  • Das interne Laufwerk wird die Adresse 8 haben genauso wie Deine 1541.

    Also müsstest Du das interne Laufwerk deaktivieren, oder auf Geräteadresse 9 ändern.

    Leider hab ich keinen Mega65 aber ich vermute das es da ein Menü/Setup gibt ?!

    Hallo Superingo,


    So ähnlich macht man das woll im sogenannten Freeze Menu... doch das funktioniert nicht bzw. Gebe ich vielleicht auch die falschen Befehle ein...

  • Danke für die info...:)

  • Beim MEGA65 sind standardmäßig die Gerätenummern 8 und 9 bereits vergeben. D.h. du musst dein 1541-II Gerät über die DIP-Schalter auf der Rückseite (bei ausgeschalteten Gerätezustand) hardwaremäßig entweder als Gerät 10 oder 11 konfigurieren:



    Für Laufwerksnummer 10 bspw: Den linken Schalter (bei einer Geräteausrichtung wie in der obigen Abbildung) "hoch" stellen und den rechten Schalter "runter" setzen.


    Dann verkabeln/anschließen der 1541-II an den MEGA65. Am MEGA65 braucht nichts weiter eingestellt werden (falls dort die Standardkonfiguration für Floppylaufwerke eingestellt ist). Diskette in die 1541-II rein und am MEGA65 bspw. DIR W,U10 eingeben:



    Edit:

    Man kann im MEGA65 auch die Geräte/LW-Nummern 8, 9 der internen Geräte/Laufwerke (echtes 3,5" FDD und virtuelles Diskimage auf SD-Karte) verschieben auf 10, 11 und dann externe IEC/Serielle-Laufwerke über die Gerätenummern 8 oder 9 betreiben. Das erfordert aber Einstellungen im MEGA65. Daher hier der einfachere Weg: Direkt externes Laufwerk hardwareseitig als 10 oder 11 konfigurieren und mit dieser Nummer im MEGA65 verwenden.

  • Das Problem durfte auch sein, das viele Programme gar nicht erst prüfen von welchem Device sie gestartet wurden und dann von Gerät 8 nachladen wollen.

    Dann hilft eine 1541 als Gerät 10 recht wenig.

    Wenn sich das Softwaremäßig auf einem FPGA Rechner nicht lösen kässt, ist das ja witzig.

  • Ich betreibe eine 1541 II am IEC Bus des MEGA65 als LW 11. Das funktioniert ohne Probleme. Hab einfach die Hardwareadresse der Floppy auf mit dem Dipschalter auf 11 codiert, angeschlossenen und es hat sofort funktioniert. Sowohl "DIR U11" wie auch LOAD"$",11 zeigen ihre Wirkung.



    Was mich irritiert ist folgendes. Bei eingestecktem IEC Kabel und eingeschalteter Floppy läuft der Motor durch und die grüne LED ist ununterbrochen am Leuchten. Erst wenn ich den MEGA65 einschalte stoppt der Motor und die grüne LED erlischt. Dieses verhalten findet man beim Anschliessen der Floppy an die C64 Hardware nicht.



    Ist das bei bei euch auch so. Kann man das irgendwie ändern?

  • butlerking : Dieses Verhalten kann man auch beim C64 finden. Es hängt aber wohl von der C64-Revision ab, ob das auftritt.

    Ok, das ist mir echt neu. Mir ist dieses Verhalten noch nie untergekommen. Ich hab hier noch einige C64 Boards die ich noch reparieren will. Da werd ich mal auf genau drauf achten ob ich eine Revision finde die den "Fehler" hat.

  • Alles probiert ging nich.. und laut Bedinungsanleitung nicht nötig...

    Hm, laut MEGA65 Userguide/Benutzerhandbuch ist es sehr wohl nötig, die externen IEC-Laufwerke auf Nummer 10 oder 11 zu betreiben:


    Nur eine Zeile unter deinem markierten Text steht, dass man die internen Laufwerke beim MEGA65 auch von 8,9 auf 10,11 legen kann und dann die externen Laufwerke als 8,9 nutzen kann.


    Ich habe keinen MEGA65 zum Testen, aber das kann man meines Wissens im Freezer so einstellen, dass die internen Laufwerke als 10,11 genutzt werden. Und dann gehen externe Laufwerke einfach als 8,9 und haben auch keine Probleme mit Spielen, die unbedingt von 8 laden wollen.

  • Nur eine Zeile unter deinem markierten Text steht, dass man die internen Laufwerke beim MEGA65 auch von 8,9 auf 10,11 legen kann und dann die externen Laufwerke als 8,9 nutzen kann.


    Ich habe keinen MEGA65 zum Testen, aber das kann man meines Wissens im Freezer so einstellen, dass die internen Laufwerke als 10,11 genutzt werden. Und dann gehen externe Laufwerke einfach als 8,9 und haben auch keine Probleme mit Spielen, die unbedingt von 8 laden wollen.

    Das ist richtig und hatte ich oben in Beitrag #9 auch so erwähnt:

    Man kann im MEGA65 auch die Geräte/LW-Nummern 8, 9 der internen Geräte/Laufwerke (echtes 3,5" FDD und virtuelles Diskimage auf SD-Karte) verschieben auf 10, 11 und dann externe IEC/Serielle-Laufwerke über die Gerätenummern 8 oder 9 betreiben. Das erfordert aber Einstellungen im MEGA65. Daher hier der einfachere Weg: Direkt externes Laufwerk hardwareseitig als 10 oder 11 konfigurieren und mit dieser Nummer im MEGA65 verwenden.

    Missverständlich war wohl die Formulierung in Beitrag #10, die eigentlich nur auf die dort zitierte Aussage bezogen war, dass eine Änderung der Geräteadresse "laut Bedinungsanleitung nicht nötig" wäre. Bei Beibehaltung der Standardeinstellung des MEGA65 müssen externe Geräte aber sehr wohl 10 oder 11 sein oder man ändert die Standardeinstellung wie in den Zitaten beschrieben im MEGA65 ab und kann dann sehr wohl externe Geräte als 8 oder 9 betreiben. Letztlich muss man laut Handbuch durchaus irgendetwas davon ändern und möglich ist es in der Tat.

  • Vielen Dank für Eure Hilfe,so funktioniert es...

    Hab mich echt wat glatt angestellt.... Meine c64 Zeiten sind schon ne weile her:)

    Sprich Schalter auf 10 umschalten... am Laufwerk


    Wie startet man dann die Programme ?

    Hab es mit "load"*",10 probiert und er zeigt mir den startbildschirm lädt dann aber nicht weiter?

    Sondern versuchte dann am 3,5laufwerk weiter zu laden...

    Im c64 Modus... fehlt da noch ein Zusatz?

    Das Programm ist auf einer Kompletten Diskette..

    "File not found error in 1080 "

    Wie gesagt er greift nicht auf das start laufwerk zu sonder auf das 3,5 und das ist "ausgeschaltet"

    Gruß Eydan

    Edit

    Einzelne Programme auf der Diskette das funktioniert:thumbsup:

    Programme die auf einer Diskette komplett sind funktioniert noch nicht...Ich probiere noch paar Sachen aus...

  • Ich würde sagen, dass nicht wenige Spiele automatisch und fix von Laufwerk 8 nachladen. Deshalb würde ich ein externes Diskettenlaufwerk auch unter 8 betreiben und lieber die internen Laufwerke umstellen.