Hello, Guest the thread was called2.2k times and contains 32 replays

last post from pastors at the

c128dcr Netzteil ohne Funktion

  • Hallo zusammen,

    nachdem letzten die 128dcr Platine nach 30 Jahren Dornröschenschlaf ein zweites Leben erhielt, machte ich mich heute an einen weiteren Schläfer.

    Es handelt sich hierbei um ein ein DVE DSP-128DCR Power Supply (hoffentlich wird das was mit der Power :))


    Nachdem heute beide Glassicherungen erneuert wurden versuchte ich auf gut Glück. Scheiterte natürlich wie erwartet denn beim Einschalten flog direkt die Sicherung mit einem klitzekleinen Funken weg.

    Die Sicherung ist die 2A beim Schalter. Es existiert zwar ein Schaltplan LINK bin mir aber nicht sicher ob dies auch für Europa/Deutschland gültig ist. So ist beim Widerstand R2 in meinem Netzteil ein 390K eingebaut und im Schaltplan 240K.

    Das Netzteil wurde bereits von irgendjemand früher bereits bearbeitet. Man sieht es deutlich am großen Kondensator im Primär Kreis.

    Daher meine Frage, wenn die Sicherung durchbrennt, lässt es sich bei einem Netzteil grob den Fehler eingrenzen?


    Hat vielleicht jemand ein identisches Netzteil oder früher mal in der Mache gehabt?

  • Hallo,

    heute kam der Ersatz Transisitor 2SC3679 von KESSLER an. Kurz die Pins mittels Diodenprüfer getestet und anders als der alte, haben diese keinen Kontakt untereinander.

    Also verlötet und die Platine wieder auf den Metallträger verschraubt. Power on und die 5V waren 0.00 auf dem Multimeter.

    Also doch mehr kaputt als erwartet... aber, die Platine hat 2 Regler und am 5V gedreht... und et voilà, da regt sich was auf dem Multimeter.

    Also 5V auf 5,10V eingestellt und 12V auf 11,90V. Die 9V AC war im unbelasteten Zustand ca. 10V, denke das paßt soweit.


    Passen die Spannungen so:

    5V eingestellt auf 5,10V

    12V eingestellt auf 11,90V

    9V AC... xxx


    Das Netzteil brummt zudem etwas, muss mal schauen woher dies kommen mag.

    Im Bild unten der defekte Transisitor mit gestreckten Beine :D

  • Hallo zusammen,

    hatte das Netzteil hier in diesem Beitrag LINK wieder repariert.

    Leider konnte ich trotz Trimmer die 12V nie über die 11,90V bewegen. Also alles durchgemessen und festgestellt, dass der Spannungswandler gar nicht mehr Output hergab.

    Also wiedermal im Internet passenden Ersatz geordert und eingebaut. Nun liesen sich die 12V sauber einstellen.

    Fragt jetzt nicht warum oder weshalb ich unbedingt die 12,00V auf 12,10V anheben wollte...

    Auf alle Fälle schaute ich nur auf das Multimeter und bemerkte nicht, dass ich mit dem Schraubendreher (Kunststoff) den inneren Kunststoff des Trimmers herausschabte. :platsch:

    Anstatt mit den 12V zufrieden zu sein drehte ich den Trimmer zurück und bin jetzt bei 10V :platsch::platsch:

    Könnte mich so in den Hintern schlagen, versaue hier ein sauber funktionierendes Netzteil ohne jeden Grund... nur um unbedingt die 12,10V und die 5,10V zu erreichen. :platsch::platsch::platsch:


    Frage an Euch, kennt jemand einen Trimmer der ähnlich wie dieser aussieht oder sogar den Originalen?


    Im Anhang habe ich mal ein Originalbild angehängt inkl. der im Schaltplan benötigten Werte.

  • Den originalen wirst Du vermutlich nur aus einem Schlachtgerät ausbauen können. Technisch wird das ein anderer vermutlich genauso gut oder besser hinbekommen. Auch wird Commodore je nach Verfügbarkeit auch verschiedene Teile im Einsatz gehabt haben. Von daher würde ich mir da keinen Kopf machen und das nehmen, was technisch passendes in das Bastelkiste oder einer Schlachtplatine ist.

  • Kenne mich mit den Trimmern nicht aus daher jetzt vielleicht unbeholfene Fragen...


    1. die Markierungen auf dem Bild, sind das die Gänge die beispielsweise bei Reichelt Shop genannt werden?

    2. ist die Pin Belegung standardisiert oder hat jeder Hersteller eine eigene Belegung?

    3. Laut dem Schemata steht beim VR2 5V Adjust 1000. Beim VR1 ist REG ADJ 100 Ohm genannt. Wofür die 5V explizit genannt?

    4. der Original hat in Breite/Länge 6x6mm, ist das dann ein SMD Bauteil?

  • die Markierungen auf dem Bild, sind das die Gänge die beispielsweise bei Reichelt Shop genannt werden?

    Laut Schaltplan hat der eine 100 Ohm und der andere 1000 Ohm (1 kOhm). Übliche Bezeichnungen sind:

    • 100 Ohm: "101", "100 Ohm", "100 R"
    • 1000 Ohm (1 kOhm): "102", "1 kOhm", "1 K"

    VR2 5V Adjust 1000 [...] Wofür die 5V explizit genannt?

    Das beduetet, dass das der Regler für die 5 V-Einstellung ist.

    Hat mit dem Bauteil nichts zu tun.

    ist die Pin Belegung standardisiert oder hat jeder Hersteller eine eigene Belegung?

    Normalerweise kann man sich darauf verlassen, dass der mittlere Pin der Schleifkontakt ist bei allen Potis. Manche haben die drei Pins in einer Linie, bei manchen sind sie V-förmig angeordnet. Sieht man aber auf den Fotos im Shop oder in den dort dazu verlinkten Datenblättern.

    der Original hat in Breite/Länge 6x6mm, ist das dann ein SMD Bauteil?

    SMD = "surface mounted deivce" = Bauteil, das auf der Oberfläche "montiert" (verlötet) ist. Heißt: Dort, wo es bestückt wird, wird es auch verlötet. Die Platine hat für dieses Bauteil keine Bohrungen.


    THT = "through hole technology" = Bauteil, das bedrahtet ist und dessen Anschlüsse zum Verlöten durch ein Lötauge in der Platine gesteckt wird. Es wird also auf der Bestückungsseite reingesteckt und auf der anderen, der "Lötseite", verlötet.


    Das betreffende Netzteil ist in "THT" aufgebaut. Wichtig sind nicht die Außenmaße des Potis, sondern die Pinabstände aka "Rastermaß".

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Hallo zusammen,

    die Trimmer sind inzwischen eingetroffen. Wäre eigentlich schonmal sehr gut, aber nun tut sich ein ganz anderes Problem auf.

    Egal in welcher Position die Trimmer sind, immer zerschießt es mir den PTC und den Power Transistor. Inzwischen habe ich 5 der 2SC und PTC verbrannt. :cry:

    Hat mir jemand einen Tip wie ich mich schonend den 5V und 12V annäheren kann?

    Durch das viele aus- und einlöten sind die Lötaugen inzwischen deutlich mitgenommen.


    Daher hoffe ich mal auf Tipps hier oder ggf. jemand der so ein Netzteil richten könnte. :/

  • sind denn die Sekundärelkos alle ok?


    Wenn es ständig den Transistor schiesst, kann das durch eine Überlastung hinweisen, d.h. das Netzteil muss zuviel Strom/Energie in die Sekundärseite schalten, um die Ausgangsspannung zu erreichen.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • Die Elkos hatte ich vorsichtshalber mal alle getauscht. Waren neue von Kessler und Reichelt. Nehme aber an die sind soweit in Ordnung.

    Die ursprünglichen Trimmer musste ich ersetzen da ich diese dummerweise innen das Kunststoff abgedreht habe.


    Das Problem ist der Transistor ist mit 2€/St. nicht gerade ein Schnapper. Ich muss irgendwie eine Vorgehensweise finden die den Verlust des 2SC Transistors vermeidet.

    Sobald das Netzteil mit Strombefeuert wird sieht man kurz einen Funken am PTC und dieser ist dann genauso wie der Transistor hin. Die Sicherungen bleiben aber immer heile.

    Die Schalterstellung der Trimmer scheint hierbei keine Rolle zu spielen. Egal ob ganz ganz nach links, rechts oder mitte, immer das gleiche Resultat :(

    Denke aber mit meinem primitiven Werkzeug werde ich so nicht weiterkommen.


    Es handlet sich übrigends um dieses Netzteil. Allerdings sind nicht alle Bauteile identisch, manche Widerstände sind deutlich größer als in den Schematics gelistet sind.

    Würde das Netzteil gerne wieder in Betrieb bekommen da die Platine deutlich wertiger aufgebaut ist als das eine Netzteil auf dem ein dicker Trafo auf einem Platinchen verbunden ist.


    Momentan sitzt der Frust über die eigene Dummheit ein funktionierendes Netzteil kaputtkonfiguriert zu haben nur um anstatt 11,90V die 12,19V zu erhalten. Naja, jetzt isses so :(

  • Ach Mist, wollte eigentlich HIER weiterschreiben...

    die beiden Threads kann ich dir auch zusammenlegen, wenn du willst.


    Du betreibst das Netzteil an 230V? Der Schaltplan ist für 120V, deshalb sind wahrscheinlich unterschiedliche Bauteile da drauf.

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • Noch ein Hinweis zu den Überlegungen weiter oben.


    Keiner der beiden Potis scheint die 12V zu regeln. Es ist ein 12V Festpannungsregler verbaut.


    VR1 REG ADJ scheint den Arbeitspunkt oder dergleichen des Schaltreglers an sich einzustellen. Wenn der falsch steht -> Überlastung, brennt durch.


    VR2 5V adjust stellt dann die Rückkopplung für den 5V Ausgang passend ein. Vielleicht so eine Art 5V Feineinstellung.


    Wie man die Grundabstimmung neu vornimmt weiß ich aber nicht. Man müsste sich wohl an den Meßwerten und Oszillogrammen im Schaltplan orientieren. Aber ich rate ab da selbst zu messen!!! Manche Meßpunkte sind nicht netzgetrennt!!!

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!

  • Hm, die Erklärung macht durchaus Sinn. Denn als ich an VR1 dreht, im Gewissen dass ich damit die 12V regle, gab es den Ausfall.

    Im ersten Beitrag ist ein Bild von der Stellung des damaligen Poti. Da die Werte des alten und neuen Poti identisch sind, gibt es eigentlich nur 3 mögliche Stellungen des Poti.

    Kann man sich tatsächlich nach der Stellung des Kreuz im Poti orientieren oder eher eine Schnapsidee?

  • du könntest mit beiden Potis in Mittelstellung starten und dann die Spannungen an der Sekundärseite messen. Da kannst du auch ein Oszi anschliessen und die Wellenform sehen. Ich weiß nicht was VR1 regelt, ob es Frequenz oder Tastverhältnis ist. Beides ist aber auch auf der Sekundärseite sichtbar und muss "sinnvoll" sein entsprechend den Bildern.


    Ich hab mal alles rot angemalt, wo im Betrieb Verbindung zu Netzspannung ist. Die Seite rechts mit den grünen Messpunkten ist galvanisch getrennt.


    ps-128dcr-usa.gif

    Zuletzt repariert:
    21.2. Logitech M570 Microschalter ausgetauscht - geplante Obsoleszenz durch Billigtaster?
    19.11. Toshiba 3,5" Floppy defekter Elko durch Kerko getauscht auf Motorplatine
    27.11. 1541B Dauerlauf, Elko im Resetschaltkreis defekt, nicht der 7406 wie zuerst verdächtigt!