Hello, Guest the thread was called1.8k times and contains 45 replays

last post from wdoelker at the

C64 ASSY 250469 Rev 4 Black Screen

  • Das ist zwar nett anzuschauen, aber hilft uns das weiter?

    :nixwiss:

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Nebenbei zum SID Sockel, wenn das kein Doppelfedersockel ist dann muss der ohnehin getauscht werden sollte das Board wieder laufen...gibt sonst nur Probleme.

    Wenn ich das Board verkaufe, werde ich mir wahrscheinlich nicht die Mühe machen. Mir geht es hier um das Reparieren und Verstehen - was mir offensichtlich nicht immer gut gelingt. Aber aus den gleichen Gründen habe ich den kompletten VIC II im Sockel durchgeklingelt, weil ich diesen Billig-Sockeln von Commodore genauso wenig traue wie alle anderen hier. Für den VIC war das aber unauffällig. Und wie sagt man so schön? Ein Problem nach dem anderen. :emojiSmiley-16:

    Schon seltsamer defekt das Board hier, bin gespannt ob ihr den Fehler findet.

    Ich auch. Von all den 250469er, die ich bisher in den Fingern hatte, waren es immer defekte CPUs, RAMs oder auch LS/4066-Chips - oder Leiterbahnen auf dem Board, etc. Ein defektes Super-PLA wäre für mich Premiere.

  • Ein defektes Super-PLA wäre für mich Premiere.

    Für mich auch.


    Bei dem Video wirste ja ganz wuschig im Kopf :freude

    Also bei jedem anderen Board bis 466 hätte ich ja jetzt gesagt: es ist die PLA. Aber wie gesagt: mir ist noch keine defekte von den dicken PLAs untergekommen (wobei ich sagen muss: ich hab grad auch so ein 469er Board hier welches quatsch macht und ich noch nicht dahintergekommen bin was da Sache ist.... auch hier deutet einiges auf die PLA hin)

  • Irgendjemand hier im Forum hatte tatsächich mal ne defekte Super-PLA meine ich. Blöd ist nur den Sockel dafür organisieren, entweder länger warten und günstig aus China oder teuer und schnelll von Mouser/Digikey. Den hat ja kaum einer der Forenuser auf Lager, weil man den ja sogut wie nie braucht. Dann muss man auch noch nen Akt machen und den Super-PLA noch aus einem anderen Board löten oder anderweitig organisieren...hm

  • Bei RP5 ist alles gut? Das sieht so etwas komisch/nachgelötet aus?

    Genau kann ich mich nicht mehr erinnert, das ist aber wahrscheinlich aus Verzweiflung nachgelötet. Das Messen der Werte ist aber unauffällig.


    RP4 vllt. auch mach Checken

    Sieht für mich von den Werten und Verbindungen auch OK aus.

  • Blöd ist nur den Sockel dafür organisieren

    Da das Motto hier im Forum ja "besser haben als brauchen" ist, habe ich Sockel für das Super-PLA da, siehe hier.

    Die kosten in China tatsächlich weniger als 1 Euro - sollte also jemand (außer mir) welche brauchen, gerne PN.


    Aber wie gesagt sehne ich mich nicht danach, das Ding auszulöten, und ich habe auch keinen Ersatz verfügbar. Ich habe hier zwar ein 250469 zum Ausschlachten, aber leider ein Rev B. Man kann die zwar auch kaufen, aber für 30+ Euro werde ich das wohl nicht machen.


    Daher wollte ich erst alle anderen Optionen ausschließen ...

  • Den hat ja kaum einer der Forenuser auf Lager, weil man den ja sogut wie nie braucht.

    nie? ..den braucht man für so ziemlich JEDES Nachbau-Projekt:

    - Micro

    - Tuning-Board

    - Modular

    - ATX

    - Tube

    .... :D

    ich nehm aber immer gedrehte Sockel - die kommen auch prima mit ausgelöteten ICs klar, die noch bissl Lötzinn-Reste dran haben:whistling:


    wdoelker : brauchst du noch immer einen PLA? ..ich hätt noch welche hier(allerdings alle "entliehen" - keine Neuware)

  • Ich weiß, der letzte Post zu diesem Thema ist schon eine Weile her. Leider ruhte das Thema bei mir etwas, bis ich heute den SuperPLA-Sockel eingelötet habe und danach den Super-PLA testen konnte, den Shadow-aSc mir dankenswerterweise zugeschickt hatte.


    Leider hat das nichts gebracht. :nixwiss:


    Was habe ich heute noch gemacht?

    • Ich habe alle (und ich meine wirklich alle) Chips auf dem Board außer dem Super-PLA getestet, entweder auf einem anderen Board der gleiche Art (250469 Rev 4) oder im miniPro (4066, 7408, etc.) -> die waren aber alle OK, auf dem anderen Board habe ich die Diagnose mit komplettem Harness durchlaufen lassen
    • Ich habe so gut wie alle Chips aus dem "Patienten"-Board entfernt, so dass nur noch Super-PLA, CPU, VIC II, RAM und ein bisschen Kleinkram auf dem Board war (selbst die 4066 habe ich noch rausgezogen)
    • Dann habe ich das Board mit dem Deadtest laufen lassen, und zwar
      • mit beiden RAM-Chips
      • mit nur einem RAM-Chip
      • komplett ohne RAM
    • Ist gar kein RAM vorhanden, zeigt Deadtest Diskobeleuchtung an:
    • Eigentlich müsste er (wenn ich das richtig verstehe, aber einfach anblinken - so macht er es jedenfalls auf allen anderen Boards, die ich ausprobiert habe
    • Sind 1 oder sogar 2 RAM-Beusteine auf dem Board. zeigt Deadtest eine konstante Farbe an, die sich nicht ändert (statisch). Diese ist interessanterweise bei jedem Start eine andere, ebenso wenn man beim Deadtest auf Reset drückt. Dann geht er - bei jedem Reset) die nächste Farben durch und fängt dann irgendwann wieder von vorne an


    So einen Kandidaten hatte ich auch noch nicht. Noch irgendwelche Ideen, außer dass ich alle Leitungen CPU <-> VIC <-> RAM <-> PLA durchklingele?


    Ach ja, und bevor jemand fragt: Ich habe beim Super-PLA-Sockel zumindest geprüft, ob es zwischen den Pins irgendwelche Kurzschlüsse gibt. Und natürlich gab es einen zwischen Pin 63 und 64. Das war schon ein bisschen doof, weil ich nicht den ganzen Sockel wieder entfernen wollte. Hätte ich mir die Bilder vom Board ohne Sockel vorher richtig angeschaut, wäre mir das wahrscheinlich früher aufgefallen.

    Nachdem ich den Sockel an der Stelle weggekratzt hatte, konnte ich den Kontakt aber unterbrechen ... :wand

  • Also lag es letztlich doch an der PLA... A12 (pin63) dauerhaft auf 5V ist eben nicht so pralle ;-)

    Da das mein erster Super-PLA-Auslötversuch war, kann ich nicht garantieren, dass die Lötbrücke nicht durch das Auslöten passiert ist. Der Rechner geht ja leider immer noch nicht.

    ne PCB NO.252311 Rev. 4 hätte ich noch hier

    Das ist nett, danke, aber ich möchte das Board ja reparieren. Tatsächlich hätte ich sogar noch selbst noch Rev4-Boards hier ... ^^

  • Der Rechner geht ja leider immer noch nicht.

    Achso... hab mich schon gewundert... weil A12 macht eigentlich keine so lustigen Streifen. Das ist eigentlich ein ziemlich sicheres Zeichen für eine defekte PLA.... jedenfalls bei nicht 469er Platinen

  • Das ist schon etwas knifflig! Heute habe ich mir noch einmal zwei Stunden genommen und mit dem immer noch defekten 250469er Board gespielt, aber es hat alles nichts gebracht.

    • Ich habe alle Chips aus dem Board genommen und in einem anderen C64 getestet (selbe ASSY und Rev), alles funktioniert wie es soll (Diag inkl. Harness)
    • Diverse Leitungen geprüft (messen am Chip-Beinchen, d.h. inkl. der Sockel), z.B. von den RAMs
    • Immer noch kein RDY- und IRQ-Signal (sind immer h), obwohl alle Leitungen vom/zum CIA1 da sind

    Interessant ist, dass Dead Test in der Kinzi v5 mit einem farbigen Bildschirm startet und nicht weitermacht. Die Farbe startet nach längerem Ausschalten immer bei grün und wechselt dann mehr oder weniger zufällig beim Reset oder Aus- und Einschalten (weiß -> hellblau -> rot -> braun -> orange -> gelb -> blau -> türkis -> weiß -> schwarz ...).


    kinzi: Eigentlich müsste da doch schon einiges laufen, damit der C64 diese bunten Hintergründe darstellt, oder? Kannst Du mir sagen, was das Dead Test bewegen kann, nach einem Bildschirm-Farbwechsel aufzuhören? Und dann auch noch bei jedem Reset mit einer anderen Farbe zu starten?

    ich hab grad auch so ein 469er Board hier welches quatsch macht und ich noch nicht dahintergekommen bin was da Sache ist

    ADAC: Du bist nicht zufällig mit Deinem 250469er weitergekommen? Falls doch, würde mich mal interessieren, woran es gelegen hat …


    Mittlerweile bin ich offen für alle möglichen Vorschläge, weil mir echt die Ideen ausgehen, was ich noch messen/prüfen könnte. :gahh:

  • ADAC: Du bist nicht zufällig mit Deinem 250469er weitergekommen? Falls doch, würde mich mal interessieren, woran es gelegen hat …

    Ne, das liegt im Moment im Regal. Aber ausser der PLA (wäre die erste defekte) oder ner defekten Leiterbahn kanns eigentlich nichts mehr sein...

    • Ist gar kein RAM vorhanden, zeigt Deadtest Diskobeleuchtung an:

    Von oben nach unten guckend, beginnend ca. ab der Box mit "Source Scart" scheint ein Muster erkennbar: Die Farbe wird heruntergezählt. Sieht man ganz gut, wenn man bei der weissen und schwarzen Linie beginnt und weiter runter guckt.


    kinzi: Gibt es im Deadtest-Code eine Stelle, welche ein dec $D020 im Loop hat?


    Edith sagt: Im source vom Deadtest Kinzi04 finden sich zwei Stellen mit einem dec $D020: einmal gaaaanz am Anfang beim reset handler und einmal beim initialen RAM-Test.

    Das Fehlen vom RDY- und IRQ-Signal _könnte_ dafür sorgen, dass bereits an "Fundstelle" 1, also am reset handler, es nicht weitergeht.

    Daher einmal alles prüfen, was beim Reset eine Rolle spielt.

  • und wieder einmal möchte ich die Gelegenheit nutzen, etwas dazuzulernen. Diesmal geht es um ein C64C-Board mit einem Black Screen. Aber zuerst:

    da ich nun, nach vielen jahren, endlich platz habe zum basteln und reparieren.

    könntest du dir nächsten monat das 9 euro monatsticket holen und mich besuchen.


    übernachten kannst du auch bei uns.


    und da ich sehr lange schlafe, kannst du morgens, wenn du möchtest die gegend hier besichtigen.

    köln, bonn, aachen usw. ist es wert.

    oder andere forumsmitglieder oder treffen von hier aus besuchen.


    dann könnten wir zusammen uns abends deinem rechner widmen.


    gruß

    helmut

  • Immer noch kein RDY- und IRQ-Signal (sind immer h), obwohl alle Leitungen vom/zum CIA1 da sind

    /RDY kommt nur, wenn der VIC initialisiert wurde und Badlines macht. Kann also nicht kommen und ist korrekt.

    /IRQ kommt nur, wenn CIA1 initialisiert wurde und IRQs auslöst. Kann also ebenfalls nicht kommen und ist auch korrekt.

    Interessant ist, dass Dead Test in der Kinzi v5 mit einem farbigen Bildschirm startet und nicht weitermacht. Die Farbe startet nach längerem Ausschalten immer bei grün und wechselt dann mehr oder weniger zufällig beim Reset oder Aus- und Einschalten (weiß -> hellblau -> rot -> braun -> orange -> gelb -> blau -> türkis -> weiß -> schwarz ...).


    kinzi: Eigentlich müsste da doch schon einiges laufen, damit der C64 diese bunten Hintergründe darstellt, oder? Kannst Du mir sagen, was das Dead Test bewegen kann, nach einem Bildschirm-Farbwechsel aufzuhören? Und dann auch noch bei jedem Reset mit einer anderen Farbe zu starten?

    Der "Initial RAM Test" testet 22 verschiedene Bitmuster durch. Bei jedem neuen Bitmuster wird die Rahmenfarbe um eines reduziert. Das würde also bedeuten, dass die CPU stehenbleibt, und zwar recht zufällig immer an einer anderen Stelle bzw. zu einem anderen Zeitpunkt.


    Da die ICs überprüft wurden, würde ich auf kalte Lötstelle oder ein Bauteil tippen, das bei Erwärmung ausfällt.


    Wie ist eigentlich der Zustand der /RESET-Leitung, wenn der Fehler auftritt? Wie ist AEC?

    kinzi: Gibt es im Deadtest-Code eine Stelle, welche ein dec $D020 im Loop hat?

    Ja, bei manchen Fehlern (z. B. Color RAM), bleibt (auch) der originale Dead Test stehen in einem Endlos-Loop. Damit man das erkennt, habe ich bei bei meinem in diesen Endlos-Loop ein DEC D020 eingebaut.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.