Hello, Guest the thread was called37k times and contains 935 replays

last post from MiCv2 at the

WiC64

  • Da muss ich mal ganz dämlich fragen:

    Also den Benutzernamen / Passwort hier aus dem Forum oder habe ich auf der WIC64 Seite Etwas verpasst?

    Um mal mögliche Mißverständnisse auszuräumen:


    Beim Benutzen des WIC64 muss man sich beim ersten Einrichten mit einem Benutzernamen und Passwort registrieren. Der Benutzername kann der gleiche sein, wie hier im F64, das ergibt sogar einen gewissen Sinn. Das Passwort sollte aber anders sein.


    Im Chat kann man dann einige Namen aus dem F64 wiederfinden, was ich ganz praktisch finde.

  • Bitte mal ein Firmware Update auf die Version vom 11.11.2021 machen - Das mit dem 0.0.0.0 stehen bleiben sollte dann behoben sein ! Habe da die Routinen geupdated das die Info's immer aktuell sind.

    Verbesserungsvorschlag: Wäre es möglich beim Start des Launchers zu prüfen, ob es eine aktuellere Firmware gibt und falls ja, den Border einmal aufblitzen lassen?

  • Das ist das Netzteil welches beim Ultimate Board dabei war 12V/1.5A

  • Also war ich doch dämlich ...

    Also irgendein Benutzername und ein unbenutztes Passwort ...


    Hintergrund:

    Ich wollte dem Beta Jan so ein Ding zukommen lassen und und vielleicht dem Adrian.

    Wäre dann blöd gewesen, wenn man das ohne F64 Account nicht nutzen könnte.


    Es sei denn, jemand von den Entwicklern hat Was dagegen.

    Dann mach ich Das nicht.

    Seit Juli 2019 wieder mit dem Commodore Virus infiziert.

    Aktuell: C64 Reloaded MK2, C64C, C64 Brotkasten Original, C64 Brotkasten in blassgrau, Amiga 500, Amiga 600, Amiga 2000 (Octagon 2008), Amiga 2000 mit PC-XT, VIC20, Commodore 16 mit 64KB Umbau nach ComputeMit Zeitschrift..

  • Bitte mal ein Firmware Update auf die Version vom 11.11.2021 machen - Das mit dem 0.0.0.0 stehen bleiben sollte dann behoben sein ! Habe da die Routinen geupdated das die Info's immer aktuell sind.

    Verbesserungsvorschlag: Wäre es möglich beim Start des Launchers zu prüfen, ob es eine aktuellere Firmware gibt und falls ja, den Border einmal aufblitzen lassen?

    Ist in Arbeit. 😊 Die Funktion dafür befindet sich bereits in der neuesten Firmware. Muss nur noch ins Portal mit eingebaut werden.


    Das Forum64 und das WiC (Portal) haben, technisch gesehen, nichts miteinander zu tun. Zur Registrierung kannst Du irgendein x-beliebigen Benutzernamen und Passwort wählen. Aber wie oben schon erwähnt macht es durchaus Sinn, zumindest den Benutzernamen gleich dem des F64 zu wählen, damit man Dich auch in der WiC-Welt erkennt.


    VG

    Thomas

  • Da es für eine kleine Diskussion gesorgt hat, möchte ich mich auch noch mal hierzu kurz zu Wort melden.


    Mag ja sein, aber hinterher sagen, das hab ich vorher schon gewusst, finde ich nicht so cool. Dann lieber gleich sagen.

    Ihr werdet mich jetzt alle doof finden, wenn ich das schreibe. Als daimansion in Posting #383 (ja, das war vor einem Monat :/) den Fehler beschrieb, hatte ich den Gedanken, dass da vielleicht ein altes Kernal in dem "zickigen" C64 steckt.


    Warum habe ich das dann nicht gleich geschrieben? Neben persönlichen Umständen, deretwegen ich momentan sowieso nicht besonders aktiv hier bin, habe ich dummerweise auch noch einfach angenommen, dass so ein simples Problem jemandem von den Beteiligten bekannt ist und längst ausgeschlossen werden konnte. Tut mir leid, das hätte Ärger und Zeit für manche sparen können. Dafür nehme ich das hier mal zum Anlass mir wieder einmal mehr bewusst zu machen, nicht zu schnell etwas als gegeben anzunehmen und mich lieber einmal mehr konstruktiv zu Wort zu melden, selbst wenn das letztlich nicht weiterhelfen sollte.

  • Aber jetzt mal ne dumme Frage, kann ich den Fehler durch Änderungen am Chat denn ausmerzen?

    Gibt ja ggf. noch mehr C64 auf der Welt mit der Konstellation?!?

    Mac Bacon hatte dazu was geschrieben:

    Falls es daran liegen sollte, ginge als Fix im Chatprogramm:

    1. Sowohl Hintergrund als auch Text auf die gewünschte Textfarbe einstellen.

    2. Bildschirm löschen (Kernal 2 füllt mit Hintergrundfarbe, Kernal 3 füllt mit Textfarbe, also dann identisch).

    3. gewünschte Hintergrundfarbe einstellen.

  • Aber jetzt mal ne dumme Frage, kann ich den Fehler durch Änderungen am Chat denn ausmerzen?

    Gibt ja ggf. noch mehr C64 auf der Welt mit der Konstellation?!?

    Der Unterschied, der in diesem Fall zum Tragen kommt, liegt darin begründet, wie der Bildschirm gelöscht wird. Beim Kernal in der Revision 2 (Revision 1 gibt es in europäischen C64 nicht) wird zum Löschen des Screens als Farbe für das komplette Colorram der Wert aus 53281 ($D021) geholt. Damit ist die Farbe für den Hintergrund und alle Zeichen im Screen identisch und dann sieht man halt nichts. Das Kernal in Revision 3 holt dagegen die aktuelle Zeichenfarbe (findet sich an Adresse 646 = $0286), um das Colorram zu setzen.


    Als Workaround für beide Kernalrevisionen kann vor dem Löschen des Bildschirms der Wert aus 646 nach 53281 geschrieben werden, dann Screen löschen, anschließend wieder den ursprünglichen Wert von 53281 herstellen. Oder noch einfacher, wie GoDot oder Mac Bacon schon schrieb: beim ausgeben von Strings diese immer mit Zeichenfarbe ausgeben.


    Welche Kernalrevision ein C64 mit originalem Kernal hat, lässt sich an Adresse 65408 ($FF80) herausfinden. Also einfach mit print peek (65408).


    Edit: CapFuture1975 war schneller.

  • Danke für die Infos, ich glaube hier müsste YPS dann unterstützen, weil die softscroll rounine von ihm ist. Die nimmt glaube ich die Farbeinstellung nicht mit. Deshalb auch erst der Effekt nach dem Scrollen. Der Anfangsbildschirm ist ja zu sehen. Und sobald der Chatraum betreten wird, wird ja gescollt. Das sollten wir in den Griff bekommen. Sind ja schon WIC in verschiedene Läder exportiert worden, da sollte das schon bei allen klappen.

  • Moin, kurze Rückmeldung meiner Tests mit verschiedenen Netzteilen.

    Ich habe jetzt drei verschiendene ausprobiert.

    12V/1.5 / 3A / 12,5A

    Bei allen Netzteilen kommt es bei mir manchmal vor das das WiC64 nach dem einschalten nicht zur Verfügung steht.

    Ich konnte es allerdings nicht gezielt reproduzieren.

  • Danke für die Infos, ich glaube hier müsste YPS dann unterstützen, weil die softscroll rounine von ihm ist. Die nimmt glaube ich die Farbeinstellung nicht mit. Deshalb auch erst der Effekt nach dem Scrollen. Der Anfangsbildschirm ist ja zu sehen. Und sobald der Chatraum betreten wird, wird ja gescollt. Das sollten wir in den Griff bekommen. Sind ja schon WIC in verschiedene Läder exportiert worden, da sollte das schon bei allen klappen.

    Um Missverständnissen vorzubeugen: auf dem Anfangsbildschirm sieht man zuerst alle derzeitig angemeldeten Mitglieder. Das funktioniert auch noch mit beliebigem Kernal. Aber sobald man den Chat startet, (z. B. mit der Leertaste wie es auf dem Bildschirm steht, es geht aber eine beliebige Taste) ist der Bildschirm leer, d. h. schwarz. Das hat mit dem Softscrolling noch nichts zu tun, soweit ich sehe.

    Welche Kernalrevision ein C64 mit originalem Kernal hat, lässt sich an Adresse 65408 ($FF80) herausfinden. Also einfach mit print peek (65408).

    Das funktioniert mitunter nicht zuverlässg, wenn jemand einen alternativen Kernal aus unbekannten Quellen hat. Ich würde mich darauf nicht (oder zumindest nicht alleine) verlassen.

  • Moin, kurze Rückmeldung meiner Tests mit verschiedenen Netzteilen.

    Ich habe jetzt drei verschiendene ausprobiert.

    12V/1.5 / 3A / 12,5A

    Bei allen Netzteilen kommt es bei mir manchmal vor das das WiC64 nach dem einschalten nicht zur Verfügung steht.

    Ich konnte es allerdings nicht gezielt reproduzieren.

    Vom Gefühl her verhält sich das folgendermassen.

    Beim ersten einschalten des Ultimate64 kommt das WiC64 auch immer mit (Dabei schliesse ich das Netzteil vor dem einschalten erst mal an)

    Erst wenn man das Ultimate64 über den Taster wieder aus und dann wieder einschaltet passiert es relativ regelmässig das das WiC64 dann stumm bleibt.

  • Ich habe kein Ultimate64, aber was heißt "WiC64 bleibt stumm". Geht das Display gar nicht an, leuchten die LED's nicht? :/

    "Was heute noch wie ein Märchen klingt,kann morgen Wirklichkeit sein.Hier ist ein Märchen von übermorgen.Es gibt keine Kupferka­bel mehr,es gibt nur noch die Glasfaser und Terminals in jedem Raum.Man siedelt auf fernen Rech­nern.Die Mailboxen sind als Wohnraum erschlossen.Mit heute noch unvorstellbaren Geschwindigkeiten durcheilen Computerclubs unser Da­tenverbundsystem.Einer dieser Com­puterclubsist der CCC.Gigantischer Teil eines winzigen Sicher­heitssystems,das die Erde vor Bedrohungendurchden Gilb schützt.Begleiten wir den CCC und seine Mitglieder bei ihrem Patrouillendienst am Rande der Unkenntlich­keit. CCC'84 nach ORION'64"

  • Die Firmware ist aktuell 11.11

    Mit "Stumm" meine ich das auf dem ESP nur die rote LED leuchtet, das Display ist dunkel und auf dem Board leuchten nur die rote und gelbe LED.

  • Die Firmware ist aktuell 11.11

    Mit "Stumm" meine ich das auf dem ESP nur die rote LED leuchtet, das Display ist dunkel und auf dem Board leuchten nur die rote und gelbe LED.

    Dass teilweise nur die rote und gelbe LED leuchten war mir auch schon aufgefallen. Da sonst aber alles lief (das mit dem dunklen Display kenne ich nicht), hab ich dem nicht viel Bedeutung beigemessen.

  • Wegen der LEDs gab es ja ein Update:

    WiC64: Neue Firmware 29.10.2021

    Im Chat wurde der Wunsch geäußert die LED auf dem ESP32 zu deaktivieren.

    Wenn man die Special Taste 5 Sekunden fest hält wird die LED Funktionalität deaktiviert (Blaue LED auf dem ESP32 und grüne auf dem WiC64 Board).

    Nochmal 5 Sekunden fest halten aktiviert die Funktion wieder. Der Zustand wird Reset-Fest im ESP32 gespeichert.

  • Die Firmware ist aktuell 11.11

    Mit "Stumm" meine ich das auf dem ESP nur die rote LED leuchtet, das Display ist dunkel und auf dem Board leuchten nur die rote und gelbe LED.

    rot hat bei mit noch nie geleuchtet :/

    "Was heute noch wie ein Märchen klingt,kann morgen Wirklichkeit sein.Hier ist ein Märchen von übermorgen.Es gibt keine Kupferka­bel mehr,es gibt nur noch die Glasfaser und Terminals in jedem Raum.Man siedelt auf fernen Rech­nern.Die Mailboxen sind als Wohnraum erschlossen.Mit heute noch unvorstellbaren Geschwindigkeiten durcheilen Computerclubs unser Da­tenverbundsystem.Einer dieser Com­puterclubsist der CCC.Gigantischer Teil eines winzigen Sicher­heitssystems,das die Erde vor Bedrohungendurchden Gilb schützt.Begleiten wir den CCC und seine Mitglieder bei ihrem Patrouillendienst am Rande der Unkenntlich­keit. CCC'84 nach ORION'64"