Hello, Guest the thread was called471 times and contains 19 replays

last post from ADAC at the

C64 zeigt nur wechselnde Farben

  • Hallo zusammen,


    ich habe vor Kurzem einen ziemlich alten C64 (Assy 250407) als Beifang bekommen und das gute Stück mag nicht so ganz. Am Anfang war es so, daß wenn man ihn eingeschaltet hat, die LED geleuchtet hat und das Bild schwarz war und er deutlich hörbar über den Lautsprecher gesummt hat. Wenn man ein Modul einsteckte, machte er je nach Modul dasselbe oder fing an, wild Farben durcheinander zu blinken.

    Mittlerweile ist es so, daß er mit den Farben auch ohne Modul zu flackern anfängt und nach 5-10 Minuten auf schwarz umspringt, immer mit dem Summton. Mit zunehmender Laufzeit, wird der Ton lauter, schwankt dann kurz und bleibt deutlich lauter als vorher. Schaltet man ihn dann kurz aus und wieder an, fängt er wieder mit dem Flackern an, der Ton bleibt aber laut. Nach weiteren 5 Minuten springt er wieder auf schwarz. Der U19 (VIC-II) wird auch recht heiß (nach 10-15 Minuten kann man den Finger nicht mehr lange drauf lassen), scheint es aber nach einem Tausch nicht zu sein. Den anderen VIC-II hatte ich vor Urzeiten mal aus einem defekten C64 ausgebaut, daher kann ich nicht mit 100%iger Sicherheit sagen, daß er noch ok ist.

    Die Stromversorgung ist ok (11.78 bei 12v, 4.98 bei 5V, gemessen nach der Anleitung hier im Forum). Allerdings habe ich eben nochmal eine definitiv funktionierende 1541-II drangehängt und die hört nicht auf zu Laufen, wenn sie am C64 angesteckt ist und beide an sind. Floppy alleine läuft beim Einschalten wie erwartet kurz an und geht wieder aus.
    Es ist wohl (aufgrund des Produktionsdatums) mal irgendwann ein neuer SID reingekommen. Der Rest sieht mir original aus.


    So, das war das Verhalten mit dem mitgelieferten Netzteil. Dies funktioniert mit einem anderen, sicher funktionierenden C64, auch nicht (schwarz/weiß Flackern) und brummt. Also wohl ne Macke am Netzteil. Nun habe ich ein anderes Netzteil genommen (von besagtem funktionierenden C64). Hier brummt es nicht, das Bild bleibt aber mit dem originalen VIC schwarz, mit dem Ersatz gelb. Einstecken vom Modul Super Games bringt ein türkisfarbenes Bild, Final Cartridge III zeigt wiederum schwarz. Die 1541 geht nach dem Selbsttest aus, wie es sein sollte, reagiert aber nicht auf Steuerbefehle.


    Mit Multimeter kann ich umgehen (s.o.), gelötet habe ich mal einen neuen Microschalter in eine Nachbau-Amigamaus und war verwundert, daß sie danach funktionierte :D Ich hätte allerdings einen Kollegen, der sich sowas ggf zutrauen würde.


    Hat jemand einen Tip für mich, was das sein könnte und wie ich das am einfachsten prüfen kann ?


    Viele Grüße

    Bossi

  • Allerdings habe ich eben nochmal eine definitiv funktionierende 1541-II drangehängt und die hört nicht auf zu Laufen, wenn sie am C64 angesteckt ist und beide an sind. Floppy alleine läuft beim Einschalten wie erwartet kurz an und geht wieder aus.

    Dann hängt /RESET - nachmessen. (Mit dem anderen Netzteil offenbar nicht?)

    Es ist wohl (aufgrund des Produktionsdatums) mal irgendwann ein neuer SID reingekommen. Der Rest sieht mir original aus.

    Erst mal alles raus, was gesockelt ist und nicht CPU, VIC, PLA, RAM heißt.


    Was hast du für Module - Spiele? Dead Test?

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Quote

    Dann hängt /RESET - nachmessen. (Mit dem anderen Netzteil offenbar nicht?)

    Richtig, mit dem anderen hängt sie nicht. Dachte, ich lasse die Info mal drin, weil das Verhalten für mich merkwürdig ist.


    Erst mal alles raus, was gesockelt ist und nicht CPU, VIC, PLA, RAM heißt.

    Da blieb dann leider nur besagter SID übrig. Hat leider nicht wirklich was am Verhalten geändert :(


    Was hast du für Module - Spiele? Dead Test?

    Nur Spiele, zwei FC III und im Keller müßte noch ein Nordic Power liegen. Bei meinen Eltern hab ich glaub vor einiger Zeit noch ein Hardcopymodul gesehen, denke aber nicht, daß das relevant wäre ;)


    Bossi

  • Welche Spiele?

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Ganz wichtig:

    Noch vorm Öffnen des C64 die Elkos tauschen! ;) (Ist ein Insider, ignorier´ das einfach).


    Meine Vorgehensweise wäre:

    Netzteil prüfen/reparieren/verschenken (Du hast ja schon gemerkt, dass damit was nicht stimmt).

    Reset-Schaltung prüfen (allerdings leuchtet mir bei Dauer-Reset nicht ein, warum dann die Farben wechseln).

    Diagnosemodul nutzen oder "auf Verdacht" PLA tauschen.

    Im Forums-Profil einen Wohnort angeben, evtl. wohnt ja jemand in Deiner Nähe,

    der ein Diagnosemodul/Ersatzteile/Messgeräte hat. ;)

    Oder auf Kinzi warten, der hat telepathische Fähigkeiten, was das Reparieren von C64 angeht. :)

  • Wizard of Wor müsste ein Ultimax-Modul sein, das müsste ohne die ROMs laufen. Kannst du das mal stecken?

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Oder auf Kinzi warten, der hat telepathische Fähigkeiten, was das Reparieren von C64 angeht.

    Danke für die Blumen.

    Ich dachte in meiner Eingebildetheit bisher immer, es läge am logischen Denken. :-D So kann man sich täuschen!

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Wizard of Wor müsste ein Ultimax-Modul sein, das müsste ohne die ROMs laufen. Kannst du das mal stecken?

    Ich hab alle schon probiert, da ich das Ohne-ROM-Laufen hier schon gelesen hatte ;) Kein Erfolg.



    Im Forums-Profil einen Wohnort angeben

    Hmm, das hat was für sich, wird gleich erledigt :thumbsup: Bei Kinzi bin ich vor knapp 2 Monaten durchs Dorf gefahren (wenn der Wohnort noch stimmt ;))

  • Bei Kinzi bin ich vor knapp 2 Monaten durchs Dorf gefahren (wenn der Wohnort noch stimmt ;) )

    Bei mir stimmt nur die Gegend, falls du auf den Karteneintrag anspielst. :-D

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Wenn man ein Modul einsteckte, machte er je nach Modul dasselbe oder fing an, wild Farben durcheinander zu blinken.

    Mit welchem Modul?

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Bei Kinzi bin ich vor knapp 2 Monaten durchs Dorf gefahren (wenn der Wohnort noch stimmt ;) )

    Bei mir stimmt nur die Gegend, falls du auf den Karteneintrag anspielst. :-D

    Ja, das habe ich. Die B193 bin ich gefahren auf dem Weg zur Silvretta.



    Mit welchem Modul?

    Wizard Of Wor zeigt grau, Solar, Soccer und Super Games nur schwarz. Würde für Ultimax bei Wizard sprechen, da es sich anders verhält, als die anderen. Und ich vermute, das farbige Flackern war vorher bei Wizard.

    Flackern tut aber nix mehr, seit ich das Netzteil getauscht habe.

  • Wizard Of Wor zeigt grau, Solar, Soccer und Super Games nur schwarz. Würde für Ultimax bei Wizard sprechen, da es sich anders verhält, als die anderen. Und ich vermute, das farbige Flackern war vorher bei Wizard.

    Flackern tut aber nix mehr, seit ich das Netzteil getauscht habe.

    Da würde ich jetzt mal Hucky zitieren ... "Es ist DIE PLA!!!!"


    Hast du außer dem Multimeter noch andere Messmittel? Sonst bist du hier schon ziemlich am Ende, wenn nichts weiter gesockelt ist.


    Den Reset-Pin der CPU kannst du noch messen mit dem Multimeter - der muss beim Einschalten kurz auf 0 V sein und dann auf ca. +5 V gehen. Zur Sicherheit dann noch manuell einen Reset auslösen (User Port Pin 1 und 3 brücken) und schauen, ob die Kiste dann anläuft.


    Ansonsten kommst du hier nicht wesentlich weiter mit deinen Voraussetzungen, außer du traust dir zu, Bauteile auszulöten, zu sockeln und weiter zu testen. Kann aber ein längeres Abenteuer werden.

    Ja, das habe ich. Die B193 bin ich gefahren auf dem Weg zur Silvretta.

    Der Punkt, den ich als Karteneintrag habe, müsste dem geografischen Mittelpunkt Vorarlbergs entsprechen und stimmt nicht mit meinem Wohnort überein, ich wohne nicht an der L193. ^^ Spielt aber keine große Rolle, Vorarlberg ist so klein, genauere Angaben rentieren fast nicht. :-D

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • "Es ist DIE PLA!!!!"

    Danke, das hatte ich befürchtet ...... gut, gab ja auch eher keine sonstigen gesockelten Chips X( PLAs sind jetzt wenn ich die anderen Threads richtig in Erinnerung habe, nicht so einfach zu bekommen, oder ?

    Nein, keine weiteren Meßgeräte. Hat für meine Autoschrauberei und für die Wohnung immer gereicht :)

    Das FC III hat nen Resetknopf, der brachte keinerlei Reaktionen. Den Resetpin kann ich nochmal messen bzw nen Userportreset machen, gehe aber davon aus, daß es nichts bringt.

    Das AUSlöten ist nicht so das Problem ....... ich hab eher so meine Bedenken mit dem Einlöten. Für kalte Lötstellen bin ich immer zu haben :D Aber probieren würde ich es. Nen passender Lötkolben für Elektronik sollte ja zu bekommen sein.

    Ich würde normalerweise, wenn ich sicher bin, daß das entsprechende Bauteil defekt ist, die Beine abknipsen und einzeln auslöten. Hab ich bei dem o.g. Microschalter auch gemacht. Einen Chip heil auslöten ....... das wird eher nicht gut gehen :thumbdown:


    Spielt aber keine große Rolle, Vorarlberg ist so klein, genauere Angaben rentieren fast nicht. :-D

    Das hab ich gemerkt ....... Bin von Lindau gekommen und war ruck-zuck durch ........ naja, bis auf den Bus, der mich (und andere) auf der Silvretta aufgehalten hat :whistling:

  • Das AUSlöten ist nicht so das Problem ....... ich hab eher so meine Bedenken mit dem Einlöten.

    Normalerweise ist die Problemlage eher umgekehrt ...

    Ich würde normalerweise, wenn ich sicher bin, daß das entsprechende Bauteil defekt ist, die Beine abknipsen und einzeln auslöten.

    Ja, das ist bei Bauteilen zu Centbeträgen sinnvoll, auch wenn man sich nicht sicher ist.

    PLAs - vor allem in Nachbau-Version - sind einfach zu bekommen. Trotzdem wäre es schade um das Bauteil, wenn es nicht die Ursache ist.


    Es stellt sich immer die Frage, was jedenfalls heil bleiben muss - das Bauteil oder die Platine?

    Bin von Lindau gekommen und war ruck-zuck durch

    Und da bist du trotzdem über die L193 gefahren? Wolltest wohl alles von Vorarlberg sehen, was? :-D Bregenzerwald, Faschina, großes Walsertal, Montafon und Silvretta in einem Zug, und Zurückfahren über Tirol, Arlberg und Rheintal? Dann hast du wirklich ein umfassendes Bild bekommen. (Vorarlberg ist übrigens 32 km² größer als das Saarland. :-P )


    Ach, kombiniere, du hast eine Motorrad-Tour gemacht, da ist diese Route nicht schlecht, stimmt. Hast du die Furka auch noch mitgenommen?

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Es stellt sich immer die Frage, was jedenfalls heil bleiben muss - das Bauteil oder die Platine?

    Es wäre halt echt schade, wenn die PLA nicht kaputt wäre. Nen Sockel kommt logischerweise eh rein, wenn ich löten muß. Dann könnte ich die 'richtige' halt weiterverwenden, wenn sie doch nicht kaputt wäre. Ich hab eben nur Bedenken, daß ich sie beim Auslöten zerschieße. Dann könnte ich sie auch gleich abzwicken ;) Kann man das testweise im Huckepack machen ? Ich kann mich duster dran erinnern, daß ich das vor Jahrzenten mal mit einem defekten Chip getestet habe. Kaputter 64er, defekten Chip bei nem heilen 64er ausgelesen, auf EPROM gebrannt und dann Huckepack drauf und geht. Einlöten hab ich das dann wen anders machen lassen :D Und nein, die 64er sind schon lange nicht mehr in meinem Besitz.

    Frage ist, wo es die PLAs gibt und ob es noch die 'echten' sind oder die, die man mittels Adapterplatine bzw Pinswapping anpassen muß.



    Ach, kombiniere, du hast eine Motorrad-Tour gemacht, da ist diese Route nicht schlecht, stimmt. Hast du die Furka auch noch mitgenommen?

    Nee, ich war tatsächlich mit dem Auto da. Furka passte leider nicht, da ich Richtung Osten gefahren bis. Walsertal hat leider nicht gereicht, weil ich nur einen Tag in Ö hatte. Mittwoch war das Wetter schon ok, da bin ich durch den Schwarzwald bis Lindau gefahren und Donnerstag war grandios. Freitag war es dann auch wieder vorbei (was ne Überraschung bei dem Sommer). Ich bin dann bis Jenbach das Inntal gefahren, mit kleinen Abstechern in die Berge, wo es paßte. Dann nach Norden Richtung D, dort in Richtung GAP abgebogen, um die Zugspitze rum (die sich unverschämterweise in einer Wolke versteckt hatte !) und dann bei Füssen auf die deutsche Autobahn und nach Hause.

    Hatte eigentlich geplant, das Timmelsjoch und den Brenner noch mitzunehmen und dann von Innsbruck direkt nach D zurückzufahren, aber Italien war mir zu riskant, da ich keine Ahnung hatte, ob und welche Wartezeiten es da gibt. OK, später von einer Kollegin gehört, daß es vermutlich kein Problem gegeben hätte. Na gut, nächstes Jahr hoffentlich. Und dann mit einer übernachtung in Ö. Das ist zu viel sonst ;)

    Vorarlberg ist übrigens 32 km² größer als das Saarland

    Und der ist auch deutlich schöner, als das Saarland ........ Ich hoffe, es liest kein Saarländer mit :pumpkin:

  • Kann man das testweise im Huckepack machen ?

    Beim PLA wohl nicht. Dessen Ausgänge sind immer eine Funktion der Eingänge, einen Zustand "wo nix rauskommt" gibt es da nicht. Also würden die zwei ICs zwangsläufig gegeneinander arbeiten.

    Ich kann mich duster dran erinnern, daß ich das vor Jahrzenten mal mit einem defekten Chip getestet habe. Kaputter 64er, defekten Chip bei nem heilen 64er ausgelesen, auf EPROM gebrannt und dann Huckepack drauf und geht. Einlöten hab ich das dann wen anders machen lassen

    Das war dann aber schon fast ein Lottosechser.

    Damit das klappt, muss das eingelötete Bauteil derart kaputt sein, dass es praktisch "nicht vorhanden" ist. Es müsste also z. B. die Chip-Select-Logik defekt sein, sodass sich das Bauteil nicht angesprochen fühlt.

    Frage ist, wo es die PLAs gibt und ob es noch die 'echten' sind oder die, die man mittels Adapterplatine bzw Pinswapping anpassen muß.

    Nein, kein Pinswapping, die Nachbauten sind Drop-in-Ersatzlösungen.

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Dann stellt sich nur noch die Frage, wo ich die bekommen kann.

    Stelle ein Gesuch hier in den Marktplatz, oder schau, ob nicht sogar welche angeboten werden.

    Gibt immer wieder Leute hier, die welche aufbauen und anbieten.

    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.


    Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.


    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.

  • Dann stellt sich nur noch die Frage, wo ich die bekommen kann. Irgendeinen Tip ?

    Ich hab noch ein paar GAL-PLAs da liegen, fertig aufgebaut (also nur reinstecken und fertig). Sind m.w. 100% kompatibel mit der original PLA.

    Verschicken könnte ich ab Donnerstag.


    Bei Interesse -> PN


    Gruß, Gerd