Hello, Guest the thread was called4.4k times and contains 158 replays

last post from feltel at the

1571-Dauerläufer

  • Dann hab ich meine 3. 1571 geöffnet (die ich vorher getestet habe) und da mal an PIN 13 vom 74LS14 (U15) gemessen da hab ich 512Khz und an Pin 12 1MHz

    Mit Masseverbindung?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • OK, dann zählt der Zähler da Mist.

    Die genaue Frequenz ist auch nicht so wichtig.


    Kannst du nochmals schnell zusammenfassen, was du schon alles ausgeschlossen hast?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Ehrlich gesagt, ich glaub hier nicht an einen "Komponentenschaden" sondern eher an Schäden an der Platine selber!


    Die Bilder in Thread #100 sehen schlimm aus! Die Verbindungen wurden hoffentlich von einer zur anderen Komponente gemessen und nicht nur die Leitungen selbst.


    Die Bilder lassen mich vermuten, dass auf der Platine eine Menge "Via-Schäden" sind!

  • kinzi also getauscht und neu alle 74er, CPU + VIAs neu + geprüft, RAM neu, ROM neu gebrannt, kleines Array neu, großes Array 42pin gegen 40 pin Array (neu getauscht), Hybrid IC auch neu.

    Alle Q Transistoren geprüft, den T520 (U21) entfernt. alle ICs haben Ihre Versorgungsspannung, 5V und 12V sind stabil

    Die Eingangsschaltung um U15 (74LS14, 7406,74266,7407) Verbindungen nach Schaltplan, verfolgt und geprüft (durchgemessen)

    Was mir noch eingfallen ist das große Array das passt doch auch in die 1541-II oder ? Wenn ja könnte ich das da mal testen.


    Capstan so schlimm ist es nicht, die paar Kontakte, Funktion ist ja gegeben, und ich kann beim entlöten nicht so lange, mit hoher Temperatur am Bauteil bleiben. dieses verdammte Lötzin, wollte einfach nicht flüssig werden

    Die Platine hat auch keine gute Qualität. Bei den anderen IC's sind keine Schäden, man prüft das natürlich vorher bevor der Sockel rein kommt, so mache ich das jedenfalls

  • dieses verdammte Lötzin, wollte einfach nicht flüssig werden

    Deshalb verzinnt man die Kontakte eines auszulötenden Bauteils "neu", dann klappt es auch mit dem Schmelzen des Lötzinns. ;)



    man prüft das natürlich vorher bevor der Sockel rein kommt, so mache ich das jedenfalls

    Man prüft das auch nachher! Insbesondere, wenn das Gerät nicht funktioniert!

    Via's brechen nicht nur im Querschnitt durch die Platine sondern auch gerne direkt an der "Öse" zur Leitung: O|---------

  • Capstan ich habe es geprüft auch nachher , gehört sich so muss nicht extra erwähnt werden.

    Selbstverständlich habe ich passendes Lötzin hinzugefügt, muss ich ja nun nicht auch noch extra erwähnen, es war halt hartnäckig das kann man doch mal sagen.

    Und ich habe langjährige Löterfahrung um dies zu wissen und auch umzusetzen.

  • Selbstverständlich habe ich passendes Lötzin hinzugefügt, muss ich ja nun nicht auch noch extra erwähnen, es war halt hartnäckig das kann man doch mal sagen.

    Und ich habe langjährige Löterfahrung um dies zu wissen und auch umzusetzen.

    Alles gut - niemand bestreitet deine Fähigkeiten. Aus der Ferne ist das alles auch schwierig, und wie gesagt, alles Hinweise oder Tipps aus "jahrelanger Erfahrung", was alles sein kann.


    Also, ich fasse zusammen:

    • Spannungen OK.
    • Reset OK.
    • Takt OK.
    • Aktivität an den /CS von ROM und RAM.
    • Bauteile alle OK.

    Es kann ja dann nur an etwas liegen, das die richtige Adressierung und/oder Datenübertragung stört. Also wird nicht viel anderes über bleiben als:

    • Alle Adressleitungen gegeneinander "ausklingeln" -> prüfen auf Kurzschluss.
    • Alle Datenleitungen gegeneinander "ausklingeln" -> prüfen auf Kurzschluss.
    • Alle Adressleitungen (insbesondere die "niedrigen") von der CPU zu jedem Bauteil durchklingeln.
    • Alle Datenleitungen von der CPU zu jedem Bauteil durchklingeln.
    • R/W von der CPU zu jedem Bauteil durchklingeln.
    • Takt an den VIAs überprüfen.
    • Reset von der CPU zu allen Bauteilen (die dranhängen, WIMRE VIAs und evtl. WD177x) durchklingeln.
    • Pull-Ups laut Schaltplan überprüfen.
    • An der CPU prüfen, ob die Pins, die laut Schaltplan nicht benutzt werden (z. B. RDY) auch auf dem Pegel liegen, auf dem "sie sollen".

    Schaltplan: https://www.forum64.de/gallery…ages/ba/3576-ba018066.gif

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Gerade mal versucht - die 1571 kommt auch ohne WD177x und ohne U9 (6522) aus dem Reset - probier das mal.


    Ansonsten - Triviallösung: Sicher, dass Q7 die LED richtig schaltet?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • die grüne LED geht beim Start kurz an und dann aus

    Das ist gut. Der Rechner läuft also schon mal wieder. Jetzt stehen die Chancen gut, dass die Kiste auch wieder läuft, also: einbauen und testen :pumpkin:


    So ich hab einen Fehler gefunden und behoben

    Was war es denn?

  • Ich habe das Laufwerk noch nicht zusammengebaut, und konnte es noch nicht testen.

    Nachdem ich Q7 geprüft hatte (alles ok), habe ich bei der CPU angefangen von Pin1 - 40 der Reihe nach, alle Wege auf Durchgang zu messen, und auf Papier (alle IC Belegungs PINs ausgedruckt) abgehakt.

    Bis ich an PIN 31 ankam der hatte eine Verbindung mit PIN 27, und da die beiden Traces auch an U$ und U9 gehen, war da natürlich auch eine Verbindung.

    Also Sockel von U9 (6522) (Zufall) entfernt und wie im Bild zu sehen war der Trace zwischen Pin 27 und 28 bzw. der Trace hatte Verbindung mit Pin 27 (D6), und dieser Trace war die Verbindung mit Pin 31 (D2).

    Ja den Fehler habe ich mir selber eingebaut, ich muss aber dazusagen, man hat es mit dem blosen Auge nicht erkennen können, erst unterm USB Mikroskop hat man eine kleine Haardünne Verbindung gesehen, wahrscheinlich von der

    Entlötpistole. Ich komme aber zum Schluss das es dieser fehler nicht sein kann, denn U9 war der 2. 40er IC nach der CPU den ich gesockelt hatte, denn als der U9 (VIA) noch drin war, hatte ich auch das Dauerleuchten von den LEDs.

    Also sagt mir das, das da irgendein defekter IC noch sein muss, momentan hab ich ja alle erneuert. Morgen baue ich zusammen, und prüfe.

    Auf dem Bild ist schon die reparierte Stelle.

  • da war viel Lötzin drauf das wollte sich nicht lösen, war mit der Heissluftstation

    Immer etwas frisches Zinn dazugeben oder mit Flussmittel arbeiten, das gröbste dann schon mal absaugen und mit der Fnöte immer in Bewegung bleiben und geduld haben... das löst sich dann schon.

  • Ich komme aber zum Schluss das es dieser fehler nicht sein kann, denn U9 war der 2. 40er IC nach der CPU den ich gesockelt hatte, denn als der U9 (VIA) noch drin war, hatte ich auch das Dauerleuchten von den LEDs.

    Also sagt mir das, das da irgendein defekter IC noch sein muss, momentan hab ich ja alle erneuert.

    Hattest du nach Tausch von U9 denn wieder alle originalen ICs eingebaut?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • ADAC Flussmittel bin ich nicht so ein freund davon, neues Zinn war drauf, ich wollte auch nicht zu lange viel Hitze drauf geben der 6522A ist mir da zu wertvoll, und die Stelle auf der Platine

    sieht schlimmer aus als es ist.


    kinzi zuerst hatte ich alle 74er außer den 74175 der war da noch nicht da, erneuert. Dann die CPU die war es auch nicht und dann U4 den 6522A - Der Rest war noch ungesockelt bis auf die CIA und das ROM. Und die ausgelötete VIA (U9) war ok lief in einer 1541-II.

    also hab ich dann weiter ausgelötet (U4) usw.

  • Gut, wir werden sehen. ^^

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • So sehr gute Nachricht, das Board funktioniert, lesen schreiben formatieren probiert an einem C64, auch am PC unter Zoomfloppy ein beidseitiges Diskimage mehrfach geschrieben, funktioniert auch.

    Obwohl ich mir der Sache vorher nicht sicher war, da die Laufwerksmechanik defekt war, ich habe es im eingebauten Kopfzustand repariert, hier war die Führung in der Laufschiene, das obere Plastik abgebrochen.

    Das war eine Fummelei, hat sich aber gelohnt. Jetzt noch Platine von unten versiegeln & Netzteil revidieren.

    Dann kann ich mich um das 2. Board kümmern.