Hello, Guest the thread was called1.2k times and contains 19 replays

last post from advotax at the

VC20 mit wirrem Charakterset, aber funktionierendem BASIC

  • Hallo,


    ich versuche gerade mit einer guten Freundin ihren VC20 wieder zum Laufen zu bringen.

    Eine richtige VC20 Ecke haben wir ja nicht, deswegen frage ich mal ganz dreist hier?



    Fehlerbild ist:

    - Rahmenfarbe vorhanden, wilde Bildfehler, keine Zeichen erkennbar (siehe Foto)

    - Rechner läuft korrekt (BASIC wird ausgeführt, VIC-1 kann angesprochen werden, LOAD von Datasette klappt)



    Alle gesockelten Chips wurden einmal entfernt und mit Kontaktspray wieder eingesetzt.

    Das Netzteil wurde getauscht und mittlerweile liegen an allen Chips direkt 5.0V an (statt vorher 4.7V).


    Ein Entfernen des Charakter-ROM bringt keine sichtbare Veränderung der Anzeige.


    Habe dann ein kurzes Programm geschrieben, welches an 0x1800 ein neues Charakterset hinlädt und den VIC auf diese Adresse umschaltet. Dieses Programm im Emulator getestet (ROM-Image kaputt gemacht, nach Laden meines Programmes ist die Ausgabe wieder OK).

    Programm dann in ne .wav konvertiert und per Datasette in den Rechner geladen. Programm läuft, Rahmenfarbe blinkt und der Sound quietscht (wie im Programm angegeben), aber der Bildschirminhalt geht von random zu leer über, anstatt dass das Charakterset aus dem RAM angezeigt wird.


    Folgende Chips müssten OK sein:

    - Character-ROM (weil entfernt)

    - CPU (weil Programme laufen)

    - RAM (weil Programme laufen. ... Macht der VIC auch einen Memory-Check beim Boot, wie der 64er?)

    - Kernal und Basic-ROM (weil BASIC korrekt ausgeführt wird)


    Verdächtige für mich:

    - VIC-I (6561)

    - Logik-ICs (z.B. die 74LS245 Bustreiber zwischen VIC und Adress/Datenbus?)


    Vorschläge, wo man jetzt am besten weitersucht?


    Hier nochmal als Stichwörter einige Details:

    - Platinenversion: VC20 (CR), PAL (keine ASSY sichtbar/gefunden?).

    - Gerät ist unmodifiziert.

    - Netzteil ist ein Eigenbau, der Trick mit den 2 Steckernetzteilen.

    - Fehler tritt ohne zusätzliche Hardware ständig auf.

    - Keine Chips werden (ungewöhnlich) heiß. Der Rechner nimmt 930mA auf der 5V Schiene auf.

    - Ja, Multimeter vorhanden, Speicheroszilloskop und Logikanalysator nicht nur bei Manawyrm, nicht bei der Besitzerin.

    - Löterfahrung ist vorhanden


    Vielen Dank für alle Hinweise!

  • Ein Entfernen des Charakter-ROM bringt keine sichtbare Veränderung der Anzeige.

    Dann könnte es z. B. defekt sein.

    Verdächtige für mich:

    - VIC-I (6561)

    Möglich. Wenn ein "Soft-Char-ROM" im RAM auch nicht angezeigt wird, ist das sogar ziemlich wahrscheinlich. Was auch dafür spricht ist, dass Programme einwandfrei laufen.

    - Logik-ICs (z.B. die 74LS245 Bustreiber zwischen VIC und Adress/Datenbus?)

    74245: Unwahrscheinlich, dann würden Programme nicht laufen.


    Das /CS des Char-ROMs wird direkt aus VA12 und VA13 des VIC generiert, bzw. kommt VA13 von "BLK4" durch den 245 (UE8). "BLK4" wird am UC5, 74LS138 generiert. Möglicherweise klemmt diese Leitung und der VIC kann das Char-ROM daher nicht ansprechen. (Dagegen spricht das Problem, dass das Soft-Charset auch nicht angezeigt wird.)

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Aus der Sicht des VIC liegt das Char-ROM bei $0000, wenn ich das jetzt richtig sehe. Da ist VA13=0, VA12=0.


    Ein Charset bei $1800 bedeutet VA13=1, VA12=1.


    Da ist für mich ein Fehler im VIC noch wahrscheinlicher.


    /BLK4 muss eigentlich sauber generiert werden, sonst klappt das Setzen der Farben und Sounderzeugung etc. nicht. Fällt damit eher aus.


    Also entweder wirklich der 245, dann aber mit komischem Fehler (nur ein Treiber kaputt, oder der VIC selbst

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Alle gesockelten Chips wurden einmal entfernt und mit Kontaktspray wieder eingesetzt.

    Galt das auch für den VIC? (weil der Deckel auf dem Foto noch drauf ist)


    Hatte mal einen Black Screen, weil der Chip (in dem Fall die CPU) nicht wirklich auf den letzten Millimeter im Sockel drin war, obwohl es kurz zuvor, vor einem Hin- und Hertausch, mit genau dieser CPU lief.

  • Das heißt, du hast dir einen neuen VIC besorgt, uraufgesteckt und er lief wieder?

    Wo hast du den Chip denn her, neu bestellt oder aber aus einem alten Rechner?

    Genau! Ich hab vorher selbst nochmal mit dem Scope verifiziert, dass keine wilden Spannungen oder komischen Signale (Buskonflikte, etc.) anlagen, sah aber alles gut aus.

    Nur deswegen hab ich mich getraut, dort den anderen Chip einzusetzen :)


    Den 6561 hatte ich noch in meiner großen Sammlung von ICs, entweder kommt der von einem Amateurfunkflohmarkt (z.B. ehemalige Interradio) oder aus so einem Pollin-Zufällige-ICs-Sortiment.

    Da hatte ich damals auch meine ganzen Z80's, U880, etc. her ^^


    Der neue VIC-1 hat jetzt natürlich auch einen Kühlkörper spendiert bekommen, er soll ja lange und gut leben :D

  • der Trick mit den 2 Steckernetzteilen

    Ja, das ist die beste Chance, sich was kaputt zu machen!


    Modernere Geräte mit mehreren Versorgungen haben nicht umsonst ein aufwändiges Power-sequencing, um die Spannungen geordnet rauf und teils auch runter zu fahren in der geeigneten Reihenfolge, um keine Querströme zw. Baugruppen auszulösen, die durchaus in der Lage sind, Schaden an Halbleitern hervor zu rufen...


    Der CR verwendet ja das gleiche Netzteil wie der C64, die gibts immer noch für relativ wenig Geld bei ebay (und anderswo vermutlich noch viel günstiger...) und eine Modernisierung ist kein Hexenwerk und auch kaum Aufwand. Dioden und Elko(s) genügen schon mal für ne erste Absicherung, ein Schaltregler (dann natürlich mit angepassten Kondensatoren oder -Filtern!) anstelle des Linearreglers, der auch schlecht tauschbar vergossen ist, ist auch keine schlechte Idee, leider existieren aber schlechte Umsetzungen davon... und wer dann noch ne 6.2 ZD und ne passende Feinsicherung sekundärseitig spendiert, ist so ziemlich auf der sicheren Seite.


    Eine aktive Crowbar, also ein Überspannungsbegrenzer "Klemmschaltung", der nen harten Kurzschluss macht ab ner gewissen Überspannung und somit die Sicherung auslöst, kann natürlich auch nicht schaden, Vorteil ist die Begrenzung auf z.b. 5.5V anstelle der hohen Streuung der Z-Diode, wo alles zw. 5.5 und 6.8V irgendwie möglich ist (was aber die Chips auch kurzzeitig aushalten und ein Fehler führt meist zum schnellen und weiteren Ansteigen, so daß die Sicherung dann auch schnell fliegt...) Hält sich aber alles finanziell und vom Aufwand her im Rahmen, ne Crow-Bar hat soeben auch 0xdeadbeef in Bearbeitung als Teil seines mod. Boards, aber ist auch separat lauffähig, muss halt von 12V auf 5V angepasst werden, wenn sie daran zum Einsatz kommen soll...

  • Ja, das ist die beste Chance, sich was kaputt zu machen!

    Ja, aber doch nicht beim VC20. Die 9V AC werden ja nur für den User-Port und die Datasette verwendet, mehr passiert damit nicht. Power-Sequencing ist da völlig egal.


    Beim C64 finde ich gerade im VIC und SID Datenblatt auf Anhieb nichts, was ein direktes Problem darstellen würde, weder in den Absolute Maximum Ratings noch den Operating Conditions sind Parameter genannt, die groß problematisch wären. Klar, 9V vor den 5V zu haben ist schöner, damit der Bus nicht über Body-Dioden die Chips versorgt ist ordentlicher, aber hey.

  • Was genau macht ein passendes Originalnetzteil anders als zwei Steckernetzteile?

    1 Netzteil: 1 Stecker, d.h. 1 Phasenlage und absolut gleichzeitiges Ansteigen der Versorgung durch 1 Trafo.


    Zwei Netzteile: unterschiedliche Phasenlagen möglich, insb. bei asymmetrischer Last am Netz, Blindströme, unterschiedliches Rampup, d.h. Baugruppen werden "hintenrum" bestromt, das geht auf die Schutzdioden bis hin zum Latchup, dann ist Feierabend!


    Leider gilt Vieles davon auch dann, wenn anstelle 1 Stecker EIN Schalter steht, dann sind es nämlich immer noch 2 Trafos (oder noch schlimmer: Schaltnetzteil und Trafo etc)...

    Zudem sind Fußschalter oder gar Steckdosenleistenschalter (in haushaltsüblicher Ausführung) bekannt für Wackelkontakte, Schaltprellen etc.


    Das mit dem Modern bezog sich NICHT auf den VC-20, sondern darauf, dass heutige Geräte oft nicht nur 2 sondern noch mehr unterschiedliche Versorgungspfade haben, die koordiniert rauf und runter gefahren werden wollen, aber schon zwei wie beim VC20-CR und C64 REICHEN für die Effekte, insb. da die MOS/CSG Bauteile nicht unbedingt durch hohe Störfestigkeit oder gar zulässige Injektionsströme bekannt sind, ganz im Gegenteil...

  • aber schon zwei wie beim VC20-CR und C64 REICHEN für die Effekte, insb. da die MOS/CSG Bauteile nicht unbedingt durch hohe Störfestigkeit oder gar zulässige Injektionsströme bekannt sind, ganz im Gegenteil...

    Das lässt sich anhand des Schaltplans resp. des VC20 nicht nachvollziehen. Wo kann da überhaupt was "hintenrum bestromt" werden? Und was davon verträgt das nicht?


    Beim VC20 sind die 9VAC lediglich für den Kassettenport zuständig und gehen ansonsten per Kabel zum Userport. Nimmst du die Sicherung raus, gibt es keine 9VAC, der VC20 läuft trotzdem (bis auf Datasette).


    1 Phasenlage und absolut gleichzeitiges Ansteigen der Versorgung durch 1 Trafo.

    Das Netzteil C64 bzw. VC20-CR hat zwei Wicklungen - eine für die 5VDC und eine für die 9VAC. Wenn ich die 9VAC nun "umpole", ist die Phase gedreht, und zwar um die maximalen 180°. Da passiert dann - gar nichts. Auch nicht, wenn der Fußschalter wackelt.


    Bist du sicher, dass du dich hier nicht im Thema geirrt hast? ?(

  • Bist du sicher

    Ja ich bin sicher, denn ich halte mich von solchem Murks grundsätzlich fern!


    Deine Argumentation -mit Verlaub gesprochen- erinnert mich an meine Kids, wenn ich sie mal wieder dabei erwische, wie sie mit 2 Stühlen aufeinander gestapelt an irgendwas im Hochregal ran wollen...


    Die ist "bislang immer gutgegangen" Story eben...


    Und dann steht mal z.B. die Datasette noch auf Play oder ist was Externes wie ein Eprommer angeschlossen und schon ist sie da, die Rückspannung und

    dann ist mal wieder der Port eines 6510 oder 6526 hinüber, auch die der 6522 halten nicht alles aus, wenn auch vielleicht mehr als die anderen Beiden...


    Und um die 180° Phasenlage EINES Trafos ging es übrigens auch gar nicht, sondern um die unmöglichsten Phasenlagen mehrerer Trafos, insbesondere aber die Einschalt-Gegeninduktion bei unterschiedlichen NETZphasenlagen, egal ob nun durch Schalterprellen, unterschiedlich große Trafos, oder gar Betrieb an 2 verschiedenen Phasen durch "geschickt" verteilte separate Steckernetzteile, manche arbeiten ja z.b. im Heizungskeller als Hobby-Raum...


    Man macht so nen Pfusch einfach grundsätzlich nicht, auch wenns 100 Mal gut ging (oder man nur nicht gleich gesehen hat, was kaputt ging...), just my 2 cents!


    kinzi : als "Inscheniör" müsstest das eigentlich auch wissen, aber interessanterweise funktioniert der "Haudrauf" Reflex ja trotz angeblichem Ignorierens ganz gut...

  • bislang

    Im Fall des VC20 jetzt 40 Jahre. Ohne dass man je von einer Geschichte gehört, wie du sie zum Besten gibst. Ganz gute Quote eigentlich.


    Wie die Datasette auf Play eine "Rückspannung" erzeugt und vor allem woraus wäre zwar interessant, aber ich denke hier im Thread sollte das nicht diskutiert werden. Dafür ist die Laberecke besser geeignet.

  • Wie die Datasette auf Play eine "Rückspannung" erzeugt

    a) Es gibt Datasetten, bei denen auch die Elektronik über die 6V versorgt wird

    b) die zwei Netzteilvariante fährst Du also seit 40 Jahren, Gratulation!

    c) auch div. SD2IECs und andere Basteleien beziehen Betriebs- oder Hilfsspannung vom Kassettenport oder Userport, eben über den 9VAC Zweig direkt oder indirekt

    d) Du weißt auch nicht, warum Du lebst und tust es dennoch, ganz gute Quote, oder?

  • Sofern die Datasette, SD2IEC und andere Basteleien keine eigene Spannungsversorgung haben, passiert da nichts. Wie auch.


    Den VC20 gibt es in Deutschland seit 40 Jahren. Nie gab es Berichte über "Rückspannung" durch externe Geräte, die am Kassettenport hängen. Die Lösung mit zwei Steckernetzteilen ist seit mindestens 20 Jahren in Gebrauch, unter anderem hier im Forum, aber auch weltweit, ist nämlich ein globales Problem. Das funktioniert also auch in 60Hz-Gegenden problemlos und da dreht sich die Phase netzseitig noch schneller! :schreck!:


    Ich weiß nicht, warum du dich so festbeißt, aber zumindest bzgl. VC20 und C64 bist du auf dem Holzweg.

  • Nochmals: es geht mir darum, die Sensibilität gegen solchen MURKS, der auch für Menschen gefährlich werden kann, herzustellen!


    Ein Verbraucher, EIN Netzanschluss.


    Das ist das Prinzip und ist GERADE HIER ja sehr leicht realisierbar, da es KEINEN Grund gibt, NICHT mit originalen oder entsprechenden, geprüften und kommerziell vertriebenen Ersatznetzteilen zu arbeiten!


    Gerade hier im Forum posten jeden Tag User, wie locker ihnen der Geldbeutel sitzt, da habe ich NULL Verständnis für solche Pfuschlösungen, um beim Netzteil dann ein paar EUR zu sparen...


    Die originalen Netzteile kann man für kleines Geld runderneuern (lassen) und stellen auch aus EMV-Sicht das Optimum dar.


    Was jeder letztlich macht, ist seine Sache, zumindest solange nichts passiert...

    Wenn was passiert, dann kommt der Staatsanwalt und mit ihm amtlich vereidigte Gutachter, zu denen auch meine Wenigkeit gehört.


    Mehr sag i nimmer!