Hello, Guest the thread was called769 times and contains 6 replays

last post from mega65 at the

Problems after flashing R3 COR

  • Hi,


    I have flashed my DevKit to version 3 of the core. At first, I was able to see the boot screen and interrupt the auto-boot, but for some reason, connecting my 1541 drive, and rebooting, I am unable to see the boot screen and it auto-loads the maze program. I disconnected the 1541 drive and tried again, but still have the same problem. The 1541 worked just fine before flashing to r3 of the COR.


    Also, not sure if that red light was there before, but maybe that's a sign that something isn't right?


    Here's a video:


    https://www.icloud.com/sharedalbum/#B0gGWZuqDGXCs5P

  • - can you access the configure menu (holding ALT while powering on) ?

    - can you access the flash menu (holding NO SCROLL while powering on) ?
    - what slot did you flash the .COR file to ?

    - try switching the MEGA65 on and press RUN/STOP a couple of times (i have the impression, the MEGA65 boots faster than your monitor syncs to the signal....)

  • 1. and 2. ALT and NO SCROLL work as expected. The menus come up eventually (much slower than before). The first time I went into the configuration menu with ALT and selected "1", the computer froze with a white screen. I powered cycled and tried again and it worked the next time.


    3. Per the instructions provided, I flashed to slot one (see attached).


    4. I did this and you are corrected, the display finally catches up with the computer, but this behavior is new as of the recent flash. Before this, the monitor worked immediately when the unit powered. The video I provided shows what is does now.


    5. I think I figured out a pattern with the red light (and the problem overall). If I boot to the Factory Core (slot 0), the monitor instantly shows output and the red light is no longer illuminated. However, if I boot with the recently flash core (slot 1), the red light always stays on and the monitor is slow to show the image from the computer. The issues appears to be caused by the core.

  • Hi matthewpomar i'll point mega65 (Paul) to this thread.

    Maybe he has an idea.


    btw. you can get rid of the MEGAmaze autoboot, if you use a tool like DirMaster on the PC, open the MEGA65.D81 image and rename the file "autoboot.m65" to "MEGAmaze".

    Please remember, when working with the SDcard, always make a backup on your PC.


    One last thing, please ensure, that you're having the latest SDfiles (Freezer.m65, etc.) on your SDcard.

    You'll always find them in a subfolder on our Scryptos server (find the link in my signature) and go to the subfolder:


    MEGA -> MEGA65 filehost -> ShareFolder -> Bitstreams -> Jenkins-Out -> mega65-core -> development -> 76-bcf0765 -> sdcard-files (this is the most recent bitstream atm)

  • Please check if your monitor supports both PAL and NTSC modes, as it might be that it is booting in a different mode by default with the newer bitstream, and MEGA MAZE when it finishes loading may be again changing the video mode. It sounds like MEGA MAZE is in NTSC from the music speed, and I think newer MEGA65 bitstreams start in PAL.


    Are you using an HDMI or VGA connection to the monitor?


    LG

    Paul.

  • Thanks Paul. I'll try to find out if my monitor supports PAL. It's a cheap Acer 1080p I picked up years ago, so I doubt it. I'm using HDMI for the input.


    With that said, the monitor works fine when the Mega 65 is set to PAL or NTSC via the Freezer menu.


    Do you know why the red light would be constantly on when using the updated COR?