Hello, Guest the thread was called397 times and contains 4 replays

last post from strik at the

nibtools unter macOS

  • Hi,


    ich habe da ein Problem.

    Ich habe auf meinem Mac (Big Sur 11.4) die nibtools wie folgt installiert:


    brew install cc65
    svn co https://git@github.com:OpenCBM/nibtools.git
    cd nibtools.git/trunk
    make -f GNU/Makefile linux
    cp nibread /usr/local/bin
    cp nibwrite /usr/local/bin
    cp nibconv /usr/local/bin
    cp nibscan /usr/local/bin
    cp nibrepair /usr/local/bin
    cp nibsrqtest /usr/local/bin


    openCBM (4.99.103) habe ich schon länger drauf, das funktioniert auch einwandfrei.


    Versuche ich, mit nibtools eine Diskette zu lesen oder zu schreiben erhalte ich folgende Fehlermeldung:


    nibread - Commodore 1541/1571 disk image nibbler

    (C) Peter Rittwage

    http://c64preservation.com

    Built Jun 8 2021 22:15:35



    Drive Version: 73,CBM DOS V3.0 1570,00,00

    Drive type: 1571

    Bumping...

    Initializing

    Sending 1571 SRQ support code...

    Uploading floppy-side code ($0454 bytes, $300-$754)...done.

    Starting custom drive code...Started!

    Testing communication...done.

    Passed basic communication test.



    USB error in xum1541_wait_status: LIBUSB_ERROR_IO

    USB error in xum1541_ioctl cmd: LIBUSB_ERROR_OTHER

    18.0: %


    Der Laufwerksmotor läuft und lässt sich nur mittels cbmctrl reset wieder "beruhigen".


    Ich nutze ein Teens-basiertes XUM1541 zum Anschluss meiner 1570 an den Mac (kein USB-Hub dazwischen).


    Weiß hier jemand Rat?

  • Für die Nutzung von nibtools muss die Floppy parallel am Teensy angeschlossen sein, nehme ich an. Ist das der Fall?


    EDIT: Irrtum: Da müsste serielles Nibblen bei 1570 oder 1571 wohl automatisch passieren. Vielleicht mal ein anderes serielles Kabel ausprobieren, das bessere Qualität hat?


    Ich gehe davon aus, dass OpenCBM ohne nibtools problemlos von der 1570 lesen und schreiben kann?


    Siehe auch: https:// groups. google. com/g/zoomfloppy-users/c/jWCmJdHxrAI


    (Direktlink auf Adresse ist vom F64 verboten)

  • Vielleicht mal ein anderes serielles Kabel ausprobieren, das bessere Qualität hat?

    Genau.

    Es glaubt niemand.

    Aber es ist Fakt (für mich).


    S3 benötigt ein sehr sehr gutes Kabel.

    Und es muss auch wirklich kurz sein.


    Bei mir läuft es nur mit einem bestimmten Kabel.

    Alle anderen Kabel laufen tadellos mit IEC, S1 und S2, aber eben nicht mit MNIB S3.




    Am sichersten läuft es aber nach wie vor mit einem parallel Kabel.

    Fast alle meine 1541 haben ein parallel Kabel.

    Und meine einzige 1571 auch.

  • pcbastler: Mit thierer und mir hast du ja schon zwei mögliche Antwortgeber hier, daher sehe ich von einer Antwort auf der https://github.com/OpenCBM/nibtools/issues/1 ab. ;)


    Die Frage nach der Firmware ist eine gute. Gib mal xum1541cfg devinfo ein und schicke uns die Ausgabe. Hast du die Firmware selbst kompiliert? Falls ja, wie? Falls nein, wo hast du sie her?


    Ansonsten ist der von emulaThor gegebene Link hilfreich, da wurde jemandem geholfen, der das gleiche Problem hatte.