Hello, Guest the thread was called18k times and contains 209 replays

last post from Etosha at the

Wer kennt "PiStorm 68K CPU replacement and more" für den Amiga 500?

  • Nebenbei (während des EM-Halbfinals England:Dänemark) habe ich es gestern geschafft, das AmigaOS 3.2 im WinUAE von CD auf ein hdf-File zu installieren und es erfolgreich mit Kickstart 3.2 auf den Amiga500 mit PiStorm hochzuladen und zu starten. Hört sich trivial an, hab aber einige Versuche gebraucht. Wer Tipps benötigt .... Leider waren im Internet kaum Tuturials zu finden (oder ich war zu doof zu suchen) :-)
    .... überlege, selbst mal so ein Tutorial zu machen. Hätte jemand Interesse? :whistling::saint:

    Mein PiStorm ist zwar noch nicht da, aber ich bin sicher, dass so ein Tutorial sehr hilfreich wäre :thumbup:

  • Ich bin auch kein großer Freund von Discord, aber Du hast Recht: Für den PiStorm ist das bis jetzt die beste Info-Quelle. Aber: Man findet die notwendigen Infos nicht so einfach, z.B. die Antwort auf die Frage: Wie mache ich ein Update meines Git-RepoClones auf dem Raspi nach einer Änderung? Was muss ich dabei beachten (Überschreiben eigener Config-Files)? Wie nehme ich RTG richtig in Betrieb, mit allen Feinheiten?
    Ist halt alles zwar der "Hotte Shit" gerade in der Amiga-Retro-Welt, aber hat halt noch "Alpha"-Stadium. Gerade Linux-Newbies sind oft überfordert, wenn irgendwas daneben geht.
    Was ich mir gestern einen abgebrochen habe, um die 3.2 mit Kick und WB zum fliegen zu bringen? Klar kannst Du Dich hinsetzen und Disketten wechseln (wenn Du welche hast, oder ein Gotek), aber man will ja flexibel sein und mehrere .hdfs zum Testen haben mit unterschiedlichen OS-Versionen und ggf. CPU-Libs. Von der Nachinstallation der Glow-Icons usw. ganz zu schweigen.

  • Ja da geb ich Dir zum Teil recht (RTG Inbetriebnahme ist tatsächlich in #faqs verlinkt, aber das ist zugegebenermaßen eher grob).


    Um auf das Update-Thema ein bisschen einzugehen: ja, man muss dazu auch tatsächlich mit git umgehen können oder es lernen - alles nicht so wirklich wild, nach 3 Updates macht man das im Schlaf (ich hab als Sysadmin da leicht reden, ich weiss...). Liegt aber, wie Du schon sagtest, in der Natur des Projekts.

  • Also Leutz,


    falls es jemandem interessiert. Das ganze war / ist ein wenig merkwürdig.

    Die WLAN Erreichbarkeit ist in meinem Cave sehr fragwürdig gewesen daher konnte raspi sich nie richtig mit Netzwerk verbinden.

    Seit ich mein WLAN hier per repeater verstärkt habe läuft das Ding ohne Probleme.


    Vielen Dank an die konstruktiven Vorschläge ( vor allem an Der Alte Bastler ;-) ) Spannung gemessen am Raspi liegt bei 4,86 Volt an.


    Festplatten lassen sich Sehr einfach mir der Anleitung einbinden. ANLEITUNG Hier wird die HD TOOLBOX vernünftig erklärt.

  • Vielen Dank für den Link auf die Anleitung! Ich hatte sie leider nicht gefunden, obwohl Mingo´s Page eigentlich ne Pflichtlektüre sein sollte. :-) So ist das halt, wenn man sich auf Google verlässt.

    Entscheidend war für mich damals die Erkenntnis gewesen, dass ich HDToolBox erst dann vernünftig ans Laufen bekomme, wenn ich in der Infoseite des Programms das SCSI-Device richtig angebe: Also SCSI_DEVICE_NAME=pi-scsi.device oder wenn man im Emulator preppen will: SCSI_DEVICE_NAME=uaehf.device. Danach war es dann >>fast<< schon einfach, die CD entpackt als HDD-FOlder einzubinden und im WinUAE von dort die 3.2 ruckizucki zu installieren. Danach Transfer per WinSCP auf den PiStorm-Raspi und siehe da ...

    Jaja, wenn ich das früher gesehenen oder gewusst hätte, wären mir viele bittere Stunden des Probierens und Reengineerens und natürlich Googelns erspart geblieben!

    Von daher: Nochmals vielen Dank für den Link, Zyntrion :thumbup:

  • Habe einen tollen Link gefunden mit detaillierten HowTos für den PiStorm und das aktuelle Update vom Juli (09.07.2021):

    http://tech.webit.nu/category/pistorm/


    Vorsicht beim Update: Die alte default.cfg wird man wohl nicht mehr verwenden können. Manche User hatten Probleme nach dem Update über GIT. Siehe General Chat des Discord-Forums "PiStorm".

  • Nachdem hier ja Ruhe eingekehrt ist, will ich mal kurz auf eine "Neuheit" im "PiStorm Universum" hinweisen.


    Es gibt nun den PiStorm2k, der in den CPU Slot am Amiga 2000 gesteckt wird und der auch mit dem Raspberry Pi 3B (Also mit 4 USB und RJ45) bestückt werden kann ...

    Seit Juli 2019 wieder mit dem Commodore Virus infiziert.

    Aktuell: C64 Reloaded MK2, C64C, C64 Brotkasten Original, C64 Brotkasten in blassgrau, Amiga 500, Amiga 600, Amiga 2000 (Octagon 2008), Amiga 2000 mit PC-XT, VIC20, Commodore 16 mit 64KB Umbau nach ComputeMit Zeitschrift..

  • Moin,


    ich habe inzwischen eine aufgebaut, zu spät Teile bestellt und wenig zeit gehabt. Die Bustreiber haben die USA nie verlassen und der chinesische Händler hat mir einfach die Kohle zurückgegeben. Taiwan ist auch trocken.


    Bin momentan auch nicht wirklich zufrieden mit dem Ergebnis. Ist halt noch in der Entwicklung. Die Slowdowns sind teilweise sehr unschön.


    Wir müssen uns noch etwas in Geduld üben. Für jemanden, der keine Turbokarte hat, ist die PiStorm schon einmal nicht schlecht, aber es geht halt auch besser.

  • HypnoToad wenn Du "Geschwindigkeitseinbrüche" hast, dann hast Du das gleiche Problem wie die meisten Leute mit PiStorm ....

    Der Raspi 3A+ wird über 60°C warm und dann drosselt der den Takt.


    Pack mal einen kleinen Kühler auf die CPU am Raspi und lasse eine. kleinen 40er Lüfter im geschlossenen A500 Gehäuse zwischen dem "Sandwich" durchblasen.

    Seit Juli 2019 wieder mit dem Commodore Virus infiziert.

    Aktuell: C64 Reloaded MK2, C64C, C64 Brotkasten Original, C64 Brotkasten in blassgrau, Amiga 500, Amiga 600, Amiga 2000 (Octagon 2008), Amiga 2000 mit PC-XT, VIC20, Commodore 16 mit 64KB Umbau nach ComputeMit Zeitschrift..

  • wird über 60°C warm und dann drosselt der den Takt.

    Ja, das ist Pflicht. Hilft aber nur bedingt.

    Entweder ist der 3A zu schwach auf der Brust oder es liegt einfach daran, dass noch am Code gepfeilt werden muss oder beides.


    Ich schiele ja mehr auf die dicke Olga, auch wenn das finaziell ein echtes Brett werden wird.

  • Hallo HypnoToad ...

    Das Problem mit der Hitze hat nix mit "schwach auf der Brust" zu tun ...

    Es ist eben ein 32 Bit Linux-System, dass auf einem 4-Kern 64 Bit SoC läuft und halt eben leider kein SMP kann ...

    Du kannst ja den HDMI vom Pi nehmen und mal htop laufen lassen ... Dann siehst Du, dass sich fast Alles auf einem einzigen Kern abspielt.

    Der Emulator ist nun eben mal Software, die einen 680020 und andere CPU emuliert ... in Software und das aufsetzend auf eine volle Linux-Distribution ...

    Kühle den Rechenknilch und der ist wirklich ohne große Mühe bei 40°C zu halten ...

    Dann schnurrt der Amiga lange und zuverlässig.

    Wenn Du besseren Code hast oder vielleicht sogar eine Art PiStorm in BareMetal Code hast ... Dann her damit.

    Ich bin gerne Tester. Wenn es dann noch die gleichen Feature hat wie der PiStorm jetzt ... Gerne teste ich auch Das.

    Seit Juli 2019 wieder mit dem Commodore Virus infiziert.

    Aktuell: C64 Reloaded MK2, C64C, C64 Brotkasten Original, C64 Brotkasten in blassgrau, Amiga 500, Amiga 600, Amiga 2000 (Octagon 2008), Amiga 2000 mit PC-XT, VIC20, Commodore 16 mit 64KB Umbau nach ComputeMit Zeitschrift..

  • Nur zur Vorsicht: Ich wollte niemanden kritisieren oder das Projekt schlecht reden. Falls das so angekommen ist, tut mir das Leid und war keines Falls so gemeint.


    PiStorm ist noch in der Entwicklung und bitte weiter machen.


    Die Grenze des Machbaren wird mit Sicherheit der Pi sein.


    Was das Thema Code betrifft: Da werde ich mich schön raushalten; mein Hobby darf nicht mein Leben bestimmen, da ist sowieso schon zu wenig Zeit über.

  • Ich habe das nicht als Kritik verstanden ...

    So ähnlich hatte ich einmal auf Discord bei Claude den "Einwand" gebracht ...

    Ich bekam aus der Community fast die gleiche, gut gemeinte Anwort, wie ich sie Dir geschrieben habe.

    Alles O.K.

    Aber was ich verstanden habe bisher ist, das da die GPIO im (fast) 210 MHz Takt gefahren werden und das der Emulator eben die GPIO eben nicht schneller "fahren" kann.

    Auf der PI Seite ist ja auch noch das Linux und die gesamte Software für den a314 Teil und die RTG Grafik am Laufen am tun.

    Ich habe mal mit dem bisschen Halbwissen, dass ich so habe in den CPLD Code geschaut ...

    Allein da wäre bei schon nach wenigen Zeilen Ende.


    Also, alles gut.

    Seit Juli 2019 wieder mit dem Commodore Virus infiziert.

    Aktuell: C64 Reloaded MK2, C64C, C64 Brotkasten Original, C64 Brotkasten in blassgrau, Amiga 500, Amiga 600, Amiga 2000 (Octagon 2008), Amiga 2000 mit PC-XT, VIC20, Commodore 16 mit 64KB Umbau nach ComputeMit Zeitschrift..