Hello, Guest the thread was called941 times and contains 43 replays

last post from axorp at the

CBM 3032 ROM in CBM 4032

  • Hallo,

    ich habe bei mir zwei CBM Rechner rumstehen, einen 3032 und einen 4032.

    Beide waren defekt, konnte aber den 3032 durch ROMs neu in den Sockel stecken (waren bereits auf Basic 4 aufgerüstet) reparieren.

    Da dieser aber fiept, würde ich gerne den 4032 zum laufen bekommen, der aber vermutlich defekte ROMs hat (bootet nicht, zeigt leere Speichertabelle beim start)

    Sollten die ROMs aus dem funktionierenden 3032 auch im 4032 funktionieren und korrekt booten? Und muss ich etwas bei der Reihenfolge beachten?

  • Das fiepen kann man aber vielleicht auch abstellen. Von welchem Bauteil kommt das? Konntest Du das herausbekommen?

    99% sicher, dass es der Flyback-Transformer ist... und ich habe nicht vor, die nächsten Monate zu sterben...
    aber das Bild wackelt auch ein bisschen (mehr wie ein leichtes Zittern im Bild, sollte glaub auch nicht so sein)

    und natürlich ist der Bildschrim um einiges kleiner, als der des 4032

  • Sollten die ROMs aus dem funktionierenden 3032 auch im 4032 funktionieren und korrekt booten?

    dein 3032 wurde ja schon auf 4032 umgebaut.

    alle roms sind bis auf das editor-rom ($Exxx) bei allen 4xxx und 8xxx geräten gleich.

    von den editor-roms gibt es verschiedene versionen.

    1. mit business oder grafik tastatur.

    2. mit umlauten oder ohne.

    3. mit crt controller oder ohne. (pet, 2xxx, 3xxx und alte 4xxx mit 9 zoll monitor haben keinen crt controller)
    die 12 zoll geräte haben den 6545 oder den 6845 oder den hitachi hd46505 = 6845 zusätzlich on board.

    da dein 3032 (4032) ja funktioniert, würde ich die 4032 roms erstmal in dem 3032 testen.

    in dem 3032 kannst du auch das editor rom vom 4032 testen.
    die inizialisierung des nicht vorhandenen crt controllers stört den nicht.

    nur umgekehrt geht es nicht, weil bei dem die inizialisierung für den crt controller fehlt und du dann kein bild bekommst.
    trotzdem könnte es ja sein, das in deinem 3032 das editor rom von einer 12 zoll version kopiert wurde.


    wenn beide geräte unterschiedliche tastaturen haben, dann geht nur die eingabe nicht, es kommen falsche zeichen.

    Und muss ich etwas bei der Reihenfolge beachten?

    ich würde nicht alle auf einmal tauschen.
    die reihenfolge ist egal.

    3032 ud9 entspricht dem 4032 ud6, $Fxxx, so kannst du den 901465-22 in den 3032 ud9 stecken.
    3032 ud8 entspricht dem 4032 ud7, $Exxx, das ist das editor rom

    3032 ud7 entspricht dem 4032 ud8, $Dxxx
    3032 ud6 entspricht dem 4032 ud9, $Cxxx
    3032 ud5 entspricht dem 4032 ud10, $Bxxx

    gruß
    helmut


  • danke, probiere ich nacher aus

  • also, hab das mal probiert - der 3032(4032) startet bei den "mittleren" korrekt, aber den beiden äußeren (901465-22; 101465-23) nicht (entweder garbage-screen oder garbage screen und danach schwarz)

    ist es wahrscheinlich/ unwahrscheinlich, dass zwei ROMs kaputt sind?


    wenn die beiden ROMs tatsächlich kaputt sind - gibt es da irgendwelche billigen Ersatzteile oder so?

    (ich bin damit nicht selber groß geworden und möchte da jetzt auch nicht wirklich reininvestieren...)

  • also, hab das mal probiert - der 3032(4032) startet bei den "mittleren" korrekt, aber den beiden äußeren (901465-22; 101465-23) nicht

    also sind die drei mittleren roms ok.


    (entweder garbage-screen oder garbage screen und danach schwarz)

    du hast die ja nacheinander getestet?


    901465-22 4032 ud6 = 3032 ud9 / $Fxxx ist das kernal rom

    bei einem defekt von diesem rom, kann ich mir vorstellen das ein garbage-screen zu sehen ist und auch bleibt,

    wenn der defekt ist.


    901465-23 4032 ud10 = 4032 ud5 / $Bxxx sprungtabellen und basicbei deinem test mit diesem rom, hast du zuerst den garbage-screen gesehen und nach kurzer zeit dann schwarz.

    dann ist der wohl auch defekt.


    der garbage screen ist immer am anfang normal. danach wird reset ausgeführt und der video speicher gelöscht = schwarz
    und dann kommt die einschaltmeldung


    bei den rechner mit einem crt controller (die mit 12zoll monitor) sieht man den garbage-screen garnicht,

    weil der crt controller erst später inizialisiert wird.



    ist es wahrscheinlich/ unwahrscheinlich, dass zwei ROMs kaputt sind?

    kann vorkommen

    wenn die beiden ROMs tatsächlich kaputt sind - gibt es da irgendwelche billigen Ersatzteile oder so?

    ja, eproms 2532 oder eproms 2732 mit adapter.
    siehe deine eproms in deinem 3032. das sind keine original roms, sondern auch eproms.

    im cc forum würde sich ganz bestimmt einer melden, der die für dich programmiert.


    die original roms müsste ich irgendwo im keller haben, aber wo.......


    du kannst aber ja nun erstmal die beiden defekten durch die aus dem 3032 ersetzen.
    und so kannst du nun deinen 4032 testen und du benötigst erstmal keinen ersatz. solange du ja immer nur einen rechner benutzt.

    gruß
    helmut

  • Mischt ihr da 3032 und 4032 ROMs? Und das soll funktionieren? :gruebel

    nein, der 3032 hat schon 4032 roms eingebaut.
    somit ist es auch ein 4032.

    nur auf das editor-rom muss man achten, wegen dem crt controller bei den 12 zoll monitor geräten.
    und ob es 40 oder 80 zeichen geräte sind und die tastatur.

    der rom satz für die 2xxx und 3xxx geräte besteht aus 4 roms.
    (der pet hat 7 roms, da die nur 2 kb haben, man kann ihn aber auch mit 4kb roms bestücken)

    und die 4xxx und 8xxx geräte haben 5 roms.

    gruß
    helmut

  • 99% sicher, dass es der Flyback-Transformer ist... und ich habe nicht vor, die nächsten Monate zu sterben...
    aber das Bild wackelt auch ein bisschen (mehr wie ein leichtes Zittern im Bild, sollte glaub auch nicht so sein)

    und natürlich ist der Bildschrim um einiges kleiner, als der des 4032

    Ok, bei dem Teil wird das dann vermutlich nichts oder nur sehr schwierig. Aber mit Sterben hat das auch nichts zu tun. Wenn Du entsprechend Abstand hälst, passiert da nichts.

  • du kannst aber ja nun erstmal die beiden defekten durch die aus dem 3032 ersetzen.
    und so kannst du nun deinen 4032 testen und du benötigst erstmal keinen ersatz. solange du ja immer nur einen rechner benutzt.

    habe ich versucht, konnte alle (den Editor ROM hab ich nicht probiert) ersetzen, ohne, dass sich das Fehlerbild geändert hat,

    außer, als ich versucht habe, den ROM UD6(4032) mit dem "F"-Eprom zu ersetzen, danach hat die Röhre auch kein Bild mehr angezeigt.
    hat der eventuell auch was mit dem Video, etc. zu tun? oder ist evtl. was anderes mit dem Board falsch?
    (ich habe keinerlei Erfahrung mit diesen Teilen, und weiß auch nicht, was mit denen gemacht wurde - die standen jahrelang in meiner Schule, bis man sie wegschmeißen wollte. Die Schüler oder Lehrer haben damals schon an den Maschinen rumgearbeitet.)



    Vielen Dank im vorraus! Habt mir schon sehr viel geholfen!

  • du hast doch alle 5 roms aus dem 4032-12-zoll in dem 4032-9-zoll gerät, nacheinander getestet?


    und die mittleren 3 roms haben in dem 4032-9-zoll gerät funktioniert?


    so können die 3 mittleren roms wieder in den 4032-12-zoll gerät. da sie ja funktionieren.


    die anderen beiden, aus dem 4032-9-zoll gerät baust du nun in deinen 4032-12-zoll gerät.

    da sie ja auch im 4032-9-zoll gerät funktionieren.

    so müsste nun der 4032-12-zoll nun auch funktionieren, wenn es nur an den beiden defekten roms liegt.

    falls nicht, dann könnte es an den ic socken liegen, bitte die pins an den (ep)roms etwas zusammen biegen.


    du hast die (ep)roms und die reihenfolge der (ep)roms nicht verwechselt?

    mache bitte ein foto von der (ep)rom bestückung in deinem 4032-12-zoll gerät.

    gruß
    helmut

  • die Sockel in der Konfiguration, die ich (glaub) hatte
    nebenbei die EPROMs, die ich ersetzt habe, der untere hat nicht funktioniert


    ebenfalls habe ich ein Foto von einem Sockel hinzugefügt, mit denen hatte ich selber das Problem, dass die ROMs rausspringen, wenn man sie reinsetzt, wenn man(übergangsweise) die ROMs runterdrückt, geht es aber...

    hat da jemand eine Idee, was man da machen kann, außer neue Sockel zu kaufen?


    PS: 300kb für ein Bild ist nicht sehr viel...


    gruß

    Benedikt

  • PS: 300kb für ein Bild ist nicht sehr viel...

    Du solltest JPG und nicht PNG für Fotos nehmen ...

  • sind die pins gekürzt worden?

    waren die roms eigelötet gewesen?

    bitte ein bild mit einer höheren auflösung senden. ich kann da kaum etwas erkennen.

    Ja, die ROMs waren ursprünglich eingelötet, daher halten die vermutlich nicht mehr gut, wenn da die Pins gekürzt werden...


    Quote

    Du solltest JPG und nicht PNG für Fotos nehmen ...

    Ja, beide Bilder waren jpeg, aber die Webseite will nur Bilder mit 300kb max - Die Bilder waren größer, hab sie daher mit Paint 3D runterskaliert, welches dann png draus gemacht hat (warum auch immer)

  • Was ist bitte ein "doppelkontakt ic sockel" - hab ich sicherlich nicht da...

    der ic sockel in deiner hand. nur neu und unbenutzt sollte er sein.

    ich habe aber Pin-Header da, könnte ich da einfach welche an die gekürzten Pins dranlöten?

    die sind viel zu dick. die nie und nimmer benutzen.
    auch keine gedrehten ic sockel als adapter benutzen.

    sonst muss man dann auch die ic sockel auf den boards dann auch danach wechseln,
    wenn man später wieder normale ics benutzen möchte.
    da gibt es nur kontaktprobleme.

    hast du die ausgelöteten roms auch direkt in den 4032-9-zoll gerät gesteckt?
    wenn du pech hast, bekommst du da nun auch kontaktprobleme.

    nie ausgelötete ics direckt in einen ic sockel stecken, nur mit einem zwischensockel.

  • Paint 3D r

    :X


    https://getpaint.net/


    Kostenlos, open source. praktisch. Auch jeder Bildbetrachter (IrfanViw, ImageGlass, ...) kann das besser.

    welches dann png draus gemacht hat (warum auch immer)

    Kann man doch beim Speichern angeben, oder nicht?

    Wenn nein, siehe oben.