Hello, Guest the thread was called2.2k times and contains 93 replays

last post from Schmitti at the

Festplatte und Grafikkarte PC10-III

  • Liebe Leute!


    Bin heute über dieses Forum gestossen und hab auch schon ein wenig gelesen und hoffe nun auf euer Feedback!


    Der Commodore PC10-III war mein erster PC, den ich 1988 geschenkt bekommen habe. Ich habe ihn unlängst wieder ausgegraben und gestartet. Es hat bis vorige Woche alles einwandfrei funktioniert, jedoch mein Commodore-Hercules monochrom Monitor gibt kein Bild mehr her. Ich wollte zunächst einen neuen Monitor kaufen, aber das ist mit 9poligem D-Sub gar nicht mehr so einfach. Daher meine Frage, ob eine 8bit ISA VGA Karte (wie diese: https://www.ebay.at/itm/ISA-8b…-pin-TESTED-/254581352473) funktionieren würde und ich einfach einen normalen VGA-Monitor anschliesse. Funktionieren tut er noch, weil ich ihn derzeit via Composite-Video am TV betreibe.

    Meine zweite Frage wäre, wo bekomme ich noch einen XT-IDE HD her, und gibt es die überhaupt noch? Was für FEstplatten könnt ihr mir empfehlen? Ich würde gerne wieder ein wenig mit dem Ding herumspielen, nachdem ich mir jetzt auch extra eine 8087 reingekauft habe, und die auch funktionert, siehe mein Video auf Youtube (

    ).

    Ich wäre euch sehr dankbar für Ratschläge.

  • Prüf mal als aller erstes den Akku auf dem Board, ob der undicht ist. Das ist die gleiche Problematik wie beim Amiga. Am Ende ätzt es die Leiterbahnen weg.


    Festplatte: IDE-XT ist geschickt, da Kontroller direkt auf dem Board. Hier gibt es welche: https://www.ebay.de/itm/Seagat…bfaef443cabebd9d2435fdfd5

    Ansonsten müsstet Du einen ST412-Kontroller extra einbauen (1 Steckplatz dadurch belegt) und eine passende ST412-Festplatte dazunehmen. Dann wird der integrierte IDE-XT-Kontroller deaktiviert.


    Grafikkarte: Vielleicht kann man das auch leicht reparieren, wenn kein Bild kommt. Ansonsten, ja solche eine VGA-Karte kannst Du nehmen und einen VGA-Monitor anschließen.

  • Festplatte: IDE-XT ist geschickt, da Kontroller direkt auf dem Board.

    Kontroller? Bei den ersten AT-BUS-"Controllern" (später: IDE-AT oder IDE), die ich sah, war der "Controller" einfach nur eine Karte, die in den 16 bittigen AT-Slot gesteckt wurde und den Bus auf das Flachbandkabel weitergab. Das dürfte bei XT-BUS-Controllern (IDE-XT) nicht anders gewesen sein.

    Das dürfte EMV-mäßig eine ziemliche Schweinerei gewesen sein...

  • Bei den ersten AT-BUS-"Controllern" (später: IDE-AT oder IDE), die ich sah, war der "Controller" einfach nur eine Karte, die in den 16 bittigen AT-Slot gesteckt wurde und den Bus auf das Flachbandkabel weitergab.

    Na ja, ein wenig Adressdecodierung muss die Karte schon noch machen, mit den drei Adressleitungen auf dem IDE-Kabel kommt man sonst nicht weit.



    Das dürfte EMV-mäßig eine ziemliche Schweinerei gewesen sein...

    Theoretisch spielt die sich allerdings in einem geschlossenen Stahlblechgehäuse ab, was das Problem etwas dämpfen sollte.

  • ich habe vor ein paar Jährchen auch meine Commodore PC10 / PC20

    mit 8Bit Grafikkarte und "neuzeitlichem" 8Bit IDE/CF Adapter (als Festplatte) ausgerüstet...


    guck mal hier: Pc20-Ii

  • Ja, gut, dass Du nach dem Akku geschaut hast. Der bei Dir ist seit einiger Zeit nicht mehr dicht und das austretende Zeug aus dem Akku, verätzt Dir die Platine.


    Dringende Empfehlung:

    Akku ausbauen und die Platine behandeln.


    Wie man das behandelt, kannst Du in diversen Themen, besonders im Amiga-Hardwarebereich hier im Forum, lesen.

    Das wäre aus meiner Sicht wichtiger als die Festplatte, da Du sonst auf mittlere Sicht vermutlich nicht mehr viel Freude an Festplatte und Rechner hättest.

    Es sieht aber rettbar aus.


    Festplatte: IDE-XT ist geschickt, da Kontroller direkt auf dem Board.

    Kontroller? Bei den ersten AT-BUS-"Controllern" (später: IDE-AT oder IDE), die ich sah, war der "Controller" einfach nur eine Karte, die in den 16 bittigen AT-Slot gesteckt wurde und den Bus auf das Flachbandkabel weitergab. Das dürfte bei XT-BUS-Controllern (IDE-XT) nicht anders gewesen sein.

    Ja, der PC 10-III war da modern unterwegs und hatte den Kontroller bereits integriert. Vorteil: Keine Karte erforderlich, die einen ISA-Steckplatz belegt. Der PC 10-III hat auch nur 3 Stück ab Werk.

  • Bei den ersten AT-BUS-"Controllern" (später: IDE-AT oder IDE), die ich sah, war der "Controller" einfach nur eine Karte, die in den 16 bittigen AT-Slot gesteckt wurde und den Bus auf das Flachbandkabel weitergab.

    Na ja, ein wenig Adressdecodierung muss die Karte schon noch machen, mit den drei Adressleitungen auf dem IDE-Kabel kommt man sonst nicht weit.

    Hm... Könnte sein, dass da noch ein kleiner Chip drauf war. Aber eher so etwas im Rahmen eines Standard 74LS-TTL-Dingens oder so, nichts spezielles.

    Das dürfte EMV-mäßig eine ziemliche Schweinerei gewesen sein...

    Theoretisch spielt die sich allerdings in einem geschlossenen Stahlblechgehäuse ab, was das Problem etwas dämpfen sollte.

    Na ja, es geht ja nicht nur um die Abstrahlung, sondern auch die Einstrahlung. Ich glaube nicht, dass die Busleitungen des 8086 darauf ausgelegt waren, durch Flachbandkabel-Antennen besonders anfällig für Einstrahlungen aus dem Gehäuse zu sein.

    Ja, der PC 10-III war da modern unterwegs und hatte den Kontroller bereits integriert. Vorteil: Keine Karte erforderlich, die einen ISA-Steckplatz belegt. Der PC 10-III hat auch nur 3 Stück ab Werk.

    Nun ja, der XT-Bus war ja nicht viel mehr als ein ISA-Steckplatz auf einem Pfostenstecker.

  • Ja, gut, dass Du nach dem Akku geschaut hast. Der bei Dir ist seit einiger Zeit nicht mehr dicht und das austretende Zeug aus dem Akku, verätzt Dir die Platine.


    Dringende Empfehlung:

    Akku ausbauen und die Platine behandeln.

    Danke für die Info.

    Habe mal das Board herausgeschraubt und mit Druckluftreiniger gesäubert. Ich hab im Anhang ein Foto. Meiner Meinung nach, ist noch nicht viel passiert, bzw. der Schaden ist sehr gering. Ich wollte den Akku herunternehmen, der ist wohl angelötet, oder hat sich der angefressen?
    Wo bekomme ich einen neuen Akku her? Habe mal geschaut und nur Akkus derselben Baugrösse gefunden, aber die haben alle 80mAh, auf meinem Akku steht aber 60mAh. Ich will nichts kaputt machen. Bitte um Bezugsquellen.

    Ich werde die Platine morgen, nachdem ich Isopropanol besorgt habe, gründlich mit einer Bürste vorsichtig abbürsten.




    Nach ein bischen Bürsten schaut das jetzt so aus:

  • Das Ding sollte so schnell wie möglich raus. Die Bauteile drumrum haben schon Grünspan. Der funktioniert ja auch ohne die Batterie noch.

    Am besten mit Essigessenz die Batterielauge neutralisieren, evtl. noch mit einer alten Zahnbürste reinigen, dann mit Wasser abspülen und

    wenn du hast mit Isopropanol das Wasser wegspülen. Das hat den Vorteil, dass Alkohol schnell und rückstandsfrei verdunstet.

  • Danke für die Info.

    Ich wollte den Akku herunternehmen, der ist wohl angelötet, oder hat sich der angefressen?
    Wo bekomme ich einen neuen Akku her? Habe mal geschaut und nur Akkus derselben Baugrösse gefunden, aber die haben alle 80mAh, auf meinem Akku steht aber 60mAh. Ich will nichts kaputt machen. Bitte um Bezugsquellen.

    Ich werde die Platine morgen, nachdem ich Isopropanol besorgt habe, gründlich mit einer Bürste vorsichtig abbürsten.

    Gern geschehen. :-)

    Der Akku ist gelötet. Wenn Du den auslötest, würde ich keinen mehr einlöten. Prinzipiell könntest Du auch einen mit 80 mAh nehmen. 60 oder 80 ist egal.

    Allerdings würde ich entweder den Akku durch eine Batterie ersetzen (dann muss aber die Ladeschaltung lahmgelegt werden) oder einen externen Akku nehmen, der per Kabel an das Board angeschlossen ist. Dann kann sowas nicht mehr passieren.

    Mit externem Akku kannst Du Dir auch einfach eine Halterung für 3 Micro- oder Mignon-Zellen nehmen. Die haben auch 3,6 V Spannung. Die Kapazität des Akkus ist eigentlich egal. Wenn Du da Micro-Zellen mit beispielsweise 550 mAh nimmst, geht das auch und hat den Vorteil, Du kannst einzelne Zellen ersetzen, wenn mal eine defekt sein sollte. Der Tonnenakku ist immer eine Einheit und die Standardzellen (Micro/Mignon) sind meist günstiger oder sogar im Haushalt vorhanden.

    Einen passenden Halter für 3 Zellen findest Du beispielsweise hier:

    https://www.pollin.de/p/batteriehalter-270184

    https://www.pollin.de/p/batteriehalter-mit-schalter-270830

  • Danke. Ich hab die Batterie mal abgezwickt. Da ich kein Gerät zum Ablöten habe, habe ich das einfach mit einer Zange gekappt. Ich habe jetzt nach einiger Recherche jetzt folgendes bestellt, und zwar einen Batteriehalter für CR2032 Knopfbatterie: https://www.ebay.de/itm/202562407323.

    Das kann man dann ja einfach drauflöten, nachdem alles sauber ist. Vor allem hat das ja die drei Pins, die Batteriefachlösung traue ich mir einfach nicht zu, brauch ja jetzt schon jemanden, der mir das anlötet. Bin da ein völlig unwissender.

  • Das kann man dann ja einfach drauflöten

    das kann man "nur" (!) weil auch eine Diode mit drauf ist,.. (da die C2032 ja KEIN Akku ist)...

    und KEIN Strom "reinfliessen" darf...


    Der Halter bzw. die Diode, ist aber die teuerste Diode der Welt ;) aber nungut... wenn man selbst nicht basteln will /kann :)

    alles gut!

  • Ich frage mich gerade wie intelligent ist die Ladeschaltung auf diesem Board ? Schaltet die rechtzeitig ab oder feuert die bis der Arzt kommt ? Mit normalen 1,2 Volt Akkus kann´s dann ganz schnell wieder vorbei sein ohne vernünpftige Ladelogik und inkontinent sind die Jungs mit der Zeit auch. Hinzu kommt die hohe Selbstentladung der Zellen (mal abgesehen von LSD Typen), wenn es gut läuft packt man die 12 Monate Marke. Sicher, man könnte das alles Managen in dem die Batterien entfernt werden wenn´s ans Einmotten geht. Ich würde das direkt mitt einer 18650er Zelle mit Schutzschaltung und einem 1S BMS aufbauen. Vorteil die geringe Selbstentladung (unter 4%) und auslaufen kann da nix mehr. Jaaa - für die die jetzt den Finger heben..... Die können abfackeln A) bei nicht fachgerechtem Umgang und Einbau, B) wenn man billigste Chinaware verwendet, C) wenn man zwei 18650er oder ähnlich nackt in der Hosentasche hat und trotteligerweise einen Schlüsselbund damit dabei tut.


    Alles in allem kostet das maximal 15 Euro und man eine lange lange Zeit keine keine Sorgen mehr.


    Trichlorid

  • Eneloops nehmen? Die haben doch kaum Selbstentladung.

    Und wenn der Originalakku 60 mAh hatte, war der Ladestrom wohl entsprechend gering. Standard wäre wohl ein Zehntel. Damit bringst Du den Eneloop nimh nicht zum Glühen...


    ;)

    Das mit dem Ladestrom sehe ich auch so. Damit wirst Du keine Micro-/Mignonzelle kaputt bekommen. Nebenbei haben die meisten diese Zellen sicher in der Bastelkiste, sind also sogar vorhanden.

  • TurboMicha:


    Ja, ich hab extra geschaut, dass diese Sperrdiode vorhanden ist.


    Schmitti:

    Diese Lösung finde ich auch interessant, vor allem weil ich noch Eneloops herumliegen habe, die passen würden. Blos wie verlöte ich das? Die Batteriehalterung hat ja drei Lötfähnchen, die Batteriehalterung hätte nur zwei. Sorry für die blöden Fragen, aber ich hab in meinem Leben noch überhaupt nie was gelötet.

  • Hüstel, also da muss ich mich doch mal Outen, mir waren diese Eneloops zwar von Namen her bekannt, aber mehr auch nicht. Bin eigentlich von einem normalen Akku ausgegangen. "Selbst nach 10 Jahren bleibt die Kapazität bei ca. 70%", na das ist doch mal eine Ansage. Sehr interessant und wieder was gelernt....:thumbsup:

    Eneloop ist nur ein Markenname. Hersteller war zu Anfang Sanyo, jetzt Panasonic. Es gibt aber auch Akku's mit gleicher Funktionalität inzwischen von diversen anderen Anbieter unter anderen Namen. Wenn man den Rechner regelmäßig nutzt, können es aber auch normale Akkus sein, die vielleicht inzwischen deutliche Kapazitätseinbußen haben. Braucht ja nicht viel Kapazität (siehe 60 mAh beim Original).


    Schmitti:

    Diese Lösung finde ich auch interessant, vor allem weil ich noch Eneloops herumliegen habe, die passen würden. Blos wie verlöte ich das? Die Batteriehalterung hat ja drei Lötfähnchen, die Batteriehalterung hätte nur zwei. Sorry für die blöden Fragen, aber ich hab in meinem Leben noch überhaupt nie was gelötet.

    Ja, wie schon geschrieben, sollten es nur zwei Kontakte sein, Plus und Minus. Es kann natürlich Plus oder/und Minus mehrfach vorhanden sein. Wenn Du solch eine 3-fach Akku-Halterung verwendest, sind die 3 Akkus darin in Reihe geschaltet, genauso wie im Akku-Pack, der original auf dem Board eingelötet war.

    An der Halterung hast Du zwei Anschlüss: Plus und Minus. Davon jeweils Plus der Halterung an Plus auf dem Board verbinden und genauso mit Minus.

    Da die Akku-Halterung jetzt am Kabel hängt, kannst Du die irgendwo im Gehäuse positionieren, wo sie nicht stört.