Hello, Guest the thread was called340 times and contains 8 replays

last post from advotax at the

Speed DOS vs. TURBO DOS Unterschiede ?

  • Hallo ,


    bei der Dursicht einiger Teile von damals™ habe ich noch zwei Adapterplatinen

    mit alternative Floppy Kernel für die 1541 alt gefunden .


    Leider hatte ich die sehr ungünstig gelagert und ein paar Stifte waren weggebrochen.

    Einen Adapter konnte ich noch "reparieren" und in eine 1541 Alps einbauen, um dann

    abzufragen was auf den Eproms drauf ist.


    Nummer 1 war Speed Dos 2,7 und Nummer 2 war ein Turbo Dos 2,7 was ich so

    nicht kannte . Das hat mir mal jemand vor über 30 Jahren gebrannt.


    Die Frage ist nun, was ist dieses Turbo Dos 2,7 ist und ob es dazu noch weitere

    Informationen gibt.


    Bei dem Speed DOS würde ich gern rauskriegen , ob das bereits 40 Tracks kann ,

    ich weiss nur noch das ich damals™ auch Nibble Kopiersoftware genutzt hatte.


    Als Gegenstück zum Testen hatte ich mir recht günstig eine alte Knebel-Floppy gekauft,

    da ist schon ein Parallel-Anschluss dran ( mit Rundkabel ) das funktioniert aber (noch) nicht.


    Dabei war auch das Gegenstück für den C64 , ein 4 Fachkernel mit 2 Schaltern .


    Das 4 fach - Kernal scheint zu gehen, ich kann über zwei Kippschalter wählen zwischen


    a) "64er System V3"

    b) "Speed DOS Plus" mit Regenbogen Logo

    c) "C64 by Exos V3"

    d) "Commodore 64 Basic V2" mit anderer Hintergrundfarbe


    Die Umschaltung am Floppykernel muss ich noch reparieren, da ist der Widerstand

    defekt/abgerissen . Ob diese Floppykernel gehen weiss ich aktuell nicht , ich konnte in einer

    Schalterstellung das Speed Dos Plus im Fehlerkanal auslesen.


    Das laden mit dem runden Parallel-Kabel führte zum "hängen". Die "Knebel-Floppy" hatte

    nur einen defekten Kondensator weshalb der Motor usw. nicht anlief . Nach der Reparatur

    läuft die im normalen Modus nun problemlos , daran liegt es nicht.


    Das Rundkabel ist nicht abgeschirmt aber die Verbindungen sind alle richtig und vorhanden.


    Mein altes Parallel Kabel von 1986 muss ich noch reparieren. Das war zumindest ein flaches.

  • Hallo ,


    das Thema ist ohne Bilder vielleicht ein wenig trocken. Da habe ich mal ein paar gemacht.


    Also die alte Knebel Floppy war in einen erstaunlich guten Zustand. Bei der Überprüfung

    lief er Motor nicht an. Die Anzeige der LEDs beim Einschalten ging aber.


    Defekt war Kondensator C2 Kurzschluss . Einen der Brückengleichrichter habe ich gleich

    mitgewechselt , dann stimmte die Spannung wieder genau.


    Beim Testlauf dann die Überraschung. Drehzahl stimmt, Allignment okay, der Kopf auch.

    Normales Laden Funktioniert , paralleles Laden geht nicht.


       


    Hier mal den C64 Multikernel und Schalter von innen , die Gehäuseschalen passen nicht zusammen , toll :rolleyes:


      


    Adapter Anschluss Parallel in der Floppy :


         


    Hier noch ein Blick auf die Floppy Schalter und die Kernal Platine



    Das Rundkabel rechts gehört zur Floppy . Das linke Kabel ist mein altes von damals™ also 1986.



    Kann hier einer was zu Turbo Dos sagen ? Hat das jemand ?


    Gruß

    Michael

  • Bei Betriebssystemen aus unbekanter Herkunft, wäre es wahrscheinlich am besten, das EPROM erstmal auszulesen und zu sichern.

    Dann hat man die Möglichkeit und kann es mit anderen bekannten Dateien vergleichen.


    Was mir aufgefallen ist an dem Bild "SUB Anschluss.jpg": Das Flachkabel verläuft über dem Kühlkörper des Spannungsreglers. Der wird recht warm und so behindert das Kabel die Kühlwirkung etwas. Vielleicht hast Du die Möglichkeit und kannst das noch anders verlegen. Wäre zumindest bei der Wärmeabfuhr des Kühlers am Regler besser im Sinne von langer Lebensdauer.

  • Hallo ,


    aufgrund der Erfolglosigkeit ein 250425 Assy vom Blackscreen zu heilen :whistling: ,

    habe ich mir die Floppy und die alten Eproms noch mal angesehen.

    Vielleicht hast Du die Möglichkeit und kannst das noch anders verlegen.

    Also das Kabel habe ich nur so fürs Foto hingelegt , das ist genug Platz zum verlegen.


    Den Fehler , warum das laden mit Parallelkabel nicht geht habe ich auch gefunden.


    Zuerst mal den Widerstand ersetzt, dann habe ich den Kernel im C64 auf Speed Dos

    gestellt und mein altes Speeddos Eprom in die Floppy eingebaut . Das hat nicht funktioniert .

    Für einen 2. Test habe ich dann das reparierte Parallelkabel von damals™ also 1986 eingebaut.


    Das hat dann auch nicht funktioniert :D


    Nach einer Sichtkontrolle wurden die Zwischensockel für den 6522 für gut befunden.


    Also als nächstes das 6522 in eine andere Floppy eingebaut und Bingo es ist ein Teildefekt :rolleyes:


    Da die Floppy mit dem defekten 6522 im "Standart Modus" einwndfrei läuft ,

    habe ich dann eine andere 6522 eingebaut . Damit hat Speed Dos dann funktioniert.


    Das Gleiche nochmal mit dem 4 Fach Floppykernal . Dort funktionierte dann Speed Dos ;

    das 64er System V3 und das normale Commodore V2 Basic.


    Das Exos V3 wollte nicht laden.


    Zum Schluss noch der Gegentest mit dem "Rundkabel" . Auch hier lief das Exos V3 nicht.

    Das 64er System V3 und das normale Commodore V2 Basic funktionierten .

    Beim Speed Dos war dann wieder Schluss , da ist vermutlich die Abschirmung dran schuld .

    Bei Betriebssystemen aus unbekanter Herkunft, wäre es wahrscheinlich am besten, das EPROM erstmal auszulesen und zu sichern.

    Dann hat man die Möglichkeit und kann es mit anderen bekannten Dateien vergleichen.

    Mittlerweile habe ich als "Newbie" 2 Eprombrenner im Marktplatz gekauft . Mit einem alten Topwin2005 habe

    ich mal versucht die Eproms zu sichern. Da ich kein "HEXer" bin , habe ich das Turbo Dos mal mit den Speed DOS

    verglichen . Da einzige was ich an Unterschieden sehe , ist das es Umbenannt wurde in Turbo Dos .

    Nummer 1 war Speed Dos 2,7 und Nummer 2 war ein Turbo Dos 2,7 was ich so

    nicht kannte . Das hat mir mal jemand vor über 30 Jahren gebrannt.

    Soweit ich heute noch zurück erinnern kann, hatte ich damals einen Wärmefehler und den hatte ich beim

    Speed Dos Eprom vermutet. Der "Bekannte" hat mir dann diese Turbo Dos Version gebrannt. War aber dann

    doch die 1541 als Fehlerursache , die bekam dann einen großen Lüfter lose obendrauf , da war der Fehler weg ......


    Gruß

    Michael

  • Okay,

    SpeedDOS gab es auch als 40T Version ... also lautet die Antwort: Ja.

    Ich formuliere die Frage anders... :D Die Frage war , ob mein SpeedDOS in de Floppy die

    40T Version war.......


    Kann ich leider nicht testen, da ich mir erstmal eine Diskette mit 40 Tracks zum kopieren

    suchen muss und sowas wie ein Nibble Copy.


    Irgendwie hatte ich auch erwartet, das die Mitsumi Floppy einen Kopf Defekt hat.......


    Was ist denn das für eine Platinenversion von deiner 1541 ? Fehlen da die zwei

    Blechkästen ?


    Sowas ähnliches habe ich auch , steht PCB NO 1540050 drauf, nur mit Blechkästen .

  • Ich denke mal nicht ... also ... woran kann es liegen?

    Gut ich habe die Floppy schon wieder verpackt.... daher kann ich nicht formatieren....

    Das 73, SPEEDDOS 2,7 1541,00,00 hatte ich bei der Abfrage auch. Also muss es an

    mir liegen .....


    Aber ein Foto aus der Hüfte habe ich mal geschossen , von meinen Blechkästen.


    Für den Zaunpfahl bin ich vermutlich zu "neu" hier.... :whistling:


    Hat es vielleicht was hiermit zu tuen ?

    1541 mit SpeedDOS+ - Dauerläufer

    Das komtm schon hin - für die 35 Track Variante gibt es wohl ROMs, die den Low-Teil beibehalten. Aber nicht für die 40 Track Variante, weil im Low-Teil die Speedinfos auch eine Anpassung brauchen - muss ja auf 40 Tracks ergänzt werden.

    Fazit:
    SpeedDOS+ 35 Track - HI ROM tauschen reicht aus
    SpeedDOS+ 40 Track - LO + HI ROM müssen getauscht werden

    Gut , dann eben keine 40 Tracks. Die Lo+Hi Rom Variante hatte ich nie.