Hello, Guest the thread was called1.1k times and contains 37 replays

last post from kinzi at the

Hilfe, ich habe meinen SID zerschossen?

  • Ich habe vor einigen Wochen einen C128 über eBay erworben und diesen ausgiebig getestet (C128 und Stromverbrauch bei 5VDC).


    Nach den Tests (habe mir extra ein Fluke 175 Multimeter dafür geleistet) ist mir aufgefallen, dass der Ton nicht mehr funktioniert. Beim Starten eines Spiels (mit Titelmelodie) knackt es kurz und der Ton ist dann extem leise wahrnehmbar. An meinem HD Game Box Konverter und dem C64 Video Kabel liegt es nicht, da selbiges mit meinem C64 funktioniert. Nun frage ich mich:

    1. wie konnte das passieren?
    2. wie grenze ich das Problem ein (Differentialdiagnose)
    3. wo bekomme ich einen neuen SID her (falls notwendig)


    zu 1. Ich habe während der C128 Funktionstests auch Spannungsmessungen am SID (6581R4) durchgeführt. Da waren nur Pin 14 (GND), PIN 25 (5V) und Pin 28 (12V) involviert. Da Spannungsmessungen hochohmig sind sollte es hier keine Schäden geben. Das einzige worst case Senario was theoretisch möglich gewesen wäre ist ein durch die Messsonde verursachter Kurzschluss zwischen Pin 28 (12V) mit PIN 27 (A.OUT).


    zu 2. Kann man durch irgendwelche Messungen direkt am SID feststellen, ob dieser noch intakt ist. Kann man PIN 27 (A.OUT) irgendwie direkt testen?


    zu 3. Wo bekommt man einen möglichst originalen SID her? Über ebay? Und was muss man hierbei beachten?


    Da der SID gesockelt ist, könnte ich ihn temporär durch einen anderen (z.B. von meinem C128DCR ) ersetzten, möchte aber keinen weiteren SID verlieren. Der SID im defekten C128 wird nicht heiss und die Spannungen 12V/5V sind korrekt .

  • Wenn alle Stricke reißen, kannst Du einen MOS 6581 bei Ebay kaufen. Zumindest bekommt man welche.

    Hast Du einen zweiten Rechner, beispielsweise einen C64 mit MOS 6581, und kannst den vermeintlich defekten SID testen?

    Danke für den Hinweis - das erscheint mir eine sichere Methode zu sein. Ich habe einen C128CDR und einen C64 zum Testen griffbereit, muß mal sehen ob die SIDs dort auch gesockelt sind.

  • Habe mehrer SIDs mit dem gleichen Symptom, da ist dann der VCA oder so zerschossen, also die Endverstärkung. Im Prinzip funktioniert die Klangerzeugung ja noch (hört man halt ganz Leise)

    Würde mich mal interessieren ob da Jemand ein brauchbares Resultat hinbekommen hat indem er einen OP Amp dahinter geschaltet hat. Wenn man den Verstärkungsfaktor an das schwache Ausgangssignal entsprechent anpasst, könnte das doch Theoretisch funktionieren oder was spricht dagegen?


    Zu Wie das passieren kann?

    Ist wohl leider "Materialermüdung" die 6581er gehen langsam aber sicher alle über die Wupper. Muss nicht durch ein defektes Board/Netzteil zustande gekommen sein. Aber vorsichtshalber mal messen ob 5 und 12v vorhanden sind und nicht mehr.

  • Wenn alle Stricke reißen, kannst Du einen MOS 6581 bei Ebay kaufen. Zumindest bekommt man welche.

    Hast Du einen zweiten Rechner, beispielsweise einen C64 mit MOS 6581, und kannst den vermeintlich defekten SID testen?

    Danke für den Hinweis - das erscheint mir eine sichere Methode zu sein. Ich habe einen C128CDR und einen C64 zum Testen griffbereit, muß mal sehen ob die SIDs dort auch gesockelt sind.

    Achtung: Aufpassen, dass es die gleichen SIDs sind. Im C128Dcr wurde nicht der 6581 verbaut. Im C64 könnte der drin sein oder auch der andere. Nicht die unterschiedlichen Typen miteinander tauschen.

    Habe mehrer SIDs mit dem gleichen Symptom, da ist dann der VCA oder so zerschossen, also die Endverstärkung. Im Prinzip funktioniert die Klangerzeugung ja noch (hört man halt ganz Leise)

    Würde mich mal interessieren ob da Jemand ein brauchbares Resultat hinbekommen hat indem er einen OP Amp dahinter geschaltet hat. Wenn man den Verstärkungsfaktor an das schwache Ausgangssignal entsprechent anpasst, könnte das doch Theoretisch funktionieren oder was spricht dagegen?


    Zu Wie das passieren kann?

    Ist wohl leider "Materialermüdung" die 6581er gehen langsam aber sicher alle über die Wupper. Muss nicht durch ein defektes Board/Netzteil zustande gekommen sein. Aber vorsichtshalber mal messen ob 5 und 12v vorhanden sind und nicht mehr.

    Sowas in der Art hatte ich auch schon mal vorgeschlagen, dass man das Ausgangssignal stärker verstärken müsste und man dann wieder beim gleichen Ergebnis ankommen würde. Allerdings wurde dazu gemeint, das würde nicht gehen. Aber das Detail, warum das nicht gehen soll, ist mir nicht klar.

  • Achtung: Aufpassen, dass es die gleichen SIDs sind. Im C128Dcr wurde nicht der 6581 verbaut. Im C64 könnte der drin sein oder auch der andere. Nicht die unterschiedlichen Typen miteinander tauschen.

    Bingo, mein C128DCR und mein C64 (ASSY 250469 Rev.4) haben keinen 6581 :( Wenn ich deine Bemerkung richtig verstehe sind 6581 und der 8580 nicht pinkompatibel - somit kann ich den SID nicht in einem anderen System bei mir testen.

  • Habe mehrer SIDs mit dem gleichen Symptom, da ist dann der VCA oder so zerschossen, also die Endverstärkung. Im Prinzip funktioniert die Klangerzeugung ja noch (hört man halt ganz Leise)

    Würde mich mal interessieren ob da Jemand ein brauchbares Resultat hinbekommen hat indem er einen OP Amp dahinter geschaltet hat. Wenn man den Verstärkungsfaktor an das schwache Ausgangssignal entsprechent anpasst, könnte das doch Theoretisch funktionieren oder was spricht dagegen?

    Wenn ich das richtig sehe, wird Audio OUT (SID) schon im C128 verstärkt?


    Ist wohl leider "Materialermüdung" die 6581er gehen langsam aber sicher alle über die Wupper. Muss nicht durch ein defektes Board/Netzteil zustande gekommen sein. Aber vorsichtshalber mal messen ob 5 und 12v vorhanden sind und nicht mehr.

    Genau das hatte ich getan - die Spannungen waren OK aber danach hat der SID nicht mehr funktioniert.

  • Das habe ich hier im Forum gefunden: „Wenn Du ein Multimeter hast, dann miss mal am SID zwischen pin 14 und pin 28 die Spannung. Vorsicht! Dabei nicht Abrutschen und Pin28 mit anderen Pins kurzschliessen. Das mag der SID nicht!“


    Das war wohl mein Fehler.


    „Zum Glueck kann ein 6581 nicht kaputt gehen, wenn er in ein board gesteckt wird, dass fuer einen 8580 gebaut wurde. Umgekehrt (8580 im 6581-Board) macht man den SID kaputt.“

  • ESD ist auch ein Thema. Wenn man das ausschließen will, würde ich Dir empfehlen im Hobbybereich ein ESD-Armband zu tragen. ESD kann leicht zu Totalausfällen, teilweisen Defekten und schleichenden Defekten führen, also Defekte, die Du am Anfang gar nicht wahrnimmst (oder wahrnehmen kannst) nd erst später degradieren. Wenn Du das bereits mit ESD-Schutz gehandhabt hast, kannst Du den Effekt jedoch ausschließen. Das gilt im übrigen nicht nur für den SID, alle Halbleiter kann das treffen.

  • SwinSID Nano ist eine billige Alternative, taugt aber nicht so viel.

    Es gibt noch aufwendigere Nachbauten, die sehr gut funktionieren, aber auch ne Ecke teuerer als das Original sind.

    Der SwinSID Nano taugt nicht viel. Der ARMSid ist ganz ok und kostet auch nicht so viel. Inkl. Versand aus CZ 35,90€ (vorgestern kam erst wieder einer hier an).

  • ESD ist auch ein Thema. Wenn man das ausschließen will, würde ich Dir empfehlen im Hobbybereich ein ESD-Armband zu tragen. ESD kann leicht zu Totalausfällen, teilweisen Defekten und schleichenden Defekten führen, also Defekte, die Du am Anfang gar nicht wahrnimmst (oder wahrnehmen kannst) nd erst später degradieren.

    Mir ist vor diesem Vorfall noch nie etwas kaputt gegangen (keine CPU, kein RAM, keine Grafikkarte) - das gilt für den PC Bereich, wie auch für Vintage Systeme (habe an einen meiner C128DCR Systeme sogar herumgelötet). Ein ESD-Armband habe ich nicht benutzt. Offenbar ist der SID besonders empfindlich oder es war Zufall? Vermutlich hängt es mit meinen Spannungs-Messungen direkt am SID zusammen. So etwas habe ich in der Vergangenheit immer vermieden. Mit meinem neuen Fluke 115 war ich da wohl etwas zu enthusiastisch. :(

  • wie konnte das passieren?

    SIDs sterben auch mal einfach so. Ist leider so. :-(

    wie grenze ich das Problem ein (Differentialdiagnose)

    Am besten den defekten SID in ein anderes Board stecken und überprüfen. ob er dort tut.

    wo bekomme ich einen neuen SID her (falls notwendig)

    Wenn man wahnsinnig genug ist bei eBay.

    Ich habe während der C128 Funktionstests auch Spannungsmessungen am SID (6581R4) durchgeführt. Da waren nur Pin 14 (GND), PIN 25 (5V) und Pin 28 (12V) involviert. D

    Uiuiuii .... Pin 28 (12) liegt neben Pin 27(sic!), und das ist Audio_In ... einmal abrutschen reicht. :/

    zu 2. Kann man durch irgendwelche Messungen direkt am SID feststellen, ob dieser noch intakt ist. Kann man PIN 27 (A.OUT) irgendwie direkt testen?

    Besser ist wie oben beschrieben ein "Ohrentest" in einem anderen Board.

    zu 3. Wo bekommt man einen möglichst originalen SID her? Über ebay? Und was muss man hierbei beachten?

    eBay, Marktplatz, anderen C64 ausschlachte, ...


    Oder einen Nachbau. Bei den Goldpreisen für originale SIDs ist es besser, man legt noch einen Zwanni drauf und kauft sich einen FPGAsid.


    ich persönlich finde die SwinSID nanos unschlagbar im Preis-/Leistungsverhältnis.

    Da der SID gesockelt ist, könnte ich ihn temporär durch einen anderen (z.B. von meinem C128DCR ) ersetzten, möchte aber keinen weiteren SID verlieren. Der SID im defekten C128 wird nicht heiss und die Spannungen 12V/5V sind korrekt .

    Nicht den funktionierenden ins "kaputte" Board stecken, sondern den kaputten SID in ein anderes Board. Wenn z. B. die Spannungsversorgung kaputt ist, tötet du sonst den anderen, funktionierenden SID auch noch.

    Fast immer... es gibt aber tatsächlich Boards, in denen der SID ab Werk verlötet war.

    Richtig, habe ich bis jetzt genau einmal "live" gesehen.

    Würde mich mal interessieren ob da Jemand ein brauchbares Resultat hinbekommen hat indem er einen OP Amp dahinter geschaltet hat. Wenn man den Verstärkungsfaktor an das schwache Ausgangssignal entsprechent anpasst, könnte das doch Theoretisch funktionieren oder was spricht dagegen?

    Das wage ich zu bezweifeln - Stichwort "Signal-/Rauschabstand". Da müsstest du schon die kaputte Stufe IM SID überbrücken/umgehen können.

    SwinSID Nano ist eine billige Alternative, taugt aber nicht so viel.

    Ich finde den prima für sein Geld, bin aber auch nicht ein "Goldohr".

    Wenn ich das richtig sehe, wird Audio OUT (SID) schon im C128 verstärkt?

    Nach dem SID kommt noch eine Transistorstufe, ein Emitterfolger, zur Stromverstärkung/Pufferung. Diese kann theoretisch auch defekt sein, praktisch habe ich das noch nie erlebt. Um das auszuschließen: Dubiosen SID in anderes Board stecken ... siehe oben.

    Das habe ich hier im Forum gefunden: „Wenn Du ein Multimeter hast, dann miss mal am SID zwischen pin 14 und pin 28 die Spannung. Vorsicht! Dabei nicht Abrutschen und Pin28 mit anderen Pins kurzschliessen. Das mag der SID nicht!“

    Genau so, siehe oben .. =O