Suchergebnisse

Suchergebnisse 1-20 von insgesamt 75.

  • Zitat von BlueBird: „Hallo, Ich suche ein Dreh schalter der ein 4 Fach Kernal umschaltet. Würde sowas Funktionieren ? ebay.de/itm/ET-3P4T-3-Pole-4-P…it-Drehknopf/191840706376 “ So einen Drehscbalter mit 4 Stellungen und 3 Polen habe ich auch schon mit einen Reprom64 verbaut und funktioniert gut.

  • C64 Tastatur auslesen (ATMega16)

    zschunky - - Bastelecke

    Beitrag

    Zitat von mc71: „Eine gedrückte Taste ist ziemlich hochohmig, vor allem im fortgeschrittenen Alter. Die Teile haben immerhin 25 bis 35 Jahre auf dem Buckel! Möglicherweise sidn die Pull-Ups im AVR zu niederohmig und man bekommt den Port-Pin nicht weit genug runter gezogen für ein sicheres Low. Die CIA und VIA mit ihren NMOS-Pegeln und relativ schwachen Pull-Ups könnten da im Vorteil sein. “ Die Pullupps bei dem Atmega sind im Datenblatt als 20k ... 50k ohm spezifiziert. Das sollte normalerweise …

  • C64 Tastatur auslesen (ATMega16)

    zschunky - - Bastelecke

    Beitrag

    Wenn man die ADCs nicht vorher aktiviert hat, muss man sie nicht zurücksetzen, da die reset-Werte der Register auf deaktiviert stehen. Das was ich meinte war schon JTAG/Clockout und solche Geschichten die per Fuse geschalten werden. Hast Du die Spannungsversorgung auch an AVCC angeschlossen? Diese wird für Port A benötigt. Ich hätte das am Ende so programmiert (wird mit LEDs nicht funktionieren): C-Quellcode (27 Zeilen)

  • C64 Tastatur auslesen (ATMega16)

    zschunky - - Bastelecke

    Beitrag

    Das muss nicht unbedingt am auslessen liegen. Manche Ports vom Atmega haben doppelte-Belegungen und die müssen explizit deaktiviert sein sonst funktionieren die Ports an der Stelle nicht. Am besten wäre wenn Du mal ein Schaltplan hochlädst und sagst welche Kombination nicht funktioniert. Ausserdem sollte man beim auslesen die Spalten nicht mit High Pegel betreiben, sondern die Spallten dann auf Eingang (=hochohmig) schalten. Warum? Beim drücken von 2 Tasten wirst Du sonst so einen Kurzschluss pr…

  • da hebe ich auch mal die Hand , einen 4-Spieler-Adapter habe ich noch nicht.

  • Zitat von DerSchatten: „Wieso geht der AVR beim Einschalten zuerst auf HIGH? Wo steht das? “ ein AVR geht nicht nach dem einschalten auf High, sondern auf hochohmig. Die Firmware im AVR muss dann den gewünschten Zustand setzen, dass kann aber eine paar us-ms dauern. Wenn man einen bestimmten Start-Pegel haben will sollte man ein Pull-Up oder Pull-Down Widerstand verwenden. Dies geht aber nur wenn im Ziel-IC kein solcher entgegengesetzter Widerstand ist, sonst is dann ein Spannungsteiler aktiv.

  • 1541 mit Longboard

    zschunky - - Diskettenlaufwerke

    Beitrag

    vielen Dank für die Infos. Ich konnte mir nun ein Exemplar ergattern: forum64.de/index.php?attachmen…a727d1e67acb979e30bdc03ed

  • 1541 mit Longboard

    zschunky - - Diskettenlaufwerke

    Beitrag

    Hallo, ich möchte mir gern eine 1541 mit einen Longboard zulegen. Kann man irgendwie die 1541, ohne sie zu zerlegen, identifizieren ob da ein Longboard drin steckt oder nicht (evt. Seriennummer oder andere Merkmale)? Grüße -Andreas

  • Zitat von manne_sahne: „Wenn ich am rechten Sicherungshalter messe habe ich da 0,055V DC ausgeschaltet und 0,018V DC eingeschaltet. Ist das normal? “ Durch die Sicherung gehen ja auch 9V AC (Wechselspannung), da wirst Du nichts vernünftiges mit DC (Gleichspannung) messen.

  • ich hatte auch mal das Problem dass Demos nicht mehr liefen, schuld war dass ich die Software IEC Emulation (um ähnlich wie bei SD2IEC vom C64 aus durch Directories zu browsen) in der Ultimate II+ eingeschaltet hatte. Nachdem ich es wieder deaktiviert hatte, hat es wieder funktioniert. Scheinbar liefen dann diverse Schnelllader nicht mehr und die Demos konnten nicht nachladen.

  • bei 2x 469er Boards hatte ich mal defekte RAMs, da war aber immer ein schwarzer Bildschirm zu sehen. Mit eingesteckten Turbo Chameleon konnte ich dann aber ein Bild sehen. Da hier der externe RAM vom TC verwendet wird, aber die Zugriffe auf den VIC funktionieren. Wenn der RAM nicht geht bleibt der Kernal beim einschalten hängen und Initialisiert den Bildschirm nicht. Die Register im VIC (inkl. $d012) haben alle nichts mit dem RAM zu tun, da sie intern im VIC sind. Diese sollten also unabhängig v…

  • CGA-SCART-Adapter

    zschunky - - x86 -alte Hardware

    Beitrag

    Zitat von zschunky: „Ich hab mir auch schon öfters überlegt eine Schaltung für den C128 zu bauen. Bei der Schaltung hier finde ich leider die Widerstände nicht optimal. Bei einen richtigen Weiß müssen dann je 0,7V an den Farbsignalen anliegen. Wenn man die Intensität zunächst vernachlässigt kommt man auf einen Gesamtwiderstand von 680+75=755ohm. Und per Spannungsteiler lässt sich dann die Spannung ausrechnen: x/5V=75ohm/755ohm, x=0,5V. 0,5V sind hier schon ein wenig entfernt von 0,7V und daher s…

  • CGA-SCART-Adapter

    zschunky - - x86 -alte Hardware

    Beitrag

    Ich hab mir auch schon öfters überlegt eine Schaltung für den C128 zu bauen. Bei der Schaltung hier finde ich leider die Widerstände nicht optimal. Bei einen richtigen Weiß müssen dann je 0,7V an den Farbsignalen anliegen. Wenn man die Intensität zunächst vernachlässigt kommt man auf einen Gesamtwiderstand von 680+75=755ohm. Und per Spannungsteiler lässt sich dann die Spannung ausrechnen: x/5V=75ohm/755ohm, x=0,5V. 0,5V sind hier schon ein wenig entfernt von 0,7V und daher sieht Dein Weiß nach h…

  • wenn ich mich richtig erinnere gab es schon mal einen Post hier mit fehlerhaften Zeichen im Ultimate Menü. Dort wurde dann unter Einstellungen der Ultimate das Timing angepasst und es hat dann funktioniert. Vielleicht hilft das hier auch.

  • Also wenn ich das Manual richtig deute: Turbo endless: lda #$80 ; turbo=1,vicTurbo=0,autoSpeed=0,speedLimit=0000 sta $d0f3 Turbo off: lda #$00 ; turbo=0,vicTurbo=0,autoSpeed=0,speedLimit=0000 sta $d0f3 edit: oups, da wohl schon jemand schneller als ich

  • Heute so gebastelt ...

    zschunky - - Bastelecke

    Beitrag

    Zitat von paranoid64: „Also die Glasscheibe ist Müll, die habe ich durch Aluminium (PEI beschichtet) ersetzt. Die Glasplatte wird nicht warm genug und auch nicht gleichmäßig. Hoffe das es mit der PEI besch. Aluplatte besser wird. “ Ich verwende in meinen CTC Dual eine Carbon-Platte. Damit bin ich ganz gut zufrieden. Kein Tape oder einsprühen, immer nur sauber halten und eine Gute Bed-Temperatur (60C PLA, 110C ABS) einstellen und der Druck bleibt da gut kleben. Wenn sich alles nach dem Druck abge…

  • Chameleon64 Update beta-9-g

    zschunky - - Chameleon

    Beitrag

    also ich hab das letzte Update drin und kann mit C= + M Disks ohne Probleme mounten.

  • auch von meiner Seite noch mal vielen Dank für Organisation. Ich bin gerne wieder dabei.

  • Zitat von Ingo: „Gestern wollte ich mal wieder ein Spielchen zocken, drücke die mittlere Taste und gehe bis zur .d64-Datei. Hier hab ich die Rechts-Taste gedrückt, um mir den Inhalt anzusehen, das hat schon ziemlich lang gedauert und die rechte grüne LED hat dabei sehr schnell geflackert. Dann hatte ich "Mount and Run" ausgewählt. Das hat wieder lang gedauert und die LED hat geflackert. Einmal ist die U auch komplett abgestürzt... Was ist das? Hängt das mit U5-Chip zusammen? “ Also bei mir ging …

  • Zitat von Centaur: „Ich habe seit Wochen im Kofferraum einen Robotron KC85/4 liegen. Ohne Tastatur, Zustand unbekannt. “ ich kann ja mal ein rgb kabel und eine tastatur dafür mitbringen, da können wir mal schauen ob sich was tut. werden wohl doch wieder zwei kisten hardware werden, ich dachte ich komme diesmal mit einer hin .