You are not logged in.

Dear visitor, welcome to Forum64. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

mike1902

Und wieder vom Wahnsinn gepackt

  • "mike1902" is male
  • "mike1902" started this thread

Posts: 170

Date of registration: Sep 25th 2010

Location: Noch immer nicht in einer geschlossenen Anstalt

  • Send private message

member since 36 month member since 36 month

1

Wednesday, January 26th 2011, 9:16pm

Wie schliesse ich eine Dual Led rot/grün an einem MMC2IEC an?

Hi,

Ich will eine Dual Led rot/grün an meinem MMC2IEC anschliessen. Irgendwie bekomme ich es nicht hin.
Beim Betrieb leuchtet rot und grün zugleich. Wie muss ich diese Led anschliessen?
Wäre für Eure Hilfe sehr dankbar.


beste Grüsse, Mike
mike1902 has attached the following image:
  • dual led.JPG
Ich bin so, wie ich bin. Also bin ich.

I wanna be a Schweinebär and Sauhund. ;)

AntaBaka

--- HNC Cheffe / DRP Vize --- (あんた バカぁ?)

  • "AntaBaka" is male
  • »AntaBaka« is a verified user

Posts: 11,235

Date of registration: Oct 29th 2006

Location: Frankfurt/Main

  • Send private message

member since 90 month member since 90 month member since 90 month member since 90 month member since 90 month

2

Wednesday, January 26th 2011, 9:26pm

Genau so, wie es an den Beinchen steht, mehr ist das nicht.

Aber das wird bei einem LarsP-MMC2IEC, wie der PeterSieg Platine nicht funktionieren, da dort die LEDs ueber die jeweilige Masse-Leitung angeschaltet werden (nicht ueber die Plusleitung wie bei der Shadowolf-Platine) und diese LED eben nur eine gemeinsame Masse-Leitung fuer beide Farben hat.

Kurz gesagt: Geht nur mit den Shadowolfplatinen.

mike1902

Und wieder vom Wahnsinn gepackt

  • "mike1902" is male
  • "mike1902" started this thread

Posts: 170

Date of registration: Sep 25th 2010

Location: Noch immer nicht in einer geschlossenen Anstalt

  • Send private message

member since 36 month member since 36 month

3

Wednesday, January 26th 2011, 9:38pm

Danke für deine Antwort. Habe mir nochmal die PeterSieg Platine angschaut.
Du hast recht. Die Led's werden über die jeweilige Masse-Leitung angeschaltet.
Ich werde dann einfach eine rote und grüne Led anbringen.
Ich bin so, wie ich bin. Also bin ich.

I wanna be a Schweinebär and Sauhund. ;)

OliverW.

Professional

  • "OliverW." is male

Posts: 939

Date of registration: Aug 25th 2005

  • Send private message

member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month

4

Wednesday, January 26th 2011, 10:32pm

Die Led's werden über die jeweilige Masse-Leitung angeschaltet.

Du kannst einen Funktionsinverter verwenden, eine Schaltung findest Du z.B. hier!

Oliver W.

mike1902

Und wieder vom Wahnsinn gepackt

  • "mike1902" is male
  • "mike1902" started this thread

Posts: 170

Date of registration: Sep 25th 2010

Location: Noch immer nicht in einer geschlossenen Anstalt

  • Send private message

member since 36 month member since 36 month

5

Wednesday, January 26th 2011, 11:33pm

Danke, Oliver
Habe jetzt zwei normale Led's dran gemacht.
Ich bin so, wie ich bin. Also bin ich.

I wanna be a Schweinebär and Sauhund. ;)

  • "Scorp.ius" is male

Posts: 1,817

Date of registration: Oct 19th 2004

Location: ja

  • Send private message

member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month

6

Thursday, January 27th 2011, 9:12am

eine Anleitung für "Doofies" habe ich hier mal geschrieben ;)
http://www.circuit-board.de/forum/viewtopic.php?f=21&t=1849

Sleepy

Intermediate

Posts: 403

Date of registration: Feb 9th 2009

Location: Köln

  • Send private message

member since 54 month member since 54 month member since 54 month

7

Thursday, January 27th 2011, 9:42am

Hi,

zu dem obigen Link würde ich anmerken dass LEDs immer mit einem Vorwiderstand zur Strombegrenzung betrieben werden. Ausnahme sind Modelle die für bestimmte Spannungen ausgelegt sind un d schon einen Vorwiderstand eingebaut haben.
Einfach "irgendwo" eine passende Spannung abgreifen und dort eine Diode anschließen kann zum einen die Schaltung beeinträchtigen, zum anderen kann sich der Pegel ändern und die LED abschießen. Also am besten immer auf 5V zurückgreifen (die dürften ja in den allermeisten Konsolen/Rechnern vorhanden sein. ;-)

Einen Rechner zur Bestimmung des richtigen Widerstandes findet man z.B. hier.



Sleepy
Totgesagte leben länger: drive Capri & play ATARI

Amiga 500 1MB mit HxC, Unmengen an ATARI-8Bit, Toch me, VCS, 2600, 7800, Jaguar, Lynx 1 + 2, Flashback 1+2

This post has been edited 1 times, last edit by "Sleepy" (Jan 27th 2011, 9:55am)


8

Thursday, January 27th 2011, 11:26am

eine Anleitung für "Doofies" habe ich hier mal geschrieben ;)
http://www.circuit-board.de/forum/viewtopic.php?f=21&t=1849

Diese Anleitung wird zumindest bei der PeterSieg/Larsp-Platine nicht funktionieren. Siehe Post #2 und #4.

This post has been edited 1 times, last edit by "abraXxl" (Jan 27th 2011, 11:58am)


9

Thursday, January 27th 2011, 11:49am

Es gibt, denke ich, auch dual LED´s, die 2 getrennte massen haben.

Aber gut, dass ich das jetzt wiess. WOllte da nämlich auch schonmal eine einbauen. Bin nur noch nihct dazu gekommen, mir die schaltung/Platine anzuschauen, wo die leds ihren gemeinsamen pin (dachte immer masse, ist jetzt ja aber der "Plus") haben.
VintageVideo Forum - Das Forum für Analoge Videotechnik!

  • "Scorp.ius" is male

Posts: 1,817

Date of registration: Oct 19th 2004

Location: ja

  • Send private message

member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month

10

Thursday, January 27th 2011, 12:26pm

jo ich mal mal den vorwiderstand mit rein.
der link hat ja mit der peter sieg platine auch nix zu tun, sondern behandelt ein SNES, bei dem der Vorwiderstand auf der Platine ist.

So, habe den Text entsprechend geändert ;)

norbi40

Intermediate

  • "norbi40" is male

Posts: 222

Date of registration: Jan 14th 2010

Location: Allgäu

  • Send private message

member since 54 month member since 54 month member since 54 month

11

Thursday, January 27th 2011, 1:08pm

Hallo
Ginge theoretisch auch mit der PeterSieg/Larsp-Platine.

In den zwei kleinen Schaltungen wäre der erste Fall so, das zwei PNP Transistoren das Ausgangssignal invertieren.
Im zweiten Fall müsste man in der Firmware die Ausgabe PORTA BIT 0 und 1 umdrehen.
Aber ob es der Aufwand wert ist ?
VG
Norbert
norbi40 has attached the following image:
  • Bildschirmfoto.png
Der Unterschied zwischen einem C64 und Windows:
Beim C 64 hast du nach dem Einschalten einen blauen Bildschirm und hast dann gearbeitet.
Bei Windows ist es genau umgekehrt. :drunk:

ikari_01

OVP-Vernichter

Posts: 89

Date of registration: Mar 9th 2008

Location: Wunstorf

  • Send private message

member since 72 month member since 72 month member since 72 month member since 72 month

12

Friday, January 28th 2011, 8:37am

Man kann auch einfach eine Dual-(oder RGB-)LED mit gemeinsamer Anode verwenden.

norbi40

Intermediate

  • "norbi40" is male

Posts: 222

Date of registration: Jan 14th 2010

Location: Allgäu

  • Send private message

member since 54 month member since 54 month member since 54 month

13

Friday, January 28th 2011, 9:21am

Hallo ,
Man kann auch einfach eine Dual-(oder RGB-)LED mit gemeinsamer Anode verwenden.
Sicher könnte man das.Wäre aber viel zu einfach . :D :D :D
VG
Norbert
Der Unterschied zwischen einem C64 und Windows:
Beim C 64 hast du nach dem Einschalten einen blauen Bildschirm und hast dann gearbeitet.
Bei Windows ist es genau umgekehrt. :drunk:

14

Friday, January 28th 2011, 9:22am

Man kann auch einfach eine Dual-(oder RGB-)LED mit gemeinsamer Anode verwenden.

Warum simpel wenn es auch richtig kompliziert geht?

Man könnte auch einen kleinen ATTiny beschäftigen das Signal aufzubereiten ... :lol33:

CrazyIcecap

pausiert

  • "CrazyIcecap" is male
  • »CrazyIcecap« is a verified user

Posts: 2,663

Date of registration: Jan 31st 2006

Location: Stiepelse

  • Send private message

member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month

15

Saturday, April 16th 2011, 5:37pm

Dumme Frage: Könnte das auch mit nem Inverter wie z.B. einem 74LS04 oder 06 und ein paar Pull-Ups funktionieren?
Pull-Up an den Eingang vom Inverter, und an den Atmel, LED Anode an den Ausgang...oder klappt das nicht? Ich frag nur, weil ich da ein paar von liegen habe, aber nicht den Atmel schrotten will.

CrazyIcecap

pausiert

  • "CrazyIcecap" is male
  • »CrazyIcecap« is a verified user

Posts: 2,663

Date of registration: Jan 31st 2006

Location: Stiepelse

  • Send private message

member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month

16

Sunday, April 17th 2011, 1:23pm

So, habs ausprobiert. Nen 74LS04 genommen, an die Eingänge (Pin 1 und 3) nen 1,8k-Widerstand und die LED-Leitung vom Atmel.
An die Ausgänge (Pin 2 und 4) über nen 560Ohm-Widerstand die Anoden der Duo-LED, Kathode an Masse.
Funzt 1A.

Edit: Hab mal die Datenblätter ein wenig überflogen....kann es sein, dass ich besser einen 74LS06 nehmen sollte?

This post has been edited 1 times, last edit by "CrazyIcecap" (Apr 17th 2011, 1:53pm)


thasti

Intermediate

  • "thasti" is male
  • »thasti« is a verified user

Posts: 182

Date of registration: Jan 10th 2008

Location: Thuringia

  • Send private message

member since 72 month member since 72 month member since 72 month member since 72 month

17

Sunday, April 17th 2011, 4:05pm

Das könnte schon sein - im Momemt wird es zwar gehen, aber laut Datenblatt ist das Maximum an Strom für den 74LS04er 4 bzw 8mA.
Für den 74LS06er sind das schon 30 bzw 48mA.


hobbycoder

Elektrofummler

  • "hobbycoder" is male

Posts: 2,032

Date of registration: Feb 23rd 2009

Location: Obernkirchen

  • Send private message

member since 54 month member since 54 month member since 54 month

18

Sunday, April 17th 2011, 4:24pm

Moment! Wenn die Anoden der LED an den Ausgängen hängen, dann nützt dir ein 06 überhaupt nicht - das ist nämlich ein Open-Collector-Treiber, der hat als Ausgangsstatus LOW oder hochohmig, kein HIGH (was du ja möchtest)! Sprich, die höhere Stromangabe bezieht sich nur auf das Sinken, aber als technische Stromquelle kann er nicht dienen... somit würde deine LED mit einem 06 immer dunkel bleiben.
How can you know where you've been?
In time, you'll see the sign
and realise your sin.

thasti

Intermediate

  • "thasti" is male
  • »thasti« is a verified user

Posts: 182

Date of registration: Jan 10th 2008

Location: Thuringia

  • Send private message

member since 72 month member since 72 month member since 72 month member since 72 month

19

Sunday, April 17th 2011, 5:41pm

Asche auf mein Haupt!


mc71

Master

Posts: 2,603

Date of registration: Nov 30th 2005

Location: ja...

  • Send private message

member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month member since 108 month

20

Sunday, April 17th 2011, 9:03pm

zu dem obigen Link würde ich anmerken dass LEDs immer mit einem Vorwiderstand zur Strombegrenzung betrieben werden.


Sag das bitte den Herstellern von LED-Schlüsselanhängern und ähnlichem Krams. Nein, die verwenden keine Spezial-LED mit eingebautem Vorwiderstand. Genausowenig wie Fernbedienungen.