Angepinnt Step-by-Step SD2IEC Lochraster Nachbau

  • Vielen Dank für al euer Lob. :winke:
    Wenn ich ein oder zwei Leute motiviert habe das SD2IEC jetzt nach zu bauen, oder das Interesse an AVR geweckt habe, dann habe ich mein Ziel schon erreicht. Zugleich war es lehrreich und eine schöne Übung das alles zusammen zu stellen und es aufs Forum zu posten.

    @AntaBaka

    AntaBaka schrieb:

    Boah, wat kompliziert :)
    Erstmal massig Geld reinstecken...


    Good Point! :)
    Je mehr man selber recherchiert, desto billiger kann man’s machen. Mein erster Programmer war auch ein Parallel Port ISP Programmer. Aber dann kommt der Punkt das man einen USB Programmer haben möchte. Dann kann man besser gleich am Anfang einen USB Programmer kaufen.
    Dabei kommt das es nicht jedermanns Sache ist einen Parallel Port ISP Programmer zu basteln.

    Es geht auch nicht darum all die erwähnten myAVR Kits zu kaufen, sondern sich die Anleitungen und allem drum herum an zu schauen. ;)

    Es wäre konstruktiv wenn du Links zu Elektronik und AVR Tutorials empfehlen könntest. Je mehr Info, desto besser. :freude
    Gruß, lordbubsy
  • lordbubsy schrieb:

    Es wäre konstruktiv wenn du Links zu Elektronik und AVR Tutorials empfehlen könntest. Je mehr Info, desto besser.
    Heh, ich?
    Ich bin da selber blutiger Anfänger :)
    Ich arbeite mit einem einfachen Selbstbau-Parallelport-ISP-Progger plus Selbstbau-Prog-Board (welches inzwischen relativ komplex geworden ist) - damit habe ich bisher knapp 40 MMC2IECs, eine handvoll SwinSIDs, XS1541 und XU1541 bespielt.

    Wobei ich aber zugeben muss, das ich bereits einen USB-Progger und das Eval-Kit von Pollin jeweils aufgebaut hier liegen habe - nur noch nicht benutzt.

    Wenn man sich aber auch mit dem Programmieren des AVR selber beschäftigen möchte und auch sehen will, was das Ding dann so macht, dann ist das Eval-Kit von Pollin mit 15 EUR unschlagbar preisgünstig.
    HomeCon- digitalretropark- Bastelseite
    -
    User ignorieren? AdBlock!www.forum64.de##ARTICLE[data-user-id="xxxxx"]
  • Hallo,

    so hab das jetzt mal nachgebaut, eingeschaltet - nix, nur die rote LED brennt.
    Habe dann mal folgendes eingetippt:
    10 OPEN15,8,15:INPUT#15,a$,b$,c$,d$
    20 CLOSE15
    30 PRINT A$,B$,C$,D$
    RUN
    danach stürzt der Rechner ab und nix geht mehr.
    Wie lang leuchtet die rote LED denn nach dem Einschalten?
    Ich hab also auch die Lösung mit der Micro-SD-Karte genommen:
    4GB von Intenso.
    Ansonsten auch alles genauso:
    “bootloader_LarsP_M644.hex“
    “sd2iec-0.9.1-larsp-m644p.bin“ im Hauptverzeichnis.
    (Auch mal in sd2iec.bin umbenannt)
    Karte ist allerdings mit FAT32 formatiert.
    Fuses:
    Low-Byte = EF
    High-Byte = 92 <--
    Extended-Byte = FD
    Stimmt also alles, was könnte das sein? Die SD-Karte vielleicht?
  • Hallo Ingo,

    Es freut mich das du den Nachbau probiert hast :)

    Das Rote LED sollte nicht länger als ein paar Sekunden aufleuchten.
    Falls das Rote LED nicht aus geht, findet der Bootloader die Firmware nicht.

    Möglich Ursachen:
    • das Fehlen der Karte
    • eine für den Bootloader nicht richtig formatierte Karte
    • das Fehlen der Firmware auf der Karte

    Ich habe das mit der angegebene formatier Software von Panasonic gelöst. Hier ein Direkter Link für die Windows XP Version (falls du es nicht schon gefunden hast). So wird die Karte mit FAT-16 formatiert und kann der Bootloader die Firmware (falls vorhanden) finden. Vorteil ist auch noch dass das schreiben auf der Karte dadurch ein Stück schneller geht.

    Wenn der Bootloader die Firmware findet blinkt das Grüne LED etwa für 3 Sekunden ziemlich schnell. Dies zeigt das die Firmware geflashed wird.

    Gruß,
    lordbubsy
    Gruß, lordbubsy
  • Hallo,

    also hab noch bischen rumgespielt:
    Ob die SD-Karte drin steckt oder nicht, das Verhalten bleibt gleich: Rote LED an.
    Als nächstes hab ich mit einem Logiktester die Pins an der SD-Karte geprüft.
    An 1, 2 und 5 waren also Impulse - anscheinend macht der AVR da was.
    Ich denke, dass es wirklich mit der SD-Karte zusammenhängt.
    Die Karte hab ich mit dem Panasonic-tool formatiert, allerdings macht er nur FAT32.
    Wo stellt man das ein, dass er FAT16 formatiert?
  • Hi,
    Hast du Post 31 gesehen?
    Bitte probier unbedingt mal die formatier Software von Panasonic aus Post 8 aus, hat bei mir funktioniert.

    Alternativ kannst du auch mal die Fuses ändern und ohne Bootloader probieren. (Mitte Post 6 ATmega brennen)
    Gruß,
    lordbubsy
    Gruß, lordbubsy
  • Ich habe die WinXP Version 2.0.0.3 benutzt, habe da nichts großartiges eingestellt. Nur bei Option den format Typ auf FULL [Erase ON]. Dies habe ich mit einer 2 gb und einer 4 gb Karte gemacht. Danach klappte das Flaschen auf Anhieb. Mehr kann ich dir leider auch nicht zu der formatierung sagen.
    Gruß, lordbubsy
  • Ingo schrieb:

    Ja, das war ja meine Frage, wie man mit dem Panasonic-Tool FAT16 formatiert,
    bei mir kommt da immer nur FAT32 raus!

    Das Panasonic-Tool formatiert Karten >2GB immer mit FAT32, da kann man nichts einstellen.

    Quellcode

    1. 10 x=rnd(-1963):fori=1to81:y=rnd(1):next
    2. 20 forj=1to5:printchr$(rnd(1)*16+70);:next
    3. 30 printint(rnd(1)*328)-217

    sd2iec Homepage